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Getting
Started
with PC Draft

Welcome to
PC Draft

The purpose of the PC Draft User Guide is to provide you with detailed
information about the features and capabilities of PC Draft. The manual is
structured so that you can refer directly to a particular feature and obtain
detailed instructions about its use. Topics in the manual include instructions
on creating, editing, moving, and arranging objects on a drawing.

Introduction

Before you proceed, you should be comfortable with terms such as click,
drag, select, and choose. You should also be familiar with the general
methods used in most Windows® applications to move, resize, and scroll a
window.

Hardware and
Software
Requirements

PC Draft is designed to run under Windows® 95 or later and Windows® NT.
Your PC Draft program will run on any PC computer with Pentium®
processor. PC Draft requires a minimum of 6 MB application memory (free
RAM) to operate, ten megabytes (10 MB) is recommended. The program
takes up about 10 MB of hard disk space.

You must run PC Draft from a hard disk. The following instructions describe
how to install PC Draft on the hard disk.

Installing PC
Draft

To install PC Draft onto your hard disk, follow these steps:
1.

Insert the PC Draft Install CD into a CD drive.

2.

Find the file icon for the Installer software and double click on
it. Once the installation program starts, follow its instructions.

The PC Draft program and its supplemental files will be installed where you
specify on your hard disk.
The installer will create a shortcut folder that you can open by selecting the
Start Menu and Programs option.
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Enabling
Microspot PC
Draft

The first time you launch PC Draft you must enter a name and valid serial
number to enable the software.
To enable Microspot PC Draft:
1.

Double-click on the PC Draft application icon to launch the
software.

2.

Enter a name and valid serial number (the organization name
is optional) into the dialog that appears.

3.

The serial number must be valid for the version you are using.
This will be supplied with the program or upgrade when
purchased.

4.

Only when you have typed in your serial number the OK
button will be available.

Click on this button to open the application.
If you click on the Demo button, the application will run in demo mode and
some of the features and menu options will be disabled.
1-2
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The Help Menu

The Help menu is used to open the PC Draft manual, product registration
and upgrade information.
The PC Draft Manual in pdf format will be included on disk with the
application. The manual will be installed on your hard drive during the
installation process.
Choose PC Draft Manual from the Help menu and Acrobat Reader will
launch and open the manual. You can then navigate through and read the
manual on screen or print sections for your reference.
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Getting Started
with a Drawing

PC Draft’s greatest strength as a drafting and design tool is the way it
enables you to define your drawing environment. Using simple menu
commands and palette choices, you can specify the default scale, drawing
units, and page setup you need for the drawing.
The scaled environment automatically keeps track of the size and area of the
objects you draw. You can display their dimensions using the Show Size
feature (see Chapter 6), the various dimension tools (see Chapter 4), or the
onscreen rulers (see Chapter 6).
NOTE: If you expect to use the same settings over and over in most of your
drawings, you can make those the defaults for all new drawings using the
File menu’s Set Defaults command; see page 1-24. If you expect to use
several different sets of defaults, you can make save each setup as a
Stationery document; see page 1-17.

With PC Draft you can draw using either English units (feet and inches) or
metric units. PC Draft offers the most commonly used English-unit metric
scales. Once you choose a unit system for your drawing, you can define the
scale you want to use.

Setting the Size
Units

To set the units for a drawing:
1.

Open the Layout menu and choose Set Scale/Units.

The Document Scale & Units dialog box will appear.
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2.

Click on the English or Metric radio button, depending on the
type of units you want to use in the document.

Whether you use the English or Metric system, you can choose the basic
units for the drawing: Decimal Inches, Decimal Feet & Inches, Decimal
Feet, Fractional Inches, or Fractional Feet & Inches in English drawings;
and Millimeters, Centimeters, Decimeters, or Meters in Metric drawings
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3.

If necessary, change the units in the Units pop-out menu.

NOTE: In metric drawings, you can choose “Hide Metric Units,” which
will prevent the unit abbreviations (“mm,” “cm,” and so on) from appearing
when dimensions are displayed on the drawing. You can also control the
number of places displayed behind the decimal point in both metric and
English decimal drawings; see Chapter 4 for more information.

Setting the Scale

Before starting a drawing, you need to determine the sizes of the objects and
the paper you are going to use. For large drawings it is impractical to draw
objects at their actual sizes; it is necessary to reduce them, yet still maintain
their proper proportions.
A scale, the ratio of the object’s size on the drawing to its size in the real
world, accomplishes this. For example, if you choose a scale ratio of onequarter inch equals a foot (1/4" = 1'), a line drawn ten inches long on a
drawing would represent a 40-foot line in the real world.
NOTE: When you paste an existing object into a drawing with a different
scale, the object will automatically adjust in size to conform to the scale of
the new drawing.
To specify the default scale:
1.

Make sure the Document Scale & Units dialog box is open.

2.

Point on the combo box beside the label, Default Scale.

3.

Press the left mouse button.

The Scale pop-up menu will appear, displaying the scales available for the
chosen unit system.
4.
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Click the wanted scale to choose it.
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The new scale will be displayed in the Default Scale combo box.
5.

Click on the OK button to close the dialog box and apply the
changes.

NOTE: In drawings that include more than one layer, you can set different
scales for different layers, if necessary (see chapter 7 for information about
using layers). However, all the layers in a drawing must use the same unit
system (English or metric).

Setting the
Drawing Size
and Layout

Depending on your needs, you can set a drawing’s page size, page
orientation, and total size. Page size is simply the size of the paper you will
be printing, and orientation is whether each page is printed vertically or
horizontally.
If necessary, you can create a drawing that will print over several sheets of
paper. The maximum drawing size is approximately 56.88 x 56.88 inches
(144.46 x 144.46 cms), depending on which page size and orientation you
choose.
The choice of page size is subject to the page sizes available with the
currently active printer or printing device; for example, if the printer you’ve
selected only supports letter-size and legal-size paper, you cannot print to
larger or smaller sheets. (See Chapter 8 for more information.)
To set your drawing’s page size and orientation:
1.

Choose the File menu’s Page Setup command.

The Page Setup dialog box will appear.
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2.

Select the paper size you want for printing your drawing.

3.

Select the page orientation (horizontal or vertical) you want
for printing your drawing.

4.

Click the OK button.

The Page Setup dialog box will disappear. Your drawing will now have the
desired page size and orientation assigned.
To set the size of your drawing:
1.

Open the Layout menu and choose Drawing Size.

A dialog box will appear, displaying the current total drawing size in the
form of a block diagram.
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This diagram represents the maximum drawing size available; each block
represents a single page. The blocks that are darkened indicate the current
drawing size. You can control the overall size and shape of the drawing by
clicking in the diagram.

To change the drawing size:
2.

Position the tip of the pointer on one of the activated page
blocks and press the left mouse button.

3.

Holding down the left mouse button, drag until you have
activated the number of page blocks required for the drawing
size you want.

4.

Release the left mouse button.

5.

Click the OK button.

The PC Draft drawing window generally shows only a portion of the overall
drawing. Therefore, when you change the drawing size it might not be
noticeable in the window until you zoom out or scroll to another area of the
drawing (see Chapter 2 for information about scrolling and zooming).

Rulers and the
“Crosshair”

PC Draft’s onscreen rulers can help you draw and position objects in precise
locations on your drawing. They appear along the top and left sides of the
drawing window, and reflect the current position of the window during
scrolling. At magnified views (zoomed in or out), they change size
accordingly.
The rulers are especially useful in conjunction with PC Draft’s “crosshair”
drawing cursor. This looks like a large pair of crosshairs that extend
horizontally and vertically across the window, into the rulers, when a
drawing tool is active.
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The rulers can show either on-screen sizes (Standard Rulers) or values that
match the current scale and units. For example, on a 1/8" = 1' scale, the
major scale ruler divisions will be in increments of eight (8 ft., 16 ft., and so
on).
To display PC Draft’s rulers:
•

Open the Layout menu and choose Show Rulers.

The rulers will be displayed, and a check mark will appear by the Show
Rulers command in the Layout menu.
To display scale rulers (if Show Rulers is checked):
•

Open the Layout menu and choose Scale Rulers.

To display standard rulers:
•
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Open the Layout menu and choose Standard Rulers.
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To activate the crosshair cursor:
•

Choose Cross Cursor from the Preference menu.

The cursor will now appear, when a drawing tool is selected, as a large pair
of crosshairs. A checkmark will appear by the Cross Cursor command in the
View menu.

Starting a
Drawing

With these settings in place, you’re ready to start drawing in earnest. The
settings you defined—units, scale, page setup, drawing size, rulers, and
drawing cursor—will remain active until you change them.
For details on using PC Draft’s drawing tools, see Chapter 2 (basic
drawing), Chapter 3 (changing the appearance of objects), and Chapter 4
(annotation, including text objects and dimension objects).

Document
Handling

•

Open PC Draft from the Start Menu.

In a few seconds a new untitled document will open on the desktop. You will
be able to name this document the first time you save it.

To Create a New
Document

1.

Open the File menu and drag until New is highlighted.

The New submenu will appear.

To Create
Multiple New
Documents

2.

Holding down the left mouse button, drag until Drawing is
highlighted.

3.

Release the left mouse button.

Once you have made your choice, a new untitled document will appear in
front of any opened documents. Each time you choose “Drawing,” a new
untitled document will be opened. Change the window sizes and positions as
you need to. To activate any opened document, just click on it.
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To Find an
Existing
Document

You can find it from the Explorer. Right click on Start Menu and left click
Explorer Option. As soon as you find the document on the right side, double
click it.

Using Open
From the File
Menu

1. Choose Open from the File menu.
A dialog box will appear listing all PC Draft-compatible documents in the
current directory.

2.

Select the title of the document you want to open by clicking on
it.

3.

Click the Open button in the dialog box.

In a few seconds the document will be open and ready for you to use.
The available types of documents that may be opened by current version of
PC Draft are listed below:
- PC Draft/MacDraft Drawings (*.mdd)
- PC Draft v.4.x Drawings (*.drf)
- PC Draft Symbol Libraries (*.dsy)
- PC Draft Stationeries (*.drs)
- PC Draft 1.0 (WinDraft) Drawings (*.dft)
- DXF and DWG files created by AutoCAD
- Windows Bitmaps (*.bmp)
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Loading Layers
Into a Drawing

PC Draft lets you load a layer from a different PC Draft document into the
active PC Draft document. When you load a layer, the layer’s contents and
scale information are imported to the active PC Draft document.
To load a layer into the active PC Draft document:
1.

Open the File menu and choose Load Layer.

A standard open dialog appears.
2.

Select the appropriate file format from the Files of type
dropdown menu.

3.

Locate and select the document you want to load.

4.

Click the Open button.

A dialog box listing the layers in the selected PC Draft document will appear.
5.

Click on the name of the layer you want.

6.

Click the Load button.
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The selected layer will be loaded into the active document as the active layer.
See Chapter 7 for information about using layers.

NOTE: The Load Layer command can also be used to import images from
graphics files saved in the TIFF format. See Appendix C for more
information about working with TIFF files.

Saving a
Document

The Save function allows you to save a new document or any changes you
have made to an existing document. You can save a copy of the whole
document onto the disk you are using, or onto any other disk you might want
to use for storage.

Saving and
Naming an
Untitled
Document

When you first create a new document, it will have the name “Untitled-#,”
where “#” is the number of new documents you’ve opened since starting PC
Draft.
To name and save the document:
1.
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Open the File menu and choose Save or Save As.
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The Save dialog box will appear.
2.

Type a name for the new document.

You may use any character or symbol on the keyboard. You can also use
uppercase or lowercase characters, with spaces between words.
3.

Click the Save button.

If there is not enough room on the disk to save your document, a message will
appear informing you that the disk is full. To save the document onto a floppy
disk if that happens, eject the current floppy disk (if any), insert a new one,
then click the Save button. To save the document onto another disk, select the
location next to Save in until the name of the volume you want is displayed,
then click the Save button.

Saving Changes After making changes to a previously saved document, you should save it so
Made to a
that the document on your disk will contain those changes.
Previously Saved
Document
To save changes made to a previously saved document:
•

Open the File menu and choose Save.

Once you have done so, the document on the disk will be updated to
incorporate the changes.
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Saving a
Document Onto
a Different Disk

If you want to save a document onto a different disk, or if you want to make a
document available for someone else, you may want to save it onto another
disk.

To save a
document onto a
different disk:

1.

Open the File menu and choose Save As.

A dialog box will appear. The dialog box will display the
PC Draft document titles and the name of the current directory.
2.

Insert the disk on which you want to save the document into the
floppy disk drive. (If you want to save your document on a file
server or another hard disk, go on to the next step.)

3.

Use the directory list to open the disk and folder in which you
want to save the document.

4.

Type a new name for the document if you want it to be saved
under a different name; otherwise it will be saved under the old
name.

5.

Click the Save button in the dialog box.

By using the Save As command you can modify an existing document and
save it as a new document with a different name, thereby preserving the
original version of that document.

Saving a Copy of
the Document

To save a copy of the document:
1.

Open the File menu and choose Save As.

A dialog box will appear.
2.

Type a name for the new version so that you can distinguish it
from the old version.

3.

Click the Save button.

The document will then be saved with the new name, along with any changes
that you have made.
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Saving a
Document as
Stationery

PC Draft lets you save stationery files, which act as templates for new
documents. For example, you can create a file containing certain images, text
and settings, then save it as a stationery file. When you open that stationery
file, PC Draft will give you a new untitled drawing containing the images,
text and settings, which you can then embellish as required for a specific
situation.
It’s as if you create a pad of stationery, perhaps featuring a company logo at a
particular scale, then “tear off” sheets of paper to use as the basis for new
drawings.
Settings that are saved in a stationery document include the scale, units, grid
snap, fill patterns and colors in the document.
To save a document as stationery:
1. Open the File menu and choose Save As.
A dialog box will appear.
2.

Click the Save As type combo box.

The Save As type pop-up menu will appear.
3.

Choose Stationery.

4.

Type a name for the file.

5.

Click the Save button.

To “tear off” a piece of stationery to use the defined settings in a new
document:
• Double-click on
the stationery icon.

A new untitled document will appear. The new document will contain the
settings and objects defined for the stationery.
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Saving a
Document in the
BMP Format

Windows® provides for integration between various software packages.
Information can be transferred between programs using the Copy and Paste
method. For example, you can insert charts into a word-processing program,
or bitmap images into PC Draft. However, the Copy and Paste method is not
always convenient.
To help solve this problem Microsoft® developed a standard file format
called the BMP format. Saving a document in the Windows Bitmap format
allows you more flexibility in transferring images to other software programs
that support the BMP format.
The major benefits of using the BMP format are that it makes it easier to use
graphics with certain page layout programs.
To save a document in the BMP format:
1.

Open the File menu and choose Save As.

After you have made your choice, the following dialog box will be displayed:

The default format for a document to be saved in is the PC Draft/MacDraft
format.
2.
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Point on the Save as type button.
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The Save as type pop-up menu will appear.

3.

Choose Windows Bitmap (BMP) format.

4.

Click the Save button.

The BMP format icon has a different appearance than a PC Draft drawing
icon. The different icons are to help you distinguish between standard PC
Draft drawings and BMP documents.
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Opening a
Document That
Has Been Saved
in the Windows
Bitmap Format

You can open a PC Draft file saved in the Windows Bitmap format using
Open or Load Layer option from File Menu.

1.

Choose Open from the File menu.

The Open dialog appears.
2.

Point on the File Format combo box, then press and hold the
mouse button.

The Format pop-up menu will appear.
If you want to view only the Windows Bitmap documents in the current
directory:
3a. Choose Windows Bitmap, then release the mouse button.
If you want to view all the documents in the current directory:
3b. Choose All, then release the mouse button.
4.

Choose the needed file from the list.

5.

Click the Open button.

PC Draft opens the BMP files as regular raster images.

NOTE: Some other applications, such as many word processors and page
layout products, can open Windows Bitmap files directly.

Setting Defaults
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You may configure a document exactly the way you want it, then decide
that you want all new documents to have that configuration. PC Draft lets
you set certain default settings, including scale, grid snap, colors, and
patterns. Once you have established these settings in a document, you can
store them as defaults so that the same settings are present in each new
drawing you create. Setting defaults is different from saving PC Draft
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stationery files. You can save many different stationery documents, each
with its own different settings. However, you can only keep one set of
defaults. Also, to use the settings saved in a stationery document, you have
to open the Stationery document. To use defaults, you simply create a new
document.
To set defaults:
1.

Open a document.

2.

Define the settings you want to save as defaults for all new
documents.

3.

Open the File menu and choose Set Defaults.

The Defaults for a new document dialog box will appear.

Getting Started With PC Draft
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PC Draft lets you specify which settings you want to keep as defaults. You
can choose to set all the available defaults, or just a few. (Sometimes,
unchecked defaults will be saved.)
To choose the defaults you want to set:
4.

Click on the check boxes beside the desired settings.

Following is a list of the default options in the dialog box and the settings that
are saved when you choose them.

“Scale/Units and Layer Setup”
-

Units
Default Scale
Places behind the decimal
Grid snap
Rotation and Angular Units

“Dimension Standards”
-

Current dimensioning standard (ANSI or metric)
All options defined in the Dimension Standards dialog box (see
Chapter 4 for details on associative dimension objects)

“Dimension Tool Formats”
-

Current dimensioning tool setting
All options defined in the Dimension Format dialog box (see
Chapter 4 for details on associative dimension objects)

“Dimension End Marks”
-

Current dimension end mark setting

“Drawing Size and Page Setup”
- Drawing size
- All options defined in the Page Setup dialog box
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“Fill Patterns and Colors”
-

Fill patterns
Colors in the document’s color table

“Line Settings”
-

Line weight
Line style
End marks
Pen color

“Text Settings”
-

Font
Size
Style
Spacing
Justification

“Snap To Object”
-

Current Snap To Object setting

“Field Names”
-

Current Object Information Field Name definitions

For the Document Display options, if the box beside the option is checked,
the option you choose will be applied to all new documents.
If you chooose "Open at Center of Drawing," new documents will open with
the scroll boxes centered on the scroll bars.

NOTE: When you click the “OK” button, PC Draft saves the defaults
automatically. It makes no difference if you later save the current drawing
file.
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Setting
Application
Defaults

PC Draft lets you define defaults that affect all new PC Draft documents you
create later. The settings you save as Application Defaults affect all
documents, even existing documents. The document-level defaults you save
affect only new documents you open.
To define the settings for the opening of new documents:
•

Click on the Application Defaults button.

The Application Defaults dialog box will appear.

When PC Draft is launched
Click the "Create a new empty,drawing" radio button if you want a new
drawing document to appear when you open the PC Draft application.
Click the "Display the open file dialog" radio button if you want the Open
dialog to appear when you open the PC Draft application.
Click the "Do nothing" radio button if you want the application to open
without opening a new document or the Open dialog.
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Palette settings
Click the "Save display state" checkbox to make all documents open with
the currently displayed palettes shown.
Click the "Save locations" checkbox to make all documents open with the
palettes displaying at their current locations.
Cursor settings
Click the "Activate Cross Cursor" checkbox to turn this option off.
Documents will open with the small cursor active rather than the cross
cursor.
Click the Show Cursor Position checkbox if you want all documents to
open with the cursor position displayed.
Object linking
Click the "New dimensions are linked to object" checkbox to turn this
option off. New dimensions drawn will not be linked to objects.
Click the "When opening a drawing, remove all existing object links"
checkbox if you wish all links between objects (including dimension
objects) to be removed when a drawing is opened.
Line settings
Click the "Zoom Line Weights" checkbox to make all documents open with
the Zoom Line Weights function on.
Click the "Hide Line Styles" checkbox to turn this option off and make all
documents open with the line styles displayed on the screen.
Many times you may want to close a document you’ve been working on, and
Closing One
open another document without quitting the application and returning to the
Document and
Opening Another desktop.
To close the current document:
1. Choose Close from the File menu.
Getting Started With PC Draft
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If the document contains unsaved changes, a dialog box will appear, asking if
you want to save changes made to your document before closing it.
2a. Click the Yes button to close the document and save the
changes.
Or,
2b. Click the No button to close the document without saving the
changes.
The PC Draft menu bar will appear above an otherwise blank screen.
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The Window
Menu

The Window menu gives you a quick method for moving to any open
drawing or symbol library.

The currently active drawing or
library appears in the Window
menu with a checkmark. You
can switch to a different
drawing or library just by
opening the Window menu and
choosing a document name.

NOTE: The Window menu will display more Windows Options if you
have more than 9 documents opened.

To switch to a different drawing or symbol library:
1.

Open the Window menu.

The Window menu will display all currently open PC Draft documents,
with the active (topmost) drawing or library indicated by a checkmark.
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2.

Choose the name
of the drawing or
library you want
to work on

The drawing or library you
choose will become active
and will be displayed in
front of the other document
windows.

To Exit PC Draft •

Choose Exit from the File menu.

If the document contains unsaved changes, a dialog box will appear, giving
you the chance to save changes made to your document before exit.
Your options and their results are as follows:
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Yes

Click on this button to save the changes
before exit.

No

Click on this button to exit PC Draft without saving
changes.

Cancel

Click on this button to void the Exit command and
return to the current document.
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The PC Draft
Document
Window

The PC Draft document window allows you to access your document for
viewing, creating, and editing the drawing area. It is designed to offer you a
drawing area with all of the essential features of PC Draft within easy grasp of
your mouse.
When you open the PC Draft application, a screen like the following will be
displayed:

As you can see, the window has several parts to it, and as you read on, each
part will be described in detail. The various elements of the screen, as well as
illustrations and descriptions of the tools within the palette, will also appear in
the pages that follow.

Fill and Line
Indicators

The two small boxes in the lower left-hand corner of the window are
the Fill and Line Indicators. The Fill Indicator, the box on the left, shows you
the current fill. The current fill is the color, shade of gray, or pattern that will
be used to fill the objects you draw. The Line Indicator, the box on the right,
shows you the current line attributes. The attributes associated with lines and
borders are collectively referred to as the “pen model” or simply, the “pen.”
The pen includes such attributes as line style, line weight, end marks, and pen
color, pattern, or shade of gray. The Line Indicator shows you how these
attributes will be used to draw lines and object borders. (See Chapter 3 for
more information.)

Fill Indicator box

Line Indicator box
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The Drawing
Area

The drawing area is the part of the PC Draft window that displays dotted line
divisions. These divisions are called grid lines. In English units, the distance
between the grid lines represents one inch; in decimal feet, one tenth of a
foot; and in metric units, one centimeter. You can use the grid lines as visual
aids to assist you in your drawing.
When you create a new document, PC Draft automatically establishes a
document size based on a single sheet of paper for the current output device.
However, you can change the size of your document at any time to
accommodate multiple pages, allowing you to create very large drawings.
For information on how to change the size of your document, refer to the
section titled, “Defining the Drawing Size” in Chapter 8.
When you first open your document, the initial view will be that of the upperleft corner of the total drawing area (unless you have adjusted the Document
Defaults to display a different region).
The menu bar appears across the top of the screen, and contains the titles of
the PC Draft pull-down menus available for your use.

The Menu Bar

The menus hold menu items. Most menu items are commands that you can
choose in order to perform various functions on your drawing.
You choose items from menus by clicking and dragging, as in other Windows
applications.

Using
Hierarchical
Menus
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PC Draft uses hierarchical menus: pull-down menus that contain submenus.
The submenus list options associated with particular menu items. For
example, the Border Position submenu in the Preference menu contains
border positions list (see Chapter 3).
A rightward-pointing triangle beside a menu item indicates that more options
related to that menu item are available.
To choose an option from a submenu:
1.

Open the pull-down menu that contains the submenu you want
to access.

2.

Move to the menu item used to access the submenu.
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A submenu will appear.

Using Keyboard
Control
Equivalents

3.

Move horizontally across the menu item to the submenu.

4.

Move down the submenu until the item you want is highlighted.

5.

Release the left mouse button.

Certain menu items can be chosen directly from the keyboard without using
the mouse. You can choose these menu items by holding down the Control
key, then pressing the key for the character beside the Control key. For
example, to choose Duplicate (from the Edit menu), you hold down the
Control key and press “D” (uppercase or lowercase) while continuing to hold
down the Control key.
For more information on the various menus and the functions accessed from
them, refer to Appendix A, “Menus and Dialog Boxes.”
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The Palettes

PC Draft’s most important tools appear in four floating palettes: the Tool
Palette, the Accessory Palette, the Dimension Palette and the Alignment
palette. The Attribute, Resize and Alignment palettes control various
attributes of the objects created using the other palettes. They are called
“floating” palettes because they can move freely around the screen. They
float above the drawing area, allowing you to draw “beneath” them.

Dimension Palette
Resize Palette

Tool Palette
Attribute Palette
Alignment palette
Accessory Palette
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Moving a Palette You can move a palette around the screen to place it in convenient locations.
To move a palette:

Hiding a Palette

1.

Position the pointer on the top or left part of the palette, or any
other part that doesn’t hold an icon.

2.

Press down the left mouse button.

3.

Holding the left mouse button down, drag the palette to the
desired location.

4.

Release the left mouse button.

You can hide a palette when you no longer need it.
To hide a palette:

Displaying
Palettes

•

Click on the palette's close box in the top right corner the
palette window, or

•

Select the palette's name from the Palettes submenu in the
View menu, or

•

Select the palette's name from the Window menu, or

•

Select the palette's name from the popup menu at the bottom
left of the document window.

The palette will disappear, and the check mark beside the palette's name in
the list will be removed.
To display a palette:
•

Select the palette's name from the Palettes submenu in the
View menu, or

•

Select the palette's name from the Window menu, or

•

Select the palette's name from the popup menu at the bottom
left of the document window.

The palette will appear, and a check mark will appear against its name in
the list. Check marks appear beside the names of palettes that are currently
displayed.
Getting Started With PC Draft
1 - 33

Pop-Up Menus

Each palette holds icons that represent certain tools or functions. Some tools
and functions have more than one option associated with them. The options
for each function and tool are accessed by means of a pop-up menu.
Icons used to access pop-up menus have clipped corners (which appear blue
on color monitors). Unlike pull-down menus, which are opened by pressing
on a word in the menu bar, pop-up menus are opened by pressing on an icon
in the palette.
To select an option from a pop-up menu:
1.

Position the cursor on the appropriate icon in the palette.

2.

Press down the left mouse button.

A pop-up menu will appear on the screen.
3.

Holding down the mouse button, drag to the menu item that
represents the desired option.

As you drag, the menu items will be highlighted.
4.
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When the desired menu item is highlighted, release the left
mouse button.
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The pop-up menu will disappear, and the tool icon will change to show you
the current option.

Using the Palette
Tools

The palettes function like boxes of tools that you can use to enter text, draw
different objects and lines, and change objects. To draw any of the objects
associated with the tools, you must first activate (select) the appropriate tool
icon. The tools are represented by icons on the palettes. Many of the tools
have options associated with them. The options are related to either how the
objects are created or to some fundamental differences in the nature of the
objects. For example, the square-corner rectangle options are related to how
you create a rectangle—either from a corner or from its center. On the other
hand, the rounded-corner rectangle options are related to the characteristics
of the rectangles’ corners. That is, you can draw proportional, constant, or
elliptical rounded-corner rectangles.
The drawing icons on the palettes show you the current drawing option, or
“current option,” for each object. When you start out using PC Draft, each
object has a default current option listed on the palette. If you want to change
the current option for an object, you have to make a choice from a pop-up
menu that lists the options associated with the object. (See the above section
on pop-up menus for information about choosing options.)
The icon will become highlighted immediately after you choose it. This
highlighting shows that it is activated and you can proceed to draw the object
associated with the icon.
You can activate other tools on a palette by positioning the pointer on the
icon and clicking the left mouse button. As long as the icon is highlighted,
you will be able to draw the object or perform the action associated with the
tool.
Following are brief descriptions of the tools available on the Tool,
Accessory and Dimension palettes.
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Tool palette

Pointer tool
Selection tool
Line tool
Square-corner
rectangle tool
Regular polygon tool
Circle tool
Polygon tool

Rotation tool
Hand tool
Special line tool
Text tool
Rounded-corner
rectangle tool
Arc tool
Freehand tool

Parallel line tool

Marker symbol tool

90º rotation tool

Attribute tool

Zoom tool

1:1 tool

Pointer tool
Use to move and change the shape of objects, make menu choices and
activate palette functions.
Rotation tool
Use to rotate a selected object.
Selection tool
Use to select objects by drawing a selection rectangle around them.
Hand tool
Use to change the position of a drawing as an alternative to using the scroll
bars.
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Line tool
Use to draw straight lines at any angle (unconstrained lines) or lines that are
restricted to a certain angle (constrained lines).
Special line tool
Use to draw lines that are perpendicular to, tangent to or offset from some
other object, or lines that start at the mid, end or center point of an existing
object.
Square-corner rectangle tool
Use to draw squares and rectangles with square corners.
Text tool
Use to add text to a drawing or edit existing text.
Regular polygon tool
Use to draw symmetrical objects with from 3 to 16 equal sides, such as
triangles, hexagons, and octagons.
Rounded-corner rectangle tool
Use to draw rounded-corner rectangles or squares.
Circle tool
Use to draw circles by diameter (D), by radius (R) or by three (3) points;
and concentric circles.
Arc tool
Use to draw arcs by radius (R) or three points (3); elliptical arcs (E); and
offset arcs.
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Polygon tool
Use to draw objects with two or more sides.
Freehand tool
Use to draw freehand lines and shapes, including Bezier and spline curves.
Parallel line tool
Use to draw parallel line figures (both single segments and open or closed
parallel polygon figures) and extrudes pairs of lines from straight edges.
Marker symbol tool
Use to draw a standard marker symbol.
90º rotation tool
Use to rotate selected objects by 90º.
Attribute tool
Use to copy and assign object attributes.
Zoom tool
Use to zoom in or out on areas of a drawing.
1:1 tool
Select to return to a single magnification view of the current drawing area.
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Accessory palette

Attach
tool

Add/delete
handle tool

Add
tool

Break
tool

Extend line Fillet
tool
tool

Mirror
tool

Subtract Trim lines Chamfer
tool
tool
tool

Unlink
tool

Link
tool

Unlink all
tool

Add/delete handle tool
Use to add or delete (if the Alt key is pressed) edit handles on objects.
Attach tool
Use to attach open shapes and edges to form single objects.
Break tool
Use to break shapes into their component edges.
Add tool
Use to add two closed shapes together to form a single object.
Subtract tool
Allows use of a line or closed shape as a "cutter" to subtract part of another
closed shape.
Extend line tool
Use to extend lines to their intersection or to a reference line.
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Trim lines tool
Use to trim ends from intersecting lines.
Fillet tool
Use to connect lines with an arc.
Chamfer tool
Use to create a beveled corner at the intersection of two lines.
Mirror tool
Use to mirror objects across a user-defined axis.
Link tool
Use to link two or more vertices together so that when one is moved the
others move with it.
Unlink tool
Use to unlink two or more vertices so that they can be moved individually.
Unlink all tool
Use to unlink all vertices of a selected object.
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Dimension
palette
Horizontal dimension
Slope dimension
Diameter dimension
Circle center mark
Dimension end marks

Vertical dimension
Perpendicular
dimension
Radial dimension
Angular dimension

Dimension mode
Dimension format

Horizontal dimension tool
Use to draw horizontal dimension lines.
Vertical dimension tool
Use to draw vertical dimension lines.
Slope dimension tool
Use to draw sloped dimension lines.
Perpendicular dimension tool
Use to draw dimension lines perpendicular to straight lines and edges.
Diameter dimension tool
Use to draw diameter dimension objects.
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Radial dimension tool
Use to draw radial dimension objects.
Circle center mark tool
Use to draw center mark for circles, arcs and ellipses.
Angular dimension tool
Use to draw angular dimension objects.
Dimension end marks popup menu
Use this popup menu to select the end marks for dimension objects.
Dimension modes popup menu
Use this pop out menu to select the mode (Single, Chained or Baseline) of
linear dimension tools.
Dimension format
Use to open the Dimension Format dialog and select the format of
dimension objects such as text, dimension arrows, leader lines and so on.
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Selecting

Remember, you must always select an object before you can make any
changes to it. Two fundamental principles of using PC Draft are as follows:
First, you select an item.
Second, you choose what to do to the item you have
selected.
For example, if you want to change the pattern of an object, you first select it,
then choose a command to change it.
You can select a single object which you want to change, or (for some
operations) you can select multiple objects in order to make the same change
to each selected object simultaneously.
Once you have selected an object, small black squares will appear on its
borders or at each end. These squares are called edit handles. For example, a
selected rectangle will have eight edit handles, and a selected line will have
one handle at each endpoint. The following procedures will show you various
ways of selecting objects on your drawing.

Activating the
Pointer Mode

Before you can select an object on your drawing, you must first activate the
pointer. The pointer is used to resize, edit, and move objects on a drawing.
To activate the pointer:
1.

Position the cursor on the Pointer icon on the palette.

When you move the cursor onto the palette, the cursor will temporarily turn
into the arrow pointer to allow you to select a tool.
2.

Click the left mouse button.

You can also return to the pointer mode by clicking on a unused area of the
drawing (except when the Text tool is active).

Selecting Objects An object is anything that you have created, including rectangles, circles,
lines, arc, freehand shapes, and text.
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To Select a Filled 1. Return to the pointer mode by clicking on the Pointer icon, or
by clicking on a blank area of your drawing.
(Solid) Object

To Select a NonFilled Object

2.

Position the tip of the pointer on the object.

3.

Click the left mouse button. (Handles should appear on the
object.)

1. Return to the pointer mode.
2.

Position the tip of the pointer exactly on the edge of the object.

3. Click the left mouse button.

NOTE: If the pointer tip is not exactly on the edge of the object, you might
miss the intended object and accidentally select an object behind the nonfilled object.

To Select a Line

1.

Return to the pointer mode.

2.

Position the tip of the pointer on the line.

3.

Click the left mouse button. (An edit handle should now appear
at each end of the line.)

To Select Objects 1. Position the pointer on the hidden object’s estimated location.
Hidden Behind
2. Click the left mouse button twice (once to select the front object,
Other Objects
and then once again to select the object hidden behind it).
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You should now see the handles of the hidden object showing through the
object in front of it, as shown in the following figure.
Once the handles appear, you can move the
hidden object, or you can choose “Bring To
Front” from the Arrange menu to make it appear
in front of other objects.

Selecting
Multiple Objects

There are two ways to select multiple objects. If you want to select objects
that are far apart (or that are separated by other objects you don’t want to
select), you can use the Shift-click selection method. If you wanted to select
objects that are close together, you can use the selection rectangle to select
them.

To Select Objects 1. Return to the pointer mode.
That Are Far
Apart—Selection 2. Select the first object by clicking on it.
Using the Shift3. Press and hold the Shift key down.
Click Method

Deselecting
Objects with the
Shift-Click
Method

4.

Select the other objects you want by clicking on them.

5.

Release the Shift key.

You can also use the Shift-click method to deselect selected objects. This
capability allows you to exclude a specific object from a selection without
deselecting all the selected objects.
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To deselect an object:
1.

Return to the pointer mode.

2.

Press and hold down the Shift key.

3.

Click on the object you want to deselect.

4.

Release the Shift key.

The edit handles will no longer appear on the object you Shift-clicked on.
This shows that the object is no longer selected.

To Select
Multiple Objects
Close Together—
Selection Using
the Selection Box
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The selection box is used to select multiple items on a drawing. The selection
box appears when you press down the left mouse button (while in the pointer
mode) and drag.
To select objects using the selection box:
1.

Return to the pointer mode.

2.

Position the pointer above and to the left (for example) of the
objects to be selected.

3.

Press and hold down the left mouse button.

4.

Drag diagonally across until you have enclosed all the objects
you want to select in the selection box.
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Notice that the cursor is now a little hand, indicating that the selection box is
active.

5.

Release the left mouse button.

NOTE: To select multiple objects that lie within the boundary of a larger,
filled object that is already selected, you must begin the selection box
outside the boundary of the already-selected object.

Using the SelectTouching
Method

The select-touching method allows you to select objects by simply bringing
the selection box in contact with each object.
To select objects using the select-touching method:
1.

Return to the pointer mode.

2.

Position the pointer above and to the left (for example) of all the
objects that you want to select.
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3. Press and hold down the Alt key.
4.

Press and hold down the left mouse button.

5.

Drag diagonally across until you have created a box that
touches all the objects to be selected.

Notice that the hand now has a little symbol above it, indicating that Select/
Touching is active.

6.

Release the left mouse button and the Alt key.

NOTE: To select multiple objects that lie within the boundary of a larger,
filled object that is already selected, you must begin the selection box
outside the boundary of the already-selected object.

Selecting All
Objects on the
Active Layer

To select all objects on the active layer:
•

Open the Edit menu and choose Select All.

Notice that all objects and text on the active layer are selected. If you choose
Select All while you are in the text mode and have an insertion point selected
in a text block, the entire text block will be selected.
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Selecting Text on The two techniques for selecting text are using the I-beam pointer (the text
Your Drawing
cursor) to select all or part of a piece of text, and using the arrow pointer to
select a whole text object. The steps for each are outlined below:

Using the I-beam Pointer to Select Text
1.

Activate the Text icon in the palette by clicking on it.

2.

Position the I-beam pointer on either side of the text you want to
select.

3.

Press and hold down the left mouse button.

4.

Drag the cursor through the character(s) until all the text you
want to select is highlighted.

See Chapter 4 for more information on selecting text using the I-beam
pointer.

Using the Arrow Pointer to Select Text
1.

Position the tip of the pointer on a text object.

2.

Click the left mouse button.

Notice that edit handles appear around the text.
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Select Special

The PC Draft Select Special command lets you select objects according to
their type, graphical attributes or object information. For example, you
could select all the circles that have a green fill and an object information
name of Class A.
Select Special is accessed via the Edit menu. The Select Special dialog
enables you to define the parameters of the objects you want to select. Any
combination of attributes can be used to define a selection: object type,
object fill color or fill pattern, object pen color or pen pattern, line weight,
line style or object information. All the items in the current (active) layer
that match your specifications will be selected.

The Select
Special dialog

Displaying the Select Special dialog
To display the Select Special dialog:
•

Choose Select Special from the Edit menu.

The Select Special dialog appears.

The Select Special options:
Type
Click on the Type popup menu and select the type of object to be selected.
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•

Select All to select all types of objects.

•

Select Text to select only text objects.

•

Select General Shape, and a further menu becomes available.
Select a particular kind of shape from this popup menu.

•

Select Dimension, and a further menu becomes available.
Select a particular kind of dimension from this popup menu.
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Object pen and object fill
If you click on the Object Pen or Object Fill checkbox, the relevant Color
and Pattern radio buttons become available.
•
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Click on a Color radio button and then on the related Color
button, the Pen Color or Fill Color popup menu will display.
Select a particular color to be used as part of your selection
criteria.
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NOTE: Object pen colors also refer to text pen colors.
•

Click on a Pattern radio button and then on the related
Pattern button, the Pen Pattern or Fill Pattern popup menu
will display. Select a particular pattern to be used as part of
your selection criteria.

Line weight
If you click on the Line Weight checkbox, the Line Weight popup menu
becomes available.
Select a particular line weight to be used as part of your selection criteria.
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Line style
If you click on the Line Style checkbox, the Line Style popup menu
becomes available.
Select a particular line style to be used as part of your selection criteria.
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Object info...
In addition to the visible attributes of objects, object information data can be
used to determine selections. Access these options by clicking on the
Object Info... button in the Select Special dialog.
When you click on the Object Info... button, an object information dialog
box appears, enabling you to specify either all or some of a drawing's object
fields as part of your selection criteria. Click on the checkboxes to specify
which object information fields should be used to make the selection, then
type the information into the relevant fields.
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Selecting objects using Select Special
To select objects using Select Special:
1.

Open the Edit menu and choose Select Special.

The Select Special dialog appears.

2.

Set the select criteria as referring to the information above.

3.

Click on the Select button.

All objects on the current layer that meet the criteria you defined will be
selected.
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Exporting a
document

The Export File command in the File menu can be used to export files in
any format supported by QuickTime Graphic Exporters, for example JPEG
and BMP formats.
To export files:
1.

Select Export File from the File menu.

A standard dialog appears.
2.

Select the appropriate file format from the Format popup
menu at the bottom of the dialog.

The relevant extension will be added to the file name and the file will be
exported in that format. See your QuickTime documentation for further
details.
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Chapter 2

Creating and
Editing Objects

Creating
and Editing
Objects

When you open a new document in PC Draft, the following characteristics
are preset (unless you use stationery or defaults):
-

-

All rectangles, circles, arcs, polygons, and freehand objects will
be shaded with a white fill (for closed objects) or no fill (for
open objects).
The document size will be a single sheet of paper.
All lines and borders of objects will be drawn with a one-pixel,
solid-black line weight.
Scale will be set at 1:1 (one inch equals one inch).
Grid lines will be displayed on the drawing area.
Snap Grid will be turned on.

Any of these conditions can be changed before or after you draw an object.

For more information on these default settings, refer to Chapter 1, and the
sections “Using the Scale Function” and “Determining the Size of Your
Document” in Chapter 6.

Fundamentals of
Drawing an
Object

To draw any object, you must be in a drawing mode. To enter a drawing
mode, you must first activate the icon in the Tool palette that identifies the
drawing tool that you want to use. The drawing procedure for most objects
is very similar: activate the tool, decide on a starting point, press down the
left mouse button, then drag to create the object.
Although the drawing procedures are nearly the same for most objects, the
drawing procedures for polygons, arcs, and curves are somewhat different.
Step-by-step instructions on how to draw and change the size of each type
of object are provided in the following pages.

Drawing Lines

PC Draft offers you two types of line tools: a constrained line tool and an
unconstrained line tool. When you use the constrained line tool, the line you
draw will snap into alignment at a specified angle. You can use the unconstrained line tool to draw a straight line at any angle.
Constrained diagonal lines can drawn be at angles of 5°, 15°, 30°, 45°, and
90°.
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You can also constrain the unconstrained line tool to increments of 45° by
holding down the Shift key as you draw.

Choosing Line
Tools

You choose the line tool you want from the Line pop-up menu on the Tool
palette.
To choose the line tool you want:
1.

Point on the Line icon on the Tool palette.

2.

Press down the left mouse button.

The Line pop-up menu will appear.
3.

While holding down the
mouse button, drag
until the type of line you
want (unconstrained or
a line constrained to a
certain angle) is highlighted.

4.

Release the left mouse
button.

The icon representing your choice will appear on the Tool palette. If you
choose a line constrained to a certain angle, the chosen angle of constraint
will appear on the palette along with the line icon.

1. Choose the angle of constraint you want from the Line pop-up
To Draw a
menu on the Tool palette.
Constrained Line
Notice that the line icon is now highlighted. This indicates that the tool is
activated.
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2.

Position the cursor in the drawing area at the point where you
want the line to begin.

3.

Press down the left mouse button.
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4.

Holding down the left mouse button, drag until you have
created a line that is the length you want.

5.

Release the left mouse button.

The diagram illustrates the results of this operation.

To Draw an
Unconstrained
Line

1.

Choose the Unconstrained icon (no angle given) from the Line
pop-up menu in the Tool palette.

2.

Position the cursor where you want the line to begin in the
drawing area.

3.

Press down the left mouse button.

4.

Holding down the left mouse button, drag in any direction
until you have created a line that is the length you want.

5.

Release the left mouse button.
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Constrained
Drawing Mode

If you hold down the Shift key as you are drawing an unconstrained line,
the line will snap at 45-degree angles. This can be useful when you need
one horizontal or vertical line, but don’t want to switch to the 90° line tool.

Snapping Along
the Length

If you hold the Alt key down as you draw a line, its length will change by
the increment controlled by the Set Grid submenu.

To Change the
Length of a Line

1.

Return to the pointer mode.

2.

Select the line you want to change.

3.

Position the tip of the pointer on one of the line’s handles.

4.

Press and hold down the left mouse button.

5.

Holding down the left mouse button, drag until the line is the
length you want.

6.

Release the left mouse button.

Rectangle
Drawing
Modes

PC Draft allows you to draw rectangles with square, rounded, or elliptical
corners.

Choosing a
Method for
Drawing
Square-Corner
Rectangles

PC Draft lets you draw square-corner rectangles in two ways: from the
corner (“Diagonal”), or from the center (“Centered”). You can specify the
method you want to use by making a choice from the Square-Corner
Rectangle pop-up menu.
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To choose a method for creating square-corner rectangles:
1.

Point on the Square-Corner Rectangle icon on the Tool palette.

2.

Press down the left mouse button.

The Square-Corner Rectangle pop-up
menu will appear.
3.

Holding down the left mouse
button, drag until either
Diagonal or Centered is
highlighted.

Diagonal activates the tool used to draw a
rectangle from one of its corners.

Centered activates the tool used to draw a rectangle from its center.
4.

Drawing a
Rectangle From
Its Corner

Release the left mouse button.

When you choose the diagonal mode for drawing square-corner rectangles,
you can define the position of one corner of the rectangle, then project the
rest of the rectangle from that corner point.
To create a rectangle from its corner:
1.

Choose Diagonal from the Square-Corner Rectangle pop-up
menu.

2.

Point where you want one corner of the rectangle to appear on
the drawing.
Press down the left mouse button.

3.
4.

Holding down the left mouse button, drag in any direction
until you have a rectangle with the size and position you want.

5.

Release the left mouse button.
Creating and Editing Objects
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Drawing a
Rectangle From
Its Center

When you choose Centered from the Square-Corner Rectangle pop-up
menu, you can center rectangles around a specific point on the drawing.
To draw a rectangle from its center:
1.

Choose Centered from the Square-Corner Rectangle pop-up
menu.

2.

Point where you want the center of the rectangle to appear on
the drawing.

3.

Press down the left mouse button.

4.

Holding down the left mouse button, drag until you have a
rectangle of the size you want.

5.

Release the left mouse button.

Constrained
Drawing Mode

If you hold down the Shift key while drawing a rectangle, it will restrict the
shape of the rectangle to a square.

Changing the
Size of a
Rectangle

To change the size of a rectangle:
1.

Return to the pointer mode.

2.

Select the rectangle you want to resize.

3.

Position the tip of the pointer on one of the edit handles.

6.
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Release the left mouse button.
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4.

Press down the
left mouse button.

5.

Holding down the
left mouse button,
drag until the
rectangle is the
size you want.

Unconstrained
Editing Mode

If you hold down the Control key while editing a rectangle, it will be
released from any active grid snap.

Rounded-Corner
and EllipticalCorner
Rectangles

With PC Draft, you can draw rounded-corner rectangles with proportional
(P) or constant (C) corners. In constant-corner rectangles, the radius of the
corner arcs remains the same regardless of the rectangle’s size. In proportional-corner rectangles, the radius increases or decreases in proportion to
the rectangle’s size.
You can also draw rectangles with elliptical (E) corners.
You can change the corner style by choosing the style you want from the
Rounded-Corner Rectangle pop-up menu.

About
ProportionalSize RoundedCorner
Rectangles

When you draw a rounded-corner rectangle, you will probably want the
corners to be proportional to the size of the rectangle.

For example, if you draw a large rectangle with large corners in the constant-corner mode, and you reduce the size of the rectangle, the corners will
become too large in relation to the size of the rectangle. This may make the
rectangle assume an unwanted elliptical shape. In the proportional-corner
mode, rounded-corner rectangles will never become distorted, regardless of
size.

About ConstantSize RoundedCorner
Rectangles

When you draw rectangles with constant corners, the corners will always
have the same radius regardless of the size of the rectangle.

Creating and Editing Objects
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About
Rectangles With
Elliptical
Corners

When you draw a rectangle with elliptical corners, the major and minor
axes of the elliptical arcs that form the corners are determined by the size of
the rectangle. Therefore, the size of the elliptical arcs on the corners grows
or shrinks in proportion to the rectangle’s size.
To choose the corner style you want for rounded-corner
rectangles:

Choosing a
Rectangle
Corner Style

1.

Point on the Rounded-Corner Rectangle icon on the Tool
palette.

2.

Press down the left mouse
button.

The Rounded-Corner Rectangle pop-up
menu will appear.

3.

Holding down the left mouse button, drag through the menu
until the corner style you want is highlighted.

4.

Release the left mouse button.

The character representing the Alt you selected (“P” for proportional, “C”
for constant, or “E” for elliptical) will appear on the palette.
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To Draw a
Rectangle With
the Chosen
Corner Style

1.

Choose the type of corner you want from the Rounded-Corner
Rectangle pop-up menu.

2.

Position the cursor where you want one corner of the rectangle
to appear in your drawing.

3.

Press down the left mouse button.

4.

Holding down the left mouse button, drag in any direction
until the rectangle is the size you want.

5.

Release the left mouse button.

Constrained
Drawing Mode

If you hold the Shift key down as you are drawing a rounded-corner
rectangle, it will restrict the shape of the rectangle to a rounded-corner
square.

Changing the
Shape of the
Corners on
Rounded-Corner
Rectangles

A selected rounded-corner rectangle has an additional edit handle called the
corner-edit handle, normally inside and near the upper left corner of the
rectangle. It is used to change the shape of the corners. With proportionaland constant-corner rectangles, you can drag the corner-edit handle in a
diagonal direction to change the radius of the corner arc and reshape the
rectangle.
To change the shape of the corners on proportional- and constant-corner
rectangles:
1.

Return to the pointer mode.

2.

Select the rectangle you want to change.

3.

Position the tip of the pointer on the corner-edit handle.

4.

Press down the left mouse button.
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Notice that as you drag the handles, the corner shape changes.
5.

6.

Changing the
Shape of
Corners on
Elliptical-Corner
Rectangles

Holding down the left mouse
button, drag downward to
the right to increase the
radius of the corners; drag
upward to the left to decrease the radius.

When the corners are the shape you want, release the left
mouse button.

When you create a rectangle with elliptical corners, the elliptical arcs at the
corners cover 90 degrees. By dragging the corner-edit handle, you can
change the X- and Y-radius of the arcs that form the corners of the rectangle, thereby changing the shape of the corners. When you reshape the
corners, the arcs will remain 90 degrees.
To reshape the corners:
1.

Return to the pointer mode.

2.

Select the elliptical-corner rectangle you want to change.

3.

Position the tip of the pointer on the corner-edit handle.

4.

Press down the left mouse button.

5.

Holding down the left mouse button, drag until the corners are
the shape you want.

6.

Release the left mouse button.

Unlike in other rectangles with rounded corners, you can drag the corneredit handle on elliptical-corner rectangles in any direction. The direction in
which you drag the handle determines the shape of the corners. The figures
below show how you can use the corner-edit handle to reshape the corners.
If you hold down the Control key while editing a rounded-corner rectangle,
it will be released from any active grid snap.
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If you drag the handle to the extreme upper
left corner, the corners will appear almost
square.
If you drag the handle to the center, the entire
rectangle will appear as an ellipse.

Circle
Drawing
Modes

You can draw a circle by its radius, by its diameter, by three points, or as a
concentric offset of an existing circle. Drawing by diameter is the default
option for circles.

To Choose a
Method for
Drawing Circles

You can specify how you want to create circles by choosing the option you
want from the Circle pop-up menu.
1.

Point on the Circle icon in the Tool palette.

2.

Press down the left mouse button.

The Circle pop-up menu will appear.
The character representing the method you chose — by radius (R), by
diameter (D), or by three points (3) — will appear in the circle icon on the
palette.

3.

Holding down the left
mouse button, drag
through the menu
until the option you
want is highlighted.

4.

Release the left mouse
button.

Creating and Editing Objects
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To Draw a
Circle by
Diameter

To Draw
a Circle by
Radius

1.

Choose Diameter from the Circle pop-up menu.

2.

Position the cursor where you want to begin drawing the circle.

3.

Press down the left mouse button.

4.

Holding down the left mouse button, drag until you have
created a circle that is the size you want.

5.

Release the left mouse button.

1.

Choose Radius from the Circle pop-up menu.

2.

Position the cursor where you want the center of the circle to
be in your drawing.

3.

Press down the left mouse button.

4.

Holding down the left mouse button, drag until you have
created a circle that is the size you want.
5.

Constrained
Drawing Mode

Release the left mouse button.

If you hold down the Shift key while drawing a circle by radius or diameter,
it will restrict the radius or diameter to horizontal, vertical, or 45-degree
increments.
After you have drawn a circle by radius or by diameter, you can change its
size by dragging one of its edit handles.

To change the size of a circle drawn by radius or by diameter:
Changing the
Size of a Circle
Drawn by Radius 1. Return to the pointer mode.
or by Diameter
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2.

Select the circle you want to change.

3.

Position the tip of the pointer on one of its handles.

4.

Press down the left mouse button.
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5.

Holding down the left mouse button, drag the handle until the
circle is the size you want.

6.

Release the left mouse button.

To Draw a Circle You can use the Circle by Three Points tool to draw a circle that passes
by Three Points through three specific points on your drawing.
To draw a circle by three points:
1.

Choose 3 Points from the Circle pop-up menu on the Tool
palette.

2.

Position the cursor on the first point through which you want
the circle to pass.

3.

Press down the left mouse button.

4.

Holding down the left mouse button, drag to the second point
through which you want the circle to pass.

7.

5.

Release the left mouse
button.

6.

Without pressing down
the left mouse button,
move the cursor to the
third point through
which you want the circle
to pass.

Click the left mouse button.

Three edit handles will appear on the circle. The edit handles correspond to
the three points used to define it.

Changing the
Size of a Circle
Drawn by Three
Points

You can change the size of a circle drawn by three points by moving the
edit handles.
To change the size of a circle drawn by three points:
1.

Return to the pointer mode.
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2.

Select the circle you want to resize.

3.

Point on one of the edit handles.

4.

Press down the left mouse button.

5.

Holding down the left mouse button, drag until the circle is the
size you want.

6.

Release the left mouse button.

When you release the left mouse button, PC Draft will redraw the circle to
pass through the three points represented by the edit handles.

Unconstrained
Editing Mode

If you hold down the Control key while editing any circle, it will be
released from any active grid snap.

Offset Circles

With PC Draft’s Circle Offset tool, you can create new circles, concentric
with existing circles. The offset circle will be of the same type and have the
same line weight, line style, and pen model as the original circle.

Offset circles can be created from any circle. Once drawn, an offset circle is
an independent circle that can be edited, moved, or otherwise manipulated
as required.
NOTE: The “parent” circle for the offset circle must be in place before you
choose the offset circle tool.
Drawing an offset circle from an existing circle requires two steps: selecting
the source circle, then clicking to specify the offset distance.

2 - 14

Creating and Editing Objects

To draw an offset circle from an existing circle:

1.

Choose the Offset Circle
icon from the Circle Tools
pop-up menu.

The cursor now reads “Click Circle,” to let you know that you need to select
a circle.
2.

Click on the circle.

The cursor now reads “Anchor” and appears near a dotted copy of the
source circle, helping you locate the offset.

Creating and Editing Objects
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3.

Move the cursor to the point where you want the offset to lie.

As you move the cursor, the dotted sketching circle gets larger or smaller.
4.

Click the left mouse button.

The offset circle is done. The cursor returns to “Click Circle,” enabling you
to create more offsets.

To exit the offset cursor mode, click the Pointer icon in the Tool Palette or
hold down the Control key and click on a blank area of the drawing.
As mentioned earlier, the offset is a circle of the same type as the original.
You can edit or alter it as needed, or even use it as the base for another
offset circle.

Arc Drawing
Modes

With PC Draft you can draw both circular and elliptical arcs. Circular arcs
specify three points on the drawing through which you want the arc to pass.
With elliptical arcs, you define an ellipse that is a certain size, then project
an elliptical arc that is the length you want.

To Choose the
Type of Arc You
Want to Draw

The arc by radius mode is the default for drawing arcs. You can choose the
type of arc you want to draw by choosing an option from the Arc pop-up
menu on the Tool palette.
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1.

Point on the Arc icon on the Tool palette.

2.

Press down the left
mouse button.

The Arc pop-up menu will
appear.

3.

Holding down the left mouse button, drag through the menu
until the option you want is highlighted.

4.

Release the left mouse button.

The character representing the type of arc you choose, (“R” for arcs by
radius, “3” for arcs by three points, or “E” for elliptical arcs) will appear on
the palette.
NOTE: When an arc is drawn with a fill, it will appear as an object shaped
like a piece of pie. To draw the arc line only, you must make sure that no
objects are selected, then choose “N” (for No fill) from the Fill Pattern or
Fill Color submenu before you draw the arc.

To Draw an Arc
by its Radius

1.

Choose Radius from the Arc pop-up menu.

2.

Position the cursor where you want to begin the radius of the
arc.

3.

Press down the left mouse button.
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4.

Holding down the left mouse button, drag in any direction
until you have created a line that represents the radius you
want.

5.

Release the left mouse button.

6.

Without pressing the left mouse button, move the cursor away
from the end of the radius line until you have created an arc
that is the length you want.

If you drag outside the border of the arc, a leader line extending from the
arc’s border to the cursor will be projected. This leader line allows you to
align the ending point of the arc with other points on your drawing.
7.

Click the left mouse button.

Constrained
Drawing Mode

If you hold the Shift key down while you define the arc’s radius, it will
restrict the definition of the arc’s radius to 45-degree increments.

Changing the
Size of an Arc
Created by its
Radius

You can change the size of an arc either by changing the length of the
radius, or by changing the length of the arc. The following steps and
diagrams will show you both methods, as well as their effect on the shape of
the arc.

To Change the
1. Return to the pointer mode.
Length of an Arc
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2.

Select the arc you want to change.

3.

Position the tip of the pointer on the small handle in the middle
of the arc’s border.
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To Draw an Arc
by Three Points

4.

Press down the left mouse button.

5.

Holding down the left mouse button, drag until the arc is the
length you want.

6.

Release the left mouse button.

Sometimes, you may not know the length of the radius of an arc, but do
know that the arc passes through three different points in a drawing. You
can create an arc that passes through the three known points by following
these steps:
1.

Choose 3 Points from the Arc pop-up menu.

2.

Position the cursor on the first point through which you want
the arc to pass.

3.

Press down the left mouse button.
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4.

Holding down the left mouse button, drag to the second point.

5.

Release the left mouse button.

6.

Without pressing the left mouse button, move the cursor to the
third point.

7.

Click the left mouse button.

NOTE: You cannot create a complete circle using the arc tool. If you
drag past the beginning of the arc, it will collapse back to a shorter length.

Changing the
Size of an Arc
Drawn by Three
Points

You can change the size of a three-point arc by moving any one of the three
handles that represent the three points originally used to define the arc.
1.

Return to the pointer mode.

2.

Select the arc you want to resize.

3.

Position the tip of the pointer on whichever handle you want to
move.

4.

Press down the left mouse button.

5.

Holding down the left mouse button, drag the handle to a new
location on the drawing.

6.

Release the left mouse button.

NOTE: You may have trouble drawing extremely shallow arcs because the
length of the radius may become too great. Likewise, you cannot draw an
arc that is absolutely flat (that is, you cannot use the arc tool to draw a
straight line) because the radius of such an arc would be virtually infinite.

To Draw an
Elliptical Arc
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You can use the Elliptical Arc tool to create elliptical arcs of a specific size
and length. When you create an elliptical arc, you first project an ellipse,
then define an arc representing a portion of the ellipse. The actual size of
the arc is determined by the size of the ellipse, and the arc’s length is
determined by the number of degrees you project it during creation.
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To draw an elliptical arc:
1.

Choose Ellipse from the Arc
pop-up menu.

2.

Point on the desired center
point of the ellipse that will be
used to define the arc.

3.

Press down the left mouse
button.

4.

Holding down the left mouse
button, drag until you have
created an ellipse that is the size
you want.

5.

Release the left mouse button.

6.

Without pressing down the left mouse button, move the cursor
until you have projected an arc that is the length you want.

A line will be attached to the
cursor. The line will extend from
the center of the ellipse to the
cursor. This line is used to define
the ending angle of the arc. If you
drag outside the ellipse, a leader
line extending from the ellipse’s
border to the cursor will be
projected. This leader line allows
you to align the ending angle of the
arc with other points on your
drawing.
7.

Click the left mouse
button.

The elliptical arc will appear on the
screen.
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Changing the
Part of the process of defining elliptical arcs involves defining the starting
Starting Angle of angle of the arc. The starting angle’s position is determined by where you
an Elliptical Arc release the left mouse button after you have projected the ellipse used to
define the arc. Normally, you define the size of the ellipse and the starting
angle of the arc at the same time. However, by using the Shift key to
constrain the size of the ellipse, you can change the position of the starting
angle without changing the size of the ellipse.
To change the starting angle of the arc:
1.

Define the arc as you normally would. (That is, choose Ellipse
from the Arc pop-up menu, press down on the center point,
and drag to project the ellipse.)

2.

When the ellipse is the size you want, without releasing the left
mouse button, hold down the Shift key.

3.

Drag the line that marks the starting angle to a new position.

The line marking the starting angle of the arc will follow the cursor’s
movement, but the ellipse will not be resized.
4.

Release the left mouse button and the Shift key when the line is
where you want the starting angle of the arc to appear.

5.

Continue to define the arc.

Editing an
Elliptical Arc

There are two ways you can edit an elliptical arc: you can change its
length, and you can change its shape. When you change its length, you
either increase or decrease the number of degrees that make up its length.
When you change its shape, you change the major and minor axes of the
arc.

Changing the
Shape of an
Elliptical Arc

By dragging the edit handle in the middle of the arc’s border, you can
change the arc’s shape without changing its length.
To change the shape of an elliptical arc:
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1.

Return to the pointer mode.

2.

Select the elliptical arc you want to change.
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Changing the
Length of an
Elliptical Arc

3.

Position the tip of the pointer on the edit handle located in the
center of the arc’s border.

4.

Press down the left mouse button.

5.

Holding down the left mouse button, drag until the elliptical
arc is the shape you want.

6.

Release the left mouse button.

You can use the edit handles on the end points of an elliptical arc to change
its length
To change the size of an elliptical arc:
1.

Return to the pointer mode.

2.

Select the elliptical arc you want to resize.

3.

Position the tip of the pointer on one of the edit handles located
at the end of arc border.

4.

Press down the left mouse button.

5.

Holding down the left mouse button, drag the handle until the
ellipse is the size you want.

6.

Release the left mouse button.
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Drawing Offset
Arcs

With PC Draft’s Arc Offset tool, you can create new arcs, concentric with
existing circular arcs. The offset arc will be the same type (radial or threepoint) and have the same line weight, line style, and pen model as the
original arc.

Offset arcs can be created from any circular arc. Once drawn, an offset arc
is an independent object that can be edited, moved, or otherwise manipulated as required.
The offset arc will snap to the active grid snap (see Chapter 6) along its
radius. If you want to change the increment, choose a different value from
the Layout menu’s Set Grid submenu.
NOTE: The “parent” arc for the offset arc must be in place before you
choose the offset tool.
Drawing an offset arc from an existing arc requires two steps: selecting the
source arc, then clicking to specify the offset distance.
To draw an offset arc from an existing arc:
1.
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Choose the Offset Arc icon from the Arc Tools pop-up menu.
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The cursor now reads “Click
Arc”, to let you know that you
need to select an arc.

2.

Click on the arc.

The cursor now reads “Anchor” and appears near a dotted copy of the
source arc, helping you locate the offset.
3.

Move the cursor to the
point where you want the
offset to lie.

As you move the cursor, the dotted
sketching arc gets larger or smaller.

4.

Click the left mouse button.

The offset arc is done. The cursor
returns to “Click Arc,” enabling you to
create more offsets.
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To exit the offset cursor mode, click the Pointer icon in the Tool Palette or
hold down the Control key and click on a blank area of the drawing.
As mentioned earlier, the offset is a normal circular arc of the same type as
the parent arc. You can edit or alter it as needed, or even use it as the base
for another offset arc.

Ellipse
Drawing
Modes

PC Draft lets you draw two types of ellipses: diagonal and centered. The
two types of ellipses differ in the way they are created. You can use the
Ellipse pop-up menu to choose the method you want to use to create
ellipses.
To choose the method you want to use to create an ellipse:
1.

Point on the Ellipse icon on the Tool palette.

2.

Press down the left mouse button.

The Ellipse pop-up menu will appear.

3.

Holding down the left mouse
button, drag until the method you
want is highlighted.

4.

Release the left mouse button.

The icon representing the chosen method will appear inside the Ellipse icon
on the Tool palette.
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Creating
a Diagonal
Ellipse

When you create a diagonal ellipse, the ellipse is projected as you press
down on a starting point and drag to define the extent of the ellipse. (In
effect, you define a rectangle whose edges are tangent to the ellipse.)
To create a diagonal ellipse:
1.

Choose Diagonal from the Ellipse pop-up menu.

2.

Point where you want the starting point of the ellipse’s bounding rectangle to appear.

5.

Creating
a Centered
Ellipse

3.

Press down the left
mouse button.

4.

Holding down the left
mouse button, drag in
a diagonal direction
until the ellipse is the
size you want.

Release the left mouse button.

When you create a centered ellipse (an ellipse drawn from its center), you
first define the center point of the ellipse, then its overall size and shape.
The ellipse is projected from the specified center point.
To create a centered ellipse:
1.

Choose Centered from the Ellipse pop-up menu.

2.

Point where you want the ellipse’s center to appear.

5.

3.

Press down the left
mouse button.

4.

Holding down the left
mouse button, drag
until the ellipse is the
size you want.

Release the left mouse button.
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Constrained
Drawing Mode

If you hold the Shift key down while creating an ellipse, it will restrict the
shape of the ellipse to a circle.

Changing the
When using PC Draft, you change the size of an ellipse using the same
Size of an Ellipse technique you would use to change the size of a rectangle: dragging one of
the eight edit handles.
To change the size of an ellipse:
1. Return to the pointer mode.
2. Select the ellipse you want to resize.
3. Position the tip of the pointer on one of the edit handles.

6.

4.

Press down the left mouse
button.

5.

Holding down the left
mouse button, drag the
handle to a new location
on the drawing.

Release the left mouse button.

Unconstrained
Editing Mode

If you hold down the Control key while editing an ellipse, it will be
released from any active grid snap.

Polygon
Drawing
Modes

You can draw two types of multisided shapes: closed polygons and open
polylines.
A polygon is a closed object made of three or more sides. It can be a
complex, irregularly shaped object made up of many straight line segments.
A polyline is an open object made of at least two straight line segments.
The line segments used for either type of object can be any length and
oriented at any angle.
The type of multisided shape you draw depends on the item you choose
from the Polygon pop-up menu.
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To choose the polygon or the polyline mode:
Choosing the
Polygon or the
Polyline Drawing 1. Point on the Polygon icon on the Tool palette.
Mode
2.

Press down the left mouse button.

The Polygon pop-up menu will appear.

Drawing a
Polygon or a
Polyline

3.

Holding down the left mouse
button, drag until the Polygon or
Polyline icon is highlighted.

4.

Release the left mouse button.

To create a polygon or polyline, you merely move to the starting point you
want for the object; press the left mouse button; drag to create the first side;
then release the left mouse button. Then you move the cursor to the next
point and click. Continue moving and clicking until you have created the
shape you want for the object. If you make a mistake as you draw the
polygon, you can easily edit the last side drawn by using the Dynamic
Editing feature, detailed in the next section.
To draw a polygon or a polyline, follow these steps:
1.

Choose either Polygon or Polyline from the Polygon pop-up
menu.

2.

Place the cursor where you want to begin drawing the object.

3.

Press down the left mouse button.

4.

Holding down the left mouse button, drag until you have
created a line segment that is the length you want (the first side
of the object).
Creating and Editing Objects
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5.

Release the left mouse button.

6.

Without pressing the left mouse
button, move the cursor until the
second line segment is the length
you want.

7.

Click the left mouse button.

8.

Without pressing the left mouse
button, move the cursor until the
third line segment is the length you
want.

9.

Click the left mouse button.

Sometimes you may decide that you want to
change a line segment after you have clicked
the left mouse button to define its end point.
You can change the length and orientation of
the last line segment drawn by using the
Dynamic Editing feature.
10. If you want to change a line
segment, move the cursor back to
the last defined point and click on
it.
Once you have clicked on this point, the
previous line will reattach to the cursor,
allowing you to move the end of that older line
to a new position on the drawing.
11. Move the cursor to a new position
on the drawing and click the left
mouse button.

2 - 30

Creating and Editing Objects

Once you have clicked the left mouse button, the line will be drawn to the
new position, and you can then continue to draw the rest of the object.
12. Move the cursor to the next point, then click the left mouse
button twice quickly.

This double-click action completes
the object. If you are drawing a
polygon, PC Draft will automatically
close the object. The last point you
clicked on will be connected to the
starting point of the polygon by a
straight line, and the polygon will be
shaded with the current fill.

If you are drawing a polyline object,
however, PC Draft will leave the
object open and selected.

Constraining
Line Segments

If you press and hold down the Shift key as you are drawing a polygon or
polyline, the current line segment will snap at 45-degree angles.

Snapping Along
the Length

If you hold the Alt key down as you draw a polygon or polyline, the current
line segment will change by the increment controlled by the Set Grid
submenu.

Changing the
Shape of a
Polygon or a
Polyline

Polygons and polylines, like all objects, display handles when they are
selected. Unlike most objects, though, they have two different kinds of
handles: major, (the handles on the vertex points or corners) and minor,
(the handles in the middles of the line segments).
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The major handles are used to move the end points of lines, which could
change both the length and angle of the lines connected to that handle. The
minor handles are used to move a line segment without changing its length
or angle.

Using the Major
Handles

1.

Return to the pointer mode.

2.

Select the polygon or polyline you want to change.

3.

Position the tip of the pointer on one of the major handles.

4.

Press down the left mouse button.

5.

Holding down the left mouse button, drag the handle to a new
location on the drawing.

6.

Release the left mouse button.

As the following illustration shows, when you move the handle, the
connecting lines will follow. As soon as you release the left mouse button,
both lines will be redrawn to the new handle location.

Using the Minor
Handles

1. Position the tip of the pointer on one of the minor handles.
2.
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Press down the left mouse button.

Creating and Editing Objects

3.

Holding down the left
mouse button, drag the
line to a new location.

4.

Release the left mouse
button.

As you drag the minor handle, the line will also move. By using the minor
handles, you can move a line and still maintain its original length and angle.

Unconstrained
Editing Mode

If you hold down the Control key while editing a polygon or polyline, the
current handle will be released from any active grid snap.

Drawing a
Regular
Polygon

PC Draft’s Regular Polygon tool allows you to draw closed polygon figures
with sides and angles of equal length. You can preset the tool to draw
figures with from 3 to 16 sides.

Depending on which variation
of the tool you select, you can
draw a regular polygon from
edge to edge or vertex; center
to edge; vertex to vertex or
edge; center to vertex
(corner).

The number of sides can be set before drawing the object by holding down
the Alt key while clicking the Regular Polygon tool icon.
To draw a regular polygon:
1.

Choose the desired tool from the Regular Polygon pop-up
menu.
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2.

Press down where you want the
center, edge, or vertex of the
polygon.

3.

Holding down the left mouse
button, drag until the polygon
is the size you want.

Notice that when you release the left mouse button, the polygon is grouped
to itself. If necessary, you can use the Arrange menu’s Ungroup Control to
ungroup the polygon for reshaping, breaking, and so on. Changing fills and
line attributes and resizing can be performed while the object is still
grouped.

Optional
Constrained
Drawing Mode

If you hold the Shift key down as you are drawing a regular polygon, the
diameter or radius will snap at 45-degree angles.

Changing the
number of sides

To set the number of sides before drawing a regular polygon:
1.

Make sure that nothing is selected on the drawing.

2.

Press and hold down the Alt key.

3.

Click on the Regular Polygon icon on the Tool palette.

The Regular Polygon dialog box will appear.

4.
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Type the number of sides desired, then press the OK button.
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Using Parallel
Lines

PC Draft’s Parallel Lines tool allows you to draw single sets of parallel
lines or polygons and polylines with double lines. You can use parallel
lines to create drawings of such things as walls, beams, and frames.
There are three Alts associated with parallel lines. You can use parallel
lines to draw a single set of straight lines, polylines, or polygons. You
choose the type of shape you want to draw by using the Parallel Lines popup menu.
To choose the type of parallel line shape you want:
1.

Point on the Parallel Line icon on the Tool palette.

2.

Press down the left mouse button.

The Parallel Line pop-up menu will appear.

3.

4.

Holding down the left
mouse button, drag
until the type of shape
you want is highlighted.

Release the left mouse button.

An icon representing your choice will appear on the palette.

Drawing a Pair
of Parallel Lines

To draw a single set of parallel line segments:
1.

Choose the Single-Line icon from the Parallel Line pop-up
menu.

2.

Press down where you want the parallel lines to start.

3.

Holding down the left mouse button, drag until the lines are
the length you want.
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4.

Release the left mouse button.
Notice that when you release the left
mouse button, edit handles appear at
the ends of the shape. You can use
these handles to change the orientation and the length of the lines.

Constrained
Drawing Mode

If you hold down the Shift key while drawing a single set of parallel lines or
a polygon or polyline shape with double lines, the lines will snap at 45degree angles.

Snapping Along
the Length

If you hold the Alt key down as you draw a parallel line it will change by
the increment controlled by the Set Grid submenu.

Editing a Pair of
Parallel Lines

To edit parallel lines:

Specifying the
Alignment of
Parallel Lines
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1.

Return to the pointer mode.

2.

Select the parallel lines you want.

3.

Point on one of the edit handles.

4.

Press down the left mouse button.

5.

Holding down the left mouse button, drag in any direction
until the lines are the length you want and oriented the way
you want them.

6.

Release the left mouse button.

There are three alignment choices for parallel lines: left, center, and right.
Alignment controls how lines, polylines, and polygons are drawn and how
they can be edited. Specifically, the alignment option determine what the
leading edge is and what part of the shape is active. As an example of what
active means, when align left is the current option, the left line will be
drawn on the grid, and edit handles will appear on the left line when the
parallel lines are selected.
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To choose the alignment option you want to use to create parallel lines:
1.

Make sure that nothing is selected on the drawing.

2.

Press and hold down the Alt key.

3.

Click on the Parallel Lines icon on the Tool palette.

The Parallel Line Setup dialog box will appear.

The alignment option are represented by three icons at the top of the dialog
box. The small arrow indicates what part of the line is active.

Changing the
Alignment of
Existing Lines

4.

Release the Alt key.

5.

Click on the icon that represents the option you want.

To change the alignment of existing lines:
1.

Select the lines you want to change.

2.

Choose the alignment option you want from the Parallel Line
Setup dialog box.
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How the
Alignment
option Affect
Parallel Lines

Align Center
When Align Center is active, the cursor
appears between the lines during creation.
The center of the two lines will lie on the
grid. When the set of parallel lines is
selected, two edit handles will appear
between the ends of the lines.

Align Left
The Align Left option is used to specify
which of the parallel lines is active.
The active line is the one that lies on the
grid and is used to edit the parallel lines.
If you draw parallel lines while the Align
Left option is active, the active line is
determined by the direction you first drag
during the creation of the shape. In
general, if you drag up, the left line is
active; if you drag down, the right line is
active.

Align Right
As with Align Left, the Align Right option
determines which of the two lines is
active. When the Align Right option is
active, the direction in which you first
drag during creation determines which line
is active. In general, if you drag up, the
right line is active; if you drag down, the
left line is active.
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These general principles apply to polygons and polylines drawn with
parallel lines. This means that the active line in the object depends on what
the current alignment option is and the direction in which you initially drag
during creation.

Drawing
Polygons and
Polylines
With Parallel
Lines

The difference between a polygon and a polyline is that a polygon is a
closed object, and a polyline is an open object. When you draw a polygon
and specify the end of the object, PC Draft automatically closes the object
by drawing two line segments between the starting and ending points. If
you draw a polyline object, the object will remain open unless you close it
yourself.
To draw a polygon or a polyline, follow these steps:
1.

Make sure that nothing is selected on the drawing.

2.

Choose the alignment option you want from the Parallel Lines
Setup dialog box.

3.

Choose either Polygon or Polyline from the Parallel Line Setup
pop-up menu.

4.

Position the cursor where you want to begin drawing the
object.

5.

Press down the left mouse button.

6.

Holding down the left mouse button, drag until you have
created a side that is the length you want.

7.

Release the left mouse button.
8. Without pressing down the left
mouse button, move the cursor
until the second side is the length
you want.
9.

Click the left mouse button.

10. Without pressing the left mouse
button, move the cursor until the
third side is the length you want.
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11. Click the left mouse button
twice.

By double-clicking the left mouse button, you specify that the object is
complete.
The active alignment option determines how the parallel lines pivot around
each ending point. When you define the ending point for a side, the end
point of the active line (or the center of the two lines in the case of center
alignment) is used as the ending point of the side. The inactive line pivots
around the ending point, following the movement of the mouse.

Dynamic Editing
of Parallel
Polygons and
Polylines

As with normal polygons and polylines, you can edit parallel polygons and
polylines (that is, polygons and polylines drawn with parallel lines) during
creation.
To edit a parallel polygon or polyline during creation:
1.

Without pressing down the left mouse button, move the cursor
back to the last vertex point.

An edit handle will appear at the last defined vertex point to help you locate
it.
2.

Click the left mouse button.

The line segment will reattach to the cursor, and you can change the length
and angle of the line segment without having to redraw the entire object.
You can continue going back and clicking on previously defined vertex
points to edit the object.
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Editing Parallel
Polygons and
Polylines

You can edit parallel polygons and polylines the same way as you would
normal polygons and polylines. Both parallel polygons and polylines have
major and minor handles.
1.

Select the polygon or polyline object you want to change.

2a. Drag one of the major handles to change the lengths and angles
of two sides.
or,
2b. Drag one of the minor handles to change the position of a side
without changing its length and angle.

Specifying the
Distance
Between Parallel
Lines

You can specify the distance between parallel lines either before or after
you draw them. The values you enter for the distance are real-world values
that reflect the current size units. For example, suppose you were working
on a document in which Fractional Feet & Inches and the scale 1/4" = 1'
were currently defined. If you entered “6” as the distance, the distance
between the lines would represent 6 feet in the real world.
To specify the distance between parallel lines before you draw them:
1.

Make sure that nothing is selected on the drawing.

2.

Alt-click on the Parallel Line icon on the Tool palette.

The Parallel Lines Setup dialog box will appear.
3.

Double-click in the text box.

4.

Type the distance you want between the lines.

5.

Click the OK button.

6.

Click on the Parallel Line tool.

7.

Draw the parallel lines.
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Changing the
To change the distance between existing parallel lines:
Distance
Between Existing 1. Select the parallel lines you want to change.
Parallel Lines
2.

Specify the distance you want between the lines in the Parallel
Line Setup dialog box.

NOTE: You can use patterns and colors to fill the gap between parallel
lines. For instructions on how to do this, see the section titled “Filling the
Gap Between Parallel Lines” in Chapter 3.

Choosing End
You can draw a single set of parallel lines and polylines with butt end caps,
Caps for Parallel that is, with line segments between the end points of parallel lines. You can
Lines
choose to draw parallel lines with no end caps, with an end cap at either
end, or with end caps at both ends.

To Draw Parallel 1. Make sure that nothing is selected on your drawing.
Lines With End
2. Alt-click on the Parallel Lines icon on the Tool palette.
Caps
The Parallel Line Setup dialog box will appear.
3.

Click on the icon that represents the end cap option you want.

4.

Click on the OK button.

5.

Draw parallel lines

The following figures show how the end cap option affect the parallel lines
you draw.

Parallel lines drawn without end
caps.
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End caps at the starting end of
the parallel lines. (That is, the
end at which you pressed down
the left mouse button and started
to draw the lines.)

End caps at both ends of the
parallel lines. End caps at the
ending points of the lines. (That
is, the end at which you released
the left mouse button and
finished drawing the line.)

End caps at the starting end of
the parallel lines. (That is, the
end at which you pressed down
the left mouse button and started
to draw the lines.)

Changing End
To change the end caps on existing parallel lines:
Caps for Existing
1. Select the parallel lines you want to change.
Parallel Lines
2.

Drawing a
Parallel Polygon
or Polyline With
a Line Joint

Choose the end caps you want from the Parallel Line Setup
dialog box.

You can choose to draw polygons and polyline shapes that have line joints
at the corners. When you choose to draw polygons and polyline shapes with
line joints, PC Draft automatically draws a line between the inside and
outside lines where the sides meet. (This feature can be used to indicate
miter joints.)
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To draw parallel lines with line joints:
1.

Make sure that nothing is selected on the drawing.

2.

Alt-click on the Parallel Line icon on the Tool palette.

The Parallel Line Setup dialog box will appear.

3.

Click on the icon with
the line joint.

To draw parallel lines without line joints:
•

Click on the Plain Line icon.

To change the option for existing polygons or polylines:

Extruding
Parallel Lines

2 - 44

1.

Select the polygon or polyline you want to change.

2.

Click on either the Plain Line icon or the Line Joint icon in the
Parallel Line Setup dialog box.

PC Draft’s Parallel Extrude tool allows you to draw pairs of lines from
existing straight-edged objects, such as lines, rectangles, or polygons.
Although the extruded lines are actually separate line segments, they give
the appearance of parallel lines.
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Lines can be extruded from parallel-line objects, provided that the parallel
objects are first separated into single lines or polygons using the Break tool.
This is useful in adding interior walls to a floor plan, for example.

Both single lines and connected polylines can be extruded. The icons for
these tools are in the Tool palette’s Parallel Lines pop-out menu.

The attributes of extruded
lines (distance between lines,
alignment, and so on) are
controlled before drawing
using the same setup dialog
box as parallel lines.

Extruding Lines
from an Edge or
Line

To add extruded lines to a straight-edged object or line:
1.

Open the Tool palette’s Parallel Lines pop-out menu.
2.

Choose the single-line
extrude icon.
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3.

Place the cursor over the edge you wish to extrude from.

4.

Press the left mouse button and drag so that the extruded lines
reach the desired endpoint, then release the left mouse button.

The new extruded line segment pair will appear on the drawing.
The new segment pair is added to the earlier object as a pair of line segments. This makes the earlier object into either an open polyline (if you
started with a closed shape) or two open polylines (if you started with an
open shape).
NOTE: Holding down the Alt key will constrain the extrusion to be
perpendicular to the original edge and make its length snap to the currently
active grid-snap distance (see Chapter 6)

Extruding
Multiple Lines
(Polylines) from
an Edge or Line

Sometimes it’s necessary to add jointed segments to a figure. The Extrude
tools Polyline option allows this.
To add extruded polylines to an edge or line:
1.

Open the Tool palette’s Parallel Lines pop-out menu.

2.

Choose the polyline extrude
icon.

3.

Place the cursor over the edge you wish to extrude from.

4.

Press the left mouse button and drag so that the first extruded
segment reaches the desired point, then release the left mouse
button.

The first extruded segment will appear on the drawing.
5.
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Move the cursor to the next point, then click the left mouse
button.
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The next segment will appear.
6.

Repeat step 5 until you have all the segments you need, then
double-click the left mouse button.

The new extruded polyline will appear on the drawing.

Extruding Lines
from a Parallel
Object

To add extruded lines to a parallel-line object:
1.

Select the Parallel Line object.

2.

Choose the Accessory palette’s Break icon.

The parallel object will be broken apart into the appropriate single-line
figures.
3.

Open the Tool palette’s Parallel Lines pop-out menu.
4.

Choose the single-line extrude icon.

5.

Place the cursor over the edge you wish to extrude from.

6.

Press the left mouse button and drag so that the extruded lines
reach the desired endpoint, then release the left mouse button.

The new extruded line segment pair will appear on the drawing.

Extruding
Multiple Lines
(Polylines) from
a Parallel
Object

Sometimes it’s necessary to add jointed segments to a figure. The Extrude
tools Polyline option allows this.
To add extruded polylines to a parallel-line object:
1.

Select the Parallel Line object.

2.

Choose the Accessory palette’s Break icon.
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The parallel object will be broken apart into the appropriate single-line
figures.
3.

Open the Tool palette’s Parallel Lines pop-out menu.

4.

Choose the polyline extrude icon.

5.

Place the cursor over the edge you wish to extrude from.

6.

Press the left mouse button and drag so that the first extruded
segment reaches the desired point, then release the left mouse
button.

The first extruded segment will appear on the drawing.
7.

Move the cursor to the next point, then click the left mouse
button.

The next segment will appear.
8.

Repeat step 7 until you have all the segments you need, then
double-click the left mouse button.

The new extruded polyline will appear on the drawing.

Setting the
Parallel
Attributes of
Extruded
Lines

To set the parallel-line attributes before drawing an extruded segment pair:
1.

Make sure that nothing is selected on the drawing.

2.

Alt-click on the Parallel Line icon on the Tool palette.

The Parallel Line Setup dialog box will appear.
3.

Change the settings as needed.

4.

Click the OK button.

Any extruded lines you draw will now match the settings you just specified.
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The Marker
Symbol

PC Draft’s Marker Symbol tool lets you add a registration-type marker to a
drawing in one simple step.

You can select the Marker tool, then click on the drawing one or more times
to add as many markers as you need; each marker is centered on the point
where you click. You can exit the Marker Symbol mode by holding down
the Alt key and clicking on a blank area of the drawing, or by clicking the
Pointer tool in the Tool palette.
Once a marker symbol is drawn, it exists as a group. You can ungroup it
into a circle and two crossed lines.
To add Marker Symbols to a drawing:
1.

Select the Marker Symbol icon in the Tool palette.

2.

Place the cursor where you want the marker to appear on the
drawing, then click the left mouse button.

The marker symbol appears.

Drawing
Perpendicular
Lines

3.

If you want to add more markers, repeat step 2 as many times
as necessary.

4.

When you are done adding markers, click the Pointer icon or
hold down the Alt key and click on the drawing.

PC Draft has a tool for drawing lines perpendicular to existing lines or to
the edges of polygons, circles, circular arcs, or square-cornered rectangles.
Once a perpendicular line is drawn, it becomes a normal unconstrained line.
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You can edit and resize it, or even move it away from its original position if
necessary.
NOTE: The “anchoring” object for the perpendicular must be in place
before you choose the perpendicular tool. The end of the line can be at any
point on the drawing, even inside an object.
Drawing a perpendicular line from an existing object to a point includes two
steps: selecting the object, then clicking the point.
To draw a perpendicular line from an existing object:
1.

Choose the Perpendicular icon from the Special Line Tools
pop-up menu.

The cursor now reads
“Click Line/Arc”, to let
you know that you need
to select a line, circular
arc, or edge of an object.

2.

Click on the line or edge.

The cursor now reads
“Click Point”, meaning
that you need to select
an endpoint for the
perpendicular line.

3.
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Move the cursor to the point where you want the perpendicular to end.
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The perpendicular line’s starting point slides along the edge or line you
selected as you move the cursor.
NOTE: You can actually draw a perpendicular from a point not on the
original shape, but on an invisible line or circle extended from it.

4.

Click the left mouse button.

The perpendicular line is done.
As mentioned earlier, the perpendicular is a normal unconstrained line,
which you can edit or alter as needed. You can even use it as the base for a
new perpendicular line.

Snapping Along
the Length

If you hold the Alt key down as you draw a perpendicular line, it will
change by the increment controlled by the Set Grid submenu.
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Tangent Line
Tools

PC Draft has two ways to draw tangent lines from circles and circular arcs.
One tool draws a tangent from a circle or arc to any point outside the circle
or arc, and the other draws a tangent from one circle or arc to another. Both
of these tools are controlled by the Special Line Tools pop-up on the tool
palette.
You can specify how you want to draw tangents by choosing the option you
want from the Special Line Tools pop-up menu. Each tool gives you a
special cursor for selecting the objects you want the tangent drawn from.
Once a tangent is drawn, it becomes a normal unconstrained line. You can
edit and resize it, or even move it away from its original position if necessary.
NOTE: The circles or arcs for the tangent must be in place before you
choose a tangent tool.

To Choose a
Method for
Drawing
Tangents

1.

Point on the Special Line Tools icon in the Tool palette.

2.

Press down the left mouse button.
The Special Line Tools popup menu will appear.
3.

4.

Holding down the
left mouse button,
drag through the
menu until the
option you want is
highlighted.

Release the left mouse button.

The icon representing the method you have chosen — from a circle or arc to
any point, or from one circle or arc to another circle or arc— appears on the
Tool palette, and the cursor changes to let you know that you need to select
a circle or arc.
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Midpoint,
Endpoint and
Center Point
Lines

Three line tools in PC Draft are: Midpoint, Endpoint and Center line tools.
These enable lines to be drawn from the midpoint or endpoint of an existing
straight edge or circular arc, or from the center of an existing object. These
tools are located in the Special Line Tools popout in the Tool Palette.
Once a line is drawn with the Midpoint, Endpoint or Center line tool, it
becomes a normal unconstrained line and can be edited, resized and moved.
The Midpoint and Endpoint line tools can be used with straight edged
objects (lines, polylines, polygons and square-corner rectangles) and
circular arcs. Any of these objects can be part of a group.
The Center line tool can be used with any individual shape.
Midpoint, endpoint and center lines are drawn in the same way as perpendicular lines. See the User Guide for details.
NOTE: As with other line tools, the line being drawn can be constrained to
increments of the active grid snap by holding down the Alt key, or to 45º or
90º increments by holding down the Shift key while drawing.

Now available in PC Draft is the ability to snap the final points of line to the
midpoint or endpoint of an existing straight edge or circular arc, or to the
center of an existing object. This is done by holding down the "M," "E" or
"C" key while drawing a line.
The midpoint and endpoint snap keys, "M" and "E," can be used when
drawing lines to straight-edged objects (lines, polygons and square-corner
rectangles) and circular arcs.Any of these objects can be part of a group.
The center snap key, "C," can be used with any shape, including shapes
within groups except for text objects, dimension objects, and bitmaps or
pixel maps.
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Note: These snap keys work with any unconstrained lines, including lines
drawn with the Special Line popout's Center, Midpoint, Endpoint, or
Tangent-to-Point tools.
To draw a line to the midpoint of an existing edge, line, or arc;
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1.

Choose a line tool from the Tool Palette and begin drawing the
line.

2.

Press and hold down the "M" key. The cursor will read
"Mid?"

3.

Holding down the "M" key, bring the cursor near the desired
edge, arc, or line.

4.

The ghost "sketcher" line will snap to the midpoint of the
existing edge, near to the cursor.

5.

Finish the line by releasing the mouse button or by clicking
once
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6.

The line will appear on the drawing between the starting point
and the midpoint specified. The cursor will revert to the line
tool, enabling another line to be drawn if needed.

Draw a line to an endpoint of an existing edge, line, or arc or to the center
of an existing object in the same way, but holding down the "E" or "C" key
instead of the "M" key.

Drawing a
Tangent from a
Circle or Arc to
a Point

Drawing a tangent from a circle or arc to a point includes two steps:
selecting the object, then clicking the point.
Normally, the tangent will be drawn clockwise away from the arc or circle.
You can draw the tangent counterclockwise by holding down the Alt key
while clicking the tangent’s endpoint.
To draw a clockwise tangent from a circle or arc:
1.

Choose Tangent to Point from the Special Line Tools pop-up
menu.
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The cursor now reads “Click Circle/Arc,”
to let you know that you need to select a
circle or arc.

2.

Click on the circle or arc. (If the object has no fill, you need to
click its edge.)

The cursor now reads “Click Point,” meaning that you need to select an
endpoint for the tangent line.

3.

Move the cursor to the point where you want the tangent to
end.

The tangent’s starting point slides around the circle or arc as you move the
cursor.
NOTE: With an arc, you can actually draw a tangent from a point not on
the visible arc, but on its “invisible circle.”

4.
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Click the left mouse button.

Creating and Editing Objects

The tangent line is done.
To draw a counterclockwise tangent:
1.

Choose Tangent to Point from the Special Line Tools pop-up
menu.

The cursor now reads “Click Circle/Arc.”
2.

Click on the circle or arc. (If the object has no fill, you need to
click its edge.)

The cursor now reads “Click Point.”
3.

Press and hold the Alt key.

The prospective tangent now projects counterclockwise away from the
circle or arc.
4.

Still holding the Alt
key, move the cursor
to the point where you
want the tangent to
end.

5.

Click the left mouse
button.
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Drawing a
Tangent
Between
Circles or Arcs

Drawing a tangent from a circle or arc to another circle or arc includes two
steps: selecting the first object, then clicking the second object.
The tangent’s final position depends on which half of each object you click.
To draw a tangent from a circle or arc to another circle or arc:

1.

Choose Tangent Between
Objects from the Special Line
Tools pop-up menu.

The cursor now reads “1st Circle/Arc,” to let you know that you need to
select a circle or arc.

2.

Click the desired starting point on the circle or arc. (If the
object has no fill, you need to click its edge.)

The cursor now reads “2nd Circle/Arc,” meaning that you need to select
another object.

3.
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Move the cursor to the half of the other object where you want
the tangent to end, then click the left mouse button.
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Drawing
Offset Lines

With PC Draft’s Line Offset tool, you can create single lines parallel to
existing straight lines or edges. (To create parallel line objects, use the
Parallel Line tools, described earlier in this chapter.) The offset line will
have the same length, angle, line weight, line style, and pen model as the
original line or edge.

Offset lines can be created from any straight line or from any edge of a
polygon, polyline, or square-cornered rectangle. Once drawn, an offset line
is an independent straight line object that can be edited, moved, or otherwise manipulated as required.
The offset line’s distance from the original line or edge normally snaps to
the X-Y grid as you drag to an anchor point. You can override the grid and
constrain the offset’s perpendicular distance to even increments by holding
down the Alt key as you drag.
NOTE: The “parent” object for the offset line must be in place before you
choose the offset line tool.
Drawing an offset line from an existing object includes two steps: selecting
the source line or edge, then clicking to specify the offset distance.
To draw an offset line from an existing object:
1.

Choose the Offset Line icon from the Special Line Tools popout menu.
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The cursor now reads “Click
Line/Edge”, to let you know
that you need to select a line
or straight edge of an object.
2.

Click on the line or
edge.

The cursor now reads “Click Point” and appears near a dotted copy of the
source line, helping you locate the offset.
3.

Move the cursor to the point where you want the offset to lie.

4.

Click the left mouse button.

To exit the offset cursor mode, click the Pointer icon in the Tool Palette.
To draw an offset line constrained by the active grid snap:
1.

Choose the Offset Line icon from the Special Line Tools popup menu.

The cursor now reads “Click Line/Edge,” to let you know that you need to
select a line or straight edge.
2.

Click on the line or edge.

A dotted copy of the source line appears with the “Click Point” cursor.
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3 . Hold down the Alt key and move the cursor.
Movement will “snap” to grid increment distances away from the original
edge.
NOTE: If you want to change the increment, choose a different value from
the Layout menu’s Set Grid submenu.
4.

Click the left mouse button.

The offset line is done.
As mentioned earlier, the offset is a normal unconstrained line, which you
can edit or alter as needed. You can even use it as the base for a new offset
line.

Freehand
Drawing Modes

At times you may want to draw an object that has a shape different from
those provided for you in the Tool palette. For this reason, PC Draft lets
you draw four types of freehand objects: freehand lines, closed freehand
shapes, Bezier curves, and spline curves.
The Freehand Shape tool allows you to draw closed freehand objects.
When you use this tool, PC Draft draws a line connecting the starting and
ending points of the object, and fills the object with the current fill. If you
happen to make a mistake as you are drawing either type of freehand object,
you can erase it and then continue drawing.
A spline is a curve that is fitted to a series of defined points on your
drawing. With a spline curve, the curve passes through all the defined
points, or “control points.”
A Bezier curve is a curve that is defined by four control points. The curve
itself passes through only two of the control points. The two control points
that appear off the curve define the shape of the curve.
You can draw either an open freehand line, a closed freehand shape, a
spline curve, or a Bezier curve by first choosing the appropriate item from
the Freehand pop-up menu on the Tool palette.
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Choosing a
Freehand
Drawing Mode

To choose the type of freehand object (either an open freehand line, a closed
freehand shape, a Bezier curve, or a spline curve) you want to draw:
1.

Point on the Freehand icon on the Tool palette, then press
down the left mouse button.

The Freehand pop-up menu will appear.
2.

Choose a tool.

To Draw a
1. Choose the type of object from the pop-up menu.
Freehand Object
2.

Position the cursor where you want to begin drawing.

3.

Press down the left mouse button.

4.

Holding down the left mouse button, drag the cursor in any
direction, creating a line just as you would with a pencil.

5.

When you have completed the freehand line or shape, release
the left mouse button.

Open Freehand
Shape
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Closed Freehand
Shape

Dynamic Editing
of a Freehand
Object

If you are drawing a closed freehand, PC Draft will draw a line between the
starting and ending point of the object when you release the left mouse
button. If you are drawing an open freehand, PC Draft will leave the object
open.
When you are using a freehand drawing tool, you can erase portions of the
shape that you are drawing by using the Shift key. If you want to erase part
of a freehand object while you are drawing it:
1.

Continue to hold the left mouse button down, but stop drawing
the line by ceasing to move the mouse.

2.

Press and hold down the Shift key.

An inverted pencil with an eraser will appear at the end of your freehand
line.

3.

4.

Constrained
Drawing Mode

Using the
mouse to move
the eraser,
retrace the
portion of the
line that you
want to remove.

Release the Shift key to continue drawing the object.

The constrained drawing mode for a freehand tool allows you to draw
straight line segments as part of a freehand object. Each time you hold the
Alt key down, a straight line will be drawn from the point where you
initially press the key, to the point where you release it. To do this, follow
these steps:
1.

Choose the freehand drawing mode you want from the Freehand pop-up menu.
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2.

Start drawing the object.

3.

Press down the Alt key.

4.

Holding down the Alt key, drag the cursor in any direction
until you have created a straight line that is the length you
want.

5.

Release the
Alt key.

Changing the
You can drag the edit handles on a freehand object to change its shape.
Shape of a
Freehand Object To change the shape of a freehand object:
1.

Return to the pointer mode.

2.

Select the freehand object you want to change by clicking on it.

3.

Position the tip of the pointer on one of its edit handles.

4.

Press down the left mouse button.
5.

Holding down the left
mouse button, drag the
handle until you have
created the shape you
want.

6.

Release the left mouse
button.

Continue to move each handle until you have obtained the shape that you
want.
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Choosing Curve
Tools

To choose the type of curve you want to draw:
1.

Point on the Freehand icon on the Tool palette.

2.

Press down the left mouse button.

The Freehand pop-up menu will appear.
3.

Drag until either Spline or Bezier is highlighted.

4.

Release the left mouse button.

An icon representing the chosen type of curve will appear on the palette.

Spline Curves

PC Draft lets you draw a type of curve that passes through a series of
defined points on your drawing. This type of object, called a spline, allows
you to pick a series of points on a drawing and fit a curve to the points.
To draw a spline:
1.

Choose Spline from the Freehand pop-up menu.

2.

Position the cursor where you want the spline to start on your
drawing.

3.

Press down the left mouse button.

4.

Holding down the left mouse button, drag until you reach one
of the points through which you want the curve to pass.

5.

Release the left mouse button.

A straight line will appear between the starting point and the cursor to show
you the slope of the curve segment.
6.

Without pressing down
the left mouse button,
move the cursor to the
next point you want the
curve to pass through
and click the left mouse
button.
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A curve will be fitted to the three points defined so far.
7.

8.

Continue moving the
cursor and clicking the
left mouse button until
you have defined all the
points to be fitted.

When you reach the last point, double-click the left mouse
button.
The completed spline curve will
appear. It will contain the current
fill, and edit handles will appear
on the control points you used to
define it.

To view the curve as you are defining end points:
1.

After you have defined the first and second control points,
move the cursor close to the next point, as described above.

2.

Instead of clicking the left mouse button, press it down.

3.

While holding down the left mouse button, drag to where you
want the next control point to appear.

When you press down the left mouse button, the curve segment will be
projected on the screen. By dragging instead of clicking, you can see the
shape and length of the curve as you draw it.
4.

Release the left mouse button.

To make the spline a closed object:
•
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Double-click on the starting point.
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Changing the
Shape of Splines

You can change the shape of a spline by dragging its control points.
To change the shape of a spline:
1.

Select the spline you want to edit.

2.

Point on one of the edit handles. (The edit handles represent
the control points that were used to define the curve.)

3.

Press down the left mouse button.

4.

Holding down the left mouse button, drag to reposition the
control point and modify the curve.

5.

When the curve is the shape you want, release the left mouse
button.

You can use the Add/Delete Handle function to add and delete handles on a
spline. (See the section “Adding and Deleting Handles” in this chapter for
details.)

Bezier Curves

PC Draft allows you to draw Bezier curves using the Bezier curve tool.
Bezier curves give you a great deal of flexibility in creating original designs
that feature elegant S-shapes and loops.
A Bezier curve is a type of curve defined at each vertex by four points,
called “control points.” Two control points define the end points of the
curve, the other control points define the direction in which the curve is
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projected. When you select a Bezier curve, the four control points are
represented by edit handles on the screen: two handles appear on the end
points of the curve, and two middle handles appear on either side of the
curve. The two handles on the end points are called “end point handles,”
and the other two handles are called “direction point handles.” You can
move the handles to modify and change the size of the Bezier curve.

When you create a Bezier curve, direction lines are used to indicate the
slope and direction of the curves you draw. A direction line is a line
between two direction control points that is tangent to an end point.
You can draw a series of Bezier curves using the Bezier curve tool. Each
individual curve actually passes through only the two end control points.
The direction lines define the overall shape of the curve. When you draw a
series of curves, the curves are connected at “joints,” or end control points
that are shared by two curves.

Creating Bezier
Curves

To create a Bezier curve:
1.

Choose Bezier from the Freehand pop-up menu.

2.

Point where you want the curve to begin.

3.

Press down the left mouse button.

This defines the first end control point of the curve.
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4.

Holding down
the left mouse
button, drag in
the direction
you want to
project the
curve.

A line with two handles will be projected in opposite directions from the
curve’s beginning point. This line is called a “direction line.” One of the
handles will be attached to the cursor. By dragging the handle, you indicate
the direction and slope of the curve. For example, if you drag the handle
down all the way to the lower right corner of the screen, a curve sloping
toward the lower right corner will result.
5.

Release the left mouse button.

The point at which you release the left mouse button defines the first
direction point.
6.

Without pressing down the left mouse button, move the pointer
to where you want the second end control point to appear.

7.

Press down the left mouse button.

8.

Holding down the left mouse button, drag to define the curve’s
second direction point, as well as the first direction point of the
next curve.

The first direction point of the next curve is associated with the handle
attached to the cursor. The second direction point of the first curve is
associated with the handle at the opposite end of the direction line.
As you drag, the curve will appear on the screen. The curve’s shape will
change as you define the second direction point.
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9.

Release the left mouse button.

With PC Draft, you can join a series of Bezier curves together. The curves
are joined at the end points. When you define the second direction point for
a curve, you also define the first direction point of the next curve you draw.
If you want to draw just one curve:
10. Click once on the final point you want included on the curve.
11. Drag to the place where you want the control handle for the
curve’s final point, then double-click the left mouse button.
If you want to continue drawing curves, repeat steps six through nine,
described above.
When you want to complete a Bezier curve, after you have created at least
one, complete curve:
1.

Click once on the final point you want included on the curve.

2.

Drag to the place where you want the control handle for the
curve’s final point, then double-click the left mouse button.

Notice that the last point on the curve is defined by the second-to-last point
you click on; when you complete the curve by double-clicking, the point
where you double-click defines the control handle, not a point on the curve
itself.
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Drawing Straight You can also draw straight lines in the midst of Bezier curves by clicking
Line Segments
instead of dragging.
To create a straight line segment after you have drawn at least one complete
curve and you are still in the Bezier curve drawing mode:
1.

Without pressing down the left mouse button, move the cursor.

2.

Click the left mouse button.

The resulting line will be curved, but the next line will be straight.
3.

Without pressing down the left mouse button, move the cursor
to where you want the end point of the line to appear.

4.

Click the left mouse button.

Continue moving the cursor and clicking the left mouse button to create a
series of straight line segments.
You can create unique designs by dragging the edit handles to modify the
Bezier curve. Edit handles appear on Bezier curves that are selected. When
you move the end point handles, you drag part of the curve along with the
handle. When you drag a direction handle, it exerts a “pull” on the curve
closest to it.
To select a Bezier curve:
1.

Return to the pointer mode.

2.

Position the tip of the pointer on the curve you want to change.

3.

Click the left mouse button.

Edit handles will appear on the selected curve.
To move the end point handles:
1.

Point on one of the end point handles on the Bezier curve.

2.

Press down the left mouse button.
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3.

Holding down the left mouse button, drag the handle to a
different point on the drawing.

4.

Release the
left mouse
button.

The end of the curve will follow the movement of the handle.
To move the direction handles:
1.

Point on one of the direction handles.

2.

Press down the left mouse button.

3.

Holding down the left mouse button, drag until the curve is the
shape you want.

4.

Release the left mouse button.

As you drag, the curve will be reshaped.
When you move a direction handle, the curve may come to a sharp corner at
that point. To keep the curve smooth, you can constrain the direction
handles so that each pair will move in concert. Pressing the Shift key will
produce this constraint.
To constrain the direction handles:

2 - 72

1.

Press and hold the Shift key.

2.

While holding the Shift key, point on one of the direction
handles.

3.

Press down the left mouse button.
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4.

Holding down the left mouse button and the Shift key, drag
until the curve is the shape you want.

The direction handle and its opposite will pivot around the handle on the
curve.
5.

Release the left mouse button and the Shift key.

NOTES: When you constrain with the Shift key and drag an edit handle on
a joint (that is, a point at which two end points meet), you change the shape
of the two curves controlled by that end control point and its opposite.
When you drag an edit handle on the end point of a straight line segment,
you reshape the straight line segment, causing it to become curved.
You can create sharp corners on a Bezier curve by pulling both direction
handles to one side, or by dragging the direction handles of a direction line
on top of an end control point.

Reshaping
Objects

There may be occasions when you want to reshape an object from straight
lines and sharp corners to curved lines and rounded corners, the straight
lines of an object to smooth lines, or vice versa. You can accomplish this
conversion by using the Reshape submenu in the Edit menu.
The objects that the Reshape Control can modify include polygons,
polylines, and freehand shapes.
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To reshape an object:
1.

Select the object you want to reshape.

2.

Open the Edit menu and drag until Reshape is
highlighted.

The Reshape submenu will appear.

3.

Select Smooth or Unsmooth (detailed explanations of the
choices follow).

4. Release the left mouse button.
After you make your choice, the object will be reshaped. You can edit the
reshaped object by using the edit handles.

Reshape Option

The Reshape Control’s Smooth and Unsmooth Options affect different
shapes in different ways.
A freehand can be smoothed to a curve that lies close to the original object,
passing near the original vertices (the new edit handles appear at the old
vertices). In addition, this new curve can be smoothed repeatedly until the
desired effect is obtained.

NOTE: With freehand objects that include sharp points, you can often get
good results by deleting or adding handles before smoothing. See the
section “Adding and Deleting Handles” in this section.
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A polygon can be smoothed to a curve that lies
inside the original object (intersecting the
midpoints of each line segment). When the
smoothed polygon is selected, its original shape
appears as a ghost outline.
A polyline can be smoothed to a curve that intersects the midpoints of each
line segment of the original object, except for the segments closest to the
ends. That is, the curve will skip over the first and last midpoints of the
original polyline.

NOTE: A polygon or polyline can be smoothed only once.

Editing an
Object’s Datum
Point

Each object in PC Draft has a datum point, which is a reference point used
when you paste the object, rotate it, or manipulate it in other ways. PC
Draft lets you change the location of the datum point for any object.
Each type of object has a default datum point. For example, the default
datum point for a rectangle is the upper left vertex.

Creating and Editing Objects

2 - 75

Assigning a New
Datum Point to
an Object

The default datum point for a grouped object is the default datum point of
the element farthest back in the stacking order.
To assign a new datum point to an object:
1.

Select the object to which you want to assign a new datum
point.

2.

Open the Edit menu and choose Edit Datum.

An “X” marker representing the datum point will appear, and the cursor will
change to the Edit Datum cursor.

3.

Click anywhere inside the bounding box (represented by the
object’s edit handles) to define the new datum point.

The X marker will appear where you clicked to mark the new datum point.
To place the datum point in the center of the object:
•

Open the Edit menu and choose Center Datum.

NOTE: The object’s center is defined as the center of the object’s “extent.”
The extent is the overall size of the object.
To exit from the Edit Datum mode:
•

2 - 76

Click on any tool icon in Tool palette, or hold down the Control
key and click the left mouse button.
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TECHNICAL NOTE: If you click near a vertex point (that is, a point
where two edges meet, such as a corner), the X marker will snap to that
vertex. You can place a datum point anywhere within the bounding box
defined by an object’s or group’s extent. However, a datum point located at
the center of the object or on a vertex point has some special attributes of
which you should be aware. Such a “fixed datum point” retains the same
relative position on the object even if you reshape or resize the object.
However, if you resize an object with a “free datum point” (a datum point
that doesn’t appear at a vertex or the center of an object) so that the datum
point’s old position is outside the object’s new bounding box, the datum
point will revert to the default position within the object or the group.
For example, suppose you assign a fixed datum point to the lower right
vertex on a rectangle. You then reshape the rectangle by dragging the
handle associated with the lower right vertex toward the upper left corner of
the drawing, as shown in the following figure.

Since a fixed datum point was assigned to the lower right vertex, the datum
point will still appear on the lower right vertex.
However, suppose you assign a free datum point near the lower right corner
of the rectangle, but not on a vertex point. In this case, if you reshape the
rectangle as in the above example, the datum point on the object on the
drawing will revert to the default datum point for rectangles, which is the
upper left vertex. The datum point will revert to its default position because
the reshape operation moved the free datum point outside the object’s
bounding box.
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Rotate 90° Tool

The PC Draft Tool Palette now includes a Rotate by 90°tool:

Select an object in the PC Draft drawing then click on the Rotate 90° tool.
The object will be rotated 90° anti-clockwise around its center.
Select the object again, hold down the Alt key, and click on the Rotate 90°

tool. The object will be rotated 90° anti-clockwise around its datum point.
(In this example, the object’s datum point is on the point of the shape.)
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The Resize
Palette

In addition to the manual resizing possible when you drag an object’s edit
handles, PC Draft includes a method for resizing objects by typing exact
size values. This gives you more precise control over the size of objects on
your drawing.
Keyboard resizing is controlled from the Resize palette. You can display the
Resize palette using the View menu’s Palette submenu. The Resize palette
can remain visible indefinitely, and can be dragged anywhere on screen as
needed, displaying the size values of the currently selected object.
Different types of objects are resized in different ways. For example, you
can resize a rectangle by specifying the exact height and width of the
rectangle, whereas resizing an arc includes entering various angle values
and a radius length.
As you select different objects, the types of values displayed in the Resize
palette will change automatically to match your selections.
For most objects, there are two approaches to keyboard resizing: you can
enter the values for the whole object, or select a point on the object,
specifying either that the point will be shifted by the changed values or that
the point will be moved to a specific drawing location. The effects the two
different methods each have on different object types are detailed on
following pages.
In general terms, to resize an object by changing its size values:
1.

Open the View menu’s Palettes submenu and choose Resize.

The Resize palette will appear. If an object or group is selected, the palette
will display the current size of the object; if nothing is selected, the palette
will not show any values.
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2.

If necessary, select the object you want to resize.

3.

Enter the new size values (such as Height or Width) you want
for the object.

4.

Click on the Apply button.

The new size will be applied to the object.
To resize an object by editing a single edit handle
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1.

Make sure the Resize palette is displayed.

2.

If necessary, select the object you want to resize.
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4. Click the Select Point button.
A special gunshot cursor will appear on the drawing.

5.

Click the cursor on the point (edit handle) you want to resize.

The Resize palette will display either the location of the point or the size
values for the object.
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6.

Enter the new values or location for that edit handle in the
Resize palette, then click the Apply button.

The new values or location will be applied to that edit handle, resizing the
object.

NOTE: If the resize operation requires the object to be enlarged beyond the
drawing area, a system beep will sound and an alert wil appear..
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Object Types
and the Resize
Palette

This section describes the resizing option for the various types of objects
and the information you can enter to resize each type of object.
NOTE: If you select multiple objects, the Resize palette will reflect (and
affect) the object selected most recently.

Lines and
Parallel Lines

Length & Angle

Changes the desired length and angle of the line. The specified angle is
measured relative to the X-axis, and the last point drawn on the line — the
“finishing point” — will normally be the one that moves.

Select Point

Enables you to select which endpoint of the line will move when you apply
a new length or angle value.
NOTE: If you change the angle of a constrained line, it will become an
unconstrained line.
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Square-Corner
Rectangles

Width &
Height

Change the width and height of a rectangle. For example, to enlarge a 1" x
1" rectangle to 3" x 3", enter 3" in both fields. A diagonally drawn rectangle
will normally resize by shifting its bottom edge or right-hand edge (or
both).

Select Point

Enables you to select which edge or corner of the rectangle will move when
you apply a new width or height (or both). For example, if you click Select
Pt, then select the rectangle’s top middle handle, then enter a new height,
the top edge will move up.

Groups

Percent
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Change size of the group proportionally by percentage. Values larger than
100% will increase its size; values smaller than 100% will reduce it.
Normally, the lower right corner will move as the group becomes larger or
smaller.
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Select Point

Enables you to select which corner of the group will move when you apply
a new percentage. For example, if you click Select Pt, then select the
group’s top left handle, then enter 200%, the top edge will move up and the
left edge will move left.
NOTE: Bitmap and pixel map objects can be made “palette resizable” by
grouping them to themselves. For example, if you paste in a bitmap or load
in a TIFF image, you can make it proportionally resizable by selecting it,
then choosing Group.

Rounded-Corner
Rectangles
(Proportional
and Constant)

Width, Height,
& Radius

Change the width and height, as with square-corner rectangles, and the
radius of the corner arc. Normally, the width and height values will resize
the rectangle by shifting its bottom edge or right-hand edge (or both).

Select Point

Enables you to select which edge or corner of the rectangle will move when
you apply a new width or height (or both). For example, if you click Select
Pt, then select the rectangle’s top middle handle, then enter a new height,
the top edge will move up.
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Elliptical-Corner
Rectangles

Width, Height,
X-Radius,
& Y-Radius

Change the width and height, as with square-corner rectangles, and the
vertical and horizontal radii of the elliptical corner arc. Normally, the width
and height values will resize the rectangle by shifting its bottom edge or
right-hand edge (or both).

Select Point

Enables you to select which edge or corner of the rectangle will move when
you apply a new width or height (or both). For example, if you click Select
Pt, then select the rectangle’s top middle handle, then enter a new height,
the top edge will move up.

Circles Drawn by
Diameter or
Radius
Diameter &
Radius
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Change the diameter or radius of the circle. A circle drawn by diameter will
normally move the last point drawn, as with rectangles; a circle drawn by
radius will normally change size so that its center doesn’t move.
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Select Point

Changes the radius or diameter distance for the selected handle. For
example, if you click Select Pt, then select a radial circle’s center handle,
then enter a new radius, the center handle will move as the circle assumes
its new size.

Circle Drawn by
Three Points

X&Y
Locations

Change the X and Y coordinates for the circle’s three edit handles. The
absolute coordinates you specify are measured from the zero origins of the
rulers.

Select Point

Same effect.
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Ellipse

Width &
Height

Change the width and height of an ellipse. A diagonally drawn ellipse will
normally resize by shifting its bottom right edit handle.

Select Point

Enables you to select which corners of the ellipse will move when you
apply a new width or height (or both). For example, if you click Select Pt,
then select the ellipse’s top middle handle, then enter a new height, the top
will move up.

Arcs Drawn by
Radius

1st A°
End A°
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Change the angle of the arc’s starting point, measured in relation to the Xaxis.
Change the angle of the arc’s ending point, measured in relation to the Xaxis.
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Radius

Change the radius of the arc.

Select Point

Same effect.

Arcs Drawn by
Three Points

X&Y
Locations

Change the X and Y coordinates for the arc’s three edit handles. The
absolute coordinates you specify are measured from the zero origins of the
rulers.

Select Point

Same effect.

Elliptical Arcs
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1st A°

Change the angle of the arc’s starting point, measured in relation to the Xaxis.

End A°

Change the angle of the arc’s ending point, measured in relation to the Xaxis.
Change the horizontal or vertical radius of the arc.

Select Point

Same effect.

Polygons and
Polylines
(including
Parallel
Polygons)
Freehands, and
Curves

Because of the complexity of these objects, you can only edit them using
the Select Point cursor.

For example, if an object has a half-dozen or more edit handles, each handle
cannot be shown in the Resize palette. Instead, you use the Select Point
button to select a single handle, then give it a new absolute location on the
drawing.
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Select Point

Change the X and Y coordinates of the location where you want the
selected handle to appear. The coordinate values are measured from the zero
origins of the rulers.
NOTE: The Resize palette treats the direction handles on Bezier curve
objects like any other edit handles.

Metapolygons

Metapolygons are the objects created when you use the Add, Subtract, or
Attach Controls to combine objects with different types of edges. You can
only resize them proportionally.
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Percentage

Changes the size of the metapolygon proportionally by a percentage of its
current size. Absolute values larger than 100% or positive relative values
will increase its size; absolute values smaller than 100% or negative relative
values will reduce it. Normally, the lower right corner will move as the
metapolygon becomes larger or smaller.

Width and
Height

Changes the width and height of the metapolygon. A metapolygon will
normally resize by shifting its bottom edge or right edge (or both).

Select Point

Enables you to select which corner of the metapolygons bounding frame
will move when you resize it. For example: if you click Select Pt and select
the metapolygon’s top left handle, then enter an absolute percentage value
of 200%, the top edge will move up and the left edge will move left.

Linear and
Radial
Dimensions

Length

Change length of the dimension object. Normally, the first reference point
(the left end of a diameter or the center of a radius) will remain fixed.

Select Point

Enables you to select which reference point will move when you apply a
new length.
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Angular
Dimensions

1st A°
End A°

Change the angle of the dimension’s starting point, measured in relation to
the X-axis.
Change the angle of the dimension’s ending point, measured in relation to
the X-axis.

Radius

Change the radius of the dimension object.

Select Point

Same effect.

Resize Units

The Resize palette uses the scale and units of the current layer. When you
select an object with the Resize palette visible, the values shown will be to
scale. When you enter values to resize an object, you should use values
appropriate to the current scale.
WARNING: If you enter unscaled units in a scaled drawing (for example, a
width “ 4" ” in a 1/8"=1' drawing), you may get unexpected results (in that
example, the four inches would appear in the drawing as 1/24 of an inch on
screen and on paper).
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If you don’t specify units with the values you enter, PC Draft will interpret
the values according to the document’s current size units. (You set the size
units using the Document Scale & Units dialog box).
Below are some examples of valid size and coordinate entries for some of
the available types of size units.
Decimal Feet and Inches
12.0'
110.3'
10'
10 in
12.3 is interpreted as 12.3'
Fractional Feet & Inches
23" = 1’11"
1' 10-3/8"

1 3/4"

Fractional Inches
1"
1/2

123-3/4"15 1/2
2-1/4

You can enter values greater than 12 inches if fractional inches are the
current size units.

Moving Using
The Resize
Palette
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The Resize Palette has two modes, Normal and Expanded. When the palette
is Expanded, it can be used to move a single object or group within the
current active layer. Expand the palette by clicking on the Expand/Contract
box at the top right of the palette.
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The Resize palette’s Position X and Y fields move the selected object or
group to an absolute position on the drawing or by relative horizontal and
vertical distances. All movement is defined in the units and scale of the
active layer.
Set the mode to relative or absolute by clicking on the Relative or Absolute
button at the top of the palette. Change a selection’s position by entering
values in the Position X and Y fields, then clicking Apply or pressing the
Enter key.
For relative movement, positive distance values will move items to the right
(in the ∆X field) or downward (in the ∆Y field). Negative values will move
items to the left or upward.

Moving Using
The Arrow Keys

Selected objects and groups can be moved using the arrow keys on the
keyboard. When a grid is active (see Chapter Six of the User Guide), each
press of an arrow key will move (or “nudge”) the current selection one grid
increment in the appropriate direction: left, right, up, or down. If no grid is
active, the selection will move one screen pixel (1/72 of an inch) for each
keystroke. Hold down the Control key and press an arrow key to release the
selection from an active grid and allow the selection to be moved one pixel
at a time.
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Expanding and
Contracting
Objects

All PC Draft objects can be increased or reduced in size by multiplying or
dividing the object’s dimensions by speciﬁed values. You can choose
whether or not to maintain the object’s proportions. The Expand and
Contract commands in the Edit menu are used to resize objects in this way.
To resize an object using the Expand command:
1.
2.

Expanding

Select the object to be expanded.
Select Expand from the Edit menu.

The Expand dialog displays.

3.
4.
5.

To maintain the object’s proportions, ensure that the Linked
checkbox is checked.
To change the object’s proportions, uncheck the Linked
checkbox.
Enter a value to multiply the X dimension of the object by.

NOTE: If the Linked checkbox is checked, the same value will
automatically be entered in the Y ﬁeld.
6.
7.
8.

Enter a different value to multiply the Y dimension of the
object by, if necessary.
Click on the OK button.
The dimensions of the object are multiplied by the speciﬁed
values and the object is expanded around its center point.

NOTE: The screen shot below shows a copy of the original shape in front of
the expanded shape.
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Contracting

To resize an object using the Contract command:
1.
2.

Select the object to be contracted.
Select Contract from the Edit menu.

The Contract dialog displays.

3.
4.
5.

To maintain the object’s proportions, ensure that the Linked
checkbox is checked.
To change the object’s proportions, uncheck the Linked
checkbox.
Enter a value to divide the X dimension of the object by.

NOTE: If the Linked checkbox is checked, the same value will
automatically be entered in the Y ﬁeld.
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6.
7.
8.

Enter a different value to divide the Y dimension of the object
by, if necessary.
Click on the OK button.
The dimensions of the object are divided by the speciﬁed
values and the object con-tracts around its center point.

NOTE: The screen shot below shows a copy of the original shape behind
the contracted shape.
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The Accesory
Palette

Contains Editing and objects manipulation functions. There are tools to
create fillets and chamfers, add handles to objects, break objects into their
edges, extend lines to their intersections, and automatically trim lines that
overlap. This palette also provides many advanced tools such as the attach
function, merge objects, cut, mirror, etc.

Extending Lines
to Intersection
Points

PC Draft allows you to extend selected lines to various points on your
drawing. You have a number of option when you use the Extend function.
You can extend two non-parallel lines to the point where they intersect; you
can extend lines to make them intersect with a reference line; and you can
extend lines to make them intersect with an existing, non-parallel line.

Extending Two
Lines to a
Common
Intersection
Point

To extend two lines to a common intersection point:

1. Select the two non-parallel
lines that you want to extend.
2. Click on the Extend tool on the
Accessory palette.
The two lines will be projected to the
point at which they intersect.

In some cases, one line might be
perpendicular to the other, and the
logical operation is to extend one line
toward the other. In such cases, PC
Draft will extend one line and not the
other.
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NOTE: If you select more than two lines and click on the Extend icon, a
dialog box will appear. The dialog box allows you to extend lines toward a
reference line or an existing line on the drawing. These option are
discussed in the following pages.

Extending Lines
Toward a
Reference Line

You can select lines on a drawing, then define an imaginary reference line
to which you want to extend the lines. The lines to be extended can be
parallel.
To extend lines to a reference line:
1.

Select the lines you want to extend.

2.

Hold down the Alt key.

(If more than two lines are selected, holding down the Alt key is not
necessary.)
3.

Click on the Extend icon on the Accessory palette.

A dialog box will appear.
“A reference line” will already be selected as the default option.
4.

Release the Alt key.
5. Click on
the Extend
button.
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The dialog box will close and a cursor will appear.

7.

Without pressing down the left mouse button, move the cursor
to the first point used to define the reference line.

If you move the cursor beyond the borders of the drawing area, the drawing
will automatically scroll.
8.

Press down the left mouse button.

A reference line will appear.
9.

Holding down the left mouse button, drag to define the
reference line.

If you hold down the Shift key while you drag, the line will snap in 45degree increments.
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10. Once the reference line is where you want it, release the left
mouse button.

When you release the left mouse button, the lines will be projected toward
the reference line, and the reference line will disapper.

Extending Lines
Toward an
Existing Line on
Your Drawing

You can also extend selected lines toward an existing line on a drawing.
The lines to be extended can be parallel to each other.
To extend lines toward an existing line on your drawing:
1.

Select the lines you want to extend.

2. Press and hold down
the Alt key.
3. Click on the Extend
icon on the Accessory
palette.
A dialog box will appear.
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4.

Release the Alt key.

5.

Click on the button beside “An existing line.”

6.

Click on the Extend button.

7.

Without pressing down the left mouse button, position the tip
of the pointer on the line to which you want the selected lines
extended.
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8.

Click the left mouse button.

PC Draft will interpret the line you clicked on as being infinite in length and
extend the selected lines toward it

With lines, rectangles, polygons, polylines, freehand shapes, Bezier curves,
Adding and
Deleting Handles and spline curves, you can add and delete handles. (Handles are associated
with edges—line segments—and vertex points. A vertex point is a point at
which two edges meet.) Often, adding or deleting handles before a reshape
operation can give greater control over the shape of the resulting object.

Adding a Handle To add a handle to a polygon or freehand:
1.

Click the Add/Delete Handle icon in the Accessory palette.

The cursor will turn into an arrow pointer with a plus sign attached to it.
This shows you that you are in the Add Handle mode.
2.

Position the tip of the pointer on the object’s border where you
want a new handle to appear.

3.

Click the left mouse button.

A new handle will appear on the object where you clicked.
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You can drag the handle associated with the new vertex to reshape the
object, just as you would any other handle.
When you add a handle to a polygon or a polyline, a minor (midpoint)
handle will also be added.

Deleting a
Handle

You can also delete handles from an object. Sometimes this, too, is a useful
action before smoothing an object. When you delete a handle, the handle
will disappear and a straight line (or a curve) will be drawn between the two
handles that were closest to the deleted handle.
To delete a handle:
1.

Click the Add/Delete Handle icon in the Accessory palette.

2.

Press and hold down the Alt key.

A minus sign will appear on the pointer to show you that you are in the
delete handle mode.
3. Position the tip of the
pointer on the handle
you want to delete,
then click the left
mouse button.

The handle will be deleted.
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The Attach Tool

The Attach tool, found on the Accessory palette, enables you to join the
edges of open objects together at their end points. For example, you can
draw any combination of lines, polylines, open freehands, curve objects, or
arcs, then arrange them so their endpoints coincide one after another, and
finally attach them together to form a single open or closed object.

You can apply a single fill, line weight, line style, or set of object
information to the new “attached” object.
If the edges of the combined objects are all straight line segments, the new
object will be an ordinary polygon. If any of the edges are curved, the new
object will be a “metapolygon.” Metapolygons can only be resized
proportionally, by dragging their corner edit handles or with the Resize
palette.
You can break a selected object into its separate edges with the Break tool.
NOTE: To align the objects to be attached together, the Snap to Object
function can be helpful. The Snap To Object function allows you to align
the vertex points of objects as you draw them. It also allows you to
reposition the vertex points of objects so the vertex points coincide. When
you reposition (drag) vertex points, the object is normally resized. However,
if you want to align existing objects without having to resize them, you can
press and hold down the Alt key, press down the left mouse button on the
vertex point of an object, and then drag the vertex point to another vertex
point. This allows you to align the vertex points of existing objects without
having to resize the objects.
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The objects to be attached together must be open. For example, you cannot
attach two rectangles together. (Closed objects such as rectangles, polygons,
or circles can be combined using the Add tool.)
To attach open objects together:
1.

Align the vertex points of the objects you want to attach
together.

(Notice that edit handles are not displayed on the vertex points that overlap.
This shows that the vertex points are aligned.)
2.

Click on the Attach icon on the Accessory palette.

Once you click on the Attach icon, the objects will be joined together. You
can then fill the new composite object.
If the new object has all straight edges, it will be an ordinary polygon and
you can resize it by dragging any of its edit handles. If the new object is a
metapolygon (with any curved edges), you can only resize it proportionally
by dragging a corner edit handle, but you can change any of its fill and line
attributes or apply object information to it.

Breaking Objects You can separate some PC Draft objects into simpler objects using the
Accessory palette’s Break tool. Rectangles, polygons and polylines, spline
or Bezier curve shapes, parallel-line objects, and dimension objects can all
be broken as detailed in the following table:
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Original Object

Resulting Shapes

Rectangles

Single lines

Circular-Cornered Rectangles
(Constant or Proportional)

Four single lines and four
radial arcs

Elliptical-Cornered Rectangles

Four single lines and four
elliptical arcs

Polygons and Polylines

Single lines

Parallel Lines (single)

Single lines

Parallel Polygons and Polylines

Individual polygons and
polylines

Original Object

Resulting Shapes

Freehand Objects

Single lines

Spline and Bezier Objects

Series of single-segment
Bezier curves

Dimension Objects

Varies; see Chapter 4 for
details.
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Metapolygons (objects with both curved and straight edges, created using
the Add, Subtract, or Attach tools): Each edge will become a separate
object. For example, an object created by adding a circle and a polygon will
break into a radial arc and several straight line segments.
WARNING: Once objects (other than polygons or polylines) are separated
using Break, they cannot be re-assembled. The one exception to this is that
the Undo Control can reverse the Break tool’s effects immediately after an
object is broken.
To break an object into its component parts:
1.

Select the object to be broken.

2.

Choose the Accessory palette’s Break tool.

The object will be broken into simpler objects, as detailed in the table
above.

The Add Tool

You can use the Add Objects tool on the Accessory palette to combine two
objects.
When you add two overlapping objects, the edges that overlap disappear
and the objects are fused together to form a single, composite object. You
can apply a single fill, line weight, line style, or set of object information to
the new “added” object.

2 - 108

Creating and Editing Objects

If the edges of the combined objects are all straight line segments, the new
object will be an ordinary polygon. If any of the edges are curved, the new
object will be a “metapolygon.” Metapolygons can only be resized
proportionally, by dragging their corner edit handles or with the Resize
palette.

To add two objects:
1.

Select the two overlapping objects you want to add.

2.

Make sure the Accessory palette is displayed.

3.

Click on the Add tool.

The selected objects will be added together.
If the new object has all straight edges, it is an ordinary polygon and you
can resize it by dragging any of its edit handles. If the new object is a
metapolygon (with any curved edges), you can only resize it proportionally
by dragging a corner edit handle, but you can change any of its fill and line
attributes or apply object information to it.
NOTE: You cannot break the merged object into the original, individual
components after you have merged them. However, you can use the Break
tool to “disassemble” the added polygon or metapolygon into its component
edges (straight or curved; see page 2-111).
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The Subtract
Tool

The Subtract Objects function lets you use one object as a “cookie cutter” to
slice away part of another object that lies beneath it.

You can also use a straight line object to slice another object in two (this
works even if the line doesn’t go all the way across the object).
The portion of the object under the cutter will be removed from the object.
You can view the results by moving the cutter to one side.

If the edges of the cut object are all straight line segments, the new object
will be an ordinary polygon. If any of the edges are curved, the new object
will be a “metapolygon.” Metapolygons can only be resized proportionally,
by dragging their corner edit handles or with the Resize palette.
To subtract part of an object using another object:
1.

Position the object to be used as the cutter on top of the object
to be cut. (If necessary, use the Arrange menu’s Bring to Front
Control.)

The cutter must overlap part of the object to be cut.
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2.

Make sure the Accessory palette is displayed.

3.

Select the cutter and the object to be cut (that is, the object
beneath the cutter).
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4.

Click on the Subtract tool icon on the Accessory palette.

If the new object has all straight edges, it will be an ordinary polygon, and
you can resize it by dragging any of its edit handles. If the new object is a
metapolygon, you can only resize it proportionally by dragging a corner edit
handle. You can change any of its fill and line attributes or apply object
information to it.
NOTE: The Subtract tool only works with two objects at a time.
When you use a line object and the Subtract tool to cut an object in two, the
line only needs to cross part of the object. The Subtract tool automatically
continues the cut straight across the rest of the object.
To use a line to cut an object in two:
1.

Position the line to be used as the cutter on top of the object to
be cut. (If necessary, use the Arrange menu’s Bring to Front
Control.)

The line must overlap part of the object to be cut; it doesn’t need to reach all
the way across the object.
2.

Make sure the Accessory palette is displayed.

3.

Select the cutting line and the object to be cut.

4.

Click on the Subtract tool icon on the Accessory palette.

The object under the cutting line will be “sliced” in two. You can view the
results by moving the pieces and the cutting-line apart.
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Creating TwoLine Fillets

A two-line fillet is an arc of a given radius tangent to two line segments. PC
Draft gives you many Alts in creating two-line fillets. You can specify the
radius of the arc that results from the operation. You can also choose what
to do with the line segments that are left over after the fillet operation is
completed. For example, you can choose to have PC Draft automatically
remove the extra line segments, trim them and leave them for you to
remove, or leave them intact. You can also indicate if you want to create a
large or a small arc.

To create a two-line fillet:
1.

Select two lines on the drawing.

2.

Click on the Fillet tool on the Accessory palette.

If the two lines intersect each other, there are four possible quadrants in
which the arc can be drawn.

3.
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Click on the desired quadrant.
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Choosing Fillet
Settings

PC Draft uses the settings defined in the Fillet Setup dialog box to perform
the fillet operation. You can change these settings. Once you choose the
settings you want in the Fillet Setup dialog box, the settings will be used for
all fillet operations until you make new choices.
To define the settings for the Fillet tool:
1.

Press down the Alt key.

2.

Holding down the Alt key, click on the Fillet icon on the
Accessory palette.

The Fillet Setup dialog box will appear.

3.

Release the Alt key.

4.

Type in the desired radius for the arc.

NOTE: The units for the values you enter are based on the size units that
were set up in the Set Scale/Units dialog box.
You have the option of creating a large arc or a small arc. The size of the
arc refers to the number of degrees in the arc.
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To make your choice:

1.

Click on the button beside
either Smaller Arc or
Larger Arc.

You have three choices in regards to how PC Draft deals with the line
segments after the fillet operation is completed.
The options are:

-

Automatic trim

When Automatic trim is selected, PC
Draft draws the arc, then removes the
extra line segments.
-

Manual trim

When Manual trim is selected, PC Draft
breaks the lines at the points where they
intersect with the arc. You can then select
the extra line segments you want to
remove.
-

No trim

When No trim is selected, PC Draft leaves
the lines intact.
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Creating
Chamfers

PC Draft’s Chamfer tool will create a beveled corner at the intersection of
two lines. You have several options in creating chamfers, such as specifying
the chamfer’s distance from the intersection point along each line. You can
also choose what to do with the line segments that are left over after the
chamfer operation is completed. For example, you can choose to have PC
Draft automatically remove the extra line segments, trim them and leave
them for you to remove, or leave them intact. Chamfer settings are
controlled using the Chamfer Setup dialog box, opened by holding down
the Alt key and clicking the Chamfer tool icon in the Accessory palette.

You can create a chamfer between two lines by either selecting the lines,
then clicking the Chamfer tool icon, or by activating the Chamfer tool, then
selecting the lines.
To create a chamfer:
1.

Select two lines on the drawing.

2.

Click the Chamfer icon in the Accessory palette.
or,

1.

Select the Chamfer icon in the Accessory palette.

The cursor will prompt you to select the first line.
2.

Click the first line.

The cursor will prompt you to select the other line.
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3.

Click the second line.

The original lines will be extended or truncated to match the specified
chamfer distances (see below).
You can specify how far along each line from the point of intersection
(actual or projected) the chamfer is defined.
To adjust the chamfer distance:
1.

Press down the Alt key.

2.

Holding down the Alt key, click on the Chamfer icon on the
Accessory palette.

The Chamfer Setup dialog box will appear.

3.

Release the Alt key.

4.

Type in the desired distances for each line, then press OK.

The dialog box will disappear. Chamfers drawn will now match the settings
you specified.
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Adjusting the
Chamfer Trim

You have three choices in regards to how PC Draft deals with the line
segments after the chamfer operation is completed.
The option are:
-

Automatic trim

When Automatic trim is selected, PC Draft draws the chamfer, then
removes the extra line segments.

-

Manual trim

When Manual trim is selected, PC Draft breaks the lines at the points where
they intersect with the chamfer. You can then select the extra line segments
you want to remove.

-

No trim

When No trim is selected, PC Draft leaves the lines intact.
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To adjust the chamfer trim:
1.

Press down the Alt key.

2.

Holding down the Alt key, click on the Chamfer icon on the
Accessory palette.

The Chamfer Setup dialog box will appear.
3.

Release the Alt key.

4.

Click the desired trim choice, then press OK.

The dialog box will disappear. Chamfers drawn will now match the settings
you specified.

Using the Trim
Function

The Trim function allows you to cause breaks in two intersecting lines at
the points where the lines intersect.
When you trim lines, PC Draft adds a vertex point at the point of
intersection. You have two trim choices: Automatic trim (the default) and
Manual trim.
To make your trim choice:
1.

Press and hold down the Alt key.

2.

Click on the Trim icon (the scissors) on the Accessory palette.

The Trim Setup dialog box will appear.
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You use the Trim Setup dialog box to choose the trim option you want. The
trim option you choose will be used for all trim operations until you make
another choice from the dialog box.
3.

Click on the button beside either Automatic trim or
Manual trim.

4.

Click on the OK button.

If you choose Automatic trim, PC Draft will automatically remove the
shorter pair of lines that result from the trim operation. If you choose
Manual trim, PC Draft will leave the pieces for you to remove at your
discretion.
To trim two intersecting lines:
1.

Select the two lines you want to trim.

2.

Click on the Trim icon on the Accessory palette.

The two lines will be broken at their point of intersection.
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Object
Information

PC Draft now allows you to associate names and other text information
(including numerals) with objects or groups. For example, if an object or
group represents a machine part with a particular name, stock number, and
manufacturer, you can name it and assign it the appropriate information.
Then if you move or copy the shape, even into a symbol library or a
different drawing, its name and various other pieces of information will
remain with it.
Object information can be used as criteria for searches using the Find and
Replace feature (see Chapter 5) or for functions in a PC Draft Report
Format (see Chapter 9).
Each object or group can have up to five text strings assigned to it, in
“fields.” The first field is always called “Name” and can be used to name
the object. You can give the other four fields different type-names,
depending on what each field represents in your drawing’s objects.
For example, if objects in a drawing
need names, stock numbers, and
manufacturers (as mentioned above),
you can define the second and third
fields as “Stock Number” and
“Manufacturer.” You can then apply
those types of data to individual
objects.
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In PC Draft, you name data fields using the Edit Field Names Control, and
put data in them for an object or group using the Edit Object Info Control.
Both Controls are in the Data menu.
To set the field names for a drawing:
1.

Choose the Data menu’s Edit Field Names Control.

The Edit Field Names dialog box appears.

2.

Double-click in a field-name field and type the desired name,
then press the Tab key to move to the next field.

NOTE: The field name can be up to 12 characters long, and can contain
any letters, numerals, or punctuation marks (including spaces).

3. Repeat the previous step
until all the field names
read as you want them
to, then click OK.
The Edit Field Names dialog box
disappears, and you have changed
the field-name defaults of the
drawing.
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Any object that you enter data for will use the field names you have
defined.
To assign object information to an item:
1.

Select the object or group.

2.

Choose the Data menu’s Edit Object Info Control.

The Edit Object Info dialog box appears, displaying the field names defined
for the drawing.
3.

Double-click in a field and type the desired text, then press the
Tab key to move to the next field.

NOTE: Each field’s information can be up to 25 characters long, and can
contain any letters, numerals, or punctuation marks (including spaces).

4. Repeat the previous step
until all the data fields
read as you want them to,
then click OK.

The Edit Object Info dialog box disappears, and you have assigned one or
more types of data to the item. You can now use the data as criteria for Find
and Replace, or manipulate them using the Report feature.
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The item will retain its data if you copy and paste it, duplicate it, or move it
— even if you put it in a different PC Draft document.
NOTE: If you copy or move the item to a document with different field
names, it will retain its object information, but the field names of the “host
document” will appear if you select the item and choose Edit Object Info.
Once an object or group has object information, you can change it at any
time.
To edit existing object information:
1.

Select the object or group.

2a. Choose the Data menu’s Edit Object Info Control.
or
2b. Hold down the Alt key and click on the object.
The Edit Object Info dialog box appears, displaying the field names defined
for the drawing and any existing object information for the selected item.
3.

Double-click in a field and edit the text as desired.

4.

Repeat the previous step until all the data fields read as you
want them to, then click OK.

The Edit Object Info dialog box disappears, and you have changed one or
more types of data for the item.
NOTE: You can also change the object information of an object or group in
a symbol library; see Chapter 7.

Object
Information In
Multiple Objects

Object information for more than one item can be added to, or edited, at the
same time. The object information can then be used as criteria for Find and
Replace operations or for creating reports.
NOTE: If you edit the object information of multiple items, only the fields
you edit will change.
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To add object information to, or edit object information for, multiple items:
1. Select the objects or groups (or both) to add object information
to or edit object information for.
2. Choose Edit Object Info from the Data menu or hold down the
Alt key and click one of the selected objects. The Object Info
dialog box will appear. The fields will be empty as the various
items you selected may already have different object
information in the same field.

3. Add the desired text information to the appropriate fields.
4. Click the OK button. All the selected objects and groups will
have the object information you specified. However, any object
information fields you did not edit will remain unchanged.

Replacing
Objects Or
Object
Information

Items can be found according to their object information, then either the
entire object (including its data), the data only (leaving the visible object),
or the visible object (leaving the data intact), can be replaced. The default
setting is to replace the object and data together.
To replace only an object’s data:
1. Open the Data menu and choose Find/Replace. The Find/Replace
dialog box will appear:
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2. Define the appropriate object information in the Find and Replace
With sections (see Chapter 5 of the User Guide).
3. Open the Replace popout menu and choose Data Only.

4. Proceed with the Find and Replace operation as required. Any items
chosen for replacement will have only their object information
replaced, the visible objects will remain unchanged.
To replace only an object, leaving its object information data, follow the
same instructions again, but choose Object Only in the Replace popout menu.
Any item chosen for replacement will be visibly replaced, but its object information will remain the same as before. The new object will effectively inherit
the replaced object’s data.
If you do something unintentionally, or want to correct a mistake, PC Draft
Reversing
Changes: Undo, lets you reverse certain actions. The Undo Control reverses execution of the
Redo, and Revert last action; the Redo Control executes the previously reversed action; and the
Revert Control returns you to the last saved version of the document.

Undo

If you choose a Control or perform an action and then change your mind, in
most cases you can choose Undo to reverse the action or the effects of the
Control.
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To undo an action or Control:
•

Open the Edit menu and choose Undo.

If the action or Control is “Undo-able,” the Control will be listed beside
Undo in the Edit menu (Undo Delete after a deletion, for example).

If the action or Control is not Undo-able, Undo will appear dimmed in the
Edit menu.

Redo

You can use Redo to re-execute an action or Control that you just reversed
using Undo. By using Undo and Redo together, you can experiment with
your drawing and PC Draft’s features. For example, you could delete an
object, observe the effect on your drawing, and choose Undo to reverse the
deletion. If you then decided that the deletion produced the desired effect,
you could choose Redo and the same object would be re-deleted.

To redo an action or Control:
•

Open the Edit menu and choose Redo.

The name of the Control you reversed by previously choosing Undo will be
listed in the Edit menu.
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NOTE: In most cases, in order to undo or redo a Control, you must choose
Undo or Redo before you perform any other action. However, there is an
exception to this rule. You can switch back and forth between documents,
performing actions on the various open documents, and PC Draft will
“remember” the last action performed in each document. This allows you
to return to an open document and undo or redo the last action you
performed in it.

Revert

If you execute a Control that is not Undo-able, or you make changes you are
unable to delete but do not wish to save, you can eliminate any unsaved
changes by reverting to the last saved version of your document. You
should use this Control with caution, since it will obliterate anything that
has not been saved.
To revert to a previously saved version of your document:
1.

Open the File menu and choose Revert.
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A dialog box will appear to confirm that you want to proceed. The dialog
box will show you the date and time when the document was last saved.
To revert to the last saved version of the document:
2a. Click on the Revert button.
To return to the current version of your document:
2b. Click on the Cancel button.
WARNING: If you revert to a previously saved version of the document,
all changes made since the last save will be deleted.

Drawing views

PC Draft offers various features for changing the view of your drawing.
Using these features you can move the drawing in the document window so
that you view a different part of the drawing, or you can zoom in or out on a
portion of the drawing to see it in more detail or to see an overall view. Any
view can be saved.

Changing the
position of the
drawing in the
document
window

To change the position of the drawing within the document window, you
can scroll the drawing, use the Hand tool or use the arrow keys on the
keyboard.

Scrolling

Scrolling in PC Draft drawings is accomplished just as it is in other PC
windows by using the scroll bars at the edges of the windows. See your
system documentation for details.

The Hand tool

The Hand tool provides an alternative method of moving the drawing
within the document window.

NOTE: You can easily return to the top left corner of your drawing by
using the Home View command (see Home view on page 2-140).

To use the Hand tool:
1.
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Click on the Hand tool in the Tool palette.
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Pointer tool
Hand tool

The cursor will change to a hand.
2.

Position the cursor over the drawing area and press the mouse
button.

3.

Holding down the mouse button, drag in any direction.

The view will move with the hand.
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4.

Release the mouse button when the desired section of the
drawing is displayed in the document window.

NOTE: You can also access the hand tool by pressing the space bar while
the Pointer tool is active.

Zooming In or
Out on a
Drawing
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When you work with a large document you may need to see the entire
drawing at one time. Or, you might need to obtain a close up view of a
particular area so that you can add small details. PC Draft gives you the
ability to change the view of your drawing in either of these cases by
providing features that allow you to zoom in or out on an area of the
drawing. Zoom controls are provided via the Zoom tool in the Tool palette,
by commands in the View menu and by a popup menu at the bottom of the
document window. There are also features that allow you to easily return to
a preset or saved view.
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PC Draft usually allows you to magnify a drawing up to 32 times, or down
to -8 times its normal size.
NOTE: The current magnification of the drawing view is shown at the
bottom of the document window.

NOTE: If you zoom out several consecutive times, and have text on your
drawing, the text will become too small to be displayed and only its edit
handles will display.

Using the Zoom
tool

Click on the Zoom tool in the Tool palette to select it.
NOTE: You can also activate the Zoom tool by holding down the Shift key
and clicking on the Pointer tool at any time.

Zoom In

To use the Zoom tool to zoom in on an area of the drawing:
1.

Select the Zoom tool.

The cursor will change to a magnifying glass with a plus sign inside it to
show that you are about to increase the magnification of the drawing.
2.

Position the cursor over the area of the drawing you wish to
zoom in on and click the mouse button.
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The magnification of the drawing view will be increased one level, and the
view will be centered around the position of the cursor.
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3.

Zoom Out

Continue to click the mouse button to zoom in further.

To use the Zoom tool to zoom out on an area of the drawing:
1.

Select the Zoom tool.

2.

Press and hold down the Alt key.

The cursor will change to a magnifying glass with a minus sign inside it to
show that you are about to decrease the magnification of the drawing.
3.

Position the cursor over the area of the drawing you wish to
zoom out on and click the mouse button.

The magnification of the drawing view will be decreased one level, and the
view will be centered around the position of the cursor.
4.

Continue to click the mouse button to zoom out further.
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Marquee Zoom

The Zoom tool can also be used to perform marquee zooms.
To use the Zoom tool to perform a marquee zoom:
1.

Select the Zoom tool.

The cursor will change to a magnifying glass with a plus sign inside it to
show that you are about to increase the magnification of the drawing.
2.

Position the cursor over the drawing.

3.

Press and hold down the mouse button, and drag over the area
you want to zoom in on.

The inner rectangle shown in the screen shot above is the area selected with
the Zoom tool. The outer rectangle represents the actual area that will be
displayed in the document window when the mouse button is released.
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4.

Zoom
Commands

Release the mouse button to display the portion of the
document selected.

The Zoom commands are found in the Zoom submenu in the View menu.

NOTE: You can choose Zoom commands several consecutive times, each
time further increasing or decreasing the level of magnification of your
view.
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Zoom Out

To use the Zoom out commands:
•

Select Zoom Out 2X or Zoom Out 4X from the Zoom submenu
in the View menu.

The magnification of the drawing view will be decreased by the specified
amount.

Zoom In

To use the Zoom in command:
1.

Select Zoom In 2X or Zoom In 4X from the Zoom submenu in
the View menu.

The view finder box and a cross cursor will appear on your drawing. This
gives you a visual indication of the portion of your drawing that will be
included in the magnified view.
2.
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Move the cursor to position the view finder over the area of the
drawing you want to zoom in on.
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3. Click the mouse button.
The magnification of the drawing view will be increased by the specified
amount, and the selected portion will display in the document window.
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NOTE: If the complete zoomed in view will fit in the document window,
the view finder will not be displayed; the new view will be displayed
immediately.

Magnification
Popup Menu
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The current magnification of the drawing view is shown at the bottom of the
document window. If you click on this area, a magnification popup menu
will display.
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•

Restore Previous
Zoom

Select a magnification value from this popup menu to zoom in
or out on your drawing.

The Restore Previous Zoom function allows you to return to the previous
magnification of your drawing, regardless of the current magnification.
To return to the previous magnification:
•

Select Restore Prev. Zoom from the View menu.

The view will zoom in or out to the previous magnification.
NOTE: You can use this command to alternate between two magnification
levels. For example, you could do some detailed editing at high
magnification, use Restore Previous Zoom to examine the whole image,
then use Restore Previous Zoom again to zoom back in and continue the
detail work.
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Controlling the
appearance of
lines and borders
in zoomed-in
views

When you zoom in on objects, you can decide if you want to have lines and
borders become magnified in proportion to the current zoom factor.
Normally, lines and borders are not magnified. For example, a 3-pixel line
will appear as a 3-pixel line even in a view magnified two times (2x).
However, you can choose that lines and borders should be magnified when
you zoom in on them. For example, that a 3-pixel line will appear to be 6
pixels in width if you zoom in to 2x magnification.
The command that controls the appearance of lines and borders in zoomed
in views is Zoom Line Weights in the Preference menu.
To make line weights appear larger in zoomed-in views than in the normal
view:
•

Select Zoom Line Weights in the Preference menu.

A check mark will appear by the menu item, and line weights will be
magnified in zoomed in views.
To make line weights remain constant regardless of the current
magnification factor:
•

If there is a checkmark against Zoom Line Weights in the
Preference menu, select Zoom Line Weights.

The check mark will be removed, and lines and borders will not be
magnified by the current zoom factor.

Home view

The view which appears on the screen when you first open a PC Draft
document is called the Home View. This view displays the an unmagnified
view of the upper left corner of the document.
To display the home view:
•

Select Home View from the View menu.

An unmagnified view of the upper left corner of the document is displayed.
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1:1 tool

You can easily return to an unmagnified view of the current area of the
document by using the 1:1 tool in the Tool palette. This is useful if you
have zoomed in on a detail and now want to see it at single magnification,
but don’t want to return to the upper left corner of the drawing as when
using the Home View command (see Home view on page 2-156).
To return to an unmagnified view of the current working area:
•

Click on the 1:1 tool on the Tool palette.

1:1 tool
The view will change to an unmagnified view of the current area.

Saved view

You can save any view of your drawing. Saved views can be of any part of
the image and at any magnification. This feature allows you to move
quickly to and from different areas of your drawing and different
magnifications.

Saving a view

To save a view:
1.

Display the view you want to save.

2.

Select Save View from the View menu.

The Save View dialog will display.

3.

Enter a name for the view.
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By default, PC Draft will assign a Control key equivalent to the first five
views you save. This means that you will be able to display a saved view by
pressing down the Control key and typing the number that corresponds to
the saved view; Control-5, Control-6 and so on.
4.

If you don’t want a Control key equivalent to be assigned to a
view, click on the Use CTRL+6 check box to deselect it.

5.

Click on the OK button to save the view.

The name of the view is added to the bottom of the View menu.

Displaying saved
views

You can display a previously saved view in two ways: by choosing the
view’s name from the View submenu or by using the Control key
equivalent (this method can only be used for up to five views).
To display a saved view:
•

2 - 142

Select the name of the desired view from the View menu.
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Deleting saved
views

When you save a view, the commands Delete View and Delete All Views
are added to the View menu.
To delete a saved view:
1.

Open the Delete View submenu in the View menu.

2.

Select the name of the view you want to delete from the Delete
View submenu.

The saved view will be deleted. If the view had a Command key equivalent
associated with it, that number will now be available for use with another
view.
To delete all views:
1.

Select Delete All Views from the View menu.

An alert will appear asking you to confirm that you want to delete the view.
2.

Click on the OK button to delete all views.
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Chapter 3

Changing the
Appearance
of Objects

Changing the
appearance of
objects

In many drawings, you may want to change the appearance of objects to
help differentiate between them. You can change their appearance by filling
objects with washes (solid fills) and patterns; by drawing lines and object
borders with different colors, patterns, line weights, line styles and pen
styles; by drawing lines with different end marks; and by choosing different
positions for object borders.
You can define attributes for fills and lines that will be applied to all objects
you draw or you can change the attributes of existing objects.
When the application is launched, the default values are white fill, black
pen, no pattern, line weight 1 point, plain line style.

Object attributes Most attributes are chosen from various pop-up menus on the Attributes
palette or the indicator boxes at the bottom left of the document window.
Others are chosen from the Preference menu.

The Attributes
palette

Displaying the Attributes palette
To open the Attributes palette:
•
•

Choose Attribute from the Palettes submenu in the View menu,
or
Choose Attribute from the pop-up menu at the bottom left of
the document window.

Fill color
Parallel line fill
Pen fill
Line weight

Fill pattern
Parallel line pattern
Pen pattern
Line style

End marks
Selecting attributes using the Attributes palette
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Selecting attributes is discussed in detail in later sections of this chapter, but
in general:
•

•

Change the attributes of existing objects by selecting the
object, opening the appropriate menu in the Attributes palette,
then making your choice.
Change the drawing's default attributes (the fill, line weight
and so on that will be applied to all new objects you draw) by
making sure nothing is selected, then opening the appropriate
menu and choosing an attribute.

The fill and line indicator boxes offer an alternative method of selecting
some attributes.

The fill and line
indicator boxes

The default attributes for the fill color or pattern and the line weight are
shown in the Fill and Line indicator boxes in the lower left corner of the
document window.

Selecting attributes using the fill and line indicator boxes
The Fill and Line indicator boxes can be used to select attributes by
accessing the appropriate pop-up menu and selecting the desired attribute.
Opening the attribute pop-up menus from the fill and line indicator boxes
To open the Fill color and pattern pop-up menus:
•
•

Click the Fill color/pattern box.
Hold down the Control key and click on the Fill color/pattern
box to display the alternate popup menu..

To open the Parallel line fill color and pattern pop-up menus:
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•
•

Position the pointer on the Fill color/ pattern box, holding
down the Alt key press left mouse button.
Hold down the Alt and Control keys and click the Fill color/
pattern box to open the alternate pop-up menu.

To open the Pen color and pattern pop-up menus:
•
•

Hold down the Shift key and click the Fill color/pattern box.
Hold down the Control and Shift keys and click the Fill color/
pattern box to open the alternate pop-up menu.

To open the Line weight pop-up menu:
•

Click the Line weight box.

To open the Line style pop-up menu:
•

Default
attributes

Hold down the Alt key and click the Line weight box.

The attributes that you can select for objects before you draw them are Fill
color and pattern, and Parallel line fill color and pattern. The pen attributes
(that is, the attributes associated with lines and object borders) that you can
define for objects before you draw them include pen style, color and pattern,
line weight (thickness), line style (solid and dashed lines), end marks
(symbols at the ends of lines), and border position. The option for each of
these attributes that is currently active is called the `default attribute'.
The current default fill and pen attributes appear on the lines and borders of
the objects you draw.
NOTE: You cannot apply both a fill color and fill pattern to an object unless
you define a colored fill pattern.
When nothing is selected on the drawing, the default attributes are shown
on the Attributes palette. When an object is selected, the Attributes palette
shows the attributes of that object.
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Setting default attributes:
To change the current default attributes for fills and lines
1.

Activate the Pointer tool on the Tool palette.

NOTE: Make sure that nothing is selected on the drawing.
2.

From the pop-up menus on the Attributes palette (or the fill
and line indicator boxes), choose the fill and/or line attributes
you want to apply to all objects you create.

The attributes you choose will automatically be applied to all objects until
you make other choices for the default attributes.

Selecting
attributes for
specific objects

You can change the fill and line attributes for selected objects without
affecting the default fill and line attributes.
To define the fill and/or line attributes for selected objects:
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1.

Select the object or objects you want to change.

2.

From the pop-up menus on the Attributes palette (or the fill
and line indicator boxes), choose the fill and/or line attributes
you want to apply to the selected objects.
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The chosen attributes will be applied only to the selected objects. The
default attributes will not be changed.

Using color

With PC Draft you can use color in a variety of ways: to fill objects with
solid colors, to fill objects with color patterns, to draw the borders of objects
and to color text. The use of solid colors is referred to as a "wash," and the
use of colors to draw lines and object borders is referred to as the "pen
color." The color you choose for the pen is applied to text as well. You can
also use colors in fill patterns and to fill the gaps between parallel lines.

Choosing the
A Windows® color system is capable of reproducing over 16 million colors,
number of colors but the number of colors you can display depends on the amount of video
to display
RAM (Random Access Memory) in your computer, and on the specification
of your monitor.
There are certain trade-offs to be aware of in choosing the number of colors
to set your monitor to display. If you choose to display millions of colors,
the rate at which the screen is redrawn will be slowed down. If you choose
to display fewer colors, the screen redraw will be faster, but there will be
fewer color choices available to you, and the system may not be able to
display all of the colors used in an existing document. The system will
attempt to display all the colors used in an existing document by using a
process called `dithering'. With dithering, the system clumps together pixels
of different colors to simulate the specified color.
To set the number of colors to display
The display choices available to you will be determined by the
specifications of your monitor and the system software you are running.
Refer to the system software documentation for details of setting the
number of colors to display on your monitor.
NOTE: If you want to use only grayscale, but you have a color or true
monochrome monitor, you will still be able to access color items, such as
Edit Colors, but in 256 shades of gray.
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The color table

The color table contains the colors used in a document. Each new document
contains a number of preset colors, which you can edit. The preset colors
and the colors you edit or create are stored in the document's color table.
The color table is represented on your screen as a submenu that shows all
the preset colors and all the colors that have been used in the document.

The colors in the color table can be chosen from the Attributes palette, the
Fill indicator box and the Edit Colors command in the Preference menu.
NOTE: When you paste objects from a different document that has colors
that are not present in the target document's color table, the colors from the
source document are preserved in the objects that are pasted, but are not
added to the target document's color table.

Editing colors

You can edit the existing colors in the color table to add your own colors.
When you edit an existing color, the existing color is replaced with the new
color in the color table.
NOTE: If you edit a color that has been used in the document, the objects
that contain the edited color will be updated with the new color.
To edit a color in the color table:
1.
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Choose Edit Colors from the Preference menu.
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The color table appears.
2.

Holding down the mouse button, drag through the table until
the color you want to edit is highlighted.

3.

Release the mouse button.

The Pick a Color dialog appears.
NOTE: You cannot edit the No fill (N), the solid white or the solid black
colors. If you try to edit one of these colors, the Color Picker dialog will not
open, and an alert will inform that you are unable to modify this fill.
4.

Use the controls in the Pick a Color dialog to choose a new
color.
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NOTE: The Pick a Color dialog is specific to the operating system. For full
details on how to use it refer to the operating system documentation.
5.

When you have chosen a new color, click the OK button to
close the Pick a Color and return to PC Draft.

The new color you chose replaces the color you selected to edit.
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Object fill color

You can use a solid color to fill the interiors of objects. Filled objects are
opaque and you can select them by clicking their borders or anywhere
within them. If a filled object is on top of another object, it hides the object
beneath it from view.

Selecting the fill
color

To select the fill color:
1.

Open the Fill Color pop-up menu in the Attributes palette.

2.

Drag until the fill color you want is highlighted.

3.

Release the mouse button. The selected fill color will be shown
on the Attributes palette.

NOTE: If you choose "N" (for No fill) from the Fill Color submenu as the
current fill color, the objects you draw will be wire frame shapes.
You can change the fill color before or after you draw the object.
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Drawing an
object with a
selected fill color

To draw an object with a selected fill color:
1.

Return to the pointer mode. (Make sure that nothing on the
drawing is selected.)

2.

Select the desired fill color from the Fill Color pop-up menu in
the Attributes palette.

3.

Draw an object.

The object will be drawn with the specified fill color.
The Fill Color Indicator box in the lower left corner of the window will
change color to indicate the color you chose.
NOTE: The chosen fill color will be used for objects until you choose
another fill color as the default.

Changing the fill
color of an
existing object

To change the fill color of an existing object:
1.

Select the object to change the fill color of.

2.

Choose the desired fill color from the Fill Color pop-up menu
in the Attributes palette.

The fill of the selected object will be changed to reflect the chosen fill color.
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Parallel fill color

PC Draft's parallel-line objects (single parallel lines, open parallel polylines
and closed parallel polygons) can include fill colors (including No Fill)
between their component edges.
NOTE: In addition to parallel fills, parallel objects can also have pen
colors, patterns and object fills.

Selecting the
parallel fill color

To select the parallel fill color:
1.

Open the Parallel Fill color pop-up menu in the Attributes
palette.

2.

Drag until the parallel fill color you want is highlighted.

3.

Release the mouse button. The selected parallel fill color will be
shown on the Attributes palette.

You can change the parallel fill color before or after you draw the parallel
line object.

Drawing a
parallel line
object with a
selected fill color

To draw a parallel line object with a selected fill color:
1.

Return to the pointer mode. (Make sure that nothing on the
drawing is selected.)
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2.

Select the desired parallel fill color from the Parallel Fill color
pop-up menu in the Attributes palette.

3.

Draw a parallel line object.

The object will be drawn with the specified fill color.
NOTE: The chosen parallel fill color will be used for objects until you
choose another parallel fill color as the default.

Changing the fill
color of an
existing parallel
line object

To change the fill color of an existing parallel line object:
1.

Select the parallel line object to change the fill color of.

2.

Select the desired parallel fill color from the Parallel Fill color
pop-up menu in the Attributes palette.

The fill of the selected parallel line object will be changed to reflect the
chosen fill color.

Pen color
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This section describes how to use colors to draw lines, borders and text. You
use the Pen Color pop-up menu in the Attributes palette to choose pen
colors.

Changing the Appearance of Objects

You can use different pen colors to help distinguish between objects.

Selecting the pen
color for lines,
borders and text

To select the pen color:
1.

Open the Pen Color pop-up menu in the Attributes palette.

2.

Drag until the pen color you want is highlighted.

3.

Release the mouse button. The selected pen color will be shown
on the Attributes palette.

NOTE: If you choose "N" (for No ink) from the Pen Color submenu as the
current pen color, the lines, borders or text you draw will be invisible. Edit
handles appear on selected objects drawn with no ink, but the lines, borders
or text will not appear on the screen or on printed drawings.
You can change the pen color before or after you draw the object or enter
the text.

Drawing a line
or object, or
entering text,
with a selected
pen color

To draw a line or object, or enter text, with a selected pen color:
1.

Return to the pointer mode. (Make sure that nothing on the
drawing is selected.)

2.

Select the desired pen color from the Pen Color pop-up menu
in the Attributes palette.
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3.

Draw a line or object or enter the text.

The line, object or text will be drawn with the specified pen color.
NOTE: The chosen pen color will be used for lines, borders and text until
you choose another pen color as the default.

To change the pen color of an existing line, object or piece of text:
Changing the
pen color of an
1. Select the line, object or text to change the pen color of.
existing line,
object or piece of
2. Choose the desired pen color from the Pen Color pop-up menu
text
in the Attributes palette.

The line or border of the selected object, or the selected text, will be
changed to reflect the chosen pen color.

Showing and
hiding fills
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You can choose to hide fills, including colors and patterns, on your drawing.
When you turn fills off, only the borders of filled objects appear.
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To hide line fills:
•

Open the Preference menu and choose Hide Fills.

Objects appear as wire frame shapes, and a checkmark appears next to the
Hide Fills command.
To display fills:
•

Open the Preference menu and choose Hide Fills again.

Objects will be drawn with their respective fills, and the checkmark
disappears from next to the Hide Fills command.

Using patterns

Fill patterns provide an effective way to distinguish between objects. Two
reasons you might want to use different fill patterns within a drawing would
be to improve its esthetics or to add meaningful information to the drawing.
In a technical drawing, an architect or engineer might use a variety of fill
patterns and inks to differentiate between various object types or textures
within the drawing. PC Draft offers a menu selection of standard fill
patterns to complement your drawing. You can use the existing patterns,
customize them or create your own. You can have up to 64 patterns in each
PC Draft document.

Customizing
patterns

The Edit Patterns feature allows you to change the patterns available in the
pattern fill submenus from the Attributes palette. When a pattern is edited,
the pattern fill submenus will be updated to show the new pattern, and the
new pattern will be saved with the document. If a pattern that has been used
to fill objects is edited, the objects will be changed to reflect the revised
pattern.
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The Edit Pattern
dialog

To open the Edit Pattern dialog:

Opening the Edit 1. Open the Preference menu and drag until Edit Patterns is
highlighted.
pattern dialog
The Edit Patterns submenu appears.
2.

Holding down the mouse button, drag until the pattern you
want to edit is highlighted and release the mouse button.

The Edit Pattern dialog appears.

NOTE: You cannot edit the No Fill ("N"), the solid white or solid black
patterns. If you try to do so, the Edit Pattern dialog will not open, and an
alert appears informing that the selected pattern may not be edited.
The edit pattern field
The large box in the center of the Edit Patterns dialog is the edit pattern
field. It shows a magnified view of the bits that make up the pattern. The
pattern is edited within this field.
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Pattern preview

The box in the upper left corner of the Edit Pattern dialog shows a preview
of the pattern as it appears on the drawing. It is updated as the pattern is
edited in the Edit Pattern field.

The pattern grid

The pattern grid can be defined as 8 x 8, 16 x 16 or 32 x 32 grid squares.
To specify the pattern grid:
•

Click the 8 x 8, 16 x 16, or 32 x 32 buttons on the left of the
Edit Pattern dialog.

NOTE: 16 x 16, or 32 x 32 patterns will not be printed on some printers or
output devices.

Scale

Scale turned off
Grid size increased
If the Scale box is turned off, as the grid size is increased, the pattern is
replicated to fill the new area.
For example: In the dialogs below, the grid size is increased from 8 x 8 to
16 x 16, then to 32 x 32. At each stage, four copies of the contents of the
Edit Pattern field are used to fill the new grid. Notice that although the
contents of the Edit Pattern field change, the Pattern Preview field remains
the same.

Grid size decreased
If the Scale box is turned off, as the grid size is decreased, the pattern is
divided and applied to the new area.
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For example: In the dialogs below, the grid size is decreased from 32 x 32 to
16 x 16, then to 8 x 8. At each stage, the contents of the top left quarter of
the Edit Pattern field are used to fill the new grid.

Scale on

Grid size increased
If the Scale box is on, as the grid size is increased, the pattern in the Edit
Pattern field remains the same, but is divided up into more squares.
For example: In the dialogs below, the grid size is increased from 8 x 8 to
16 x 16, then to 32 x 32. At each stage, the contents of the Edit Pattern field
remain the same, but the pattern is divided into more grid squares. Notice
that the contents of the Pattern Preview field are scaled up at each stage.

Grid size decreased
If the Scale box is on, as the grid size is decreased, the pattern in the Edit
Pattern field remains the same but is divided into less grid squares. Colors
are averaged out in this process.
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For example: In the dialogs below, the grid size is decreased from 32 x 32
to 16 x 16 then to 8 x 8. At each stage, as four grid squares are combined to
make one new grid square, the average color of the four squares is used for
the new square. Notice that the contents of the Pattern Preview box are
scaled down at each stage.

Color mode

Patterns can be edited in two modes: black and white, and color/grayscale.
If you have a monochrome system, color options will still be available in
the Edit Pattern dialog, but as colors/grayscales cannot be seen, they cannot
be used effectively. In this case, patterns will consist of black and white
bits, the black bits representing the pattern design and the white bits the
background. If you have a color system, you can edit patterns using an
unlimited number of colors.
You can work with only one color at a time while editing patterns. The
selected color is called the current color and is displayed in the small box
on the right of the dialog, above the Other button. This box is also a button
used to access the Pattern Color menu.

The current
color button

To change the current color:
1.

Click on the Current Color button and hold down the mouse
button.

The Pattern Color pop up menu will appear:

Changing the Appearance of Objects

3 - 19

2.

Hold down the mouse button, drag to select the color you want
to use, and release the mouse button.

The selected color will display on the Current Color button. This color will
be used for pattern editing until another color is chosen.
NOTE: The current color is always black when you operate in black and
white mode.

Choosing a color
which is not
available in the
Pattern Color
menu
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The Other button allows you to select colors that are not available in the
Pattern Color menu.
To choose a color which is not available in the Pattern Color menu:
1.

Click on the Other button. The Pick a Color dialog box will
appear.
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2.

Select a color from the Pick a Color.

3.

Click OK to close the Pick a Color dialog box and return to the
Edit Pattern dialog box.

The color selected from will be displayed on the Current Color button.

Clearing the
current pattern

At times, you may want to clear all the bits from the Edit Pattern field and
start afresh rather than alter an existing pattern.
To clear all the bits from the Edit Pattern field:
•

Click on the Clear button

The field will be cleared.

Filling the entire
field

If you need to fill the entire field with the current color you can do this with
one mouse click using the Fill button.
To fill the entire field:
•

Click on the Fill button.
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The entire Edit Pattern field will be filled with the current color.
Pattern editing tools
The tools at the right of the pattern edit field are used to edit the current
pattern.

The Overlay tool

The Overlay tool is used to apply a pattern over the one in the Edit Pattern
field.
To apply a pattern over the one in the Edit Pattern field:
1.

Click the Overlay tool and hold down the mouse button.

The Fill Patterns submenu appears.
2.

Holding down the mouse button, drag the cursor over the
pattern you wish to apply, and release the mouse button

The selected pattern will be applied over the current contents of the Edit
Pattern field using the current color.

The Invert tool
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The Invert tool is used to invert the color of the bits in the Edit Pattern field.
In black and white mode, this action will change all the black bits to white
and all the white bits to black. If color bits are included in the pattern, when
the Invert tool is used, each bit will be changed to the color on the opposite
side of the color wheel to the original color, and the brightness will also be
inverted. For example, a light pink color will become a dark green/blue,
while a dark red will become a light green/blue.
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To invert the color of the bits in the Edit Pattern field
•

Click the Invert tool.

The color of the bits in the Edit Pattern field will be inverted

The Flip
horizontal tool

The Flip Horizontal tool is used to flip the pattern in the Edit Pattern field
around the vertical axis.
To flip the pattern in the Edit Pattern field around the vertical axis:
•

Click the Flip Horizontal tool.

The pattern will be flipped.

The Flip
vertical tool

The Flip Vertical tool is used to flip the pattern in the Edit Pattern field
around the horizontal axis.
To flip the pattern in the Edit Pattern field around the horizontal axis:
•

Click the Flip Vertical tool.
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The pattern will be flipped.

The Pencil tool

The Pencil tool is used to add or delete individual bits or series of bits, or to
draw lines in the Edit Pattern field.
To add bits to the Edit Pattern field one at a time:
1.

Click the Pencil tool and move the cursor over the Edit Pattern
field.

2.

Click the Edit Pattern field to add a square of the current
color.

To add a series of bits:
1.

Click in the Edit Pattern field and drag, holding down the
mouse button.

2.

Bits showing the current color will be added to the pattern as
you drag.

3.

Release the mouse button when you are finished.

To draw lines:
•

Constrain the movement of the Pencil tool to a horizontal or
vertical direction by holding down the Shift key while you
drag.

To delete black bits in Black and White mode:
•
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Select the Pencil tool and click the black bits you want to
delete.
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To delete color bits in the Color mode:
•

Hold down the Control key, then click the color bits to be
deleted.

The Eye dropper tool
You can use the Alt key to change the pencil tool to an eye dropper, and use
this to choose the color of any bit in the Edit Pattern field as the current
color.:
1.

Select the Pencil tool, hold down the Alt key and move the
pointer into the Edit Pattern field.
The pointer will change to an Eye Dropper tool.

2.

Click the Eye Dropper tool on the bit of the color you require
to be the current color.

The current color will be changed to reflect your choice.

The Finger tool

The Finger tool is used to blend together the current color and the color of
any bit in the Edit Pattern field, or the colors of adjacent bits in the Edit
Pattern field.
To blend the current color with the color of any bit in the Edit Pattern field:
1.

Select the Finger tool.

The Finger cursor shows the current color, which is the first of the two
colors to be used in the blending process.
2.

Move the cursor over the Edit Pattern field and click the bit
with which you want to blend the current color.

The bit clicked will change to a new color that is the average of the Finger
cursor color and the color of the bit clicked. The Finger cursor color will
also be updated to show the new color.
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To blend the colors of a series of bits:
1.

Select the Finger tool.

2.

Click in the Edit Pattern field and, holding down the mouse
button, drag the Finger cursor across bits of varying colors.

The average of the color values of the Finger cursor color and the bits
dragged across will be calculated, and applied to the bit.
NOTE: If you hold down the Shift key while dragging, the movement of
the Finger cursor will be constrained to a horizontal or vertical direction.

When you release the mouse button, the Finger cursor shows the color last
applied to a bit. To reset the Finger cursor color to the current color, click
the Finger tool icon again. To reset the Finger cursor color to a color in the
pattern, hold down the Alt key and click one of the colors in the pattern.
NOTE: The Finger tool can be selected in Black and White mode, but the
mode is automatically changed to color.

The Paint
bucket tool

The Paint Bucket tool is used to change bits in the Edit Pattern field to the
current color.
To change bits in the Edit Pattern field to the current color:
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1.

Click the Current Color button and choose the color from the
Pattern Color pop-up menu.

2.

Click the Paint Bucket icon and then click a bit in the Edit
Pattern field.
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The bit clicked and all bits of the same color connected to it, are changed to
the current color.
3.

The Hand tool

If you hold down the Alt key with the Paint Bucket tool
selected, the tool will be changed to the Eye Dropper tool. Click
a bit in the Edit Pattern field with the Eye Dropper tool to
select the color of that bit as the current color.

The Hand tool is used to move the pattern within the Edit Pattern field.
To move the pattern within the Edit Pattern field:
1.

Click the Hand tool and move the cursor over the Edit Pattern
field.

2.

Holding down the mouse button, drag the pattern to reposition
it within the Edit Pattern field, and release the mouse button.

The B&W batton The B&W button is used to convert patterns to black and white.
To convert patterns to black and white:
•

click the B&W button.

Any bits used in the pattern that are more than 50% saturated will be
changed to black. Bits that are less than 50% saturated will be changed to
white.
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Revert
•

Click the Revert button to return to the pattern you originally
selected to edit. Any changes you have made will be lost.

Undo
•

Click the Undo button to remove the effects of your last action
only.

Cancel
•

Click the Cancel button to close the Edit Pattern dialog and
return to your PC Draft drawing without making any changes
to the fill patterns.

OK
•

Click the OK button to close the Edit Pattern dialog and
return to your PC Draft drawing accepting the changes you
have made to the selected fill pattern. The Fill Pattern pop-up
menu will be updated to show the new pattern, and the new
pattern will be saved with the document. If a pattern that has
been used to fill objects is edited, the objects will be changed to
reflect the revised pattern.

Object fill
patterns

You can use a pattern to fill the interiors of objects. Filled objects are
opaque and you can select them by clicking their borders or anywhere
within them. If a filled object is on top of another object, it hides the object
beneath it from view.

Selecting the fill
pattern

To select the fill pattern:
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1.

Open the Fill Pattern pop-up menu in the Attributes palette.

2.

Drag until the fill pattern you want is highlighted.
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3.

Release the mouse button. The selected fill pattern will be
shown on the Attributes palette.

NOTE: If you choose `N `(for No fill) from the Fill Pattern submenu as the
current fill pattern, the objects you draw will be wire frame shapes.

Drawing an
object with a
selected fill
pattern

You can change the fill pattern before or after you draw the object.
To draw an object with a selected fill pattern:
1.

Return to the pointer mode. (Make sure that nothing on the
drawing is selected.)

2.

Select the desired fill pattern from the Fill Pattern pop-up
menu in the Attributes palette.

3.

Draw an object.

The object will be drawn with the specified fill pattern.
The Fill Pattern Indicator box in the lower left corner of the window will
change to indicate the pattern you chose.
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NOTE: The chosen fill pattern will be used for objects until you choose
another fill pattern as the default.

Changing the fill
pattern of an
existing object

To change the fill pattern of an existing object:
1.

Select the object that you want to change.

2.

Select the desired fill pattern from the Fill Pattern pop-up
menu in the Attributes palette.

The fill of the selected object will be changed to reflect the chosen fill
pattern.

Parallel fill
pattern

PC Draft's parallel-line objects (single parallel lines, open parallel polylines
and closed parallel polygons) can include fill patterns (including No Fill)
between their component edges.
NOTE: In addition to parallel fills, parallel objects can also have pen colors
and patterns, and object fills.
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Selecting the
parallel fill
pattern

To select the parallel fill pattern:
1.

Open the Parallel Fill Pattern pop-up menu in the Attributes
palette.

2.

Drag until the parallel fill pattern you want is highlighted.

3.

Release the mouse button. The selected parallel fill pattern will
be shown on the Attributes palette.

You can change the parallel fill pattern before or after you draw the parallel
line object.

Drawing a
parallel line
object with a
selected fill
pattern

To draw a parallel line object with a selected fill pattern:
1.

Return to the pointer mode. (Make sure that nothing on the
drawing is selected.)

2.

Select the desired parallel fill pattern from the Parallel Fill
pattern pop-up menu in the Attributes palette.

3.

Draw a parallel line object.

The object will be drawn with the specified fill pattern.
NOTE: The chosen parallel fill pattern will be used for objects until you
choose another parallel fill pattern as the default.
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Changing the fill
pattern of an
existing parallel
line object

To change the fill pattern of an existing parallel line object:
1.

Select the parallel line object that you want to change.

2.

Choose the desired parallel fill pattern from the Parallel Fill
pattern pop-up menu in the Attributes palette.

The fill of the selected parallel line object will change to reflect the chosen
fill pattern.

Pen pattern

This section describes how to use patterns to draw lines and borders. Use
the Pen Pattern pop-up menu in the Attributes palette to choose pen
patterns. You can use different pen patterns to help distinguish between
objects.

Selecting the pen
pattern for lines
and borders

To select the pen pattern:
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1.

Open the Pen Pattern pop-up menu in the Attributes palette.

2.

Drag until the pen pattern you want is highlighted.

Changing the Appearance of Objects

3.

Release the mouse button. The selected pen pattern will be
shown on the Attributes palette.

NOTE: If you choose `N `(for No ink) from the Pen Pattern submenu as the
current pen pattern, the lines and borders you draw will be invisible. Edit
handles appear on selected objects drawn with no ink, but the lines or
borders will not appear on the screen or on printed drawings.
You can change the pen pattern before or after you draw the object.

Drawing a line or To draw a line or object with a selected pen pattern:
object with a
1. Return to the pointer mode. (Make sure that nothing on the
selected pen
drawing is selected.)
pattern
2.

Choose the desired pen pattern from the Pen Pattern pop-up
menu in the Attributes palette.

3.

Draw a line or object.

The line or object will be drawn with the specified pen pattern.
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NOTE: The chosen pen pattern will be used for lines and borders until you
choose another pen pattern as the default.
To change the pen pattern of an existing line or object:
Changing the
pen pattern of an
1. Select the line or object that you want to change.
existing line or
object
2.

Choose the desired pen pattern from the Pen Pattern pop-up
menu in the Attributes palette.

The line or border of the selected object will be changed to reflect the
chosen pen pattern.

Showing and
hiding fills

You can choose to hide fills, including colors and patterns, on your drawing.
When you turn fills off, only the borders of filled objects appear.
To hide fills:
•

Open the Preference menu and choose Hide Fills.

Objects appear as wire frame shapes, and a checkmark appears next to the
Hide Fills command.
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To show fills:
•

Open the Preference menu and choose Hide Fills again.

Objects will be drawn with their respective fills, and the checkmark
disappears from next to the Hide Fills command.

Line and border
attributes

The attributes that define the appearance of lines and borders are sometimes
referred to as the `pen model' or simply, the `pen'. The attributes for the pen
include pen style, line weight, line style and end marks. The border
position of an object can also be specified. The various options for each
attribute are selected using pop-up menus in the Attributes palette or, in the
case of pen style and border position, from the Preference menu.
Pen color or pattern are discussed in other sections of this chapter.
NOTE: Many of the pen model attributes you choose do not affect only
lines, they also affect the borders of objects. For example, when you select a
certain line weight and color, these attributes will be applied to line
segments used to draw rectangles, circles, polygons and so on.

Pen styles

There are two types of pen style: Blade and Round. The pen style options
apply to lines and objects.
The pen style affects the width of angled lines and the appearance of the
ends of lines and of joins:
•

Blade (Accurate width): Lines remain a constant width
regardless of their angle. The line ends will be straight.

•

Round (Accurate width): Lines remain a constant width
regardless of their angle. The line ends will be rounded.
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Blade

Selecting pen
styles

Round

To select a pen style:
1.

Open the Pen Style submenu in the Preference menu.

2.

Drag until the desired pen style is highlighted.

3.

Release the mouse button. A checkmark appears next to the
selected pen style on the submenu.

You can change the pen style before or after you draw the line or object.

Drawing an
To draw an object with a selected pen style:
object with a
selected pen style 1. Return to the pointer mode. (Make sure that no objects on the
drawing are selected.)
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2.

Select the desired pen style from the Pen Style submenu in the
Preference menu.

3.

Draw an object.
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The object will be drawn with the specified pen style.
NOTE: The chosen pen style will be used for objects until you choose
another pen style as the default.

Changing the
pen style of an
existing object

To change the pen style of an existing object:
1.

Select the object to change the pen style of.

2.

Select the desired pen style from the Pen Style submenu in the
Preference menu.

The selected object will be changed to reflect the chosen pen style.

Line weight

Line weight refers to the thickness of lines and borders. Line weight is
measured in pixels (picture elements).
There are eleven different line weights. They vary in size from hairline to
13 pixels. The numbers beside the line weights indicate the number of
pixels that make up the line weight.
NOTE: Although the hairline, 0.5 and 0.75 line weights appear as one point
thick on the screen, they will print at their designated weights on any printer
with a resolution of 300 dpi or more.
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Selecting line
weights

To select the line weight:
1.

Open the Line Weight pop-up menu in the Attributes palette.

2.

Drag until the line weight you want is highlighted.

3.

Release the mouse button. The selected line weight will be
shown on the pop-up menu.

You can change the line weight before or after you draw the line or object.

Drawing a line or To draw a line or object with a selected line weight:
object with a
1. Return to the pointer mode. (Make sure that no objects on the
selected line
drawing are selected.)
weight
2.
3.

Choose the desired line weight from the Line Weight pop-up
menu in the Attributes palette.
Draw a line or object.

The line or object will be drawn with the specified line weight.
NOTE: The chosen line weight will be used for lines and borders until you
choose another line weight for the default line weight attribute.

3 - 38

Changing the Appearance of Objects

Changing the
line weight of an
existing line or
object

To change the line weight of an existing line or object:
1.

Select the line or object to change the line weight of.

2.

Choose the desired line weight from the Line Weight pop-up
menu in the Attributes palette.

The line or border of the selected object will be changed to reflect the
chosen line weight.
NOTE: For information about how to make line weights appear either
magnified or at their normal size while in a zoomed in view.

Line style

The term `line style' refers to whether a line is solid or one of an assortment
of dashed lines. You can use the preset line styles provided with PC Draft or
customize them to make your own. You can use line styles in object
borders and straight lines.
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Selecting line
styles

To select the line style:
1.

Open the line style pop-up menu in the Attributes palette.

2.

Drag until the line style you want is highlighted.

3.

Release the mouse button. The selected line style will be shown
on the pop-up menu.

You can change the line style before or after you draw the line or object.

Drawing a line or To draw a line or object with a selected line style:
object with a
selected line style 1. Return to the pointer mode. (Make sure that no objects on the
drawing are selected.)
2.
3.
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Choose the desired line style from the line style pop-up menu in
the Attributes palette.
Draw a line or object.
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The line or object will be drawn with the specified line style.
NOTE: The chosen line style will be used for lines and borders until you
choose another line style for the default line-style attribute.

Changing the
line style of an
existing line or
object

To change the line style of an existing line or object:
1.

Select the line or object to change the line style of.

2.

Choose the desired line style from the line style pop-up menu in
the Attributes palette.

The line or border of the selected object will be changed to reflect the
chosen line style.
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Editing line
styles

PC Draft provides you with a variety of preset line styles. You can use these
line styles or customize them to suit your needs. When you create your own
custom line styles, each line style can be made up of numerous dashes and
gaps. You can specify the length of each dash and gap.
To select a line style to edit:
1.

Open the Preference menu and drag until Edit Line Styles is
highlighted.

The Edit Line Styles submenu appears.

2.

Holding down the mouse button, drag until the line style you
want to edit is highlighted, and release the mouse button.

The Edit Dashed Line Style dialog appears. The line style you chose to edit
appears in a box below the ruler.
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To edit the line style:
1.

The default measurement for the lengths of dashes and gaps is
inches. To use centimeters to measure the lengths of dashes and
gaps, click the cm radio button.

2.

Without pressing down the mouse button, move the cursor
onto the box containing the line.

Notice that a flag appears above or below the line style (depending on
whether you point above or below the line). You use the flag to specify the
length of dashes and gaps. When you point above the line, the flag turns
white to show you are ready to add gaps to the line. When you point below
the line, the flag turns black to show you are ready to add dashed segments.
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3.

You can edit the line in the following ways:

•

To add a gap or a dashed segment: Position the cursor above
the line to add a gap or below the line to add a dashed segment.
Without pressing down the mouse button, move the pointer to
where you want the dash or gap to begin. As you move the
pointer, notice that the flag moves along with it. Press and hold
down the mouse button, drag to the right until the dash or gap
is the length you want and release the mouse button.

•

To shorten a segment: Position the cursor near the segment you
want to shorten. Holding down the mouse button, drag to the
left until the segment is the length you want and release the
mouse button.

•

To erase the line style: Position the cursor near the right end of
the line. Hold down the mouse button, drag to the extreme left
end of the line and release the mouse button.

Notice that a tick mark on the ruler follows the movement of the flag. The
tick marks show the beginning and end of each segment (either dash or
gap). Notice also that the sample line style below the line will be changed to
reflect the new style and shows you how the line style will appear on a
document.
NOTE: You can create a line style with segments that extend beyond the
limit of the edit box. Although the edit box will not show these segments,
the sample below the box shows you how the line will appear on the
drawing.
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The line style will be repeated after the last segment of the line:

Showing and
hiding line styles

4.

When you have finished editing the line style, click one of the
following buttons.

•

OK: To accept the modified line style and place the line style
into the Line Style pop-up menu for use with lines and borders.

•

Revert: To revert to the original line style (the line style you
originally chose to edit).

•

Cancel: To close the dialog without applying your changes.

If your drawing contains many objects with line styles, you might want to
increase the rate at which the screen is redrawn by hiding the line styles
while you work. When line styles are hidden, solid lines appear on the lines
and objects instead of the line styles.
To hide line styles:
•

Open the Preference menu and choose Hide Line Styles.

Lines will be drawn with solid lines, and a checkmark appears next to the
Hide Line Styles command.
To display line styles:
•

Open the Preference menu and choose Hide Line Styles again.

Lines will be drawn with their respective line styles, and the checkmark
disappears from next to the Hide Line Styles command.

End marks

End marks are symbols on the ends of lines that are used for annotating
drawings. You can make end marks appear on lines by using a set of end
marks in combination with the Line tools, the Polyline tool, the Freehand
Line tool, the Bezier curve tool or the Spline tool.
NOTE: The end marks you can use for the above objects are separate from
the end marks you use for dimension lines .
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Selecting end
marks

To select end marks:
1.

Open the end marks pop-up menu in the Attributes palette.

2.

Drag until the desired end marks are highlighted.

•

Drag down the left side of the pop-up menu to choose a left end
mark; it appears at the beginning of a line.

•

Drag down the right side of the pop-up menu to choose a right
end mark; it appears at the end of a line.

•

Drag down the centre of the pop-up menu to choose both left
and right end marks; these appear at each end of a line.

3.

Release the mouse button. The selected end marks will be
shown on the pop-up menu.

You can change the end marks before or after you draw the line or object.

3 - 46

Changing the Appearance of Objects

Drawing a line or object with selected end marks
To draw a line or object with selected end marks:
1.

Return to the pointer mode. (Make sure that no objects on the
drawing are selected.)

2.

Choose the desired end marks from the end marks pop-up
menu in the Attributes palette.

3.

Draw a line or object.

The line or object will be drawn with the specified end marks.
NOTE: The chosen end marks will be used for lines and borders until you
choose other end marks for the default end marks attribute.
Changing the end marks of an existing line or object
To change the end marks of an existing line or object:
1.

Select the line or object to change the end marks of.

2.

Choose the desired end marks from the end marks pop-up
menu in the Attributes palette.

The end marks wiil be chended to shosen from pop-up.
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Border positions

There are three types of border position: Line Inside, Line Centered and
Line Outside. The border position options apply to objects only, not to lines.
All three border positions affect objects differently, these differences are
discussed later in this chapter. In general though, border position is
important with regard to how objects are aligned. PC Draft uses the position
of an object's edit handles to align objects. It is important to keep this in
mind when you align objects, as border position controls the position of the
edit handles relative to the width (that is the line weight) of the border .

Border position applies only to square-corner and rounded-corner
rectangles, parallel line objects, circles and arcs. You can draw these objects
with a certain border position or change the border position of selected
objects.

3 - 48

Changing the Appearance of Objects

Selecting border
positions

To select a border position:
1.

Open the Border Position submenu in the Preference menu.

2.

Drag until the desired border position is highlighted.

3.

Release the mouse button. A checkmark appears next to the
selected border position on the submenu.

You can change the border position before or after you draw the line or
object.

Drawing an
object with a
selected border
position

To draw an object with a selected border position:
1.

Return to the pointer mode. (Make sure that no objects on the
drawing are selected.)

2.

Choose the desired border position from the Border Position
submenu in the Preference menu.

3.

Draw an object.

The object will be drawn with the specified border position.
NOTE: The chosen border position will be used for objects until you
choose another border position as the default.

Changing the
border position
of an existing
object

To change the border position of an existing object:
1.

Select the object to change the border position of.
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2.

Choose the desired border position from the Border Position
submenu in the Preference menu.

The border of the selected object will be changed to reflect the chosen
border position.

How border position affects objects
Border position determines the location of the edit handles on the border of
an object, and as PC Draft uses the edit handles as reference points for
alignment and size calculations, border position affects the alignment and
size readings of objects.

Line Inside
When you draw an object with the border position
Line Inside, the border of the object appears between
the cursor and the object during creation. When you
select an object created with the border position Line
Inside, the edit handles appear on the outside of the
object. When Show Size is on, the size shown
represents the entire object, including its borders.
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Line Centered
When you draw an object with the border position
Line Centered, the cursor appears centered within
the object's borders during creation. When you select
an object created with the border position Line
Centered, the edit handles appear in the center of the
object's borders. When Show Size is on, the size
shown is the size of the object measured from the
center of the object's borders.
Line Outside
When you draw an object with the border position
Line Outside, the border of the object appears
outside the cursor during creation. When you select
an object created with the border position Line
Outside, the edit handles appear on the inside of the
object. When Show Size is on, the size shown is the
size of the object's interior, excluding the object's
borders.

Copying
attributes

An object's graphic attributes (fill, pen color or pattern, line weight and line
style etc.) and object information can be copied and applied to another
object using either the Attributes tool or the Copy Attributes and Apply
Attributes commands in the Edit menu. The Apply Attributes command can
be used to apply changes to all of the objects selected, while the Attributes
tool applies changes only to the object clicked.
Any settings for applying attributes will be stored only while the application
is running.
The default options for applying attributes are to apply only graphic
attributes, not object information.
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Copying
attributes using
the Attributes
tool

To copy attributes using the Attributes tool:
1.

Click the Attributes tool in the Tool palette

2.

Click an object.

The default attributes will be applied to the object.
3.

With the Attributes tool still selected, hold down the Alt key
and click an object.

The cursor turns into an empty eye dropper.

The object's pen and fill attributes will be copied
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4.

Release the Alt key, the cursor turns into a full eye dropper.

5.

Click another object to apply the copied pen and fill attributes
to it.
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NOTES:
• Attributes will be applied only to the object clicked, even if that object
is part of a group.
• The apply action can be undone by selecting Undo Eye Dropper from
the Edit menu immediately after the apply action.
•
Hold down the Alt key and click in the drawing window with the
Attributes tool, and the tool reverts to the Arrow tool.
Checking and changing attributes before applying them
You can check and, if necessary, change copied attributes before applying
them. There are two ways of doing this when you use the Attributes tool.
The first is to use the Apply Attributes dialog, in which case any changes
will be applied to that action only. The second is to use the Attributes
Options dialog, in which case the settings remain as specified until changed
or until the application is closed.

Using the Apply
Attributes dialog

To open the Apply Attributes dialog before applying attributes to an object:
1.

Select the Attributes tool and hold down the Shift key.

The full eye dropper icon is followed by three dots to show that the Apply
Attributes dialog will appear when an object is clicked.
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2.

Click an object.

The Apply Attributes dialog appears.

3.

Using the
Attributes
Options dialog

Click the Object Fill, Pen Model, Object Information and
Parallel Fill boxes to specify that these attributes should be
applied to the object you have clicked. Any changes made to
the Apply Attributes dialog relate to this apply action only.

To open the Attributes Options dialog:
1.

Hold down the Alt key and click the Attributes tool, or select
the Attributes tool and choose Tool Options from the
Preference menu.

The Attribute Options dialog appears.
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2.

Copying
attributes using
the Edit menu

Click the Object Fill, Pen Model, Object Information and
Parallel Fill boxes to specify that these attributes should be
applied to objects. Settings remain as specified until changed
or until the application is closed, rather than just for the next
use of the tool.

To copy attributes using the Edit menu:
1.

Select the object from which you want to copy attributes.

2.

Open the Edit menu and choose Copy Attributes.
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The object's graphical attributes and object information will be stored.
3.

Select the object or objects to which you want to apply these
attributes.

4.

Open the Edit menu and choose Apply Attributes.

The copied attributes will be applied to the selected object or objects.

NOTE: The apply action can be undone by choosing Undo Apply Attributes
from the Edit menu immediately after the apply action.

Checking and
changing the
attributes before
applying them
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As when using the Attributes tool, there are two ways of checking and
changing the attributes before applying them when you use the Edit menu.
You can use the Apply Attributes dialog, or use the Attributes Options
dialog.
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Using the Apply
Attributes dialog

To open the Apply Attributes dialog before applying attributes to an object:
1.

Hold down the Shift key when you choose the Apply Attributes
command in the Edit menu.

The Apply Attributes dialog appears.
2.

Using the
Attributes
Options dialog

Click the Object Fill, Pen Model, Object Information and
Parallel Fill boxes to specify that these attributes should be
applied to the selected object or objects. Any changes made to
the Apply Attributes dialog relate to this apply action only.

To open the Attributes Options dialog:
1.

Choose Attributes Options from the Edit menu.

The Attributes Options dialog appears.
2.

Click the Object Fill, Pen Model, Object Information and
Parallel Fill boxes to specify that these attributes should be
applied to objects. The settings remain as specified until
changed or until the application is closed, rather than just for
the next use of the Apply Attributes command.

Picture
backgrounds

There may be occasions when you position a picture object on top of
another object, and want the lower object to show through the background
of the foremost object. PC Draft allows you to do this using the Fill Pattern
pop-up menu in the Attributes palette.

Transparent
picture
backgrounds

To make the background of a superimposed picture transparent:
1.

Select a superimposed picture.

In the example below, a stylized picture of the sun has been placed on top of
a picture of the world map. Note that the opaque white background of the
sun picture is obscuring part of the map.
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2.

Choose 'N' (for `No Fill') from the Fill Color pop-up menu, or
`N' (for `No Fill') from the Fill Pattern pop-up menu in the
Attributes palette.

The background of the foremost picture becomes transparent, allowing the
picture beneath to be shown through.

Opaque picture
backgrounds
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The background of a picture can be given a colored or patterned fill in the
same way as other objects. Select the picture and choose a color from the
Fill Color submenu or a pattern from the Fill pattern submenu in the
Attributes palette.
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Annotating
Your Drawing

Annotating Your Annotation describes or gives information about an object in a drawing. In
PC Draft, annotation is of three kinds: text, area calculation, and
Drawing
dimension objects. Text, in a PC Draft document, consists of all letters,
punctuation, and numbers. Once text is created, it is recognized as a single
object and you can then use most functions with it, such as moving and
duplicating.
The Text function allows you to use a variety of fonts, styles, and character
sizes. You can arrange text lines with single spacing, one and a half spacing,
or double spacing. Text can also be justified to the left, center, or right within
each individual text block.

Entering Text

You can enter text in two ways: using the regular text mode or the
paragraph text mode. In the regular text mode, you click on the drawing to
define an insertion point, then type in the text. You define the end of a line
of text by pressing the Enter key. In the paragraph text mode, you drag to
define a text rectangle of a certain size (either with the Text tool or another
drawing tool), and the text you enter into the rectangle automatically
“wraps” when it reaches the side of the rectangle.

Entering Regular To enter regular text, that is, text that does not automatically “wrap”:
Text
1.

Activate the Text icon in the palette by clicking on it.

You will notice that when you activate the text icon and then move the cursor
onto the drawing area, the cursor changes into an I-beam pointer. The I-beam
pointer indicates that you are in the text insertion mode.
2.

Position the I-beam pointer where you want to begin inserting
text.

3.

Click the left mouse button.

A flashing vertical bar will appear at the point where you clicked to show that
you can now begin typing.
4.

Enter the text by typing on the keyboard.
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You can continue to enter text in various places on your drawing by moving
the I-beam pointer to the desired place, clicking the left mouse button, and
typing.
If you make a typing mistake as you are entering text, simply use the Delete
key to remove the error and then type the correct character. To start a new
line in the same text block, just press the Enter key and continue to type.
5.

Entering
Paragraph Text

After you have finished entering text, click on the Pointer tool.

On many occasions, you may wish to enter a paragraph of text and restrict it
to a certain rectangular shape, such as a column. PC Draft’s paragraph text
feature allows you to define a rectangle of any size, then type text into it. As
you enter the text into the rectangle, the words will automatically wrap
around to the next line when the letters reach the edge of the rectangle. If you
type to the bottom of the rectangle, the text will scroll within the rectangle to
keep the line you are typing visible. Paragraph text cannot extend beyond the
drawing edge.
You can define the paragraph text rectangle by drawing a rectangle with the
Text tool, by drawing a rectangle or other object, or by selecting an existing
rectangle or other object. (If you draw or select a non-rectangular object and
start typing, the text will appear in a rectangle superimposed over the object.)
To use the paragraph text feature with the Text tool:
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1.

Activate the Text tool.

2.

Position the I-beam pointer where you want to begin entering
text.

3.

Press down the left mouse button.

4.

Holding down the left mouse button, drag in a diagonal
direction until you have defined a rectangle that is the size you
want.
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7.

5.

Release the left mouse
button.

6.

Start entering text from the
keyboard.

When you are done, click on the Pointer tool to end the text
entry.

To use the paragraph text feature with the Rectangle tool (or other drawing
tool):
1.

Activate the Rectangle tool (or other drawing tool).

2.

Position the pointer where you want to begin entering text.

3.

Press down the left mouse button.

4.

Holding down the left mouse button, drag in a diagonal
direction until you have defined an object that is the size you
want.

5.

Release the left mouse button.
6.

Start entering text from the
keyboard.

7.

When you are done, click on
the Pointer tool to end the text
entry.

NOTE: The text and the object you drew to locate the text are separate
objects; you can move and reshape them separately.
To use the paragraph text feature with an existing rectangle or other shape:
1.

Select the object.

2.

Start entering text from the keyboard.
Annotating Your Drawing
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3.

When you are done, click on the Pointer tool to end the
text entry.

NOTE: The text and the object you selected to locate the text are separate
objects; you can move and reshape them separately.

Reshaping a
Block of
Paragraph Text

Once the paragraph of text is entered, you can reshape the paragraph using
the edit handles. To reshape the paragraph:
1.

Return to the pointer mode.

2.

Select the paragraph of text by clicking on it.

Edit handles should appear on the text block.
3.

Position the tip of the pointer on one of the edit handles.

4. Press down the left
mouse button.
5. Holding down the left
mouse button, drag
until the
paragraph
is the shape you want.
6. Release the left mouse
button.

Selecting Text
for Editing

Sometimes you will want to edit text you have previously entered on your
drawing. PC Draft has three ways to edit text: replacing an existing word or
line of text by selecting it and retyping in its place; inserting characters or
words at any selected point in the text; and backspacing to delete text.
Before you can edit a piece of text, you must select it. You can select text by
using the pointer while in the pointer mode, or by using the I-beam pointer.
(When you select text using the pointer mode, any changes you make will
affect the entire text block.)
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Using the I-Beam To select text using the I-beam pointer:
Pointer
1.

Click on the Text tool icon in the palette.

2.

Position the I-beam pointer to either side of the text you want to
change.

3.

Press down the left mouse button.
4.

Holding down the left mouse
button, drag through all the text
you want to edit.

5.

Release the left mouse button.

Notice that the text becomes highlighted as you drag through it. Using this
method of selecting allows you to select a single character or an entire block
of text.

Selecting a Word You can select an individual word by double-clicking on it.
To select a word:
1.

Position the I-beam pointer on the word you want to select.

2.

Double-click the left mouse button.

Once you have double-clicked on a word, you can extend the selection to
Extending the
Selection of Text include other words in the text block by following these steps:

Selecting a
Range of Text

1.

After the second click, hold the left mouse button down.

2.

Drag through the text until all the words you want to select are
highlighted.

3.

Release the left mouse button.

You can select a range of text in a block, including multiple lines of text, by
using the Shift-click method.
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To select a range of text:
1.

Position the I-beam pointer at the starting point for the range.

2.

Click the left mouse button.

3.

Press down the Shift key.

4.

Position the I-beam pointer on the ending point for the range.

5.

Holding down the Shift key, click the left mouse button.

6.

Release the left mouse button and the Shift key.

The text between the specified starting and ending points will be selected.

Using the Arrow
Pointer to Select
Text

To select text using the arrow pointer:
1.

Position the pointer tip on the block of text that you want to
select.

2. Click the left mouse button.

Notice that a rectangle and/or a set of edit handles appears around the text,
indicating that it is selected. This method of selecting text allows you to
change the text attributes (including the font, size, and style) of the selected
text block.

Selecting Rotated To select rotated text:
Text for Editing
1.

Activate the Text tool in the palette.

2.

Click on the block of rotated text you want to edit.

The text will temporarily be rotated to zero degrees (horizontal orientation) to
allow you to edit it.
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When you are through editing the text:
3.

Click on the Pointer tool.

Once you click on the Pointer tool, the text will return to its rotated position.
NOTE: If you print rotated text on most printers that are not PostScript®compatible, the text will print out at the resolution of the printer hardware.

Selecting All
Text

You can select all the text on the active layer if you want to make a global
change to text attributes. This feature is useful if you change the scale of the
drawing and then want to change the size of the text to make it conform with
the new scale.
To select all the text on the active layer:

Hiding All Text

1.

Return to the pointer mode.

2.

Open the Text menu and choose Select All Text.

At times, you may want to temporarily remove the display of all text from the
document. If you choose to hide the text and then print or plot the document,
the text will not appear on the output. You might use this feature to hide all
the text before you generate a test plot of a drawing to shorten the plotting
time. If you are working on a complex drawing with many elements, you
could use this feature to minimize the amount of time it takes to redraw the
screen after you scroll or zoom.
To hide all text:
•

Open the Text menu and choose Hide Text.

All the text on the drawing will be temporarily removed from the screen and
from any output until you choose to re-display the text. A check mark will
appear beside Hide Text in the Text menu.

Redisplaying All
Text

When you want to make the text appear on the screen and on your output, you
can choose the Hide Text command again.
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To redisplay all text:
•

Open the Text menu and choose Hide Text (with the check
mark).

The check mark will disappear from beside Hide Text in the Text menu, and
the text in the drawing will be visible.

Replacing
Existing Text

Once you have selected any portion of text, you can immediately replace it by
simply typing in the new text. As soon as you begin typing, the old text will
disappear. As you enter the new text, all of the non-selected text in the line
will automatically adjust to make room for the text you are entering.

Inserting Text
Into Existing
Text

On many occasions you will want to insert a single character, a word, or a
sentence into an existing piece of text.
To insert text:
1.

Activate the Text tool in the palette by clicking on it.

2.

Position the I-beam pointer on the desired insertion point.

3.

Click the left mouse button.

4.

Type in the character or words that you wish to insert. (Keep in
mind that you can press the Delete key to backspace over
characters or words.)

In this mode, you can continue to pick insertion points in other pieces of text
on your drawing and edit them as well.
Once you have completed all the editing that you want to do:
5.

Click on the Pointer icon in the palette.

Deleting Selected There are two simple ways to delete text that you have selected. You can
either:
Text
•
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Open the Edit menu and choose Cut or Clear
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or,
•

Press the Delete key

Changing the
Appearance of
Text

You can choose the way you want to present text either prior to entering the
text, or by changing the text after it has been entered. There are many options
to choose from to obtain the effect that you desire. PC Draft allows you to
use many different font types, sizes, and styles for text.

Determining
Font, Style, and
Size Before Text
Entry

To define attributes for text before you enter it:
•

Make sure that no text is selected on the drawing before you
make each choice.

To define the font, size and style:

1.

Open the text menu and select Font.
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2.

Select the font, size and style that you want.

3.

Click on the OK button.

After you have made your choices for text:
1.

Activate the Text icon in the palette by clicking on it.

2.

Position the I-beam pointer where you want to add text.

3.

Click the left mouse button.

4. Enter the text on your drawing.

Changing the
Appearance of
Existing Text

You can change the font, size, and style of any existing text. You can check
to see which attributes a given piece of text possesses by selecting the text
and the submenu associated with the attribute of interest.
To assign an attribute to text on the drawing:
1.

Select the text you wish to change. (You can select and change
single characters using the Text tool’s I-beam cursor, or all the
words in a text block using the pointer.)

2.

Choose the text attributes you want from the Text menu’s Font.

Each time you make a choice from the Text menu, the selected text will
change to reflect that choice.

Changing the
Case of Text

On some occasions you may enter a piece of text in one case, such as
lowercase, and then decide that you want it in uppercase or in title format.
You could clear the text and re-enter it; however, PC Draft offers you the
ability to change the case of existing text.
To change the case of text:
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1.

Select the text that you want to change by clicking on it.

2.

Open the Text menu’s Case submenu.
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3.

Drag until the case option you want is highlighted.

The results of each choice are as follows:

UPPERCASE:

Converts all selected text to uppercase.

lowercase:

Converts all selected text to lowercase.

Title Text:

Capitalizes the first character of each word in
selected text.

Choosing Line
Spacing

PC Draft offers you flexibility in choosing line spacing (also called
“leading”) options to suit your needs. You can have one, one and a half, or
two spaces between lines of text. You can choose the line spacing attribute
prior to entering text, or you can change the spacing on existing text.

Choosing the
Line Spacing
Before Entering
Text

To choose the line spacing prior to entering text:
1.

Make sure that no text is selected on the drawing.

2.

Choose Line Spacing from the Text menu.

The Line Spacing submenu will appear.
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Changing the
Line Spacing of
Existing Text

3.

Drag the cursor until the line spacing you want is highlighted.

4.

Click the left mouse button.

5.

Enter text as you would normally.

To change the line spacing of existing text:
1.

Select the block of text to be changed by clicking on it.

2.

Choose Line Spacing from the Text menu.

The Line Spacing submenu will appear.

Moving Text

3.

Drag the cursor until the line spacing you want is highlighted.

4.

Click the left mouse button.

Once you have created a block of text, you can move it to a different location
on your drawing if you want. Notice that when you create a line of text and
then click anywhere else, the text becomes surrounded by a box or edit
handles. This indicates that PC Draft recognizes the piece of text as an
object. You can move the text just as you would move any other object.
To move a piece of text:
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1.

Point on the text block.

2.

Press down the left mouse button and hold it until the white
arrow pointer appears.
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3.

Drag the text to its new position.

4.

Release the left mouse button.

Aligning Text

There are two ways to align text: justifying a line of text with another line
during text entry; and aligning text with an object or another piece of text that
is treated as an object.

Justifying Text
During Text
Entry

To justify text as you enter it:
1.

Make sure that no text is selected on the drawing.

2.

Open the Text menu’s Justification submenu.

3.

Drag until the type of justification you want (Left, Center, or
Right) is highlighted.

4.

Click the left mouse button.

5.

Activate the Text tool by clicking on it.

6.

Click where you want the text to appear.

7.

Begin typing.

Notice that each time you press the Enter key, the next line of text is justified
according to your choice (Left, Center, or Right).
You can change the justification of an existing text block by selecting the text
block and then choosing the justification option you want from the Text
menu’s Justification submenu.

Aligning Text as
an Object

To align text with another piece of text or an object:
1.

Select the piece of text to be aligned by clicking on it.

2.

Open the Arrange menu and choose Alignment Options .
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3.

Once the Alignment dialog box is displayed, choose the
alignment method you want.

4.

Click on the OK button.

5.

Click on the object with which you want the text block aligned.

Once you have clicked on one of the text blocks, all selected text and objects
will snap into alignment with the text on which you clicked according to the
specified alignment attribute.
For more information on using the Align command, see the section called
“Aligning Objects,” beginning in Chapter 5.

Dimensions

PC Draft’s Dimension tools allow you to add dimension lines to your
drawing so that you can display and print the sizes of (or distances between)
various lines and objects. Dimensions display sizes and distances in realworld units according to the scale of the drawing.
Dimension lines in PC Draft show the distance between two points on the
drawing. If you change the length of the dimension line, the value
associated with it will be updated to reflect the new length, according to the
current scale.
In addition, PC Draft can show and print the size of an angle. Angular
dimensions appear in degrees of arc, regardless of the scale of a drawing.
Like dimension lines, angular dimension objects display updated values
after editing.
PC Draft’s dimensions are specialized objects that can incorporate a range
of recognized drafting formats and standards, including witness lines,
extension gaps, and so on.

Linked
dimensions

4 - 14

Dimension objects that are drawn with reference to object vertices will be
linked to those points by default. This means that if the object is resized, the
dimension object and the value associated with it will be updated to reflect
the new size.
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Object vertices and dimension objects can be linked and unlinked using
some of the tools in the Accessory palette.

Types of
Dimension
Objects

The dimension objects are created and controlled using the tools and popout
menus of the Dimension Palette. The Dimension Palette can be displayed
using the View menu’s Palettes submenu.
The dimension tools can create linear (horizontal, vertical, sloped, or
perpendicular), radial (radius or diameter), and angular dimensions.
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Linear dimensions can consist of a single dimension span, several
dimensions chained together, or several dimensions measured from the
same baseline, as shown below.

Linear dimensions are created independently of existing objects, but can use
existing vertices, corners, and so on as their points of reference. If the Snap
to Object feature is active, the dimension tools will snap the reference
points to existing corners and handles.
Radial dimensions appear as straight lines (like linear dimensions), but
measure the radius or diameter of an existing circle, ellipse, or arc.

Angular dimensions measure the angle of arc between any two straight lines
or edges of square-cornered rectangles, polygons, or polylines (single-line
or parallel). The lines or edges need not intersect.
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In addition to the three types of dimension tools, PC Draft includes a Circle
Center mark tool, for marking the center of a circle, arc, or ellipse.

Dimension
Standards and
Formats

PC Draft follows recognized drafting and design standards for dimensioning
in English units (as mandated by the American National Standards Institute,
or ANSI) and metric units (matching the BS-308, DIN, ISO, and JIS
standards). These standards, which you can modify in PC Draft to meet
your own needs, control the sizes and lengths of such dimension elements
as witness lines, leader lines, gaps between elements, and so on. A
drawing’s dimension standards are displayed and set using the Dimension
Standards dialog box (see below), which is opened using the Dimension
Standards: Custom button in the Set Scale/Units dialog box.

PC Draft also allows you to control the formats of dimension objects. You
can define whether a dimension object’s text is displayed horizontally, how
dimension arrows are positioned, where (and whether) leader lines appear,
and so on. The Dimension Format dialog box is opened using the Format
button in the Dimension palette.
Annotating Your Drawing
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The use of each element in the Dimension Format dialog box is detailed
beginning on page 4-25.

Standards

Although PC Draft’s dimension standards follow approved guidelines for
English-unit and metric drawings, you can adjust them to meet your own
needs.
These attributes are controlled using the Dimension Standards dialog box.
They can be adjusted for selected dimension objects or defaults, to
determine the attributes for dimension objects drawn subsequently.

To change the dimension standard defaults for a drawing:
1.

Open the Layout menu and choose the Set Scale/Units
command.

The Document Scale & Units dialog box will appear.
2.
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Click the Dimension Standard: Custom button.
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The Dimension Standards dialog box will appear.

3.

Click and type in the appropriate fields to change standards as
needed.

4.

Click the OK button.

The Document Scale & Units dialog box will appear again. The Dimension
Standard: Status field will now read “Custom.”
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5.

Click the OK button.

The dimension standards you revised will now be the standards for all new
dimension objects.

To Change the
Dimension
Standards for
Existing
Dimension
Objects:

1. Select the dimension object or objects.
2.

Click the Format button in the Dimension palette.

The Dimension Format dialog box will appear.

3.

Click the Standards... button

The Dimension Standards dialog box will appear.
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3.

Click and type in the appropriate fields to change standards as
needed.

4.

Click the OK button.

The Dimension Format dialog box will appear again.
5.

Click the OK button.

The dimension objects you selected will now appear revised as you
specified. For details on the effects of each standard attribute, see the
following section.

Dimension
Standard
Attributes

Witness Extension
The Witness Extension is the length the witness line extends beyond the
dimension line itself. (Units indicate distance on screen and on the printed
drawing, not in scaled units.)
Witness Line Gap
The distance from each reference point to the beginning of its witness line.
(Units indicate distance on screen and on printed drawing, not in scaled
units.)
Dimension Text Gap
The distance from any side of the dimension text to the dimension line or
arc. (Units indicate distance on screen and on printed drawing, not in scaled
units.)
Leader Length
The length of the leader line connecting the dimension text to the dimension
line or arc. (Units indicate distance on screen and on printed drawing, not in
scaled units.)
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Outside Line Length
The length of the lines indicating a linear dimension when the dimension
object is formatted so that the lines are outside the witness lines, pointing
“inward.” (Units indicate distance on screen and on printed drawing, not in
scaled units.)

Tolerance Text
A percentage value determining the point size of tolerance text (if any)
relative to the dimension value text. Values can range from 25% (one-fourth
the size of the dimension text) to 200% (twice the size of the dimension
text).
Tolerance Space Scale
A percentage value determining the line spacing when two lines of
tolerance value text appear together (either two tolerance values or tolerance
limits). The percentage is relative to the size of tolerance text itself, and
ranges from 25% (one-fourth of a line) to 200% (two lines, or double
spacing). Since a 100% setting single-spaces the text, values less than 100%
percent may result in overlapping, depending on the font chosen for the
dimension object.
Circle Center Length, Gap, and Extension

These settings determine the size attributes
of the Circle Center mark (made with the
Circle Center mark tool), as shown.
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Although the values are given in screen units rather than scale units, Circle
Center marks will change size as appropriate if a whole drawing is rescaled.
Revert to Standard
Clicking this check box instantly returns all the settings in the dialog box to
the ANSI or Metric standard values.

Formats

Some of the display attributes for dimension objects can be adjusted for
existing dimensions. These attributes are controlled using the Dimension
Format dialog box. They can also be adjusted as drawing defaults, to
determine the attributes for dimension objects drawn subsequently.
To change dimension format defaults for a whole drawing:
1.

Make sure no objects are selected by clicking on a blank area
of the drawing.

2.

Click the Format button in the Dimension palette.

The Dimension Format dialog box will appear.

3.

From the Dimension Type pop-out menu, choose the type of
dimension (Linear, Radial, or Angular) that you want to
change.
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4.

Adjust the settings as needed.

5.

If you want to set defaults for more than one dimension type,
repeat steps 3 and 4.

6.

When you are done, click the OK button.

The dialog box will disappear, and the formats you revised will now be the
defaults for all new dimension objects.
To change the dimension formats for existing dimension objects:
1.

Select the dimension object or objects.

2.

Click the Format button in the Dimension palette.

The Dimension Format dialog box will appear.

3.

Adjust the settings as needed, then click the OK button.

The dialog box will disappear, and the selected objects will be changed as
you specified.
For details on the effects of each format attribute, see the following section.
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Dimension
Format
Attributes

Dimension Type
If no object is selected, this pop-out menu controls which type of dimension
object tool’s defaults are adjusted: linear, radial, or angular.
Text Display
This pop-out menu controls whether dimension text is displayed
horizontally on the drawing, or along, above, or below a dimension,
extension, or leader line.
Text Centered
Controls whether dimension text is centered on a dimension line or
dimension arc.
Text Framed
Controls whether dimension text appears within a frame.
Witness Lines
Controls whether witness lines are displayed.
Arrows Inside
Controls how end marks (usually arrowheads) appear on dimension objects.
Round Off
Controls whether dimension values are rounded off. (The values available
for rounding off are in the scale and units of the drawing.)
Leader
Applicable only when dimension text appears horizontally outside a
dimension object, this item controls whether a leader line extends from a
dimension line to the left or to the right.
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R, D Symbol
Applicable only to radial dimensions, this item controls whether the radius
or diameter symbol leads or follows the dimension value.
Tolerance
This pop-out menu controls how many tolerances are displayed: None; One,
for a single “plus/minus” value determined by the Tol. 1 field below; Two,
for a “plus” value from the Tol. 1 field and a “minus” value from the Tol. 2
field (as in “333 cm +1cm -2cm”); or Limits, for two dimension values
calculated from the Tol. 1 and Tol. 2 fields in place of original dimension
value (as in “331 cm / 334 cm” in place of “333 cm”).
Tol. 1, Tol. 2
These fields control the default values for tolerance displays, as described
above.
Dimension Label
When this box is checked, you can replace an existing object’s dimension
text with a text string of your own choosing. Any tolerances will be hidden
if this option is chosen.
NOTE: If you need to type an angular degree symbol ( ° ) in the label, use
Alt-248.

Dimension End
Marks

PC Draft’s dimension lines and dimension objects can have end marks,
usually arrows or slashes at the ends of a dimension line. The end marks for
dimension objects are controlled by the pop-out menu near the bottom of
the Dimension palette; the end marks for ordinary lines are controlled by the
End Marks popup menu in the Attribute palette, as described in Chapter 3.
With both dimensions, you can specify different end marks for each end of
the line. To change the end marks of an existing dimension object:
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1.

Select the object.

2.

Move the cursor to the Dimension palette’s End Marks pop-up
menu and click the left mouse button.
The pop-out menu will open.
3. Move the cursor to highlight
the desired end marks: Highlight
the left end for the end mark to
appear at the start of the line or
arc, the right end for it to appear
at the finish of the line or arc, or
in the middle for it to appear at
both ends.
4. Click the left mouse button.

The end marks you specified will appear on the object.

To change the end marks before drawing dimension object.
1.

Make sure nothing is selected.

2.

Move the cursor to the Dimension palette’s End Marks popout menu and click the left mouse button.
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The pop-out menu will open.
3.

Move the cursor to highlight the desired end marks: Highlight
the left end for the end mark to appear at the start of the line
or arc, the right end for it to appear at the finish of the line or
arc, or in the middle for it to appear at both ends.

4.

Click the left mouse button.

The end marks you specified will appear on any new dimension objects you
draw.

Drawing
Dimension
Objects

PC Draft’s dimension objects include linear (horizontal, vertical, sloped, or
perpendicular), radial (radius or diameter), and angular dimensions. The
creation of each type is detailed over the following pages.
Once created, dimension objects can be independently resized and edited
much like other PC Draft shapes. In addition, their attributes, such as color,
line style, text font, and so on can be controlled in the standard fashions.
Different components of a dimension object can be treated independently
once the object is disassembled using the Accessory palette’s Break tool.

Linear
Dimension
Objects

PC Draft’s linear dimension tools (horizontal, vertical, slope, and
perpendicular) let you display and print distances between points, either in
pairs (single dimensions), strung together (chained dimensions), or from a
single starting point (baseline dimensions).
Single:

Chained:

Baseline:
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The user-defined reference points for linear dimensions can be either part of
existing objects (on corners or edges) or independent points on the drawing.
To show an object’s size precisely, it’s usually necessary to put the
dimension’s reference points on the object’s corner points (or other edit
handles).
The horizontal and vertical dimension tools create dimension lines that are
constrained to horizontal or vertical orientations. When edited, moved, or
resized, horizontal and vertical dimension objects retain their original angles
of orientation.

The slope dimension tool can create
dimension lines running in any
direction on a drawing. Slope
dimensions can be edited, moved, or
resized to any angle.
The perpendicular dimension tool
creates dimensions perpendicular to
lines or to the edges of square-cornered
rectangles, polygons, and polylines
(single-line or parallel). When edited,
moved, or resized, perpendicular
dimension objects retain their original
angles of orientation.

Horizontal
Dimension
Objects

To create a single horizontal dimension line:

1.

Select the horizontal dimension
tool from the Dimension palette.
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The cursor will now read “1st point.”
2.

Click the first point for the dimension line (on an object's
corner, if desired).

The cursor will now read “2nd Point.”
3.

Click the second point for the dimension line.

The cursor will now read “Anchor,” and include an outline of the
dimension’s text box.
4.

Click on the drawing where you want the text value to appear.

The dimension object will be complete, with the horizontal distance
between the two points displayed where you specified.
To change the attributes of a horizontal dimension object, select the object,
click the Format button in the Dimension palette, and change the various
settings as required.

Chained Linear
Dimensions

For all linear dimension tools, you can also draw a string (or chain) of linear
dimension lines, one after the other.

To create a chain of linear dimension
lines:
1.
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Open the modes pop-out menu
in the Dimension palette and
choose Chained.

2. Select a linear dimension tool from the Dimension palette.
The cursor will now read “1st point.”
3.

Click the first point for the dimension line.

The cursor will now read “Next Point.”
4.

Click the second point for the dimension line.

The cursor will now read “Anchor,” and include an outline of the
dimension’s text box.
5.

Click on the drawing where you want the text box to appear.

The distance between the first two points will appear, and the cursor will
now read “Next Point.”
6.

Click the next point for the dimension line.

The cursor will read “Anchor” again.
NOTE: If you hold down the Shift key, you can constrain the placement of
the next dimension text block to the same plane as the first segment’s text.
7.

Click on the drawing where you want the next text box to
appear.

The distance between the second and third points will appear, and the cursor
will now read “Next Point.”
8.

Continue as in steps 6 and 7 until you want to exit the
dimension-drawing mode, then click the Pointer tool in the
Tool palette.
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The dimension objects will be complete, with the appropriate distances
between the various points displayed where you specified.
The Chained mode of the dimension tool creates a series of single
dimension objects, which can be moved, resized, or edited independently.

Baseline Linear
Dimensions

PC Draft lets you draw several linear dimension lines from one starting
point.

1. Open the modes pop-out menu in
the dimension section of the
Dimension palette and choose
Baseline.
2.

Select a linear dimension tool from
the Dimension palette.

The cursor will now read “1st point.”
3.

Click the first point for the dimension line. (This will be the
base point for all the dimension objects created in this process.)

The cursor will now read “Next Point.”
4.

Click the second point for the dimension line.

The cursor will now read “Anchor,” and include an outline of the
dimension’s text box.
5.

Click on the drawing where you want the text box to appear.

The distance between the first two points will appear, and the cursor will
now read “Next Point.”
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6.

Click the next point for the dimension line.

The cursor will read “Anchor” again.
7.

Click on the drawing where you want the next text box to
appear.

The distance between the first and third points will appear, and the cursor
will now read “Next Point.”
8.

Continue as in steps 6 and 7 until you want to exit the
dimension-drawing mode, then click the Pointer tool in the Tool
palette.

The dimension objects will be complete, with the appropriate distances from
the first baseline point to the various other points displayed where you
specified.

The Baseline mode of the dimension tool creates a series of single dimension
objects, which can be moved, resized, or edited independently.

Vertical
Dimension
Objects

To create a single vertical dimension line:

1.

Select the vertical dimension tool from
the Dimension palette. The cursor will
now read “1st point.”

2.

Click the first point for the dimension
line.
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The cursor will now read “2nd Point.”
3.

Click the second point for the dimension line.

The cursor will now read “Anchor,” and include an outline of the
dimension’s text box.

4. Click on the drawing where you want
the text value to appear.

The dimension object will be complete, with the vertical distance between
the two points displayed where you specified.
You can also draw vertical dimension lines in a string (or chain) one after
the other, or emanating from one starting point (or baseline); see the
“Chained Linear Dimensions” and “Baseline Linear Dimensions” sections
earlier in this chapter for details.

To change the attributes of a vertical dimension object, select the object,
click the Format button in the Dimension palette, and change the various
settings as required. (See pages 4-23 and 4-28 for information on the effects
of the different dimension format and standards settings.)

Slope Dimension
Objects

To create a single slope dimension line:
1.

Select the slope dimension tool from the Dimension palette.

The cursor will now read “1st point.”

2.
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Click the first point for the
dimension line.

The cursor will now read “2nd Point.”
3.

Click the second point for the dimension line.

The cursor will now read “Anchor,” and include an outline of the
dimension’s text box.
4.

Click on the drawing where you want the text box to appear.

The dimension object will be complete, with the distance along the slope
between the two points displayed where you specified.

You can also draw slope dimension lines in a
string (or chain) one after the other, or
emanating from one starting
point (or
baseline); see the “Chained Linear Dimensions”
and Baseline Linear Dimensions” sections earlier
in this chapter for details.

To change the attributes of a slope dimension object, select the object, click
the Format button in the Dimension palette, and change the various settings
as required. (See pages 4-23 and 4-28 for information on the effects of the
different dimension format and standards settings.)
PC Draft has a specific tool for creating dimension lines perpendicular to
existing lines or to the edges of square-corner rectangles, polygons, or
polylines (single-line or parallel).

Perpendicular
Dimension
Objects

To create a perpendicular dimension line:

1. Select the perpendicular dimension
tool from the Dimension palette.
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The cursor will now read “Click Line/Edge.”

2.

Click the line or edge for the first point of the dimension line.

The cursor will now read “2nd point.”
3.

Click the second point for the dimension line.

The cursor will now read “Anchor,” and include an outline of the
dimension’s text box.
4.

Click on the drawing where you want the text box to appear.

The dimension object will be complete, with the perpendicular distance
from the edge of the object to the point you chose displayed.
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NOTE: If you hold down the Alt key while drawing a perpendicular
dimension line, its length will be constrained to increments of the current
snap-grid distance.
If you move, edit, or resize the perpendicular dimension line, it will retain
its original orientation (its “perpendicularity”).
You can also draw perpendicular dimension lines in a string (or chain) one
after the other, or emanating from one starting point (or baseline); see the
“Chained Linear Dimensions” and “Baseline Linear Dimensions” sections
earlier in this chapter for details.
To change the dimension attributes of a perpendicular dimension object,
select the object, click the Format button in the Dimension palette, and
change the various settings as required.

Radial
Dimension
Objects

PC Draft’s radial dimension tools let you display and print the radius or
diameter of a circle, arc, or ellipse.
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To apply a radial dimension to an object:
1.

Select the radial dimension tool from the Dimension palette.

The cursor will now read “Click Circle/
Arc.”
2. Click the circle, arc, or ellipse.
The cursor will now read “Anchor,” and
include an outline of the dimension’s text
box.

NOTE: To constrain the angle of the dimension line to 45° increments,
hold down the Shift key after selecting the circle, while clicking the anchor
point where the dimension text is to appear.
3.

Click on the drawing where you want the text value to appear.

The dimension object will be complete, with the radial distance displayed
where you specified.

Diameter
Dimensions
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Diameter dimensions are drawn in much the same manner.
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To create a diametric dimension:

1. Select the diameter dimension tool
from the Dimension palette.
The cursor will now read “Click Circle/
Arc.”
2. Click the circle, arc, or ellipse.
The cursor will now read “Anchor,” and
include an outline of the dimension’s text
box.

NOTE: To constrain the angle of the dimension line to 45° increments,
hold down the Shift key after selecting the circle, while clicking the anchor
point where the dimension text is to appear.
3.

Click on the drawing where you want the text box to appear.

The dimension object will be complete, with the diametric distance
appearing where you specified.

Circle Center
Marks

PC Draft includes a special tool for indicating the center of circles, ellipses,
and arcs. It appears in the Dimension palette.
NOTE: Circle Center marks cannot be applied to ellipses and elliptical arcs
that have been rotated.
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To apply a Circle Center mark:
1.

Select the Circle Center Mark tool in the Dimension palette.

The cursor will read “Click Circle/Arc.”
2. Click the circle, arc, or ellipse.

The Circle Center mark will appear over the object

The mark can be disassembled (using the Accessory palette’s Break tool)
and edited if necessary. In addition, you can change the tool’s size defaults;
see page 4-23 for details.

Angular
Dimension
Objects
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PC Draft’s angular dimension tool lets you display and print the angles
between different lines or edges, whether they intersect or not. You can
apply an angular dimension object to any pair of straight lines or edges of
square-cornered rectangles, or polygons or polylines (single-line or
parallel).
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To create an angular dimension:
1.

Decide which two lines or edges you want to apply a dimension
object to.

2

Select the angular
dimension tool from the
Dimension palette.

The cursor will now read “1st Line/Edge.”
3.

Click the first line or edge.

The cursor will now read “2nd Line/Edge.”
4.

Click the second line or edge.

The cursor will now read “Anchor,” and include an outline of the
dimension’s text box.
5.

Click on the drawing where you want the text value to appear.

The dimension object will be complete, with the angle between the two
edges displayed where you specified.
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NOTE: To display the obtuse rather than acute angle between two lines or
edges, hold down the Alt key after selecting the second edge, while clicking
the point where the dimension text is to appear.
To change the attributes of an angular dimension object, select the object,
click the Format button in the Dimension palette, and change the various
settings as required.

Linking and
unlinking
dimension
objects

Dimension objects that are drawn with reference to object vertices will be
linked to those points by default. This means that if the object is resized, the
dimension object and the value associated with it will be updated to reflect
the new size.
Object vertices and dimension objects can be linked and unlinked using
some of the tools in the Accessory palette. These tools can also be used to
link object vertices with other object vertices in the same way.

To display the Accessory palette:
Displaying the
Accessory palette
•
•
•

Select Accessory from the Palettes submenu in the View menu,
or
Select Accessory from the Window menu, or
Select Accessory from the popup menu at the bottom left of the
document window.
Link Unlink Unlink all

Dimension objects (and other objects) can be linked by positioning the
dimension object on an object vertex and using the Link tool from the
Accessory palette to link the two objects at that point. Once linked, a
dimension object will be automatically updated if the object it is linked to is
resized.
NOTE: Many dimension objects are automatically linked to object vertices
when they are first drawn.
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Link

To link objects:
1.

Draw or locate the objects, or object and dimension object, to
be linked.

2.

Position the objects so that a vertex point of one object is at the
same location as a vertex point of the other object.

3.

Open the Accessory palette (if necessary) and select the Link
tool.

The cursor will display with a question mark next to it.
4.

Click on the points that are to be linked.
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The vertex point of the dimension object will be linked to the other object.
If the object is resized the dimension object will be automatically updated.

Other vertex points can be linked in the same way.
Dimension objects (and other objects) can be unlinked from an object by
using the Unlink tool from the Accessory palette to break the link between
the two objects at a specific point. Once unlinked, a dimension object will
not be updated if the object it was previously linked to is resized.

Unlink

To unlink objects:
1.

Locate the objects, or object and dimension object, to be
unlinked.

2.

Open the Accessory palette (if necessary) and select the Unlink
tool.

The cursor will appear with a question mark next to it.
3.

Click on the points that are to be unlinked.

The vertex point of the dimension object will be unlinked from the other
object. If the object is resized the dimension object will not be updated.
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Other linked objects can be unlinked in the same way.
You can break all the links for an object by using the Unlink All tool from
the Accessory palette to break all the links associated with a selected object.
This will be faster than using the Unlink tool if an object is linked to
another object at more than one point, or is linked to several different
objects, and you want to remove all the links.

Unlink all

To break all an object’s links:
1.

Select the object (or dimension object) you wish to remove all
links from.

2.

Open the Accessory palette (if necessary) and select the Unlink
All tool. An alert will appear warning that you are about to
remove the all the links from the selected objects.
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3.

Click Cancel to return to the drawing without removing the
links, or click Unlink to remove all the links from the selected
objects.

If you click Unlink, all the links will be removed from the selected object. If
dimension objects were selected, or linked to the selected objects, they will
no longer update if the object is resized.

Breaking
Dimension
Objects

The Accessory palette’s Break tool can be used to separate dimension
objects into distinct lines and so on. This is necessary when you want to
give different line attributes to different parts of a dimension object.
In most cases, the components of a dimension object will appear the same
after the use of the Break tool; that is, their positions and attributes will not
change. Once the object is broken apart into separate objects, each new
object can be moved, edited, resized, or otherwise changed like any other
PC Draft object.
WARNING: A dimension object that has been broken apart cannot be
converted back (“reassembled”) into a dimension object. The partial
exception to this is the fact that the Undo command will reverse any
immediately preceding Break tool. However, if elements from a brokenapart dimension object are edited, moved, or de-selected, the Undo
command will no longer be able to reverse the Break tool.
To break apart a dimension object:

4 - 46

1.

Select the dimension object you want to break apart.

2.

Open the Accessory palette and click the Break icon.
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The dimension object will become several objects of different types, each
editable individually.
The various kinds of dimension objects are affected in different ways by the
Break tool. In all cases, reference points will be lost.

Effects of the
Break tool on
Dimension
Objects

A linear or radial dimension will become an unconstrained point-to-point
dimension line, with or without end marks as determined by the original
object. Any witness, extension, or leader lines will become unconstrained
individual lines, and any frame around the dimension text will be deleted.
An angular dimension will become an unfilled radial arc. Any extension
arcs will become separate unfilled radial arcs, and witness or leader lines
will become unconstrained individual lines.
Dimension labels and tolerances will become ordinary text objects. Any
frame around the dimension text will be deleted.
Circle center marks will become individual unconstrained lines.

Area Calculation PC Draft’s automatic Area Calculation feature can determine and display the
area of a selected object for you. If you later change the size of the object, the
displayed size is changed automatically.
This feature can calculate the areas of simple objects, like rectangles and
circles, or complex objects, such as complex polygons and freehand shapes.
When the area of an object is calculated, it always reflects the current scale
and units of the drawing.
There are two ways to use this feature: to calculate the areas of individually
selected objects, or to obtain the net area of several overlapping objects.
These two methods are explained below.
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Calculating the
Area of
Individual
Objects

1.

Select the object whose area you want to determine.

2.

Open the View menu and choose Show Area.

Once you have made your choice, the area will be displayed approximately in
the center of the object.

Calculating the
Net Area of
Overlapping
Objects

There might be occasions when you will want to calculate the net area of
objects that overlap. Selecting each object and choosing Show Area will only
calculate the areas of the individual objects — and totalling those figures
would yield a larger value than the actual net area. To obtain the net area of
overlapping objects, you need to trace the borders of the area to be calculated
using either the polygon or freehand drawing tool. (What you are actually
doing is creating a shape that overlays your existing set of objects.) PC Draft
will treat the resulting traced shape as an individual object. By choosing
Show Area for this object, you can obtain the net area of all of the overlapping
objects.
To calculate the net area using the Polygon tool to trace the boundary, follow
these steps:
1.

Activate the Polygon icon in the palette.

2.

Trace the outermost borders of the overlapping objects.

Once you have finished tracing the boundaries of the overlapping objects, the
polygon will be complete. It should already be selected. If it is not, click on
the polygon to select it.
3.

Open the View menu and choose Show Area.

After you have done so, the polygon will appear like the figure below.
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The area value displayed will be the net area, and the portions of the objects
that overlap will be compensated for. If you want to see the individual
objects that are currently hidden by the polygon, choose N (for No fill) from
the Fill Pattern submenu before you trace the boundary.
NOTE: If the overlapping objects contain reshaped objects, you will have
to use the freehand drawing tool or one of the curve tools to trace them,
thereby obtaining an approximation of their net area.

Hiding the Area
Calculation
Display

Modifying or
Moving Area
Calculation
Values

To hide the Area Calculation display:
1.

Select the object with the area display you wish to hide.

2.

Open the View menu and choose Hide Area.

There may be many occasions when you will want to have control over the
appearance and/or positioning of area values. PC Draft uses the current font
attributes for such values. These attributes include the current attributes for
the font type and size. PC Draft uses the Windows system font (usually 12point Arial) as the preset font and size when you create a new document.
There may be times when this font size is inconvenient, such as when you are
displaying area values on small objects, and the size of the text value
overwhelms the size of the object.
For this reason, PC Draft gives you the flexibility to change the values of font
type and size. In addition, it allows you to separate the values from their
related objects and move them to any location on your drawing. In the case
of small objects with area values, you can move the displayed values away
from the object. If you want to tidy up your drawing, you can move these
values into an information table. Remember, if you change the size of an
object, the calculated value in the table will automatically be updated to
reflect the object’s or line’s new size.
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To Change the
Font Attributes
Before You Use
Show Area

1.

Return to the pointer mode. (Make sure that no objects on the
drawing are selected.)

2.

Open the Text menu’s Font submenu and choose the font, size
and style you want.

1. Select the area value you want to change.
To Change the
Font Attributes
for Existing Area 2. Open the Font submenu and choose the font you want.
Calculation
Values
3. Open the Size submenu and choose the size you want.
NOTE: If you are a PostScript printer user, you can choose a laser printer
font to obtain a high-quality output.

Moving Area
Calculation
Values

You can move or detach the text of area values from objects. The Ungroup
command will detach area calculation values completely, and the Shift key
can be used to move area calculation values away from objects.
By selecting the object and then choosing Ungroup, you can detach the text
value and move it to a different location on the drawing, where it will remain
even if you move the object. This unique feature offers an extreme level of
flexibility, especially if you want to place the values into an information
table.
By holding down the Shift key, you can move the area calculation value away
from an object. If the object is then moved to a different location on the
drawing, the text will move with the object and maintain the same position
relative to the object. For example, suppose you detached area value from a
rectangle, then moved the value one grid division above the rectangle. If you
dragged the rectangle to the left, the value would follow the rectangle’s
movement, but it would still remain one grid above it.

Using Ungroup
to Detach and
Move Values
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To move or detach text values by ungrouping the text from an object:
1.

Select the area value you want to move.
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Using the Shift
Key Method to
Move Values

2.

Open the Arrange menu and choose Ungroup.

3.

Click on a blank part of the drawing to deselect the object and
value.

4.

Position the tip of the pointer on the text value.

5.

Press and hold down the left mouse button.

6.

Holding down the left mouse button, drag the text to the desired
location (into an information table, for example).

7.

Release the left mouse button.

Now if you move the object with a calculated area, the value will remain
where you placed it. The value will remain associated with the object. This
means that if you change an object’s area, the value in the table will be
automatically updated to reflect the new area.
To move an area value using the Shift key method:
1.

Position the tip of the pointer on the area value.

2.

Press down the Shift key.

3.

Press and hold down the left mouse button.

4.

Release the Shift key.

5.

Holding down the left mouse button, drag the value to the
desired location.

6.

Release the left mouse button.
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If you want to constrain the movement of the value to a horizontal or vertical
direction, keep the Shift key down as you drag.
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Chapter 5

Moving and
Arranging
Objects

Moving Objects

Often you may create an object, then decide to move it to a new location on
your drawing. PC Draft allows you to move lines and objects to any location
within your drawing. There are four methods you can use to move objects:
selecting and dragging; cutting or copying, then pasting; the Move command;
and the Position command.

Using the Select
and Drag
Method

To move an object using the select and drag method:
1.

Select the object you want to move by clicking on it.

2.

Point on the object.

3.

Press and hold down the left
mouse button until the white
arrow pointer appears.

4.

Holding down the left mouse
button, drag the object to the
new position.

5.

Release the left mouse button.

Be careful not to position the pointer on an edit handle when you move an
object. Edit handles are for changing the size and shape of an object.
When you drag objects, ghost images of the objects will be visible as you
drag them. When you drag an object or group of objects, the original stays in
place until you release the left mouse button.
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If you drag an object beyond the borders of the drawing area, the drawing will
automatically scroll to keep the object visible.
If you want to move multiple objects or grouped objects, simply select the
objects or group you want to move, then drag the objects or group to a new
position.

Constraining the
Movement of
Objects

If you hold down the Shift key while you are moving objects, the object's
movement will be restricted to a horizontal or vertical direction.

Using Cut, Copy, By using the Cut and Paste functions, you can remove objects from one
location of your drawing, then paste them in a different location. The Cut
and Paste
function deletes selected objects from the drawing and places them on the
Clipboard. The Copy function makes a copy of selected objects and places
the copy on the Clipboard, while leaving the original objects in place. You
can place several objects on the Clipboard as long as they are selected and cut
or copied at the same time. The objects are stored on the Clipboard until you
use Cut or Copy on a different object.

To Cut and Paste 1. Select the object you want to move.
an Object
2.

Open the Edit menu and choose Cut.

Notice that the selected object is removed from the drawing.
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3.

Position the pointer where you want to paste the
cut object.

4.

Click the left mouse button.

5.

Open the Edit menu again and choose Paste.
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Once you have chosen Paste, the object will reappear where you clicked on
the drawing. (Or, if you didn’t click anywhere, in the center of the drawing
window.)

To Copy and
Paste an Object

The Copy and Paste functions allow you to make a copy of an object and
paste the copy into another area of the drawing without affecting the status of
the original.
To copy an object and paste the copy into a different location:
1.

Select the object you want to copy.

2.

Open the Edit menu and choose Copy.

A copy of the object will then be stored on the Clipboard for your use.
3.

Position the pointer where you want to paste the copy, then click
the left mouse button.

4.

Open the Edit menu again and choose Paste.

The object will be pasted into this new location.
You can continue to paste objects that have been cut or copied into as many
areas on your drawing as you like by simply selecting the insertion point, and
choosing Paste from the Edit menu. The objects will remain on the Clipboard
until you cut or copy a different object on your drawing, at which time the
first object will be erased from the Clipboard and replaced with the new
object.
You may often want to use an object within your drawing in more than one
location. To accomplish this you can use either the Copy and Paste functions,
as described above, or the Duplicate function. These functions will save you
the time of re-drawing the object again and again.

Using the
Repeated Paste
Function

You can use the Repeated Paste function, accessed from the Edit menu, to
paste multiple copies of the same object into various locations on a drawing.
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To use the Repeated Paste function:
1.

Copy the object you want.

2.

Open the Edit menu and choose Repeated Paste.

When you choose Repeated Paste, the pointer changes to an “X,” and any
object on the Clipboard (that is, the object you cut or copied) is pasted into
the drawing at each point you click on. While in this mode, you can scroll the
window and continue to paste objects.
3.

Click where you want the object to appear.

4.

Repeat the last step until you’ve pasted as many copies of the
object as you want.

A copy of the object will appear at each point you click on the drawing. The
object’s datum point will be used as the reference point for the paste
operation.
5.

Using cut/copy
and paste to
transfer items
from one PC
Draft document
to another
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Click on the Pointer tool when you are done pasting.

PC Draft allows you to cut/copy and then paste all or part of a drawing into
another PC Draft document.
To cut or copy part of a drawing:
1.

Select all or part of the drawing you wish to move.
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2.

Open the Edit menu and choose Cut or Copy.

The selected objects will be stored on the Clipboard.
To paste objects into a different PC Draft document:
1.

Open the document where you wish to paste the objects stored
on the Clipboard.

2.

Point where you want to paste the objects into the drawing.

3.

Click the left mouse button.

4.

Open the Edit menu and choose Paste.

The objects that you cut or copied will be pasted into the specified area.

NOTE: When you cut or copy objects from one drawing and paste them
into another drawing, the objects that you pasted will automatically take on
the scale of the new drawing. For example, if you were to cut or copy an
object from a drawing with a scale of 1" = 20', and then paste it into a
different drawing with a scale of 1" = 10', the object would appear twice as
large as it did on the original drawing. In reality, the object is still the same
size, but it is represented at the new scale.
With the Edit menu’s Move command, you can move objects or groups
with great precision by entering values from the keyboard. The coordinates
of the selected objects are shown in the current layer’s scale and units.
The “Move a Copy” option sends a copy of the selection to a particular
location while leaving the original in place.
You can also move objects or groups you select to another layer. Because
the Move dialog box opens with the selection’s current location entered,
you can easily move or copy it to the same spot on a different layer. This
can be useful, for example, if you need to show walls or posts in the same
location on many layers in a plan view drawing.
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NOTE: The Move command can only move or copy objects between layers
that have the same scale. To move objects between layers with different
scales, use the Cut or Copy and Paste commands.
The datum point of the selected object or group (see Chapter 2 for
information about datum points) is used as the reference for moving.
Therefore, to move an object, you specify the desired location (the X and Y
coordinates) of the object’s datum point. If you select multiple objects or
groups, PC Draft will use the datum point of the top left item as the
reference.
To move objects or groups to a particular location on the drawing:
1.

Select the objects or groups you want to move.

2.

Open the Edit menu and choose Move.

The Move dialog box appears, displaying the current location of the
selection (for example, 2 3/4" from the top edge of the drawing and 2 1/16"
from the left).
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3.

Type in the X and Y coordinate values for the new location.

4.

If you want to move the selection to another layer, choose the
layer name from the To Layer drop - down.
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5.

If you want to leave the original in place, moving only a copy,
check Move a Copy.

6.

Click on the Move button.

The selection is moved to the new location.
The default zero origin for both rulers (the point where X=0 and Y=0) of
the coordinate system is the upper left corner of the window. The rulers
along the top and left sides of the window are used to control the zero
origins. In this default coordinate system, X values increase from left to
right and Y values increase from top to bottom.
You can change the zero origins of the rulers. For instructions on how to do
this, see “Setting the Rulers’ Zero Points” in Chapter 6.
NOTE: If the move operation requires the object to be moved beyond the
edge of the drawing, an error message will appear.

The Position
Command

Sometimes you may decide that a drawing you have started needs to be
moved so it will appear in a different area on the page when printed (as in
the illustration below).

One way to move the whole drawing is to select all objects, then drag them
to a better position. However, that method will work in only one layer at a
time.
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PC Draft’s Position command lets you move all objects on all layers at one
time. With this command, you specify where you want the top left corner
of the image to be. You enter numbers showing how far the image will be
from the top and left edges of the drawing window. (When a drawing is
printed, the edge of the drawing window represents the edge of the printable
area on the page, which is usually a little smaller than the whole page. See
Chapter 8 of the PC Draft Reference section for more information about the
printable area of the page.)
To change the drawing’s position on the page:
1.

Choose Position... from the Layout menu.

If the document contains objects, the Position Document dialog box will
appear, with the current upper left corner’s onscreen position displayed. (If
the document contains no objects, nothing will happen.) There may not be
an object at that location, because the corner is defined by an imaginary
rectangle that encloses all objects on all layers of the drawing.
NOTE: The location displayed will reflect all layers, even those that are
currently hidden.
Because the box controls positioning on the printed page, the values
displayed do not reflect the drawing’s scales or rulers, but the actual
distance on the screen (and on the printed page). That is, even if the
drawing is set to show ten feet per inch, with the zero points of both rulers
in the center of the image, the Position Document values will display the
onscreen distances from the left and top edges of the drawing window.
NOTE: The dialog box will display the measurements in the current
document’s onscreen units, whether inches or centimeters.
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2.

Select the Left (X) field and enter the distance you want the
image to be from the left edge of the drawing window (and of
the print area on the finished page).

3.

Select the Top (Y) field and enter the distance you want the
image to be from the top edge of the drawing window (and of
the print area on the finished page).

NOTE: PC Draft will let you move objects partly or entirely off the page.
That will happen if you enter either a negative value or an extremely large
positive value for one or both fields. Negative values will move the top left
corner of the image beyond the top or left edge of the document, and large
positive values can move the bottom right corner of the image beyond the
bottom or right edge (depending on drawing size).
If you accidentally move part of your drawing beyond the drawing window,
you can bring it back by using the Edit menu’s Undo command
immediately or by using the Position command again and entering different
values in the X and Y fields as needed.
4.

Click the Position button.

Your entire drawing will be moved within the document window according
to your specifications.
NOTE: If you enter values that are too large (or too “small,” in the case of
negative numbers), you will see an alert box telling you the range of
possible values. If this happens, click the alert box’s OK button, then enter
new values in the X and Y fields as needed.

Using the Clear
Function

Objects can be removed from the drawing using the Clear function. Clearing
an object deletes it permanently. However, it can be recalled by using Undo
before you perform any other action.

To Clear a Single 1. Select the object to be deleted from the drawing by clicking on
it.
Object
2.

Open the Edit menu and choose Clear.

The selected object will be erased from the drawing.
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To Clear
Multiple Objects

To Clear the
Entire Contents
of a Layer

1.

Select the objects to be deleted from the drawing by Shiftclicking on them, or by using the selection rectangle.

2.

Open the Edit menu and choose Clear.

There might be times when you want to throw away all the contents of the
active layer and start over again. To accomplish this:
1.

Open the Edit menu and choose Select All.

Notice that all the objects on the active layer are now selected.
2.

Open the Edit menu again and choose Clear.

NOTE: You can also press the Delete key to delete selections.
The Duplicate command makes an exact copy of any object or line you have
created. The duplicate object is placed on top of the original in a slightly
offset position, and is selected. You can then drag the duplicate into position
on your drawing.
To duplicate an object:
1.

Select the object you want to duplicate.

2. Open the Edit menu and
choose Duplicate.

To make a second or third duplicate, simply choose the Duplicate command
again, and again. Each new duplicate will appear on top of the previous one
in a slightly offset position.

Auto-Spacing of
Duplicate
Objects
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If you want to create a row or column of identical, evenly spaced objects, the
Duplicate function incorporates an auto-spacing feature that allows you to
determine the distance and angle you want between objects. You can then
make new duplicates that will be automatically placed at that distance and
angle.
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To automatically distribute duplicates during creation:
1.

Select the object to be duplicated.

2.

Open the Edit menu and choose Duplicate.

3.

Position the pointer on the selected duplicate.

4.

Holding down the left mouse button, drag the duplicated object
to the desired position, relative to the original.

5.

Release the left mouse button.

6.

Open the Edit menu and choose Duplicate again.

Notice that the second duplicate is automatically placed. Keep choosing
Duplicate to produce as many duplicates as you need.

NOTES:
• Hold down the Shift key and choose the Duplicate command to create
duplicate with no offset. Use this option to create a duplicate that is placed
directly on top of the original.
• Hold down the Control+Alt key to avoid duplicating locked objects. All
other objects in the selection will be duplicated.

Linear
Duplication

The Linear Duplication feature enables you to make many duplicates of
objects or groups, laid out in straight lines or arrays, in just a few steps.

The Linear Duplication dialog box (opened by choosing Linear from the
Edit menu’s Duplication submenu) gives you choices regarding the distance
and angle of duplication, as well as number of directions (one or two) for
duplicating selections. You can also define the duplication interval by
horizontal and vertical offset. (Duplication distances appear in the scale and
units of the drawing.)
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To duplicate an object or group in a single direction:
1.

Select the object or group for duplication.

The Linear Duplication dialog box appears.
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2.

Open the Edit
menu’s
Duplication
submenu.

3.

Choose Linear...

4.

In the Number of Copies field, type the total number of copies
you want (including the original).

5.

In the Distance field, type the distance you want between
copies

Distances between objects will be in the drawing’s scale and units.
6.

In the Angle field, type the desired angle of duplication.

Angle values increase counter-clockwise: zero degrees is straight to the
right, 90° is straight up, 180° is straight to the left, and 270° is straight down
the page. Negative values make the angles increase in the opposite
(clockwise) direction.
7.

Click OK.

A row or column of duplicates appears, beginning with the original
selection.

You can also define the duplication interval by horizontal and vertical
offset, entering an X and Y value to determine the positions of the copies.
To perform duplication with X and Y values defining the offset:
1.

Select the object or group for duplication.

2.

Choose Linear... from the Edit menu’s Duplication submenu.

The Linear Duplication dialog box appears.
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3.

Click the Distribute:
X & Y Offset radio
button.

The X and Y distance fields
appear.
4.

5.

In the Delta-X field,
type the desired
horizontal offset for
each duplicate.

In the Delta-Y field, type the desired vertical offset for each
duplicate.

Negative values move duplicates up or to the left.
6.

Enter the number of copies desired, then click OK.

A row or column of duplicates appears, set apart by the values you entered
in the X and Y offset fields.

Duplication in
Two Directions

With Linear Duplication, you can duplicate an object or group in two
directions at the same time. You create a row or column of duplicates, as
detailed above, and simultaneously create duplicates of that row or column.
Two-direction duplication can create rectangular arrays, in the simplest
case, or sets of rows and columns offset at any combination of distances or
angles.
For example, one-direction duplication settings of 6 copies at 2 feet and
zero degrees (0°) would give you five duplicates, each 2 feet apart,
appearing in a horizontal row to the right of the original selection.
Combining those one-direction settings with two-direction settings of 4
copies at 1 foot and 270° would give you 3 duplicates of the first row, one
foot apart, directly below (270°) the first row.
To duplicate in two directions:
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1.

Select the object or group for duplication.

2.

Choose Linear... from the Edit menu’s Duplication submenu.

The Linear Duplication dialog box appears.
3.

As detailed in the preceding section, specify the first direction’s
number of copies and their duplication offset, by distance and
angle or X/Y offset (in the example above, that would be six
copies at a distance of two feet and an angle of zero degrees).

4.

Click the Two Directions radio button.

The choices for Two Directions become active.
5.

Enter the second direction’s number of copies and their
duplication offset, by distance and angle or X/Y offset (in the
example given, that would be four copies at one foot and 270
degrees).

The Two Directions settings define the number and locations of the
duplicates of the row or column defined by the One Direction settings.
6.

Click OK.
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The duplicates appear: an “original” row or column as defined by the
settings under One Direction, and duplicates of that row or column defined
by the settings under Two Directions.

Circular
Duplication

Sometimes it’s useful for multiple copies of shapes or groups to appear in
circular arrangements in a drawing. You can get that effect by carefully
copying, dragging, and rotating objects, but it’s usually easier to use PC
Draft’s Circular Duplication feature.
With Circular Duplication, you can duplicate objects or groups so that they
appear arranged along a circle or arc, or in concentric circles or arcs.

The Circular Duplication dialog box (opened by choosing Circular from the
Edit menu’s Duplication submenu) gives you choices regarding the number
of copies in each circle, the total sweep of duplication (so that you can have
the copies appear proportionally around a full circle or any size of arc) or
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number of incremental degrees between duplicates, the number of
concentric rings or arcs, the distance (in the scale and units of the drawing)
between concentric rings or arcs, the amount of angular shift between rings,
and the center of the array.
To duplicate an object or group in a single circle:
1.

Select the object or group you want to duplicate.

2.

Open the Edit
menu’s
Duplication
submenu.

3.

Choose
Circular...

The Circular Duplication dialog box will appear.

4.

In the Number of Copies field, type the total number of copies
you want (including the original).
Moving and Arranging Objects
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5.

Make sure that Distribute: Proportionally is selected and that
the angle entered is 360°.

These settings ensure that the distribution will be all the way around a
circle.
6.

Click Datum or Center to fix the distribution between the
duplicates’ datum points or between their centers.

7.

If you want each copy to be rotated according to its position on
the circle, make sure Rotate Copies is checked.
If you uncheck Rotate
Copies, each duplicate in the
ring or arc will have the
same angle orientation as the
original object, as shown.

8a. To locate the Circle Center (the center of distribution), enter X
and Y values (in the drawing’s scale and units), then click OK;
or,
8b. Make sure the Next Mouse Click choice is checked, click OK,
then click the centering cursor at the desired center point after
the dialog box disappears.
A ring of duplicates will appear, centered around the point you specified
(either with the X-Y location or with the mouse click).
You can also duplicate an object or group around part of a circle,
distributing them either proportionally along a “sweep” you define or
incrementally (with a specified angular distance between the items).
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To duplicate an object or group proportionally along an arc:
1. Select the object or group you want to duplicate.
2.

Duplication in
Concentric
Circles or Arcs

Open the Edit menu’s Duplication submenu, then choose
Circular...

The Circular Duplication dialog box will appear.
3.

Enter the total number of copies you want (including the
original).
4.

Make sure
Distribute:
Proportionally is
selected.

That setting will distribute
the copies evenly along the
arc you specify in the next
step.

5.

In the Angle field, enter the total degrees for the sweep of the
arc.

NOTE: A positive angle value yields a counterclockwise sweep, a negative
value yields a clockwise sweep.
6.

Click Datum or Center to fix the distribution between the
duplicates’ datum points or between their centers, and check
Rotate Copies if you want each copy to be rotated .
7. To locate the Circle
Center, enter X and Y
values (in the drawing’s
scale and units), then click
OK, or select Next Mouse
Click, click OK, then click
the centering cursor at the
desired center point after
the dialog box disappears.

Moving and Arranging Objects

5 - 19

The duplicates will appear, proportionally filling the arc you defined,
centered around the point you specified.
The position of the original object relative to the circle center will determine
the starting angle and the distribution radius of the duplicates.
To duplicate an object or group incrementally along an arc:
1.

Select the object or group you want to duplicate.

2.

Open the Edit menu’s Duplication submenu, then choose
Circular...

The Circular Duplication dialog box will appear.
3.

Enter the total number of copies you want (including the
original).

4.

Make sure
Distribute:
Incremental is
selected.

5.

In the Angle
field, enter the
degrees desired
between copies.

That setting will space each copy the number of degrees you specify.
NOTE: A positive angle value yields a counterclockwise sweep, a negative
value yields a clockwise sweep.
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6.

Click Datum or Center to fix the distribution between the
duplicates’ datum points or between their centers, and check
Rotate Copies if you want each copy to be rotated.

7.

To locate the Circle Center, enter X and Y values (in the
drawing’s scale and units), then click OK, or select Next Mouse
Click, click OK, then click the centering cursor at the desired
center point after the dialog box disappears.
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The duplicates will appear,
incrementally spaced at the angle
you specified. The position of the
original object relative to the circle
center will determine the starting
angle and the distribution radius of
the duplicates.
Duplicating a selection in multiple circles or arcs, you use the same
methods as in single-circle duplication to define the number of copies in
each ring or arc, distribution and angle within each ring, distribution by
center or datum point, rotation of copies, and center point of the array. In
addition, you can specify the number of concentric circles or arcs, the
distance between additional circles or arcs, and the shift angle (if any) for
each circle or arc.
To duplicate a selection in basic multiple arcs or circles:
1.

Select the object or group you want to duplicate.

2.

Open the Edit menu’s Duplication submenu, then choose
Circular...

The Circular Duplication dialog box will appear.
3.

Enter the number of copies you want in each concentric circle
or arc (including the original).

4.

Check Distribute: Proportionally or Incremental.

5.

In the Angle field, enter the degrees for the sweep of the arc (if
proportional ) or angular distance between copies (if
incremental).

NOTE: A positive angle value yields a counterclockwise sweep, a negative
value yields a clockwise sweep.
6.

Click Datum or Center to fix the distribution between the
duplicates’ datum points or between their centers, and check
Rotate Copies if you want each copy to be rotated.
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7.

In the Concentric Circles/Arcs: Total Number field, enter the
number of circles or arcs desired.

8.

In the Radius field, enter the distance desired (in the drawing’s
scale and units) between concentric circles or arcs.

This value defines the distance each additional arc or circle will appear
outside the first arc or circle; it does not affect the distance from the
innermost circle or arc to the center of the array.
9.

To locate the Circle Center, enter X and Y values (in the
drawing’s scale and units), then click OK, or select Next Mouse
Click, click OK, then click the centering cursor at the desired
center point after the dialog box disappears.

The duplicates will appear, in the number of concentric circles or arcs you
defined, centered around the point you specified.
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As mentioned above, you can shift each concentric circle or arc of
duplicates by a specified number of degrees.
To duplicate a selection using the Shift Copies option:
1.

Select the object or group you want to duplicate.

2.

Open the Edit menu’s Duplication submenu, then choose
Circular...

The Circular Duplication dialog box will appear.
3.

Enter the number of copies you want in each concentric circle
or arc (including the original).

4.

Check Distribute: Proportionally or Incremental and enter the
degrees for the sweep of the arc (if proportional ) or angular
distance between copies (if incremental).

5.

Click Datum or Center to fix the distribution between the
duplicates’ datum points or between their centers, and check
Rotate Copies if you want each copy to be rotated .

6.

In the Concentric Circles/Arcs: Total Number field, enter the
number of circles or arcs desired and in the Radius field, enter
the distance desired (in the drawing’s scale and units) between
concentric circles or arcs.

7.

In the Shift Copies field, enter the number of degrees to shift
each concentric circle or arc from its inner neighbor.
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This angle defines the angular shift of each additional arc or circle, moving
outward from the innermost arc or circle; it does not affect the incremental
or sweep angle within each circle or arc.
8.

To locate the Circle Center, enter X and Y values (in the
drawing’s scale and units), then click OK, or select Next Mouse
Click, click OK, then click the centering cursor at the desired
center point after the dialog box disappears.

The duplicates will appear, in the number of concentric circles or arcs you
defined, each shifted by the specified angle.

Arranging
Objects

You can use the commands in the Arrange menu to manipulate the positions
of objects. You can perform the following actions using the commands in the
Arrange menu: align objects, flip objects, group and ungroup objects, send
objects to the back, bring objects to the front, move objects forward and
backward, lock and unlock objects, and distribute objects on a line. The
commands in the Arrange menu affect the objects on the active layer. (See
the section titled “Using Layers” in Chapter 7 for information about using
multiple layers in a document.)
When you create multiple objects on the same layer, the newest object
created appears on the top plane, while the oldest object appears on the
bottom plane: each new object appears on the plane above the last object. At
times, you might want to move an object in front of or behind other objects on
the same layer. The functions that allow you to do this are Bring to Front,
Send to Back, Move Forward One, and Move Back One.

Bring to Front
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If an object is currently behind other objects, you can move it in front of the
other objects by using the Bring to Front function.
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To bring an object to the front:

Send to Back

Move Forward
One

Move Back One

1.

Select the object you want to move to the
foreground.

2.

Open the Arrange menu and choose Bring to Front.

To reposition an object behind all other objects in a layer:
1.

Select the object you want to move to the background.

2.

Open the Arrange menu and choose Send to Back.

To move an object forward one level:
1.

Select the object you want to move forward.

2.

Open the Arrange menu and choose Move Forward One.

To move an object back one level:
1.

Select the object you want to move back one level.

2.

Open the Arrange menu and choose Move Back One.
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Grouping
Objects

Sometimes you might create an image that includes several individual
objects. In such instances, you might want to group the individual objects
together so that you can treat them as a single object. When objects are
grouped together, most functions you choose thereafter will be performed on
the entire group just as though it were a single object.
To group several objects together:
1.

Select all objects that you want in a group.

2.

Open the Arrange menu and choose Group.

Notice that the objects are now surrounded by a single set of edit handles.
This indicates that all objects within the edit handles are part of this group
and will be treated as a single object. You can perform any function on the
group, such as move, duplicate, or fill, and the entire group will respond to
that command. Once you have grouped several objects, you cannot
reposition or edit any individual object or piece of text within the group
unless you first ungroup the objects.

Resizing Groups
of Objects

There may be times when you would like to enlarge or reduce the size of a
group of objects (objects that have been grouped together using the Group
function). PC Draft gives you the ability to change a group’s size
proportionally or non-proportionally (vertically or horizontally).
By changing the size of a group proportionally, you can maintain the original
shapes of the individual objects within the group. Objects within the group
will become larger or smaller without becoming distorted.
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To proportionally resize a group of objects:
1.

Select the group you want to resize.

2.

Position the tip of the pointer on one of the edit handles on the
corners of the group.

3.

Press down the left mouse button.

4.

Holding down the left mouse button, drag until the group is the
size you want.

5.

Release the left mouse button.

The grouped object will change in size proportionally to its original size.

To resize a group of objects non-proportionally:
1.

Select the group you want to resize.

2.

Position the tip of the pointer on one of the edit handles on the
corners of the group.

3.

Press down the left mouse button.

4.

Holding down the left mouse button, press the Alt key.

5.

Holding down the left mouse button and the Alt key, drag until
the group is the size you want.

6.

Release the left mouse button and the Alt key.
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Effects of Group
Resizing on
Automatic
Features

There are some unique advantages that you should know about when you
change the size of a group. Because several of PC Draft’s features are
automatic, they are conveniently active when you change the size of a group.

Automatic Area
Calculation

If any of the objects in the group contain an area calculation display, the area
of each of those objects will be recalculated automatically to reflect the new
size of the object.

Dimension Lines

If any of the objects in the group are dimension lines, the numerical value of
the dimension line will automatically change to reflect the new length.

Show Size

If the Show Size window is displayed, it will indicate the overall size of the
group.

Ungrouping
Objects

If you no longer require a set of objects to be grouped, or if you need to edit
one of the individual objects, you can use the Ungroup function to return the
objects to their individual status.
To ungroup objects:
1.

Select the group of objects by clicking on one of the objects.

2.

Open the Arrange menu and choose Ungroup.

Notice that each object has its own set of edit handles again. This is an
indication that the objects are no longer part of a grouped set, and that you
can now select and edit each object individually.

Aligning Objects
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Aligning objects means to line objects up relative to some other point. You
can specify exactly how the objects should be aligned using the Alignment
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Options dialog, the Alignment command and the Alignment palette. The
Alignment palette is used to align objects with each other; the Alignment
palette is used to align specified parts of objects with specified parts of
other objects, a reference point or the grid; the Alignment command is used
to align objects according to the current settings in the Alignment Options
dialog.
The alignment choices for a vertical plane are: Align Left Sides, Align
Centers, and Align Right Sides. The choices for a horizontal plane include:
Align Tops, Align Middles, and Align Bottoms. You can combine a
horizontal choice with a vertical choice, and also align objects to the current
grid setting.
To use the Alignment function, follow these steps:

1. Select the object you wish to
align.
2. Open the Arrange menu and
choose Alignment Options.
The Alignment dialog box will
appear.

3a. Click on the icon that represents the desired alignment option.
or,
3b. Click on up to two buttons (one each from the horizontal row
and the vertical row) that represent the desired alignment
option.
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4.

Click on the Align button.

The cursor should change to a click Reference Object and arrow
combination.
5.

Click on the selected object to be used as a reference for the
alignment.

To align selected objects to the current grid setting:
•

Click on the box beside “to the grid” in the Alignment Options
dialog box.

To align objects to one element of a group (rather than to the group as a
whole), hold down the Alt key when the question-mark cursor appears, then
click on the element with which you want to align the other objects.

Alignment
palette

The Alignment palette provides tools for you to carry out the most common
alignments without having to access the Alignment Options dialog.
To display the Alignment palette:
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•

Choose Alignment from the Palettes submenu in the View
menu, or

•

Choose Alignment from the Window menu, or

•

Choose Alignment from the popup menu at the bottom left of
the document window.
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Align Bottom Edges

Align Top Edges

Align Left Edges

Align Right Edges

Align Vertical Centers

Align Horizontal Centers

NOTE: The remaining buttons are used to distribute objects along a line.
To use the Alignment palette:
1. Select the objects to be aligned.
2. In the Alignment palette, click on the desired alignment button.
The Click Reference Object will appear.
3. Click on the object to align the other object(s) with.
The objects will be aligned according to your specifications.

Distributing
objects

Objects can be positioned and aligned along a defined line. This can be
done using the Distribute On Line command or using options in the
Alignment palette.

Distribute on line The Distribute on Line function allows you to position and align selected
command
objects along a line that you define. The objects are distributed according to
their level on the drawing, i.e. the object farthest back will appear on the
distribution line first, and the foremost object will appear last. By default,
the objects will automatically align themselves along their centers, and will
be equally spaced apart on the line. You can also choose to align the objects
according to their datum points.
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To distribute objects on a line:
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1.

Select the objects to be distributed.

2.

Open the Arrange menu and choose Distribute on Line.

3.

Move the pointer to the point on your drawing where you
would like to place the first object.

4.

Press down the left mouse button.

5.

Hold down the mouse button and drag in the direction you
want to distribute the objects.
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6.

Release the left mouse button.

The objects will be distributed along the line you specified. Their center
points will be spaced equally apart along the line.

NOTES:
• To align objects according to their datum points, press and hold down the
Alt key after you open the Arrange menu and choose Distribute on Line.
• To constrain the line the objects are to be distributed along, hold down the
Shift key as you define the line and it will snap to 45-degree increments.

Alignment
palette

The distribute controls in the Alignment palette distribute objects in the
same way as the distribute command, but the line is defined for you.
To display the Alignment palette:
•

Select Alignment from the Palettes submenu in the View menu,
or

•

Select Alignment from the Window menu, or

•

Select Alignment from the popup menu at the bottom left of
the document window.
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Distribute horizontally
by center

Distribute vertically
by center

Distribute horizontally
by datum

Distribute vertically
by datum

To use the distribute controls in the Alignment palette:
1.

Select the objects on the drawing to be distributed.

2.

Click on the appropriate button to distribute the objects
horizontally or vertically by center or by datum point.

The objects will be distributed along an line in the manner specified.

Flipping Objects

Sometimes you may want to display the reverse image of an object. For this
reason, PC Draft offers the Flip function. The Flip function allows you to
flip both horizontally and vertically to achieve a variety of effects.
You can duplicate an object and then use the Flip function to create the other
side of that object for the sake of symmetry, as well as convenience.

Flipping an
Object
Horizontally
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To flip an object horizontally:
1.

Select the object you want to flip.

2.

Open the Arrange menu and choose Flip Horizontal.
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To flip an object vertically:
Flipping an
Object Vertically
1.

Select the object that you want to flip.

2.

Open the Arrange menu and choose Flip Vertical.

Once you have made your choice, the object will be flipped
vertically.

The Mirror
Tool

In addition to the Flip commands, PC Draft has a tool for mirroring an
object or group at any angle you define, not just horizontally or vertically.
The Mirror Tool is in the Accessory Palette.

The mirroring can either move and “turn around” the original selection or
make a turned copy while leaving the original in place. The mirror image of
your selected items will appear across the axis you define, opposite the
original’s position, and the same distance from the axis as the original. You
define the axis of mirroring with a temporary onscreen reference line.
NOTE: Text objects and bitmap or pixel-map objects (such as those pasted
in from a paint-type program or loaded in from TIFF files) will not be
reversed, but will appear at the position defined by the mirror operation.
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To mirror an object or group:
1.

Select the object or group for mirroring.

2.

Make sure the Accessory palette is displayed.

3.

Click the Mirror tool.

The cursor will change to a white arrowhead.
4.

Before pressing the left mouse button, move the cursor to the
first point you’ll use to define the reference line.

5.

Press and hold the left mouse button.

A dotted reference line will appear.
6.

Holding down the left mouse button, drag to define the
reference line (the axis of mirroring).

If you hold down the Shift key, the line will snap in 45-degree increments.
7.

Once the reference line is at the desired angle, release the left
mouse button.

The selection will be mirrored across the plane you defined with the
reference line.
NOTE: By leaving the Show Size palette open as you mirror an object, you
can get precise control of the mirroring line’s angle.
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Mirroring a
Copy of an
Object

Sometimes you may need a mirror-image of an object, but still want to
leave the original in place. You can specify that a copy is mirrored using the
Mirror Tool configuration dialog box.
To mirror a copy of an object or group:
1.

Make sure the Accessory palette is displayed.

2.

Hold down the Alt key and click the Mirror tool.

The Mirror Tool configuration dialog box will appear.

3.

Click the “Copy of
Object(s)” radio button,
then click OK.

4.

Select the object or group for mirroring.

5.

Click the Mirror tool.

The cursor will change to a white arrowhead.
6.

Before pressing the left mouse button, move the cursor to the
first point you’ll use to define the reference line.
7.

Press and hold the left mouse
button.

A dotted reference line will appear.
8.

9.

Holding down the left mouse
button, drag to define the
reference line (the axis of
mirroring).

Once the reference line is at the desired angle, release the left
mouse button.
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A copy of the selection will be
mirrored across the axis you defined
with the reference line, while the
original remains in place.

Lock and
Unlock

When more than one user has access to the same document, you may want to
protect your work from being changed by mistake. You may also want to
ensure that an object isn’t accidentally moved once it is in its proper position.
In these circumstances, you can use PC Draft’s Lock feature to make sure
certain objects remain unchanged.

To Lock
Objects

Objects locked on the drawing cannot be edited, moved, copied, pasted, or
deleted. None of PC Draft’s functions will affect locked objects.

To Unlock
Objects
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1.

Select the objects you want to lock.

2.

Open the Arrange menu and choose Lock.

Notice that the edit handles are dimmed, indicating that the objects are
locked.
1.

Select the locked objects you want to unlock.

2.

Open the Arrange menu and choose Unlock.
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Rotating objects
Rotate by 90°
tool

PC Draft provides several tools and commands that can be used to rotate
objects freely or by specified amounts.
The PC Draft Tool palette includes a Rotate by 90°tool:

To rotate an object 90° anti-clockwise around its center:
• Select an object in the drawing then click on the Rotate 90° tool.

To rotate an object 90° clockwise around its center:
• Select an object in the drawing, hold down the Shift key, then click on the
Rotate 90° tool.

To rotate an object 90° anti-clockwise around its datum point:
• Select an object in the drawing, hold down the Alt key, then click on the
Rotate 90° tool. In this example the datum point is marked by a small circle.
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The Rotate tool and Rotate command allow you to rotate objects by any
Rotate tool and
Rotate command angle you want.
You can rotate objects in various increments using the mouse; to enter a
specific value via the keyboard, use the Rotate Options.
You can rotate single objects, multiple objects, or grouped objects. Unless
you specify otherwise, selected single or multiple objects will rotate around
their individual centers. If you wish you can also specify the center of
rotation for selected objects.
To enter rotation mode:
•

Select Rotate from the Arrange menu, or

•

Click on the Rotate tool in the Tool palette

To exit rotation mode:
• Click on the Pointer tool.
Rotating an object
To rotate an object in five-degree increments (the default):
1.

Select the object to be rotated.

2.

Select the Rotate tool or choose Rotate from the Arrange
menu.

3.

Position the cursor in the window and press down the mouse
button.

The cursor will change into a rotation indicator.
4.
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Hold down the left mouse button, drag in a circular direction
until you have rotated the object the desired number of
degrees, and release the mouse button.
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To see the exact number of degrees an object is being rotated, open the
Show Size window.

To rotate an object in one-degree increments:
•

Press and hold down the Control key while rotating an object.

To rotate an object in minutes or decimal fractions:
1.

Press and release the Shift key while rotating an object.

2.

Continue to drag the mouse in a circular direction to rotate the
objects in minutes.

The number of degrees will remain fixed.
To rotate an object in seconds:
1.

Press and release the Shift key twice while rotating an object.

2.

Continue to drag the mouse to rotate the objects in seconds.
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As you rotate the object in seconds, the number of degrees and minutes are
constrained.

Returning to
You can return to the previous rotation units (from seconds to minutes, and
previous rotation minutes to degrees) by using the Control key.
units
To return to the previous rotation units:
•

Press the Control key while in the rotation mode.

Rotating
multiple objects

When rotating multiple objects, by default each object rotates around its
individual center.

Rotating
grouped objects

When rotating a grouped object, all the objects in the group rotate around
the center of the group, unless you specify a different center of rotation.

Rotating text

The rotation feature works exactly the same way when you rotate a text
block as it does when you rotate other objects.
Bitmaps cannot be rotated.

Choosing the
Objects are usually rotated about their centers, however you can also
centre of rotation specify any point on the drawing as the center of rotation.
To rotate objects around a specified point:
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1.

Select the objects you want to rotate.

2.

Select the Rotate tool or choose Rotate from the Arrange
menu.

3.

Position the cursor on the point you want to use as the center
of rotation.
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You can use the scroll controls to move to a part of the drawing that is
outside your current view.

Rotate to zero
command

4.

Press down the Alt key.

5.

Press down the mouse button.

6.

Hold down the mouse button and the Alt key, drag in a
circular direction until you have rotated the object the desired
number of degrees.

7.

Release the mouse button and the Alt key.

The Rotate to zero command allows you to return an object to its original
angle of rotation.
To return an object to its original angle of rotation:
1.

Select a rotated object.
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2.

Choose Rotate to Zero from the Arrange menu.

The object will be returned to its original angle of rotation.

Rotate options

You can use the keyboard to directly enter the rotation values in degrees,
minutes, and seconds, via the Rotate Options dialog.

The Rotate
Options dialog

To display the Rotate Options dialog:
1.

Select the object or objects you want to rotate.

2.

Choose Rotate Options from the Arrange menu.

The Rotate Options dialog will appear.

Amount of
rotation
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The fields available to enter the rotation amount will vary depending on the
Angular Display option selected in the Document Scale and Units dialog.
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The above screen shot shows the field that will display when decimal
degrees is selected as the unit of angular display.
To enter an amount for rotation, double-click in the appropriate field and
type in a value.

Direction of
rotation

The default direction for rotation is counterclockwise. To rotate an object in
a clockwise direction, click on the Clockwise checkbox.

Center of
rotation

The default center of rotation is the center of the selected object or objects.
To rotate objects about their datum points, click on the Datum of object(s)
radio button. To rotate objects about a specified reference point, click on the
A reference point radio button.
If the A reference point radio button is checked, the Rotate Options dialog
will disappear and the Rotation cursor will display over the drawing.
Position the cursor at the point you want to use as the center of rotation and
click the left mouse button.
To rotate an object or objects:
1.

Select the object or objects you want to rotate.

2.

Choose Rotate Options from the Arrange menu.
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The Rotate Options dialog will appear.
3.

Enter the desired angle of rotation.

4.

Specify the direction and center of rotation.

5.

Click on the Rotate button.

6.

Specify the reference point to rotate about if necessary.

The selected object or objects will be rotated the specified number of
degrees, minutes, and seconds around the requested center of rotation.
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To rotate an individual object (in five-degree increments, which is the
default):
1.

Select the object to be rotated.

2.

Choose Rotate in the Arrange menu.

3.

Position the cursor in the center of the window.

4.

Press down on the drawing area.

Sometimes you may need to quickly find certain objects or groups in a large
drawing. Scrolling and examining all the items in a drawing to find the one
you want can be time-consuming and inaccurate, so PC Draft includes a Find
and Replace feature.
You can automatically find and select objects or groups that have names or
other object information assigned to them. The feature is most useful for
finding items that have been copied many times in a drawing (for example,
pieces of furniture in an office layout or architectural features in a plan view).
The Data menu’s Find/Replace command will display a dialog box that
enables you to instantly locate certain items, and even replace them with
other objects.
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Find and Replace

You can define the objects to be found by using checkboxes to specify all or
some of the object information fields assigned to them. For example, you
can find objects that have particular data in all fields by checking all the
field boxes, or find objects that have a particular name and part number by
checking only those boxes. (For more information about defining field
names and assigning object information, see Chapter 2.) The quickest way
to define search criteria is with the “Use Mouse” button, which lets you
enter all of an item’s object information instantly by clicking on it; you can
then de-check unwanted fields, if necessary. You can also manually type the
desired object information in the appropriate fields; keep in mind, though,
that any typing errors will affect the results of the search, and may cause the
wrong objects to be found.
Objects or groups will be found and replaced in either the current layer or in
all layers of a drawing, depending on whether the “All Layers” option is
checked.

For repeated find actions, you can shrink the dialog box (by clicking the
arrow check) so that it doesn’t block as much of the drawing.

Finding Objects

To find objects or groups with particular object information:
1.
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Make sure the objects or groups you want to find have object
information, and that one of them is visible in the drawing
window.

Moving and Arranging Objects

2.

Choose Find/Replace from the Data menu.

The Find/Replace dialog box will appear, with no information entered.

3a. Under “Find,” type in the desired object information for each
field
or,
3b. Click the Find: Use Mouse button.
NOTE: In drawings with many items that have object information,
temporarily de-checking the Find fields’ checkboxes can speed the typing of
Find criteria.
The Find/Replace dialog box will temporarily
disappear, and the “?” cursor will appear on the
drawing.
4.

Click on a sample of the object or group with the desired
object information.

The Find/Replace dialog box will reappear, with all the object’s information
displayed in the fields and the total number of items found displayed at the
lower left.
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5.

If you want to search on every layer of the drawing, check the
All Layers box.

NOTE: The default is to search in the active layer only.
6.

If you don’t want to search on every object-information field,
de-check the fields you want ignored.

NOTE: It’s possible to find objects or groups that share some object
information data, but are not identical. For example, two items might have
the same name but different part numbers, and both would be found if
“Name” was checked and “Part Number” was not.
7.

Click the Find Next button.

The first matching object will be selected, and the Find/Replace dialog box
will display the remaining number of objects or groups that meet the criteria
checked (that is, the count will be reduced by one).
You can continue to find matching objects by clicking the Find Next button
again. If the dialog box is obscuring too much of the drawing, you can
shrink it using the arrow check:
•

Click the arrow check.
The Find/Replace dialog box will shrink to its reduced mode.
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Continue clicking Find Next as long as you need to. You can return the
Find/Replace dialog box to full size at any time by clicking the arrow check
again.
•

Replacing
Objects

When you are done finding or replacing objects, click the close
box at the upper right of the dialog box.

When you use the Find feature, often you will want to replace the objects or
groups you find with different items. The Replace options in the Find/
Replace dialog box will replace some or all of the found items with copies
of whatever object or group you specify.
As with the Find feature, you can only replace using an object or group that
has object information assigned to it.
TECHNICAL NOTE: The replacement object must be unique; that is, it
must have a unique set of data in its object information fields. When an
object is replaced, the datum of the replacement object will occupy the same
location as the datum of the original object.
You can replace objects either one at a time (bypassing some if desired
with the “Find Next” button), or all at once with the “Replace All” button.
If you replace objects one at a time, the Undo button will reverse the
replacement of the last single object or group.
The best way to select the replacement object is with the “Replace: Use
Mouse” button.
To find and replace objects or groups:
1.

Choose Find/Replace from the Data menu.
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The Find/Replace dialog box will appear, with no information entered.
2.

Specify the objects or groups to be found (either with the Find:
Use Mouse button or by typing field data directly).

3.

Make sure the fields you want to use as criteria are checked.

4.

If you want to find and replace on every layer of the drawing,
check the All Layers box.

5.

Click the Replace: Use Mouse button.

The Find/Replace dialog box will temporarily disappear, and the “?” cursor
will appear on the drawing.
6.

Click the object or group you want to use for replacement.

The Find/Replace dialog box will reappear, with all the object information
displayed in the Replace fields. Because replacement selections must be
unique, PC Draft always uses all object information fields to define a
replacement. (Although PC Draft uses all fields as criteria for the
replacement, some fields can be empty. For example, an object can have all
its fields blank except for “Name” and still be used as a replacement.)

7.

Click the Find Next button.

The Find/Replace dialog box will display the number of objects or groups
that match the checked “Find” fields, and the first matching object will be
selected.
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8.

If you want to replace this particular found object, click the
Replace button.

The selected object will be replaced with a copy of the object you defined as
the replacement.
9.

Click the Find Next button.

The next object that matches the Find criteria will be selected. You can
replace it, click Find Next again to move to the next matching object, or
click Undo to reverse the replacement.
To replace all matching objects or groups:
10. Click Replace All.
All objects that match the Find criteria will be replaced.
11. When you are done finding and replacing objects, click the
close box at the upper right of the dialog box.
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Chapter 6

Using
Drawing
Aids

Using Drawing
Aids

PC Draft offers several useful features that make your drawing tasks much
easier. This chapter discusses these Drawing Aids in detail.

Show Size

PC Draft is a precision drawing application program designed to help you
create detailed drawings. The Show Size function makes it easier to draw
objects precisely because it can display the size of each object on your
drawing. Show Size gives you a continuous display of an object’s size as you
draw or resize it. It also displays the degree of rotation as you rotate objects
(angles of rotation range from zero to 360 degrees, moving counterclockwise
from a rightward-pointing — “due East” — orientation).
The units displayed in the Show Size window are determined by the current
options chosen in the Document Scale & Units dialog box. For more
information, see the section in this chapter titled “Setting the Size Units.”
To display the Show Size window:
1.

Select Show Size from the Palettes submenu in the
View menu, or

2.

Select Show Size from the Window menu, or

3.

Select Show Size from the popup menu at the bottom left of the
document window.

The Show Size window will appear.

Using Show Size
With Drawing
Tools
Text Tool

The Show Size window displays the length (“X=”) and height (“Y=”) of the
rectangle you use to define the block for paragraph text.

Line Tools

The Show Size window for the line tools (including the Perpendicular,
Tangent, Parallel, and Extrude tools) displays the length of the line and the
angle at which the line is drawn. (“X=” represents the length; “A˚=”
represents the angle.)
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Square-Corner
Rectangles

The palette displays the “X” and “Y” values for a square-corner rectangle.
The X value represents the width of the rectangle, and the Y value represents
its height.

Rounded-Corner
and EllipticalCorner Rectangles

When you draw a rounded-corner rectangle, the palette shows you the radius
(“R=”) of the corners, the height (“Y=”), and the length (“X=”) of the
rectangle. The palette shows the major and minor radii of the arcs on the
corners of Elliptical-Corner Rectangles.

Circles by Diameter
and by Radius

PC Draft allows you to draw circles three ways: by their diameter, by their
radius, and by three points.
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BY DIAMETER
When you draw a circle by its diameter, the Show Size window displays
“D=” to represent the size of the circle’s diameter.
BY RADIUS
When you draw a circle by its radius, the palette displays “R=” to represent
the size of the circle’s radius.

Arcs by Radius

As you drag to create the radius of an arc, the Show Size window displays
both the length of the radius (“R=”) and the starting angle (“A˚=”). The
starting angle is the angle between the line attached to the cursor and the Xaxis.

Once you release the left mouse button and move the mouse to create the arc,
the Show Size window changes to display two different readings: the delta
angle (“∆A˚=”) and the angle (“A˚=”). The delta angle is the difference
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between the starting angle and the ending angle of the arc. The delta angle is
the actual number of degrees through which the arc passes. The angle
reading represents the angle between the ending angle (shown on-screen by
the line attached to the cursor) and the X-axis.

Arcs by Three Points

As you create an arc by three points, the Show Size window will not become
active until you are moving from the second to the third point in the arc. At
that time, it will become active and display the entire arc angle.

Elliptical Arcs

When you start drawing an elliptical arc, the palette shows you the height
(“Y=”) and width (“X=”) of the ellipse used to define the size of the arc. It
also shows you the starting angle (“A˚=”), which is the angle between the
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line attached to the cursor and the X-axis. When you finish defining the size
and the starting angle of the arc, the palette shows you the delta angle
(“∆A˚=”) and the angle. The delta angle is the difference between the
starting angle and the ending angle. The delta angle is the actual number of
degrees through which the arc passes. The angle (“A˚=”) represents the angle
between the ending angle (shown on-screen by the line attached to the cursor)
and the X-axis.

Ellipses

The Show Size window for ellipses displays both the “X” and “Y” diameters
of the ellipse. The “X” represents the width of the ellipse, and the “Y”
represents the height of the ellipse.

Polygons

The Show Size window for polygons functions in the same way as the Show
Size indicator for lines. The palette displays the length of the line (“X”) and
the angle (“A˚=”). The palette displays this information for each side of the
polygon as it is drawn.

Using Show Size
With Rotation

During rotation, the Show Size function shows you how much you have
rotated an object. You can rotate objects in degrees, minutes, and seconds or
in degrees and decimal fractions. See the section titled “Using the Rotate
Function” in Chapter 5 for information about rotating objects.

Hiding the Show
Size palette

To remove the Show Size window from the screen:
1.

Click on the window's close box, or
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2.

Choose Show Size from the Palettes submenu in the View
menu, or

3.

Choose Show Size from the Window menu, or

4.

Choose Show Size from the popup menu at the bottom left of
the document window.

The Show Size window will be removed from the screen, and there will no
longer be a checkmark against its name in the Palettes submenu etc.

Rulers

Rulers are used as drawing aids to help you position objects in precise
locations on your drawing. Rulers appear along the top and on the left side
of the drawing window. The displayed rulers reflect the current position of
the window during scrolling, and their scale reflects the current
magnification level. PC Draft offers two types of rulers: standard and
scale.
To display PC Draft’s rulers:
•

Open the Layout menu and choose Show Rulers.

The rulers will be displayed, and a check mark will appear by the Show
Rulers command in the Layout menu.

Standard Rulers

Standard Rulers are the type of rulers with which you are probably familiar.
To display standard rulers:
•

Scale Rulers
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Open the Layout menu and choose Standard Rulers.

Scale Rulers reflect the current drawing scale of your document. For
example, on a 1/8" = 1' scale, the major ruler divisions will be in increments
of eight (8 ft., 16 ft., and so on). Scale rulers display measurement divisions
according to the current size unit settings. For instance, if “decimal feet” is
the current setting, the scale rulers will be displayed in decimal feet,
matching to the current drawing scale.
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For more information about size units, refer to the section titled “Setting the
Size Units” in this chapter.
To display scale rulers (if Show Rulers is checked):
•

Open the Layout menu and choose Scale Rulers.

Below is an example of scale rulers with a scale of 1/8" = 1' and size units set
at fractional feet and inches.

Setting the
Rulers’ Zero
Points

There may be occasions when you want to change the zero point of the rulers
from the upper left corner of your drawing to some other convenient point on
your drawing. For instance, you may want to set the zero point of the rulers
to one edge of an object so that you can position other objects relative to that
particular point. For this reason, PC Draft allows you to change the zero
point of the ruler.
When you change the zero point of one or both of the rulers, the positioning
of the new zero point is dependent upon the grid snap. You can change the
zero point of either the top or left ruler independently, or change the zero
points of both rulers at the same time.

Setting the Zero
Points of the
Rulers
Independently

To change the zero point of either the top or the left edge ruler independently
of the other:
1.

Position the tip of the pointer on the ruler where you want the
new zero point to appear.
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2.

Click the left mouse button.

This method of changing the zero point works the same for both the top and
the left rulers.

Resetting the
Zero Points of
the Rulers
Independently

To change the zero point of either the top or the left edge ruler back to the
upper left corner:
1.

Hold down the Control key.

2.

Position the tip of the pointer on the ruler.

3.

Click the left mouse button.

The zero point for that ruler will revert to the upper left corner, while the
other ruler’s zero point will be unchanged. This method of resetting the zero
point works the same for both the top and the left rulers.

Setting the Zero
Points of Both
Rulers
Simultaneously

You can change the zero points of both rulers simultaneously by using the
cursor. In this way, you can easily align the zero points of both rulers to a
point on your drawing.
To set the zero points for both rulers at the same point:
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1.

Position the tip of the pointer in the box where the two rulers
cross at the upper left corner of the drawing window.

2.

Press down the left mouse button.

3.

Holding down the left mouse button, drag diagonally downward
and to the right until the cursor is positioned on the new zero
point you want for both rulers.

4.

Release the mouse button.
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Resetting the
Zero Point of
Both Rulers
Simultaneously

To reset the zero point to the upper left corner of your drawing:

Cursor Position
Indicator

The Cursor Position Indicator is designed to inform you of the position of the
cursor (that is, the crosshair cursor, the arrow pointer, and the various other
pointers) on your drawing. This allows you to accurately determine the
starting and ending points of an object, and also gives you the ability to make
inquiries about the position of any point on your drawing.

•

Click in the small box where the two rulers cross at the upper
left corner of the drawing window.

Like all of PC Draft’s automatic features, the Cursor Position Indicator
conforms to the environment of your drawing. The X/Y display of the
cursor’s position is displayed to the scale of the drawing and in the size units
that are currently selected.
The Cursor Position Indicator shows the absolute position of the cursor in
regards to the zero origin. The zero origin of the cursor position (X=0, Y=0)
is determined by the zero points on the rulers. Therefore, if you move the
zero points on the rulers, the zero origin of the Cursor Position Indicator will
also change. This feature is very useful, especially when you want to make
measurements relative to a specific point on your drawing.

Activating the
Cursor Position
Indicator

To activate the Cursor Position Indicator:
•

Open the View menu and choose Show Cursor Position.

Once you have made your choice, the X/Y position of the cursor will be
displayed on the bottom left edge of the document window as shown in the
following figure.
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Now as you move the cursor around on your drawing, the display will inform
you of the cursor’s X/Y position relative to the zero points of the rulers.
The default zero origin on the rulers is always the upper left corner of your
drawing. To change the zero origin of the Cursor Position Indicator, you
must change the zero points on the rulers.

Hiding the
Cursor Position
Indicator

If you do not want the cursor position displayed, follow this step:
•

Open the View menu and choose Show Cursor Position.

The cursor position will disappear, and the check mark will be removed from
the Show Cursor Position command.

Grid Snap and
Grid Lines

The grid snap feature (accessed from the Set Grid command in the Layout
menu) lets you superimpose an invisible grid over your drawing so that
objects can be drawn, moved, or resized precisely with little effort. Whereas
grid lines provide visual guidelines that assist you in drawing, the grid snap is
an invisible network of “magnets” that affects the drawing and placement of
objects.
You should set the grid snap to the smallest length you need in or between
objects in your drawing. For example, if you wanted to draw a line that is
5-3/4 inches long, you should set the grid snap to one-quarter inch. With the
grid snap set this way, the cursor will snap to every quarter-inch increment as
you draw the line.
Values displayed in the Set Grid submenu will always be expressed in the
current scale and unit system. For more information, see the section in this
chapter titled “Setting the Size Units.”

Choosing a New
Grid Snap
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Before you set the grid snap, you should choose a scale to be used for your
drawing. The grid snap setting should be appropriate for that scale. (See the
section in this chapter titled “Using the Scale Function” for information about
setting scales.)
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To choose a new grid snap:

1.

Open the Layout menu and drag until Set Grid is highlighted.

The Set Grid submenu will appear.
The Set Grid submenu shows the grid spacing choices for the current scale.
Each scale has its own set of possible grid spacings. For example, a scale of
1:1 (1"=1") in fractional units will have increments as small as 1/64th of an
inch and as large as 1/4 of an inch.
2.

Drag through the submenu until the grid snap you want is
highlighted.

3.

Click the left mouse button.

If you open the Set Grid submenu again, you will see that a check mark
appears beside the chosen grid snap. The check mark indicates the
document’s current grid snap.

Using the Grid
Snap Function

When a grid snap other than “None” is chosen, any object you draw or move
will automatically be positioned to the nearest grid position. You will not be
able to begin or end a draw or move action between the grid snap positions.
For example, if you were moving an object with the grid spacing set at 1/4
inch, the object would move in quarter-inch increments.
You can activate or deactivate the grid snap to suit your needs at the time.

Using Drawing Aids
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To Deactivate the At times you may want to turn off the grid snap when you draw or move
Grid Snap
objects. To turn off the grid snap:
1.

Open the Layout menu and drag until Set Grid is highlighted.

The Set Grid submenu will appear.

To Activate the
Grid Snap

2.

Drag until None is highlighted.

3.

Click the left mouse button.

1.

Open the Layout menu and drag until Set Grid is highlighted.

The Set Grid submenu will appear.
2.

Drag until the grid spacing you want is highlighted.

3.

Click the left mouse button.

Releasing
You can temporarily suspend the grid snap function by holding down the
Objects From the Control key as you move or draw an object. This technique allows you to
position an object on a location that does not happen to fall at a grid point.
Grid Snap
For example, if you press and hold down the left mouse button as you are
drawing the side of a polygon, the line will be released from the grid snap.
WARNING: Be advised that if you deactivate the grid snap while drawing
or moving an object, that object will be removed from the grid. This means
that it will be difficult for you to draw lines or borders tangent to the object,
or align the object with other objects. In order to place the object back on
the grid, you will have to use the Align to Grid function, which is described
below.

Snapping Edges
and Lines Along
Their Lengths
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If you draw an object with the grid snap on, its edges will get longer by
small increments or jerks. You can apply the current grid snap to a line by
holding down the Alt key as you draw. For example, if the current grid snap
is 1/4" and you draw a 30˚ line while holding the Alt key, the line will grow
in quarter-inch increments.
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Align to Grid

There will be times when you might create, move, or paste into a PC Draft
document objects that are not on the current grid.
To align the objects to the current grid:
1.

Select the objects to be aligned.

2.

Open the Arrange menu and choose Alignment Options... .

The Alignment Options dialog box will be displayed.

3.

Click "to the grid" radio button.

4.

On the grid, representing the selected object(s), click on the grid
squares to specify which parts of the object(s) are to be aligned,
or check the "Datum" checkbox below the grid.

5.

Click on the Align button.

Once you have made your choice, the selected objects will be aligned to the
closest grid snap in the manner that you have chosen.

Using Drawing Aids
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Angle Snap

You should set the angle snap to the angle you need in or between objects in
your drawing. For example, if you wanted to draw a line at an angle of 14º,
you should set the angle snap to 2º. With the angle snap set this way, the
cursor will snap to two degree increment as you draw the line.
Setting the angle snap
To choose a new angle snap:
1.

Open the Layout menu and drag until Set Angle Snap is
highlighted.

The Set Angle Snap submenu will appear. A check mark indicates the
document's current angle snap.

The Set Angle Snap submenu shows the possible angle choices.
2.

Hold down the mouse button, drag through the submenu until
the angle snap you want is highlighted, and release the mouse
button.

The angle snap remains as set until it is changed again.
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Using the angle snap function
When an angle snap other than None is chosen, objects you draw (to which
angle is relevant) will automatically be positioned to the nearest angle snap
position. You will not be able to draw lines between the angle snap
positions.
You can activate or deactivate the angle snap to suit your needs at the time.
Turning the angle snap off and on
At times you may want to turn off the angle snap when you draw objects.
To turn off angle snap:
1.

Open the Layout menu and drag until Set Angle Snap is
highlighted.

The Set Angle Snap submenu will appear.
2.

Hold down the mouse button, drag until None is highlighted,
then release the mouse button.

To turn on angle snap:
1.

Open the Layout menu and drag until Set Angle Snap is
highlighted.

The Set Angle Snap submenu will appear.
2.

Hold down the mouse button, drag until the angle snap you
want is highlighted, then release the mouse button.

Releasing objects from the angle snap
You can temporarily suspend the angle snap function by holding down the
Shift key as you draw an object. This technique allows you to draw an
object at an angle that is not an angle snap line.

Using Drawing Aids
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Snap to Object

You can choose to make one object snap to another object in the drawing.
When Snap to Object is on, the cursor will snap to the vertices of existing
objects. For example, you could draw a line and make one of its end points
coincide precisely with a corner of a rectangle.
By default, the Snap to Object function is active when you open a new PC
Draft document.
To turn off the Snap to Object feature:
•

Open the Layout menu and choose Snap to Object On.

The check mark will be removed from the command, and the feature will be
deactivated.
To turn on the Snap to Object feature:
•

Open the Layout menu and choose Snap to Object On.

The check mark will be added the command, and the feature will be
activated.

Setting the Size
Units

The Size Units function lets you determine the units in which you want to
work. The specification of units affects the Show Size window, the grid snap
spacing, the scale options, the units of rotation, and the display of the scale
rulers. The unit size options are accessed from the Layout menu.
To specify the units:
1.

Open the Layout menu and choose Set Scale/Units.

The Document Scale & Units dialog box will appear.
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2.

Using English
Units

Click on the button beside English or Metric, depending on the
type of units you want to use in the document.

To use English units in your drawing:
1.

Open the Layout menu and choose Set Scale/Units.

Once you’ve done so, the Document Scale & Units dialog box will be
displayed.

2.

Click on the button beside the title, English.

If you use English units, you can choose from the following units options:
Decimal Inches
Decimal Feet & Inches
Decimal Feet
Fractional Inches
Using Drawing Aids
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Fractional Feet & Inches
To make your units choice:
3.

Click the Unit Size combo box located beside the English and
Metric buttons.

The Unit Size pop-up menu will appear.

The pop-up menu shows you the various unit size options that are available
when you are working in English units. For instance, if you were to choose
“decimal feet,” the Show Size window, the grid lines and snaps, the
numerical values of the scale rulers, and the dimension and area calculations
would all be presented in decimal feet.

Choosing the
Number of
Decimal Places
for Calculation
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4.

Drag until the type of size units you want is highlighted.

5.

Click the left mouse button.

PC Draft provides you with the capability of selecting the number of decimal
places that you desire in numerical displays. You can choose either one, two,
three, or four places behind the decimal point, as well “None” (no places) to
display integers only. The values will be rounded off to the selected number
of decimal places. The default number of places behind the decimal is two.
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In larger scales, the number of decimal places allowed for display may be
reduced automatically.
The decimal places option is only available when you are working in Metric
units or decimal English units.
To change the number of decimal places, follow these steps:
1.

Open the Layout menu and choose Set Scale/Units.

Once you have done so, the Document Scale & Units dialog box will be
displayed.
2.

Point on the Places combo box.

3.

Click the left mouse button.

The decimal places pop-up menu will appear.

4.

Drag through the pop-up menu until the desired number of
decimal places is highlighted.
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5.

Click the left mouse button.

When you are done making your choices from the dialog box:
•

Click on the OK button to close the dialog box and apply the
changes.

Once you have made your choice, all numerical displays, including
dimension lines and area calculation displays, will be rounded off to the
selected number of decimal places. All new displays of values will also
reflect your choice.

Using Metric
Units

When you want to work in metric units:
1.

Open the Layout menu and choose Set Scale/Units.

The Document Scale & Units dialog box will be displayed.
2.

Click the Metric radio button.

If you use Metric units, you can choose from the following units options:
Millimeters
Centimeters
Decimeters
Meters
To make your choice:
1.

Click the places combo box.

The Metric Unit Size pop-up menu will appear.
If you were to choose “Centimeters,” the Show Size window, the grid lines
and snaps, the numerical values of the scale rulers, and dimension and area
calculations would ALL be presented in centimeters.
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2.

Drag until the type of units you want is highlighted.

3.

Click the left mouse button.
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4.

Click on the OK button.

Once you’ve made your choice, all objects will be converted to the new units,
and the numerical values for any objects drawn afterwards will display the
new units (unless the Hide Metric Units feature is active — see below).

Hiding Metric
Units

In many metric drawings, displaying the units is unnecessary. PC Draft
allows you to hide the unit names so that areas and dimensions are shown in
numerals only.
To hide metric units:
1.

Open the Layout menu and choose Set Scale/Units.

The Document Scale & Units dialog box will be displayed.
2.

Click the Metric radio button.

3.

Click the Hide Metric Units checkbox.

The box will be checked, and the units will not be displayed with the
drawing’s dimension line and area values.

Setting the
Rotation Units

The Angular Display choice lets you decide the units in which you want
rotation and angular dimensions displayed and calculated. You can choose
whether rotation appears in decimal degrees (for example, 63.58˚) or in
degrees, minutes, and seconds (for example, 47˚ 22' 30").
To specify the rotation units:
1.

Open the Layout menu and choose Set Scale/Units.

The Document Scale & Units dialog box will appear.
2.

Click the Decimal Degrees or Degrees,
Min. & Secs. radio button, depending on the type of units you
want to use in the document.

See Chapter 5 for information on rotating objects, and Chapter 4 for
information on using angular dimensions.
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Using the Scale
Function

Before starting a drawing, you need to determine the sizes of the objects and
the paper you are going to use. For large drawings it is impractical to draw
objects at their actual sizes; it is necessary to reduce them, yet still maintain
their proper proportions.
A scale accomplishes this. A scale is the ratio of the object’s size on the
drawing to its size in the real world. For example, if you choose a scale ratio
of one inch equals ten feet (1" = 10'), a line drawn ten inches long on a
drawing would represent a 100-foot line in the real world. (To save yourself
the trouble of calculating the size of each object to the scale of the drawing,
you should use the Show Size function.)
PC Draft offers 25 different Feet & Inches scales and 20 Metric scales for
your use. This versatility allows you to create a drawing at one scale, and
then have it automatically converted to a different scale.
You can also have up to four drawings, all at different scales, displayed on
the screen at the same time. This makes it easy for you to copy and paste
between drawings. When you paste an object into a drawing with a different
scale, the object will automatically adjust in size to conform to the scale of
the new drawing.
NOTE: The scale you choose is used as the default scale for the
document. You can assign a different scale to each layer on your drawing if
you wish. (See the section titled “Assigning a Different Scale to a Layer” in
Chapter 7 for more information.) The default scale you specify in the
Document Scale & Units dialog box will be assigned to new layers. If you
change the default scale in the Document Scale & Units dialog box, the
layers using the default will be rescaled.

Setting the Scale

To specify the default scale:
1.

Open the Layout menu and choose Set Scale/Units.

The Document Scale & Units dialog box will appear.
2.
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Click the radio button beside English or Metric, depending on
the type of units you want to use in the document.
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3.

Click the Default Scale combo box.

The Scale pop-up menu will appear.
4.

Drag the mouse cursor, drag until the scale you want is
highlighted.

5.

Click the left mouse button.

The new scale will be displayed in the Default Scale pop-up menu.
6.

Click on the OK button to close the dialog box and apply the
changes.

The dialog box will disappear and your drawing will now reflect the new
scale. If you create a drawing at one scale, and then decide later to change to
a new scale, simply follow the steps outlined above to choose a new scale.
The appearance of the objects on the drawing will either grow or shrink,
depending on the new scale chosen.
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NOTE: Scale can also be changed in any layer via the Layer Setup
window. See Chapter 7, “Symbol Libraries and Layers.”

Scaling text

If you change the scale of a document that contains text, an alert displays
asking if you want to scale the text or not.

•

Click Yes if you want the text to be resized according to the
new scale, or

•

Click No if you wish the text to continue to display at the size it
currently is on screen.

NOTE: Scale can also be changed in any layer via the Layer Setup window.

Angular display

The Angular Display choices let you specify the units in which you want
rotation and angular dimensions to be displayed and calculated.
You can choose to display the rotation units in decimal degrees (e.g.
63.58º), in degrees and minutes (e.g. 51º 14'), in degrees, minutes and
seconds (e.g. 47º 22' 30"), or in user defined units.

To specify the rotation units:
•
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In the Document Scale & Units dialog, click on one of the radio
buttons in the Angular Display section, depending on the type
of units you want to use in the document.
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Setting the
Rotation Units

User defined units
If you click on User defined units, you can specify the number of units to a
circle by typing a value in the Units to a circle field.

With a value of 16 units to a circle, at one decimal place, 90º will be
displayed as 4.0.
Decimal places
If you choose decimal degrees or user defined units for the units of angular
display, you can also select the number of decimal places you would like to
display for angular values.
To change the number of decimal places:
1.

Click on the Places button.

The decimal places popup menu will appear.

2.

Holding down the mouse button, drag through the popup
menu until the desired number of decimal places is highlighted,
then release the mouse button.

Once you have made your choice and closed the dialog, all angular displays
will be rounded off to the selected number of decimal places.
Using Drawing Aids
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Chapter 7

Symbol Libraries
and Layers

Using Symbol
Libraries

Symbol libraries give you the ability to save, catalog, and reuse standard
images, or symbols. You can take previously created symbols out of symbol
libraries and put them directly onto your drawing. With on-line symbol
libraries you can create electrical and architectural symbols, or commonly
used images, like logos, notices, and figures. You can then store them in an
easy-to-access library document, and insert the symbols into various
drawings. The symbols in the libraries retain all their drawing attributes,
such as their scale, rotation, and object information fields.

Creating a New
Symbol Library

To create a new symbol library:
1.

Open the File menu and drag until New is highlighted.

The New submenu will appear.
2.

Drag the mouse cursor until Symbol Library is highlighted.

3.

Click the left mouse button.

A new symbol library window will appear.

Symbol Libraries and Layers
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Shrinking the
Library Window

You can shrink the symbol library window down to palette size by clicking
the arrow check box at the right-hand end of the title bar.

With the palette version, you can quickly place symbols into a drawing.

Saving a Symbol
Library

You can assign a name to a symbol library to help organize your collection of
symbols. For example, an architect might maintain a separate library for
architectural symbols, or a desktop publisher might maintain libraries for
logos and figures.
To save a symbol library under a certain name:
1.

Open the File menu and choose Save As.

A dialog box will appear.
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2.

Type in a name.

3.

Use the directory list to specify the folder in which you want to
save the library, if appropriate.

4.

Click on the Save button.
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The symbol library will be saved under the specified name in the specified
folder or on the specified disk.

Opening an
Existing Symbol
Library

You use the Open command in the File menu to open symbol libraries stored
on disk. Once a symbol library is open, you can paste objects into it from
your drawing, or copy symbols in the library and paste them into your
drawing.
To open a symbol library stored on disk:
1.

Choose the Open command from the File menu.

A dialog box will appear.
2.

Choose Symbol Library from the Files of type pop-up menu.

The list box will display the available symbol libraries in the current
directory.
If the symbol library you want is stored in another folder or on another disk:
3.

Select the folder or drive as necessary to view the contents of the
folder that contains the symbol library you want.

4.

Select the name of the symbol library.

5.

Click on the Open button.

The symbol library window will appear on the screen.
You can open symbol libraries created with PC Draft only.
NOTE: The new PC Draft supports the symbol libraries created using this
version 4.3 or later. You will recognize these by thesuffix* .dsy.

Inserting Objects You can use PC Draft’s drawing tools to create objects and then insert them
Into a Symbol
into a symbol library:
Library
1.

Cut or copy the object on your drawing that you want to insert
into a library.

Symbol Libraries and Layers
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2.

Open a symbol library.

3.

Paste the object into the library.

When you insert a new symbol into a library, the default name “NewSymbol#” (where “#” is a number that increases as new symbols are added to the
library) is assigned to the symbol. You can change the default name. The
symbol names appear in a list box, and the current symbol is displayed in a
viewing area at the bottom of the symbol library window.

List Box
Name Field
Object Info.
Fields

Viewing
Area

The following text provides in-depth instructions on how to insert an object
into a library:
1.

Select the objects you want on the drawing.

If several objects are selected, they will be pasted as one symbol into a
library.
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2.

Open the Edit menu and choose Cut or Copy.

3.

Open a symbol library.

If an existing symbol library is open, click on its window to make it active.
If no library is open, create a new library or open an existing library.
When the symbol library you want is open and active,
4.

Open the Edit menu and choose Paste.

The symbol you cut or copied in PC Draft will appear in the symbol library.
The name “New-Symbol-#” (where “#” is a number that increases as new
symbols are added) will appear in the name box and the list box. Both
entries will be highlighted.

Naming Symbols

To change the name for a symbol in the library:
1.

Use the scroll controls beside the list box to display the name
you want to change, if necessary.

2.

Click on the symbol name you want to change.

3.

Type a new name in the name box.

4.

Click on the Rename button.

NOTE: Pressing Enter after typing the new name will not preserve the
name; you must click the Rename button.
The new name will appear in the symbol library’s list box in alphabetical
order.
NOTE: The name assigned to a symbol in a library file is preserved as part
of its object information when it’s pasted into a drawing.

Searching for
Symbols by
Their Names

If you have a large number of symbols in a library, you might find it
convenient to search for symbols by name.

Symbol Libraries and Layers

7-5

To search for a symbol by name:
1.

Type in the name of the symbol you want to find.

NOTE: You do not have to enter the complete name. If you enter part of
the name, PC Draft will try to match what you enter with the appropriate
symbol name.
2.

Click on the Find button.

PC Draft will attempt to locate the name you specified. If a name that
matches is found, PC Draft will highlight the symbol’s name in the list box
and display the symbol in the viewing area.

Editing Symbols

When a symbol is in a library, you cannot change its appearance directly
(though you can paste it into a drawing at any time and resize, ungroup, or
otherwise edit it, then paste it back into the library). You can, however,
change a symbol’s object information and datum point.

Changing a
Symbol’s Object
Information

In addition to the symbol’s name, the symbol library window includes text
boxes for the other five fields of object information allowed in PC Draft. You
can add or edit object information with the symbol library window open.

Object Info.
Fields
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NOTE: In a symbol library, the field names always retain their generic
numbering (“Field 2” through “Field 5”), rather than using whatever field
names you might have assigned in a particular drawing. That’s because
symbol libraries are, themselves, separate files. When you paste a symbol
that has object information into a drawing, its object information will
automatically be assigned to the respective fields, no matter what the field
names are in that drawing.
To add object information to a symbol:
1.

Use the scroll controls beside the list box to display the symbol
you want to add object information to, if necessary.

2.

Click on the name of the symbol you want to add object
information to.

3.

Click in one of the object information fields and type the object
information.

NOTE: As in a drawing, the maximum length for object information is 25
typed characters.
4.

Click on the Rename button.

NOTE: Pressing Enter after typing the new object information will not
preserve it; you must click the Rename button.
5.

Repeat steps 3 and 4 as needed with the other object
information fields.

To change a symbol’s object information:
1.

Use the scroll controls beside the list box to display the symbol
you want to change, if necessary.

2.

Click on the name of the symbol you want to change.

3.

Click in one of the object information fields and edit the object
information.

4.

Click on the Rename button.
Symbol Libraries and Layers
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NOTE: Pressing Enter after editing the object information will not preserve
the changes; you must click the Rename button.
5.

Repeat steps 3 and 4 with the other object information fields, if
necessary.

NOTE: If you paste a group or object that already has object information
into a library, the object information is pasted along with the item and will
appear in the library window’s object information fields; it can then be
edited if necessary. In any case, a symbol’s object information will stay
with the symbol if you paste it into another drawing.

Assigning a New PC Draft lets you change the location of the datum point for each symbol. A
Datum Point to a datum point is a reference point on an object. The datum point is important
Symbol
because you can use it as a reference point when you paste symbols into a
drawing.

Each type of object has a default datum point. For example, the default
datum point for rectangles is the upper left vertex. The default datum point
for a grouped object (most symbols are grouped before pasting into a library)
is the default datum point of the object at the back of the group.
To assign a new datum point to a symbol:
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1.

Open the symbol library that contains the symbol whose datum
point you want to change.

2.

Click on the name of the symbol you want in the symbol library
list box.

3.

Click on the Datum button. (You can also accomplish steps 2
and 3 by double-clicking on the symbol’s name.)

Symbol Libraries and Layers

The edit handles associated with the symbol will appear. The datum point is
represented by an “X” marker on the symbol.

4.

If necessary, use the size box to display the entire symbol.

5.

Click inside the bounding box (represented by the edit handles)
to define the new datum point.

The “X” marker will appear where you clicked to mark the new datum point.
To place the datum point in the center of the symbol:
•

Click on the Center button.

NOTE: The symbol’s center is defined as the center of the symbol’s
“extent.” The extent is the overall size of the symbol.
To apply the datum point change to the symbol:
•

Click on the Done button.

Symbol Libraries and Layers
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You can also finish editing the symbol’s datum point by clicking on the name
of another symbol.
Technical Notes: If you click near a vertex point (that is, a point where two
edges meet, shown on screen by a major edit handle), the datum point marker
will snap to that vertex. You can place the datum point anywhere within the
bounding box. (The bounding box is the overall extent of the symbol or
group.) However, a datum point located at the center of the object, or on a
vertex point, has some special attributes of which you should be aware. This
type of datum point, called a “fixed datum point,” retains the same relative
position on the symbol even if you reshape or resize the symbol after you
have pasted it onto a drawing. However, if you resize a symbol that has a
“free datum point” (a datum point that doesn’t appear on a vertex point or the
center of a symbol) in such a way that you make the datum point appear
outside the symbol’s bounding box, the datum point will revert to the default
datum point position that applies to the object or the group. This change only
applies to the symbol on the drawing. The original symbol in the library will
not be affected.
As an example, suppose you
assigned a fixed datum point to the
lower right vertex on a rectangle,
copied the symbol, and then
pasted it into a drawing.

You then reshaped the rectangle by dragging the handle associated with the
lower right vertex toward the upper left corner of the drawing, as shown in
the following figure.
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Since a fixed datum point was assigned to the lower right vertex, the datum
point will still appear on the lower right vertex.
However, suppose you had assigned a free datum point that appeared in the
lower right corner of the rectangle, but not on a vertex point. In this case, if
you reshaped the rectangle in the same way as in the above example, the
datum point on the symbol on the drawing would revert to the default datum
point for rectangles, which is the upper left vertex. This would occur because
the reshape operation moved the free datum point outside the symbol’s
bounding box.

Inserting
Symbols Into
Drawings

When you want to insert a symbol into a drawing, you select the symbol you
want from a list containing the names of the symbols in the current library.
PC Draft lets you preview a symbol before you paste it into your drawing.
The symbol you choose from the list of symbols appears in a viewing area at
the bottom of the symbol library window. You can get symbol into a drawing
by pasting it or placing it.
To paste a symbol into a drawing:
1.

Open the symbol library that contains the symbol you want to
paste into your drawing.

2.

Click on the symbol name. (If necessary, use the scroll controls
to display the name of the symbol you want in the list box.)

The chosen symbol will appear in the viewing area.
3.

Open the Edit menu and choose Copy.

4.

Activate the drawing you want by clicking on it.

5.

Click on the drawing where you want the symbol to appear.

6.

Open the Edit menu and choose Paste.

The chosen symbol will appear where you clicked on the drawing. The
symbol’s datum point will be used as the reference point for the paste
operation. This means that the object’s datum point will appear where you
clicked.

Symbol Libraries and Layers
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NOTE: If the symbol you have selected is too large to fit in a drawing, you
won’t be able to paste it in. In such cases, you might try re-scaling the
drawing to make room for the symbol.

Placing Symbols If you need to insert many symbols, or many copies of one symbol into a
from the Library drawing, it may be easiest to put the library window into its “palette” mode.
Palette
When library is in palette mode, you can rapidly place symbols directly into
the drawing.
To shrink the symbol library window to palette mode:
•

Click the arrow check box at the upper right of the window.

The library window will shrink to palette size. The list of symbols will appear
as a popout menu.
To place a symbol in a drawing:
1.

Use the library’s popout menu to choose a symbol by name.

2.

Click the Place button.

The pointer will change to an “X-shaped” cursor.
3.

Move the cursor over the drawing.

4.

Click where you want the symbol to appear.

A copy of the symbol will appear at each point you click on the drawing (the
symbol’s datum point will be aligned under the cursor at each click).
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To exit from the Place mode:
•

Click on the Pointer icon.

WARNING: When the library appears as a palette, you cannot use the
usual Cut, Copy, or Paste commands with it. To use those commands with a
library, or to edit symbols’ datum points, names, or object information, you
must click the arrow check box at the upper right of the palette to put it back
in “full window” mode.

Using the
Repeated Paste
Function

You can use the Repeated Paste function, accessed from the Edit menu, to
paste multiple copies of the same symbol onto various locations on a
drawing.
To use the Repeated Paste function with symbols:
1.

Copy the symbol you want.

2.

Activate a drawing window by clicking on it.

3.

Open the Edit menu and choose Repeated Paste.

When you choose Repeated Paste, you enter a special mode. In this mode, an
object on the Clipboard (in this case the symbol you copied) is pasted onto
the drawing at each point on which you click. While in this mode, you can
scroll the window and even activate different layers and continue to paste
symbols.
4.

Click where you want the symbol to appear.

A copy of the symbol will appear at each point you click on the drawing (the
symbol’s datum point will be aligned under the cursor at each click).
To exit from the Repeated Paste mode:
•

Click on the Pointer icon.

Symbol Libraries and Layers
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Using Scaled and When you insert an object into a symbol library, PC Draft lists the units and
Unscaled
scale in which the symbol was created at the top of the list box. This
Symbols
information is stored with each symbol. (You can find out the scale and units
that are associated with a particular symbol by clicking on the symbol’s name
and then reading the information at the top of the list box.) If you put a
symbol into a drawing whose scale is different from the symbol’s, the symbol
will seem to grow or shrink to match the scale of the drawing. However, you
can choose to paste an unscaled symbol into drawings. When you paste an
unscaled symbol into a drawing, the symbol appears the same physical size
on the drawing as in the library.
To paste unscaled symbols onto a drawing:
1.

Click on the name of the symbol you want to paste.

2.

Click on the check box beside “Unscaled.”

3.

Copy and Paste or Place the symbol into a drawing.

The symbol will appear in its original size on the drawing. The “Unscaled”
check box acts as a toggle. When it is checked, all symbols you copy and
paste onto drawings will be unscaled until you uncheck it.

Deleting Symbols To delete a symbol:
From Symbol
1. Open the symbol library that contains the symbol you want to
Libraries
delete.
2.

Click on the symbol name.

3.

Open the Edit menu and choose Clear or Cut.

The symbol will be deleted from the library.

Closing a Symbol To close a symbol library:
Library
•

Click in the symbol library’s close box.
or,

•
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Open the File menu and choose Close.
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If you insert any objects into a new symbol library and then close the library,
a dialog box will appear asking if you want to save the changes.
To save the library and its contents:
•

Click on the Yes button.

When you click on the Yes button, a dialog box will appear. (See the section
titled “Saving a Symbol Library” in this chapter for more information.)
To close the library without saving the library or its contents:
•

Using Layers

Click on the No button.

PC Draft allows you to use multiple layers on a drawing. However, only one
layer can be active at a time, which means that you can draw and edit objects
on only one layer at a time. The name and scale of the active layer appear
beside the document name in the title bar. The number of layers you can use
in a document is only restricted by the amount of memory you have.
You can also display or print layers individually using PC Draft’s Slide Show
feature, described later in this chapter. Normally, all layers are printed, not
just the currently active layer.
You can assign a distinct name to each layer and change the order of layers.
Each layer can have a different scale. You can choose to hide specific layers
(which makes them both invisible and non-printing), and you can make
objects on inactive layers either appear dimmed (gray) or display their fills
and line attributes (including colors). Layers are controlled through the
Layer Setup dialog box.
To display the Layer Setup dialog box:

Symbol Libraries and Layers
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Displaying the
Layer Setup
Dialog Box
•

Choose
Layer
Setup
from the
Layout
menu.

The Layer Setup
dialog box will
appear.

When you open a new PC Draft document, you start out working on Layer-1.
The names of existing layers appear in the list box on the left side of the
dialog box.

Active, Inactive,
Visible, and
Hidden Layers

Only one layer can be active at a time. The active layer is the only layer you
can edit. In the Layer Setup dialog box, a bullet symbol appears beside the
name of the active layer.
Inactive layers can be hidden or visible. Only the objects on visible layers
appear on the screen and on printed output. A check mark appears beside the
names of visible layers. When a layer is hidden (see the section titled
“Hiding Layers” in this chapter for information on hiding layers), the check
mark is removed.

Selecting Layers

You can select a single layer or a number of layers in the Layer Setup list box.
Selecting a Single Layer
To select a single layer:
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1.

Point on the layer’s name in the list box.

2.

Click the left mouse button.
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The name of the selected layer will be highlighted in the list box and the text
box.
Selecting Multiple Layers
To select layers listed in consecutive order:
1.

Point on the name of the first layer in the range of layers you
want to select.

2.

Press down the left mouse button.

3.

Holding down the left mouse button, drag the cursor through
the names of all the layers that you want to select.

As you drag, the names you drag through will be highlighted.
4.

When you have highlighted the names of all the layers you want
to select, release the left mouse button.

To select multiple layers that are not listed in consecutive order:

Renaming
Layers

1.

Click on the name of the first layer you want to select.

2.

Press down the Control key.

3.

Holding down the Control key, click on all of the other layers
you want to select.

You can easily rename layers, assigning descriptive names that reflect the
contents of individual layers.
To rename a layer:
1.

Click on the name you want to change in the Layer Setup list
box.

The selected name will be highlighted in the list box and the text box below
the list box.
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2.

Type in a name for the layer.

3.

Click on the Rename button, or press Return.

The new name will appear in the list box and the text box.

Creating New
Layers

To create a new layer:
•

Click on the Add button in the Layer Setup dialog box.

The name of the new layer will appear at the bottom of the layers listed in the
list box. PC Draft assigns the default name “Layer-#” to new layers, where
“#” is a number that reflects the total number of layers in the document. For
example, if you had ten existing layers in a document, the next layer you
added would be named “Layer-11.”

Selecting the
Active Layer

Because only one layer can be active, you must select the layer you want to
edit. When a layer is active, you can select and modify the objects on it.
To select the active layer (that is, the layer you want to edit):
1.

Click on the name of the layer in the list box.

2a. Click on the Edit Layer button.
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or,
2b. Double-click on the name in the list box.
To close the Layer Setup dialog box:
3.

Click on the close box.

The Layer Setup dialog box will close and the selected layer will be
activated.
You can also select the active layer by using the up/down arrows on the right
side of the drawing window. The arrows reflect the layer stacking order
shown in the Layer Setup dialog box.
By clicking on the up or down arrow, you can scroll through the defined,
visible layers without having to open the Layer Setup dialog box.
To activate layers that are stacked on top of the base layer:
•

Click on the up arrow until the layer you want to edit is
activated.

To activate layers toward the bottom of the layers stack:
•

Selecting the
Active Layer
Using the Layer
Button

Click on the down arrow until the layer you want to edit is
activated.

You can also select the active layer by using the Layer Button on the right
side of the drawing window. By clicking on the button, you can open a popup menu listing visible layers near the active layer.
To switch layers using the Layer Button:
1.

Click the layer button.

The menu of layer names will appear.
2.

Choose the name of the layer you want to switch to, and click
on it.

Symbol Libraries and Layers

7 - 19

Selecting the
Active Layer
Using the Layer
Tool

Sometimes you can see the object you want to edit, but you can’t remember
which layer it’s on. The Layer Tool, below the Layer Button, is the best
way to get to a visible layer quickly. Once selected, the Layer Tool’s cursor
enables you to click an object in another layer, automatically activating that
layer.
To switch layers using the Layer Tool:

1.

Click on the layer tool.

The layer selection cursor will appear.

2.

Click on an object in a different layer.

The new layer will be activated, and you will be able to work with objects
in that layer.

Hiding Layers

At times, you may find it convenient to hide the inactive layers on the
drawing.
The contents of hidden layers are not only removed from the screen, they are
also omitted from printed output. This allows you to print only the contents
of the layers you want. You cannot hide the active layer.
To hide inactive layers:
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1.

Select the inactive layers you want to hide.

2.

Click on the Hidden check box.

The check mark will be removed from the names of the layers you have
hidden.

Specifying How
the Objects on
Inactive Layers
Are Displayed

The layers will be redisplayed when you uncheck the Hidden check box.
The preset choice for objects on inactive layers is to be displayed without fills
and with their borders dimmed. This avoids confusion as to which objects
are on the active layer.
However, you can choose to have the objects on inactive layers appear with
their fills and border attributes, including colors and patterns. This allows
you to preview your drawing before you print it.
To make the objects on inactive layers retain their normal
appearance:
1.

Select the grayed out layers you want to appear with their
normal fills and colors.

2.

Uncheck the Grayed box.

The Grayed check box will be cleared, and the objects on the selected layers
will appear with their normal fill and line attributes when their layers are
inactive.

Arranging
Layers

As you add layers, new layers are placed on top of the existing layers on the
drawing, in a process analogous to placing transparent sheets of plastic on top
of each other. The layer at the top of the list in the list box is at the rear of the
drawing, and the layer at the bottom of the list in the list box is at the front of
the drawing.
Objects on an upper layer will appear on top of objects on a lower layer. If
objects are opaque (that is, filled), and overlap objects on a lower layer, they
naturally cover portions of the objects beneath them. Sometimes, you might
want to move objects on a lower layer in front of an upper layer. To do this,
you need to rearrange the layers.
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There are four commands you can use to rearrange layers:
Bring To Front
Send To Back
Move Forward One
Move Back One
These choices are discussed in the following pages.
Bringing a Layer to the Front
To bring a layer to the front, thereby making the objects on it appear on top of
all other objects on the drawing, you can use the Bring To Front command.
To bring a layer to the front:
1.

Choose Layer Setup from the Layout menu.

2.

Select the layer you want to bring to the front.

3.

Point on the Arrange button.

4.

Press down the left mouse button.

The Arrange Layers submenu will appear.

7 - 22

Symbol Libraries and Layers

5.

Drag the mouse cursor until Bring To Front is highlighted.

6.

Click the left mouse button.

When you release the left mouse button the objects on the selected layer will
appear on top of all other layers on the drawing. Also, the name of the
selected layer will move down to the bottom of the list in the Layer Setup
dialog box. You can also move multiple layers to the front. If you select
more than one layer and then choose Bring To Front, all the selected layers
will be moved towards the top of the drawing, and the layers’ names will be
moved towards the bottom of the list in the list box.
Sending a Layer to the Back
When you want objects on a layer to appear behind all other objects, you can
send the layer to the back.
To send a layer to the back:
1.

Choose Layer Setup from the Layout menu.

2.

Select the layer you want to send to the back.

3.

Press down on the Arrange button.

4.

Drag the mouse cursor until Send To Back is highlighted.

5.

Click the left mouse button.

When you release the left mouse button, the selected layer’s name will be
moved to the top of the list. Also, the objects on that layer will appear behind
the objects on all the other layers.
You can send more than one layer at a time to the back. To do so, simply
select the layers you want to send to the back, then choose Send To Back.
Moving Layers Forward One Level
You can move layers up one at a time by using the Move Forward One
command.
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To move layers up one level:
1.

Choose Layer Setup from the Layout menu.

2.

Select the layers you want to move up.

3.

Press down on the Arrange Layers button.

4.

Drag the mouse cursor until Move Forward One is highlighted.

5.

Release the left mouse button.

When you release the left mouse button, the selected layers will be moved
forward one level on the drawing. The layers’ names will be moved down
one position in the list.
You can repeat the above steps to continue to move layers forward one level
at a time.
Moving Layers Backward One Level
You can also move layers toward the back of a drawing one level at a time.
To move layers backward one level:
1.

Choose Layer Setup from the Layout menu.

2.

Select the layers you want to move backward.

3.

Press down on the Arrange button.

4.

Drag the mouse cursor until Move Backward One is
highlighted.

5.

Click the left mouse button.

When you release the left mouse button, the selected layers will be moved
back one level on the drawing, and their names will be moved up one place in
the list.
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You can assign different scales to the various layers in your document. This
Assigning a
Different Scale to allows you to include details with an overall floor plan drawing, or details of
a part of a machine within the drawing of the entire machine.
a Layer
The default scale for each layer is the scale that was defined in the Document
Scale & Units dialog box. When you start out with a new document, the
default scale is 1:1; therefore, unless you change the default scale for the
document using the Document Scale & Units dialog box, the default scale for
each new layer will be 1:1.
To define a new scale for a layer:
1.

Select the layer you want.

2.

Point on the button that shows the current scale of the layer
(The button below the check box titled “Grayed”).

3.

Press down the left mouse button.

The Layer Scale pop-up menu will appear.
4.

Drag the mouse cursor until the scale you want to apply to the
selected layer is highlighted.

5.

Click the left mouse button.

The scale you chose will appear on the button. When an individual layer is
selected in the list box, the scale for that layer appears on the button.
The scale for the active layer appears on the title bar beside the document and
layer names.
NOTE: The scale you choose in the Document Scale & Units dialog box
is the default scale for the document. When you add a new layer, the new
layer assumes the default scale. However, you can assign a different scale
to each layer on your drawing if you wish. You should be aware that if you
change the default scale in the Document Scale & Units dialog box, the
layers that use the default scale will be changed to the new scale. The
layers that you’ve given custom scales will be unaffected by changes made
to the default scale.
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Merging Layers

PC Draft allows you to merge the objects on two or more layers into one
layer. All the layers to be merged must have the same scale.
WARNING: You cannot undo the merging of layers.
To merge layers:
1.

Select the layers you want to consolidate into one layer.

2.

Click on the Merge button.

A box will appear to confirm that you want to proceed.
3a. Click on the OK button to merge the selected layers.
Or,
3b. Click on the Cancel button to void the operation.
If you choose “OK”, a new layer named “Merged Layer-#, ” will be created,
where “#” is the number of merged layers in the drawing.

Deleting Layers

You can delete specific layers, along with all their contents. All but the last
layer in the document can be deleted.
WARNING: You cannot undo the deletion of layers.
To delete layers:
1.

Select the layers you want to delete.

2.

Click on the Delete button.

If the layers contain any objects, a dialog box will appear to confirm that you
want to proceed.
3a. Click on the OK button to delete the layers.
or,
3b. Click on the Cancel button to cancel the deletion.
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Slide Shows

PC Draft’s layer feature enables you to use different layers as presentation
slides. With the View menu’s Slide Show command, you can display a
drawing’s layers as slides one after another, without menu bars or other
tools, advancing either automatically or manually. You can also designate
one layer as a “master slide,” which will appear as a background for all the
other slides.
In Slide Show mode, any layer that exceeds the screen size is reduced to fit
on the screen.

Image in
Drawing Window

Image in
Slide Show Mode

In addition, the File menu’s Print Special command will print layers
separately, either at their full sizes or reduced to fit each layer on a page.
You can also use Print Special to print the currently displayed layer by
itself.
The order of slide presentation is determined by the order of layers. The
layer that appears first in the Layer Setup dialog box’s list of layers will
appear first in the slide show; if the Master Slide option is active, the layer
listed first will act as the master (or background) slide.
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Layers that are hidden will not be displayed in Slide Show mode or printed.
Layers can be displayed in a slide show that advances when you change the
slide manually or when an interval you determine has passed.
To display a drawing’s layers as a slide show with manual control:
1.

Open the View menu and choose the Slide Show command.

The Slide Show dialog box will appear.

2.

If necessary, click the radio button next to Display Slides:
Manually, and then click the Play button.

The first slide will appear.
3.

When you want to see the next slide, press the Right Arrow key
on the keyboard or press the left mouse button.

The next slide will appear.
4.

If you want to move back to the previous slide, press the Left
Arrow key on the keyboard.

The previous slide will appear.
5.
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When you are done with the slide show, press the Esc key.
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PC Draft will revert to normal drawing mode.
The following table details the controls for manual slide show mode:
Move forward one slide:

Mouse button or
Right Arrow key

Move backward one slide:

Left Arrow key

Leave Slide Show mode:

Esc key

You can set the slide show to advance from slide to slide automatically after
a set interval. You control how long the preset interval is (it can range from
one second to 999 seconds, which is 16 minutes and 39 seconds).
In automatic Slide Show mode, PC Draft will repeat the sequence of slides
indefinitely. Pressing the Esc Key will put PC Draft back into regular
drawing mode.
To display a drawing’s layers as a slide show with automatic advance:
1.

Open the View menu and choose the Slide Show command.

The Slide Show dialog box will appear.

2.

If necessary, click the Display Slides: Automatically radio
button.
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3.

Double click in the Seconds field, if necessary, then type the
number of seconds for each slide to be displayed.

4.

Click the Play button.

The first slide will appear. After the number of seconds you specified, the
next slide will appear. When all the slides have been displayed, the slide
show will start over.
5.

When you want the slide show to stop, press the "Esc" key.

PC Draft will revert to normal drawing mode.
NOTE: You can use the automatic slide advance feature to create primitive
“animated” sequences. Set the interval to one second and move or edit
objects on different layers to that they appear to “jump” or change as the
slides advance.

Master Slides

You can use one layer as a “master slide,” forming a single background for
all the other slides in a slide show.
PC Draft treats the first layer listed in the Layer Setup dialog box as the
master slide. To move a different layer to that position, you can use the
Layer Setup dialog box’s Send to Back command.
The Master Slide option works with both manually and automatically
advanced slide shows.
To display a drawing’s layers as a slide show with a single background:
1.
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Open the View menu and choose the Slide Show command.
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The Slide Show dialog box will appear.

2.

If necessary, click the Display Slides: Manually, or Display
Slides: Automatically radio button, and set any necessary time
interval.

3.

Click the Master Slide check box.

4.

Click the Play button.

The first slide will appear, consisting of the first and second layers
combined into one image.
5.

If necessary, advance to the next slide.

When the show is advanced (either manually or automatically), the second
slide, combining the first and third layers, will appear. As the show
advances, each succeeding layer will be displayed over the first layer.
6.

When you want the slide show to stop, press the "Esc" key.

PC Draft will revert to normal drawing mode.

Printing Slides

PC Draft’s Print Special command (found in the File menu) will print slides
sequentially, either reduced to fit the current printer’s pages or at their full
size, and with or without the first layer appearing as a “master” background
for the other slides. The Print Special command can also print the
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currently active layer alone, without any other layers appearing on the
resulting hardcopy.
Layers that have been marked “hidden” using the controls in the Layer
Setup dialog box will not be printed.
To print a drawing’s layers separately as sequential slides:
1.

In the File menu, open the Print Special... submenu and choose
the Slides... command.

The Print Slides dialog box will appear.
2.

Click either the Reduced to Fit or Full Size radio button.

The Reduced to Fit option will shrink any layers that are larger than the
current printer’s paper size so that they each appear on a single page. The
Full Size option will leave all layers at their actual sizes, so that larger
layers may print on several pages.
3.

If you want to print the slides with the first (bottom) layer as a
master background, make sure the Use Layer-1 As Master
checkbox is checked.

4.

Click the Print button.

The layers or slides will print out in sequential order.
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Drawing Layout
and Printing

Drawing Layout
and Printing

Using PC Draft, you can create drawings of up to 56.88 inches high by 56.88
inches wide. You can define the desired drawing size by using the Page Setup
choices in conjunction with the Drawing Size feature. The Page Setup dialog
box, accessed through the Page Setup command in the File menu, determines
the size of the individual pages that make up the overall drawing area. The
Drawing Size feature, accessed from the Layout menu, has a graphical
interface that lets you select the number of pages needed to achieve the
desired overall size of the drawing.
Before you define the overall size of your drawing using the Drawing Size
feature, you should specify the type of output device you will use, and the
Page Setup dialog box to specify information about the page setup.
You can configure your Printer Driver directly from the Page Setup dialog
box.

To do so, click the Printer button and choose the printer from the pop up
menu beside Name.

Defining Your
Page Setup

The Page Setup command allows you to choose how you want your
document to appear on the printed page. The page setup depends on the type
of printer you select. (See “Printing a Document” in this chapter for
information about choosing printers.)
Drawing Layout and Printing

8-1

Properties

Normally, the choices of properties include Paper, Graphics and Device Options.
Your properties options are dependent on the particular printer you will use,
such as HP®, Xerox®, or Epson®. The type of printer is also very important
in defining the maximum size and the type of media that you will be able to
use (for example Inkjet, Laser, Dot Marix, etc.).
To select your Paper Option:
• Open the File menu and choose Page Setup
• Click the Printer button from the Page Setup dialog box
• Choose your printer and click Properties button
The following dialog box will be displayed so that you can choose your
various paper size.
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Paper Size

You will notice that there are a variety of paper types offered in the dialog
box. Each paper type has its own block size. The block size refers to the
physical page size of the pages in the PC Draft drawing area.
Normally the printer drivers offer the standard sizes of papers. Below are the
most common paper sizes for desktop printers:
• Click the icon to choose the paper size.

Letter
Legal
Executive
A4
A5
B5

8.5” x 11”
8.5” x 14”
7.25” x 10.50”
8.26 x 11.69”
5.83 x 8.26”
7.17” x 10.13”

Some printers include Envelope and Custom sizes.

Orientation

The Printer Drivers offer a number of special printing features. These
features allow you to set the orientation of the pages on the drawing area and
control the way a drawing can be printed.
The available page orientations are Portrait and Landscape. Select Portrait
orientation to print objects vertically on the page, or Landscape orientation to
print objects horizontally on the page.
_______________________________________________________________
NOTE: PC Draft will get the page orientation from the printer driver. We
recommend setting up your printer driver as the default printer, even if PC
Draft allows you to change your printer on the fly.
________________________________________________________________

Graphics
Options

Resolution:
Under Resolution, you will find different options for setting up the print
quality. Some drivers display the Resolution options as pop up menus
expresed in dots per inch (dpi), others offer different Quality options that
Drawing Layout and Printing
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indicate the resolution (for example maximum or minimum resolution). The
number of dpi will depend on the printer.
Dithering:
The printer driver can offer Dithering options to print bitmap, vectors, or to
get good quality output for different types of media.
Some drivers will give an intensity option enabling you to make the image
either darker or lighter.
You may also have the option, depending on your driver, to set up the number
of copies desired.

Device Option

This option is part of some printer drivers. If your driver has this option, it
will allow you to setup the Printer features.
__________________________________________________________________
NOTE: You may find an option giving you a choice to either print in
Postscript or not. We recommend to not use the Postscript options with PC
Draft.
__________________________________________________________________

Defining Your
Drawing Size

Once your page setup is complete, you are ready to define the overall size of
the drawing.
To set the size of your drawing:
•

Open the Layout menu and choose Drawing Size.

A dialog box will appear, displaying the current total drawing size in the form
of a block diagram.
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You can see the diagram is divided into blocks. This diagram represents the
maximum drawing size available, and each of the blocks represents a single
page. The blocks that are darkened indicate the current drawing size.
To change the drawing size:
1.

Position the tip of the pointer on one of the activated page
blocks.

2.

Press down the left mouse button.

3.

Holding down the left mouse button, drag until you have
activated the number of page blocks required to make up the
drawing size you want.

4.

Release the left mouse button.

5.

Click on the OK button.

As you know, the PC Draft drawing window generally shows only a portion
of the overall drawing. Therefore, when you change the drawing size it won’t
be noticeable until you zoom out or scroll to another area of the drawing.
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PC Draft
Printing Options

PC Draft lets you make choices that affect how pages are printed out. For
example, you can specify the way pages in a document are numbered, and the
order in which they are printed.

Specifying How
Pages Are
Numbered

You can choose to number pages by column or by row. In either case, page
one will appear in the upper left corner of the document.
To number pages by column, in ascending order from top to bottom, or by
row (from left to right:):
1.

Open the Layout menu and choose Drawing Size.

The Drawing Size dialog box will appear.
2.

Printing in
Reverse Order

Click on the button to the left of the page numbering option you
want.

To print the pages in the document from the last page to the
first page (for printers that produce pages face up):
•

Click on the check box beside Print Last Page first in the
Drawing Size dialog box.

After your drawing is complete, you can print it on any printer.

Printing a
Document

Before you print, make sure that you have chosen the printer you want to use.

Choosing Your
Printer

To choose a printer:
•

Open the Start menu and choose Printers from the Settings
submenu.

A dialog box will appear displaying the available printers.
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To Setup your default printer:
•

Right click the printer icon

•

Holding down the left mouse button, drag until the "Set as
Default" is highlighted and release the button.
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Number of
Copies

8-8

The Print dialog box for the laser printers provides you with a number of
printing options. You can specify the number of copies you want to print, the
range of pages, the source for the paper, and whether or not you want to print
out information about the print job.
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Page Range

If you want to print only some of the pages in the document, you can specify
the range of pages you want to print by doing the following:
1.

Click in the box beside Pages From, then type the number of the
first page in the range you want to print.

2.

Click in the text box beside To, then type the number of the last
page in the range.
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To Transfer
Objects to Other
Applications
Using BMP

1.

Select the object or objects you want to move.

2.

Open the Edit menu and choose Copy.

3.

Switch to another application, which accepts graphics.

Once you leave PC Draft, all graphic objects on the Clipboard will be
converted to the BMP format.
4.

Open the Edit menu and choose Paste.

The objects in the Clipboard will appear as a BMP image in the application’s
window.

Opening BMP
Files with Other
Applications

Many applications, including some word processors and page layout
programs, can open BMP files directly, treating them as graphics inserted in
text documents.
(To learn about saving documents in the BMP format, see Chapter 1.)
In many word processing and page layout programs, you can manipulate
BMP images (by cropping, resizing, or panning) just as you can any other
imported graphics.

Resizing Bitmap
Images

There may be occasions when you want to enlarge, reduce, or even distort the
shape of a bitmap image produced from a program such as Paint®. PC Draft
allows you to enlarge or reduce the size of a bitmap image without distorting
the image. PC Draft also allows you to change the size of a bitmap image in
one direction at a time.

Resizing in One
Direction

To resize a bitmap image in one direction only:
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1.

Select the bitmap image you want to resize.

2.

Position the tip of the pointer on one of the edit handles in the
middle of the bitmap’s bounding box, (that is, the handles on the
top, bottom, left and right sides).

3.

Press down the left mouse button.
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Constrained
Resizing

4.

Drag until the bitmap image is the size you want.

5.

Release the left mouse button.

If you stretch a bitmap from one of its corner edit handles, you will be able to
resize the bitmap image’s size in a proportional manner, (that is, the heightto-width ratio will be maintained).
To resize a bitmap image while maintaining its proportions:

Resizing the
Height and
Width
Separately

1.

Select the bitmap image you want to resize.

2.

Choose Group from the Arrange menu.

3.

Point on one of the edit handles on the corners.

4.

Press down the left mouse button.

5.

Drag until the bitmap image is the size you want.

6.

Release the left mouse button.

You can use the handles on the corners with the Alt key to change the bitmap
image’s horizontal and vertical size independently. This method allows you
to change the image’s proportions while resizing it. (This means that the
height-to-width ratio of the image will not be maintained.)
To resize a bitmap image while changing its proportions:
1.

Select the bitmap image you want to resize.

2.

Point on one of the corner edit handles.

3.

Press down the left mouse button.

4.

Press down the Alt key.

5.

Holding down the left mouse button and the Alt key, drag until
the bitmap image is the size you want.

6.

Release the left mouse button and the Alt key.
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Printing Slides

PC Draft’s Print Special command (found in the File menu) will print slides
sequentially, either reduced to fit the current printer’s pages or at their full
size. The Print Special command can also print the currently active layer
alone, without any other layers appearing on the resulting hardcopy.
Layers that have been marked “hidden” using the controls in the Layer
Setup dialog box (see Chapter 7) will not be printed.
To print a drawing’s layers separately as sequential slides:
1.

In the File menu, open the Print Special... submenu and choose
the Slides... command.

The Print Slides dialog box will appear.

2.

Click either the Reduced to Fit or Full Size radio button.

The Reduced to Fit option will shrink any layers that are larger than the
current printer’s paper size so that they each appear on a single page. The
Full Size option will leave all layers at their actual sizes, so that larger
layers may print on several pages.
3.

Click the Print button.

The layers or slides will print out in sequential order.
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The Report
Feature

The Report
Feature

Often, you may want to extract information from your drawing in the form
of a report (a Bill of Materials, for example). Or you may need a report
detailing the properties of objects in your drawing, such as perimeter, area,
length, or other measurements.

Reports can be very useful for such things as determining the cost of a
project or counting items in a drawing (such as furniture in an office layout
or components in a mechanical drawing). Just about any drawing can be
made more meaningful using PC Draft’s report functions.
Any change made to your drawing will be reflected in your reports. Once
you create a report, you don’t have to remember if you’ve changed the
length of a wall or added furniture or fixtures to a layout. PC Draft’s
automatic updating of any data you’ve designated for a report can save you
hours of work and prevent many mistakes.
PC Draft reports can include data about any objects to which you’ve
assigned object information, such as names. In the Report Format window,
you designate which items of object information you want included as
criteria, which functions (Count, Height, Length, Width, X Dimension, Y
Dimension, Area, or Perimeter) you want performed on the data, label the
items if necessary, then print or display the report results.
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You can also link a report to the Microsoft® Excel® worksheet, and then use
Excel’s powerful calculation and formatting features on the report’s data (to
generate cost estimates, for example).

Creating a
Report

Most report actions, including creation of a new report, begin with the
Report Formats dialog box. The dialog box displays the names of all of a
drawing’s reports, and its buttons initiate creating, editing, renaming, and
deleting reports, as well as loading reports in from other drawings.
To create a report:

1.

Choose the Data
Menu’s Report
Formats... command.

The Report Formats dialog box
will appear.
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2.

Click the
New button.

A default name for the report will appear in the list box and the text field.

3.

If you want a
more
descriptive
name for the
report, type it in
the text field,
then click
Rename.

The report’s name will change in the list box.

You can now edit the report, setting it up to display the data you want.
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Setting up a
Report

PC Draft’s report formats can display the individual or total lengths, widths,
heights, areas, and perimeters of objects or sets of objects chosen by the
object information you specify. The reports can also display the count or
(the total number ) of objects that match your criteria.
Report formats include three basic elements: Functions, such as COUNT;
Criteria for the functions (for example, you can COUNT all objects with
Name = “Desk” and Type = “Wood”); and Text for headings and notes.

Criteria
Row

Text Cells

Function
Row

ROW
Popouts

When the report is printed, not all the parts will appear on paper.
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Result
Column

You set up a report mainly by using the row pop-out menus. These let you
quickly define whether a row will contain text, criteria, or a function. All
you need to do is mouse down at the end of the row and make your choice.
The default condition for rows is text; any row not marked in the leftmost
column is a text row. You can enter text in
the row’s cells just by clicking and typing.
You can also choose Text from the row
menu to define a text row.
Choosing Criteria from the row menu makes
that row a criteria bar. Each column in the
criteria bar will have a menu containing the
list of object field names you can use for
criteria. You can choose a field name for a
column or leave it Undefined.
Adding a function to your report is as easy
as choosing it from the menu. Once you’ve
done so, the name of the function will be
displayed at the beginning of the row. To set
the criteria for the function, you enter the desired Object Info into the
column under the appropriate field name.
You can either type an object’s information manually to establish criteria or
point and click the appropriate object after clicking the “Obj. Info” button in
the Report Format window. This allows you to choose a function like
COUNT, then click on a sample of the object you want to count. Its Object
Info will automatically be inserted into the appropriate criteria fields.
You can continue to define additional rows of functions using the same
field names, or insert a new criteria bar to change the field names used in
the functions that follow. (Each function row is controlled by the closest
criteria bar above it.) Inserting criteria bars and adding functions below
them allows you to create comprehensive reports that may extend over
multiple pages if needed.
You can establish the parts of a report in any order, and add or delete rows
as needed.
To set up a report’s text:
1.

Choose the Data Menu’s Report Formats... command.
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The Report Formats dialog box will appear.
2.

In the list of reports, select the report you want to edit.

3.

Click the Edit button.

The Report Format window will appear.
4.

Decide on a row you want to use for text.

In a new report, each row will be blank in all columns, showing that it is a
text row.
5.

Click in the first cell where you want to have text, then type the
text.

6.

Move to the next cell, if necessary, by pressing the Tab key.

NOTE: Text can be wider than a single column, if the next cell in the row
is empty.
7.

Repeat steps 4 through 6 until all the text is in place.

To set up a report’s criteria bars:
1.

Open the report, if necessary.

The Report Format window will appear.
2.
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Decide on a row you want to use for criteria.
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3.

Open the Row Popout menu at the left end of the row and
choose Criteria.

The row will read “CRITERIA” in the first column, showing that it is a
criteria bar. All the cells in the bar will read “Undefined.”

4.

Move the cursor to a cell where you want a criterion, then
press the left mouse button.

A popout menu listing the drawing’s field names will appear.
NOTE: The field names will be either the default field names or the field
names you’ve defined for the drawing.

5.

Choose the field name you want for the criterion in this
column.

The field name will appear in the criteria bar.
6.

Repeat steps 4 and 5 till you have established all the criteria
for this criteria bar.

7.

If you want more than one criteria bar in the report, repeat
steps 2 through 6 as needed.

Once you’ve established the criteria bars, you can set up the function rows
and fill them with object information.
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Functions

PC Draft’s reports extract different types of information from different
types of PC Draft objects. All the functions except Count give results
measured according to the scale and units of the layers containing the
objects.
Area displays the area of an object, or the sum of the areas of multiple
items or items in a group. (This function does not return a value for text
objects and dimension objects.)
Count displays the total number of objects and groups that meet the criteria
of the function row.
Height displays the unrotated vertical size of an object or group, or the sum
of vertical sizes of multiple items. For example, if a one-inch square has
been rotated 45 degrees, this function will still show its height as one inch.
(This function does not return a value for text objects and dimension
objects.)
Length displays the longest measurement of an object or group, or the total
of the longest measurements of multiple items. For lines, linear dimension
objects, and radial dimension objects, that is the distance between the two
ends or reference points. For most other objects, the length is the longer of
the horizontal or vertical (X or Y) extents of the object; if the object has
been rotated, the value is determined as if the object had not been rotated.
(This function does not return a value for text objects and angular
dimension objects.)
Perimeter displays the length of a line, the perimeter of any other object or
group, or the total of those measurements of multiple items. (This function
does not return a value for text objects and dimension objects.)
Width displays the unrotated horizontal size of an object or group, or the
sum of horizontal sizes of multiple items. For example, if a one-inch square
has been rotated 45 degrees, this function will still show its width as one
inch. (This function does not return a value for text objects and dimension
objects.)
X-Dimension displays the horizontal size, measured along the horizontal
axis, of an object or group, or the sum of horizontal sizes of multiple items.
For example, if a one-inch square has been rotated 45 degrees, this function
will show its X-Dimension as about 1.4 inches. (This function does not
return a value for text objects and dimension objects.)
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Y-Dimension displays the vertical size, measured along the vertical axis, of
an object or group, or the sum of vertical sizes of multiple items. For
example, if a one-inch square has been rotated 45 degrees, this function will
show its Y-Dimension as about 1.4 inches. (This function does not return a
value for text objects and dimension objects.)

Function Rows

To set up a report’s function rows:
1.

Open the report, if necessary.

The Report Format window will appear.
2.

Decide on a row you
want to use for a
function.

3.

Open the Row Popout
menu at the left end of
the row and choose a
function.

The row will display the name of
the function in the first column,
showing that it is a function row.

4.

Object
Information

If you want more than one function row in the report, repeat
steps 2 through 3 as needed.

The report’s criteria bars cause PC Draft to search for objects or groups that
match the object information entered in the function rows, then display the
results in the Results column.
You need to enter the object information in each function row. If you
remember the precise object information needed (and its precise spelling),
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you can type it into the function’s cells under the appropriate field names
(listed in the criteria bar above). However, you can also use the Obj Info
button to point and click an example of the object directly, so PC Draft can
enter the object’s information in the function row automatically, under the
correct field name.
To enter the object information for an item:
1.

Open the report, if necessary.

The Report Format window will appear.
2.

Click in the function row.

A flashing text-insertion cursor will appear in the cell you clicked.
3.

Click the Obj Info button
at the lower left of the
report window.

4.

Click the object you want to
use for the function’s
criteria.

The Report Window will disappear from over the drawing window, and the
cursor will have a question mark attached.

The Report Window will reappear, and the selected row will display the
object’s information in the appropriate columns.

5.
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If you want object information in more than one function row
in the report, repeat steps 2 through 4 as needed.
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NOTE: If an object’s data is in a column that is “Undefined” in the criteria
bar, it will be treated as a text label and ignored by the function’s criteria.

Running the
Report

When all the criteria bars, text labels, function rows, and object information
are in place, you’re ready to run the report by printing it (either to the screen
or to a printer). That will put the results of the functions in the Results
column for each function.
Printing to the screen creates a Print Report window that shows you the
results of all the functions and gives you a preview of how the report will
look on paper.

You can also print to the screen if you just want to see the results of the
report, but don’t need a copy on paper.

To print the report to a printer:
1.

If you want to adjust the printed report’s page setup, choose
Page Setup... from the File menu.

The Page Setup dialog box for your active printer will appear. You can
make various changes to the printed report’s page setup (depending on the
printer model). For example, you may need to print the report in horizontal
mode (sometimes called “Landscape” mode).
2.

Make any desired selections in the Page Setup dialog box, then
click OK.

3.

Open the Data menu’s Print Report submenu, then choose the
report you want to print.
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The Print Report To dialog box will appear.
4.

Select the
Printer
button, then
click OK.

The Print dialog box
for your active printer
will appear.

5.

Make any desired selections in the Print dialog box, then click
Print.

The report will be printed.

To print the report to the screen:
1.

Open the Data menu’s Print Report submenu, then choose the
report you want.

The Print Report To dialog box will appear.
2.

Select the Screen button, then click OK.

The Print Report window will appear.
You can scroll around to examine the report’s appearance and results. If you
want to revise the report before printing it, you can.
To edit the report before printing:
1.

Click on the Report Format window.

The Report Format window will become active.
2.

Make any needed changes to the report.

3.

Click on the Print Report window.

The Print Report window will become active.
4.
9 - 12

Click the Update button.
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The Print Report window will be updated to reflect your changes.
Once you’ve determined that the report appears properly, you can print it,
making any necessary page setup changes.
NOTE: You can also continue to work and make changes to the drawing. If
you want to see the results of the changes you’ve made in the drawing, you
can activate the Print Report window and click its Update button. PC Draft
will then recalculate all the report’s functions and display the new results in
the window.
To print the report:
1.

If you want to adjust the page settings before sending the
report to the printer, click the Page Setup... button.

The Page Setup dialog box for your active printer will appear.
2.

Make any desired selections in the Page Setup dialog box, then
click OK.

The Print Report window will reappear, reflecting your Page Setup changes.
3.

Click the Print... button.

The Print dialog box for your active printer will appear.
4.

Make any desired selections in the Print dialog box, then click
Print.

The report will be printed.

Formatting a
Report’s
Appearance

You can make various changes to a report’s appearance, depending on how
you want it printed. A report can have a particular font, size, and text style.
Cells, columns, or rows can have their text justified right, left, or centered.
Rows can be inserted or deleted, and the width of columns can be changed.
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For example, certain text labels or object information items might take up
more space than the default column width allows. Or you may need to add
more rows to make room for more functions.
To change the text font or size used in a report, you open the Text menu and
make the appropriate selections. Your choices will be applied to the whole
report.
You can apply different text justifications to different cells, rows, or
columns, by using the Text menu’s Justification submenu:
To change the justification of a cell:
1.

Click in the cell.

2.

Open the Text menu’s
Justification submenu.

3.

Choose the desired
justification.

The cell will be justified in the manner you chose.
To change the justification of a row:
1a. Click the first cell in a row (next to the row control button).
or,
1b. Hold down the Shift key and click the row control button.
The row will be selected.
2.

Open the Text menu’s Justification submenu.

3.

Choose the desired justification.

The row will be justified in the manner you chose.
To change the justification of several rows:
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1a. Click the first cell in a row (next to the row control button).
or,
1b. Hold down the Shift key and click the row control button.
The row will be selected.
2.

Press the Shift key.

3.

While holding down the Shift key, click the next row’s first
cell.

4.

Repeat step 3 until all needed rows are selected.

5.

Open the Text menu’s Justification submenu.

6.

Choose the desired justification.

The rows will be justified in the manner you chose.
To change the justification of a column:

1.

Click the column
control.

The column will be selected

2.

Open the Text menu’s Justification submenu.

3. Choose the desired justification.
The column will be justified in the manner you chose.
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To change the justification of several columns:
1.

Click the column control.

The column will be selected.
2.

Press the Shift key.

3.

While holding down the Shift key, click the next column’s
control.

4.

Repeat step 3 until all needed columns are selected.

5.

Open the Text menu’s Justification submenu.

6.

Choose the desired justification.

The column will be justified in the manner you chose.
To change the width of a column:
1.

Move the pointer to the right-hand edge of a column control.

The cursor will change to the column adjustment cursor.

2.

Hold down the left mouse button and drag left or right to
define the new column width.

A reference line will appear as you move the cursor.
3.

When you’ve defined the width you want, release the left
mouse button.

The column will assume the width you specified.
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To insert a row:
1a. Click the first cell in a row (next to the row control button).
or,
1b. Hold down the Shift key and click the row control button.

The row will be selected.
2.

Choose the Edit menu’s Insert Row command.

A new row will appear above the selected row.

NOTE: If you select several rows and choose Insert Row, the same number
of rows will be inserted above the selected rows. If you choose Insert Row
with no rows selected, a new row will be added to the bottom of the report.
To remove a row:
1a. Click the first cell in a row (next to the row control button).
or,
1b. Hold down the Shift key and click the row control button.
The row will be selected.
2.

Choose the Edit menu’s Delete Row command.

The row will be deleted, and the rows below will move up.
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Renaming a
Report

Sometimes you may need to change the name of an existing report. The
Report Formats dialog box’s Rename button makes that easy.
To rename a report:
1.

Choose the Data Menu’s Report Formats... command.

The Report Formats dialog box will appear.
2.

In the list of reports, select the report name that you want to
change.

The report’s name will appear in the text field.
3.

Type the report’s new name in the text field, then click the
Rename button.

The new name will appear in the list box.

Loading a
Report from
Another
Drawing

Each PC Draft report format is stored as part of a drawing file. After you
have created reports for several drawings, you may find that a report format
created for one drawing would be useful in another drawing. The Report
Formats dialog box’s Load feature lets you “copy” report formats into the
current drawing file.
Once a report is loaded into a drawing, it uses the field names defined for
that drawing, no matter what the field names were in its source file.
However, it retains the order of the fields, and any text-display attributes
that were already defined.
To load a report from another drawing:
1.

Choose the Data Menu’s Report Formats... command.

The Report Formats dialog box will appear.
2.

Click the Load button.

A dialog box listing the PC Draft drawings in the current directory will
appear.
3.
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Use the directory list to display the drawing containing the
report you want to load.
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4.

Click on the drawing’s name.

5.

Click on the Open
button.

A dialog box listing the report
formats in the selected PC Draft
document will appear.

6.

Click on the name of the report format you want.

7.

Click on the Load button.

The Report Formats dialog box will appear again, with the report you chose
displayed in the list of the current drawing’s report formats. You will be
able to edit, rename, or print that report from the current drawing.

Deleting a Report You can delete specific reports, along with all their contents.
WARNING: You cannot undo the deletion of reports.
To delete a report:
1.

Choose the Data Menu’s Report Formats... command.

The Report Formats dialog box will appear.
2.

In the list of reports, select the report that you want to delete.

3.

Click on the Delete button.

A dialog box will appear to confirm that you want to proceed.
4.

Click OK to delete the report, or click the Cancel button to
cancel the deletion.
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NOTE: If the report has been cloned and linked, the deletion will
automatically break the link; see the next section for more about cloning
and linking reports.

Cloning and
Linking Reports

You can copy or “clone” PC Draft’s report formats into worksheet
document files created with Excel®, a popular application program sold by
the Microsoft® Corporation. The advantage of cloning a report is that you
can use Excel’s powerful mathematical functions to calculate useful
information from the data in the PC Draft report.
For example, if you’ve created a report that shows the total number of times
a particular part is used in a technical drawing, you can use the cloned
worksheet version to learn the total cost of using those parts. Likewise, you
could calculate the total cost of using a certain type of carpet, if your
original report shows the total area of a floor.
If you choose to link a cloned report, you can make changes in the original
drawing, re-run the report, and then automatically update the report’s Excel
clone. That means you can quickly get new cost estimates (for example)
when you add, change, or remove items in your plans or drawings.
In addition, you can use Excel’s advanced page-formatting features to
modify a report’s presentation.
To clone a report into an Excel spreadsheet:
1.

Choose Report Formats...

The Report Formats dialog box will appear.
2.

Select the report you want cloned, then click Edit.

The Report Format window will appear.

3.

Click the Clone button.

The Clone dialog box will appear.
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4.

Choose Copy Only,
Copy & Link
Results, or Copy &
Link All.

5.

Click the Clone
button.

Because Excel cannot
recognize most English-unit
measurements (such as 4' 10")
as numerals, PC Draft may
display a dialog box letting
you decide whether to convert
fractional English units to
decimal numerals.
6.

Select a unit choice,
then click OK.

PC Draft will launch Excel, and the report will be entered in an Excel
worksheet. Its format will be the same as if printed from PC Draft.
After the report is cloned, you can edit it, calculate from its data, or reformat
it in Excel just as you would any other Excel worksheet.

About Links

If you choose Copy Only in the Clone dialog box, the report will be
editable in Excel, but any changes made to the report in PC Draft will only
appear in a worksheet if you clone it again.
If you choose Copy & Link Results, the report will appear in Excel with
the Results column linked to PC Draft. If you change the drawing or report
in PC Draft, the changed results will appear automatically in the worksheet
after you choose Update Link in the Data menu. However, any changes to
the report’s text and criteria made in PC Draft will not appear in the
worksheet unless you create another clone.
If you choose Copy & Link All, the report will appear in Excel with all the
report cells linked to PC Draft. If you change the elements of the drawing,
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or the text, criteria, or results of the report in PC Draft, the changes will
appear automatically in the worksheet after you choose Update Link in the
Data menu.

Updating and
Breaking Links

When you make changes to a report that you’ve linked, you’ll generally
want to make sure that the revised data is reflected in the corresponding
worksheet. The Update Link feature enables you to accomplish that quickly
and easily.
In other cases, you may want to remove links that you’ve established. The
Break Links command severs any report link you no longer need or want.
To update a link after changing a drawing or a report:
1.

Open the Data menu’s Update Link submenu.

The Update Link submenu will appear, listing any linked reports. (Reports
without links will not appear in this submenu.)
2.

Choose the report you want updated.

Once you release the left mouse button, PC Draft will update the report’s
links to the worksheet file.
To break a link:
1.

Open the Data menu’s Break Link submenu.

The Break Link submenu will appear, listing any linked reports. (Reports
without links will not appear in this submenu.)
2.

Choose the report you want unlinked.

PC Draft will break the report’s links to the worksheet file.
NOTE: If you delete a report that has been cloned and linked, the deletion
will automatically break the link.
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APPENDIX A

Menus and Dialog Boxes
FILE MENU
New

Creates a new untitled document or symbol
library. The document’s size will be one
page. The dimension of the drawing area is
determined by the paper type (U.S. Letter,
U.S. Legal, and so forth).

Open

Opens the directory of existing PC Draft
documents on the disk. This command also
gives you the option of opening other disks
that contain PC Draft documents.

Load Layer

Loads a layer into a document.

Close

Closes and puts away a document. Prior to
closing, a dialog box will ask if you want to
save the changes made to the document.

Close All

Closes and puts away all documents. Prior to
closing each one, a dialog box will ask you to
save the changes made to the document.

Save

Saves the contents of your drawing to the
disk and leaves the drawing open.

Save As

Saves a copy of the current drawing. You
will be asked to name the document, and
then a copy of the drawing with its new name
will be saved onto the disk.

Revert

Reverts to the last saved version of the
document.

Export
Report

Exports the current report as a text file.
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Export File

Exports PC Draft document as a graphic
image.

Set Defaults

Saves the settings that affect the drawing
environment, such as scale, grid snap, size
units, and so on.

Page Setup

Determines the print format, such as paper
size, page orientation, pagination, and
reduction factor.

Print

Prints out the drawing in a specified quality
mode (on some printers). The print dialog
box enables you to set the page range, the
number of copies of the print-out, and
whether the drawing will be printed on
continuous or cut sheet paper.

Print Special

This submenu either prints the active
(current) layer or separately prints each layer
of a drawing.

Exit

Exits from the application.

EDIT MENU
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Undo/Redo

Undo reverses the last operation performed.
Redo performs the operation that was
reversed by Undo.

Cut

Removes a selected object from the drawing
and places it on the Clipboard.

Copy

Copies a selected object on the drawing and
places it on the Clipboard.

Paste

Pastes an object from the Clipboard onto the
drawing at the point where you click the left
mouse button.
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Paste Unscale Pastes an object without scale.
Clear

Deletes a selected object from the drawing.

Repeated
Paste

Enables you to repeatedly paste an object
onto a drawing.

Copy
Attributes

Copies the item's object information and
graphic attributes.

Apply
attributes

Applies the attributes to one object.

Attributes
Option

Displays the attribute options dialog box.

Duplicate,
Duplication

Enables you to duplicate selected objects on
the drawing, either one at a time or in linear
and circular arrays.

Select All

Selects all the objects on the active layer.

Select None

Deselects all objects in a document.

Select Special Displays the Select Special Dialog Box to
setup the information about the object(s) that
you will select.

Move

Displays a dialog box that enables you to
move or copy selected items to precise
locations on the drawing.

Expand

Displays a dialog box that enables you to
increase the size of selected object by
multiplying the object's dimensions by
specifyed values.
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Contract

Displays a dialog box that enables you to
reduce the size of selected object by dividing
the object's dimensions by specified values.

Reshape

Displays a submenu that lets you smooth and
unsmooth several types of objects.

Edit Datum

Enables you to define a new datum point for
a selected object.

TEXT MENU
The Text menu contains various choices for
defining text attributes, such as text font,
size, style, line spacing, case, and so on.

A-4

Font

Lists the font sizes and styles installed on
your system.

Justification

Justifies text horizontally and vertically
inside the text block.

Line Spacing

Displays a submenu that lists the following
line spacing options for text.

Case

Controls the case (UPPERCASE, lowercase,
or Title Text) of text.

Select All
Text

Selects every text object in the current layer.

Hide Text

Hides text on the drawing. When this item is
checked, text is omitted from hardcopy
output as well.
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PREFERENCE MENU
Border
Position

Displays a submenu that lists the following
options for border position.

Border Inside Includes all the object’s border in the
measurement of its overall extent.

Border
Centered

Includes only the center of the object’s
border in the measurement of its overall
extent.

Border
Outside

Excludes the object’s border from the
measurement of its overall extent.

Pen Style

Allows to change a pen style of the selected
object.

Zoom Line
Weights Off/
On

When Zoom Line Weights is active, lines
and borders are magnified in proportion to
the current zoom factor. (Normally, line
widths are displayed as they would appear at
a normal view, regardless of zoom factor.)

Hide Line
Styles

When Hide Line Styles is active, solid lines
will appear on lines and objects instead of
line styles.

Edit Colors

Displays the available colors. After you
choose the color you want to edit, a dialog
box used to modify the chosen color is
displayed. (Edit Color is only active when
you run the program on a color system.)

Edit Patterns

Displays the available patterns. After you
choose the pattern you want to edit, a dialog
box used to edit the chosen pattern is
displayed.
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Hide Fills

Hides all the fills (patterns and washes) on
the drawing.

Cross Cursor

Activates and deactivates the large,
crosshair-style drawing cursor.

Tool Options

Displays dialog boxes with options to set up
the Parallel Line Tool and the Regular
Polygon Tool.

VIEW MENU
Zoom

This submenu’s commands increase or
decrease the current magnification by a
factor of two or four.

Restore Prev. Changes the view back to the most recent
level of magnification.
Zoom
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Home View

Changes view to upper left corner of
drawing, with no magnification.

Palettes

Displays or hides the Tool palette, Attribute
palette, Accessory palette, Dimension
palette, Show Size palette, and Resize
palette.

Show Cursor
Position

Displays the X and Y coordinate position of
the cursor. The preset (0,0) position is the
upper left corner of the document.

Show Area,
Hide Area

Calculates and displays or hides the area
values of selected objects.

Slide Show

Displays the dialog box used to control the
Slide Show feature.

Delete View

Displays the dialog box used to name and
save specific views of the drawing.
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Save View

Displays a submenu that lets you delete
views that were previously saved.

Delete All
Views

Deletes all views that were previously saved.

[View Names] Enables you to quickly choose and display a
previously saved view.

ARRANGE MENU
Bring to
Front

Moves selected objects to the front of the
active layer.

Send to Back

Moves selected objects to the back of the
active layer.

Move
Forward One

Moves selected objects forward one level on
the active layer.

Move Back
One

Moves selected objects back one level on the
active layer.

Group

Combines two or more objects so that they
can be treated as a single object with a single
set of edit handles.

Ungroup

Converts grouped objects to their original
state with their own individual set of edit
handles.

Rotate

Lets you rotate a selected object or group.

Rotate to
Zero

Lets you return rotated objects or groups to
their original orientations.
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Alignment
Options

Displays a dialog box that lets you specify
rotation for a selected object or group by
entering precise units of rotation.

Flip
Horizontal

Flips selected objects horizontally on the
drawing.

Flip Vertical

Flips selected objects vertically.

Align Again

Repeats the last alignment.

Rotate
Options

Displays a dialog box showing the various
alignment options.

Distribute on
Line

Distributes selected objects along a straight
line, and spaces them equally about their
centers or datum points.

Lock

Restricts objects on the drawing so they
cannot be changed by any of PC Draft’s
functions such as move, edit, fill, and so on.

Unlock

Returns locked objects to their original
condition so they can be moved, edited, and
so on.

DATA MENU

A-8

Edit Field
Names

Displays the names of object information
fields, enabling you to edit them.

Edit Object
Info

Displays the object information for a selected
object or group, enabling you to edit it.

Find/Replace

Displays the Find/Replace dialog box, which
allows you to find and replace items
according to their object information.
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Report
Formats

Displays the Report Formats dialog box,
enabling you to create, load, delete, rename,
and edit report formats.

Print Report

Enables you to print report formats to a
printer or to the screen.

Update Link

Updates links from report formats to Excel
files.

Break Link

Breaks links between report formats and
Excel files.

LAYOUT MENU
Layer Setup

Displays the dialog box that lets you add,
delete, hide, display, merge, and rearrange
layers on your drawing.

Set Scale/
Units

Displays the dialog box that lets you choose
the units, default scale, and dimension
standards for a drawing.

Set Grid
Snap

Displays a submenu that enables you to
choose from the various grid snaps available
in English or metric scales. The grids will
reflect the current scale and size units chosen.

Set Angle
Snap

Displays submenu with options to choose
angle snaps available in English or Metric
scales.

Show Rulers

Displays the rulers on the top and left sides of
the drawing.

Scale Rulers

Displays rulers based on the current scale of
the drawing. The scale rulers also reflect the
current size units.
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Standard
Rulers

Displays the standard rulers in which the
major ruler divisions are spaced one inch
apart.

Snap to
Object On/
Off

When Snap to Object is active, objects you
draw or move will snap to the vertices of
nearby objects on the drawing.

Hide Grid
Lines

Turns grid lines off.

Hide Page
Breaks

Turns page boundary lines on or off.

Drawing Size

Displays a dialog box that enables you to set
the size of the drawing.

Position

Moves all objects on all layers of a drawing
at the same time.

WINDOW MENU
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Show/Hide
All Palettes

Shows/hides all the palettes

Tool

Shows/hides the Tool palette.

Attrrbute

Shows/hides the Attribute palette.

Accessory

Shows/hides the Accessory palette.

Dimension

Shows/hides the Dimension palette.

Show Size

Shows/hides the Show Size palette.

Resize

Shows/hides the Resize palette.

Alingment

Shows/hides the Alingment palette.
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Status Bar

Shows/hides the Status Bar

Cascade

Arranges multiple opened windows in a
overlapped fashion.

Tile

Vertically arranges multiple opened
windows in a non-overlapped fashion.

Arrange
Icons

Arranges icons for minimized windows at the
bottom on the main window.

HELP MENU
Help Topics

Displays the Online Help Application with
brief information about the most important
issues.

Register
Information

This option connects you to the Online
Registration page.

Update
Information

This option connects you to the Microspot
Web site.
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Dialog Boxes
Page Setup/ Printer Properties

The Page Setup dialog boxes allow you to choose options for the different
paper types. There is a different Page Setup dialog box for the various types
of available printers. Each paper type corresponds to a particular page size.
The Page Setup dialog box allows you to specify how the pages on the
drawing are oriented. Page orientation allows you to print your document
with the drawing oriented either horizontally or vertically on the page.
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Print

The print dialog boxes let you make choices about the printout of your
drawing. You can select the number of copies of the document to be printed
from this dialog box, and in some Printer Drivers you can specify whether the
paper feed is continuous (Automatic) or on individual sheets (Hand Feed).
You can also specify a paper cassette or manual feed as the paper source.
The Properties button allows you to set up options for the printer.

Align Options
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The alignment option allows objects to be horizontally aligned by their tops,
centers, or bottoms. Objects can be vertically aligned by their left, middle, or
right sides. Objects can be centered on top of each other, aligned with a
specified part of the selected object(s) or to a specified part of a reference
object, aligned to a reference point, or aligned to a datum point. You can
align objects using either the alignment icon or the labeled buttons. This
dialog box also allows you to align objects to the grid.

Document Scale & Units

The Document Scale & Units dialog box, accessed using the Set Scale/Units
item in the Layout menu, sets up your drawing environment. Through this
dialog box, you can define the drawing scale, the size and angular units, and
in the case of metric and decimal English units, the number of places behind
the decimal for size values.
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Drawing Size

This dialog box is used to add or remove the page blocks that make up the
overall drawing size. Clicking on the unfilled blocks adds additional sheets
of paper to the drawing area. Clicking on the filled blocks close to the upper
left corner of the block diagram removes sheets from the drawing area. As
the number of sheets of paper is increased, the total drawing size is calculated
and displayed to the left of the diagram. You can also use this dialog box to
specify the order in which pages are printed.

Select Special

The Select Special dialog box, opened via the Edit menu’s Select Special
command, enables you to select objects in a drawing according to their
graphic type, attributes, or object information.
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Layer Setup

This dialog box is used to control the layers on the drawing. Clicking on a
layer name in the list box (on the left side of the dialog box) selects the layer.
Double-clicking on the layer name makes it the active layer. By first
selecting certain layers, and then clicking on a check box or using a button,
you can change the attributes for layers. When the box beside Hidden is
checked, PC Draft hides the objects on the selected layers; when the box
beside Grayed is checked, the objects on the selected layers appear without
their normal fills. You can change the order of layers by selecting layers,
pressing on the Arrange button, and choosing an arrangement option.
Clicking on the Delete button erases the objects on selected layers. Clicking
on the Merge button combines the objects on selected layers onto one layer
(the selected layers must have the same scale). Clicking on the Add button
adds a new layer to the drawing.

A - 16

Appendix A - Menus and Dialog Boxes

Symbol Library

The Symbol Library dialog box lets you store and retrieve commonly used
objects. To locate a symbol in a library, type in the name of the symbol you
want, and then click on the Find button. To select a symbol, click on its
name. The symbol will appear in the viewing area at the bottom of the
window. To rename a symbol, select the symbol, type in a new name, and
then click on the Rename button. To paste symbols into a scaled drawing at
the same physical size as they appear in the library, click on the box beside
Unscaled before you copy the symbol. You can also use this dialog box to
edit the datum points and object information of selected symbols.

Find/Replace
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The Find/Replace dialog box, accessed using the Find/Replace command in
the Data menu, enables you to find and replace items you specify according
to their object information, in one or all layers of the current drawing.

Rotate Options

The Rotate Options dialog box lets you specify the number of degrees and
decimal fractions of a degree (or degrees, minutes, and seconds) you want to
rotate selected objects. To open the Rotate Options dialog box, choose
Rotate Options in the Arrange menu. To specify the desired amount of
rotation, double-click in the appropriate text box and type in a value. To
specify clockwise rotation, click on the button beside clockwise. To rotate
around the datum point of the object, click on the check box beside “Datum
of Object(s)”. After you have made your choices, click on the Rotate button.
To rotate objects around a certain point on the drawing, click on the button
beside “A reference point,” click on the Rotate button, then click on the
desired reference point on the drawing.
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Set Defaults

The Set Defaults dialog box lets you save certain settings for documents.
The saved settings will be present in new documents you create. To open the
Set Defaults dialog box, choose Set Defaults from the File menu. To choose
the settings you want to save, click on the check boxes beside the desired
settings. To save defaults that affect how new documents are opened, and the
status of the Cursor Position Indicator and the Show Size palette, click on the
Application Defaults button. Click on the OK button to save the defaults.

Move Object

The Move Object dialog box, accessed using the Move item in the Edit menu,
enables you to move selected objects or groups to a location you type in.
Through this dialog box, you can move or copy the selected object to any
location in any layer of the current drawing.
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Edit Line Styles

The Edit Line Styles dialog box lets you create custom line styles. You create
the line styles by defining the length of the gaps and dashes in the line. To
edit a line style, choose a line style from the Edit Line Style submenu, which
is accessed from the Line menu. Click on the button beside inch to use inches
for the units of measure; click on the button beside cm to use centimeters. To
define the line style, move the pointer to the field in the center of the dialog
box. If you position the pointer above the line a white flag will appear; if you
position the pointer below the line a black flag will appear. The white flag is
used to add gaps; the black flag is used to add dashes. To add a gap or dash,
point where you want to add a gap or dash, press down the left mouse button,
holding down the left mouse button, drag until the gap or dash is the length
you want. Then release the left mouse button.
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Dimension Formats

The Dimension Formats dialog box, opened by using the Format button in the
drawing tools palette, enables you to control the appearance of dimension
objects, including settings such as how dimension text is displayed, the
position of leader lines and dimension end marks, the use of tolerance values,
and whether to replace a calculated dimension value with a text string of your
choice. Default settings can be changed separately for Linear, Radial, and
Angular dimensions.

Dimension Standards

The Dimension Standards dialog box, opened via the Dimension Formats
dialog box (for existing objects) or the Document Scale & Units dialog box
(for setting document defaults), enables you to alter the dimension settings
defined according to ANSI or international metric standards.
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Edit Field Names

The Edit Field Names dialog box, opened via the Data menu’s Edit Field
Names command, enables you to edit the object information field names for
the current drawing.

Edit Object Information

The Edit Object Information dialog box, opened via the Data menu’s Edit
Object Info command, enables you to edit the object information for a
selected object or group.
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Linear Duplication

The Linear Duplication dialog box, accessed using the Linear command in
the Edit menu’s Duplication submenu, enables you to duplicate selected
items as many times as you specify, in one or two directions according to
distance and angle or vertical and horizontal displacement.

Circular Duplication

The Circular Duplication dialog box, accessed using the Circular command
in the Edit menu’s Duplication submenu, enables you to duplicate selected
items in single or concentric circles or circular arcs. You can define the
sweep or increment of the circle and the angular offset and radii of concentric
circles.
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APPENDIX B

Special Usage of Keys

Hold down the appropriate key to achieve the following results.

Shift Key

(Normally constrains an action)

Line tool:

Constrains lines to snap at 45-degree increments.

Rectangle tool:

Constrains the shape to a square. (Applies to rounded-corner, square-corner,
and elliptical-corner rectangles.)

Circle tool:

(by Radius or by Diameter) Constrains the line used to define the radius or
diameter to snap at 45-degree increments.

Arc tool:

Arcs by Radius: Constrains the line used to define the radius to snap at
45-degree increments.
Elliptical Arcs: Constrains the size of the ellipse that is used to define
the arc and allows you to change the starting angle of the arc without
changing its size.

Polygon tool:

Constrains the line segments to snap at 45-degree increments during creation.

Freehand tool:

Activates the eraser, allowing you to delete part of the freehand shape during
creation.

Rotation:

Changes the rotation units. The first press of the Shift key activates rotation
in minutes; the second press activates rotation in seconds.

Moving objects:

When held down after dragging begins, constrains movement of objects to a
horizontal or vertical direction. With multiple objects, pressing Shift before
dragging moves one object independently of other selected objects.

Selecting objects: Extends the selection to include non-selected objects you click on. Also
deselects the selected objects you click on.

Distribute On
Line:

Constrains the line used to define the distribution of objects to snap at 45degree increments.
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Pattern Editor
dialog box:

Constrains the movement of the pointer and the Finger-Painting tool to a 90degree angle.

Pointer tool:

Activates the alternate Zoom cursor (magnifying glass).

Control Key

(Normally releases a constraint)

Rotation:

Allows rotation in one-degree increments. Also returns to the previous
rotation units; takes you from rotation-in-seconds to rotation-in-minutes, and
from minutes to degrees. Also, returns you to the pointer mode when you
click on the drawing.

Zoom:

Returns you to the pointer mode when you click on the drawing.

Dimension/ Area
Calculation
values:

Allows you to move point-to-point dimension line and area calculation
values away from dimension lines and objects.

Alt Key

(Normally activates an optional mode of operation)

Distribute On
Line:

When you choose Distribute On Line from the Arrange menu, objects are
distributed on a line according to their datum points.

Finger-Painting
tool:

(in Pattern Editor dialog box) resets the Finger-Painting tool color to the
color you click on.

Zoom:

Activates the Zoom Out mode.

Add/Delete
Handle:

Activates the Delete Handle mode.

Selection
rectangle:

Selects all the objects that are inside or touching the rectangle.

Align Objects:

Aligns selected objects to one element in a group, rather than to the group as a
whole.
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Tool Icons:

Opens the optional dialog boxes for certain drawing tool icons: Parallel lines,
Fillets, Chamfers, Extend.

Line, Polygon,
Parallel, Offset,
and Perpendicular tools:

While drawing, snaps the length of lines, polygon segments, polyline
segments, parallel lines, parallel polygon segments, parallel polyline
segments, and perpendicular lines, and the offset distance of offset lines, to
the currently active grid snap increment.

Space Bar
Pointer tool:

Activates the Pan feature when you drag while in the pointer mode. This
allows you to scroll horizontally and vertically at the same time.

Key
Combinations
Pan feature:

Shift-space bar constrains panning to 90-degree movement when pointer tool
is selected.

Bezier curves:

Shift-Alt constrains Bezier handle pairs to move in tandem.

Deselect All:

Shift-Control-A deselects any selected objects.

Select All Text
(In Open Text):

Within a text block, Control-A selects all text characters.

Cropping:

Shift-Alt permits cropping of a bitmap or pixel map by dragging a corner edit
handle.
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APPENDIX C

Importing and Exporting Files with PC Draft

File Import and
Export in PC
Draft

PC Draft can import image document files from the formats listed below.
This appendix details the conversion issues involved in retrieving each type
of image with PC Draft.
•
•
•

TIFF File
Loading

TIFF format files, such as scanned images
DXF files (PC Draft will also export DXF&DWG)
MacDraft files

TIFF stands for “Tag Image File Format.” It’s a standard format for highresolution images, and is often used to save images stored with scanning
devices.
PC Draft will load certain TIFF images (from files compatible with the
TIFF 5.0 format) into drawings via the Load Layer command. To be
compatible with PC Draft, the file must have a file type of “TIFF.”
Each TIFF file’s images will be placed in a separate layer (with the same
name as the original file). The images will appear as pixel-map objects.
You can move such objects to other layers using the Cut or Copy and Paste
commands, or you can (for larger images) use the Layer Setup command’s
Merge Layers option to combine them into layers with other parts of the
drawing.
To load a TIFF file into PC Draft:
1.

Choose Load Layer... from the File menu.

The Load Layer dialog box will appear.
2.

If necessary, open the Format pop-up menu and choose All or
TIFF.

Both the All and TIFF format choices will list TIFF documents.
3.

Use the directory list to display the TIFF file you want to open.

4.

Double-click on the title of the file.

The image or images will be loaded into a new layer with the same name as
the original TIFF file.
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TIFF images, like other pixel-map objects, can be resized by dragging
handles. Unlike bitmaps, some pixel maps do not resize proportionally.
However, you can get around this by selecting a pixel map and choosing
Group from the Arrange menu. That will group the object to itself (put it in
a “group of one”). It can then be resized proportionally like other PC Draft
groups (see Chapter 5 of the PC Draft Reference section for more
information about resizing groups).
PC Draft can export files in the following formats: BMP, JPEG, MaxPaint,
PhotoShop, PICT, PNG, QuickTime Image, SGI Image, TGA, TIFF.
SeeApple, QuickTime documentation for details.

DXF File
Exchange

DXF is a standard file type for exchanging images among different graphics
and drawing programs. PC Draft lets you save PC Draft drawings as DXF
files and open DXF files created with other programs. (The DXF file format
was developed by AutoDesk®, Inc., the manufacturer of AutoCAD®.
To save a document as a DXF file:
1.

First save the drawing as an ordinary PC Draft drawing.

NOTE: Because PC Draft creates a DXF file by converting a PC Draft
drawing from the disk, rather than straight from RAM, you must save the
drawing as a PC Draft file first.
2.

Open the File menu and choose Save As.

A dialog box will appear.
3.

Type in a name.

4.

In the file format popout menu, choose DXF, then click the
Save button.

To open a DXF file:
1.

Choose the File menu’s Open command.

A dialog box will appear.
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2.

In the file format popout menu, choose DXF.

3.

Highlight the name of the desired file in the list box, then click
the Open button.
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The Set Scale/Units dialog box will appear.
4.

Set the desired scale and units and click OK.

NOTE: The Set Scale/Units dialog box that precedes the DXF import does
not re-calculate the DXF file into a new scale or onscreen size. It only
determines what scale will be applied to the drawing. The onscreen size of
the drawing must be determined in the source program.
The DXF image will appear in a new untitled PC Draft drawing.

DXF Export
Issues

Because the DXF format does not handle as many kinds of shapes and
attributes as PC Draft’s own file format, certain attributes in a PC Draft
drawing are changed in the resulting DXF file. These changes are defined
below:
• The image moves to the upper left corner of the drawing window.
• Circles, arcs, and straight lines become one pixel thick. Other object
outlines retain their line weights.
• All shapes lose their fills.
• Custom line styles are limited to eleven segments (dashes or blanks).
• Rectangles (including squares) become polygons.
• Rounded-corner rectangles become polygons (with many sides emulating
the corner arcs).
• All three types of circles (radial, diametric, and three-point) become radial
circles.
• Ovals (ellipses) become polygons with many sides.
• Radial and three-point arcs become radial arcs. Elliptical arcs expand to
polygons emulating full ellipses.
• Parallel objects become sets of line segments (one segment per side or end
cap).
• Freehand shapes become polygons (mid-segment edit handles added).
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• Bezier curves become many-sided polylines (open polygons).
• Splines become many-sided polylines.
• Smoothed freehands and polygons or polylines become many-sided
polygons or polylines.
• Dimension objects become simple lines or arcs, with circles, polygons, or
lines emulating the end marks; witness lines become simple lines and value
text blocks become independent text objects.
• Area calculation text becomes an independent text object.
• Bitmap objects, including high-resolution pixel maps, are omitted.
• Text assumes the default application font, preserving the upper-left
position of the original text object.
• Each line of a multi-line text object becomes at least one separate text
object. Each point at which the text style changes within a line begins a new
text object. For example, a line ending with one bold-faced word would
become two text objects; a line containing one bold-faced word in the
middle would become three text objects.
• Each line of a rotated multi-line text object becomes a separate text object,
rotated about its own center. (To line these objects up properly after
conversion to DXF, rotate them back to the horizontal, group them, then
rotate the group to the desired angle.)

DXF Import
Issues

PC Draft can open DXF files created using other programs, subject to
various limitations. Before opening a DXF file with PC Draft, or if you are
having trouble opening a DXF file, read over the following list of issues.
• Scale and Units: The Set Scale/Units dialog box that precedes the DXF
import does not re-calculate the DXF file into a new scale or onscreen size.
It only determines what scale will be applied to the drawing. The onscreen
size of the drawing must be determined in the source program.
• These DXF items are not supported by PC Draft: X-Refs (External
References); 3-D objects or entities; solid objects or entities; block
attributes.
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• If a DXF file created using AutoCAD does not open in PC Draft, check to
see that all unused items (blocks, layers, and so on) have been purged from
the source file. If there is resident information from deleted blocks, the
DXF files will not open. Also, before creating the DXF file, it’s best to
explode and purge nested blocks, which increase the complexity of files,
sometimes making them non-openable.
• When generating a DXF file select a text DXF export format in your
source program. (Some programs offer a binary DXF output, which is not
supported in PC Draft.)
• If a drawing comes in, but some or all of it is off of the page, use the
Layout menu’s Position command to properly position the drawing onto the
page. (Different CAD programs use different X / Y origin points, as well as
handling curves differently. The result of these translations can cause the
drawing to import partially or entirely off of the page.)
• If some or all of the drawing entities are not visible in the imported file,
choose the Edit menu’s Select All command, then use the Attribute palette’s
Pen Color or Pen Pattern popout menu to assign the objects a new pen color
(you may need to repeat this for each layer). When importing a DXF file,
PC Draft matches the objects’ original colors to its active color table.
Sometimes the result of a color match can be a hard-to-see color (white ink
on a white background, for example). Assigning a new pen color remedies
this.

DWG format
documents

PC Draft includes a DWG File Exchange Library, so PC Draft is able to
read and write files in DWG format.

Reading DWG
files

To read files in DWG format, launch PC Draft and choose Open from the
File menu. In the standard Open dialog, choose DWG from the Files of
Type list, then choose the file to open.
To open a document saved in DWG format
1.

Open the File menu and choose Open.

2.

Choose DWG from the Files of Type list in the standard Open
dialog.

3.

Locate and click the name of the document that you want to
open.

4.

Click the Open button.
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The Set Scale/Units dialog appears.
5.

Set the desired units. The default scale in this dialog is set to
Automatic (which will select a scale for you that PC Draft
believes is correct), but you can choose to set it manually. Now
click OK.

6.

DWG files use nonspecific units of measurement. Enter a value
to specify how many DWG units there should be per foot or
per metre in the PC Draft document.

The DWG image will be displayed in a new untitled PC Draft drawing.

DWG import
issues

Currently PC Draft does not support objects in DWG documents that
contain hatches or BMP. The first time such an object is encountered during
the read process, a dialog appears informing you that the type of object is
not supported. These objects will not be read into the PC Draft document.

Writing DWG
files

To save documents in DWG format
1.

Choose Save As from the File menu.

The standard Save dialog appears.
2.

Enter a name for the document.

3.

Specify the location to save the document.

4.

Choose DWG from the Save as type list.

The DWG extension will automatically be added to the file name.
5.

Click the Save button.

The document will be saved in DWG format, with the name and at the
location specified.
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Opening old
MacDraft files

PC Draft also supports files created with PC Draft 1.5, WinDraft 1.2 and
MacDraft for Windows. The suffix for these files is .dft.
Using MacDraft 4.2.1 or later you will be able to save your files as PC Draft
1.5, WinDraft or MacDraft for Windows format.
To open the .dft files just place the files into your PC computer, open your
File menu from PC Draft, select the Open option and choose PC Draft 1.5
Drawing (.dft) from type of file. Select the file from the list and click the
Open button.

NOTE: If you do not have MacDraft 4.2.1 or a later version, please contact
Microspot for information about the conversion kit options.
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A
Add Tool 2-108
Adding and Deleting Handles 2-103
Align Left 2-38
Align Objects A-13
Align Right 2-38
Align to Grid 6-13
Aligning Objects 5-28
Aligning Text 4-13
Alignment palette 1-32
angular degree symbol 4-26
Angular Dimension Objects 4-40
Angular Dimensions 4-40
Angular dimensions 4-14, 4-16
Angular Display 6-21
animation, primitive 7-30
Annotation 4-1
annotating your drawing
with dimension lines 4-14
Application Defaults 1-24
Apply button 2-80
Arcs 2-1
arcs by radius 2-18
changing the size of an arc by radius 2-18
drawing an arc by radius 2-17
drawing arcs with a fill 2-17
elliptical arcs
editing an elliptical arc 2-22
arcs, concentric 2-24
Area 9-8
Area Calculation 4-47
ARRANGE MENU A-7
Arranging Layers 7-21
Arranging Objects 5-24
Arrows Inside 4-25
Attach tool 2-105
Attributes Palette 3-1
Attributes Tool 3-53
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AutoCAD® C-2

B
Baseline 4-28
baseline dimensions 4-28
Baseline Linear Dimensions 4-32
Bezier curves 2-67
Bezier curves see Curves 2-1
Bill of Materials 9-1
Bitmap Images 8-10
bitmaps 2-85
Border Position A-5
Border Positions 3-49
Borders 2-1
Break command 2-106
Break Link A-9
Break tool 2-106
Break tool on Dimension Objects 4-47
Breaking Dimension Objects 4-46
Breaking Links 9-22
Bring to Front 5-24
Bringing a Layer to the Front 7-22

C
Calculating the Area 4-48
Calculating the Net Area of Overlapping Objects 4-48
Case A-4
case 4-10
Centimeters 6-20
Chained 4-28
chained dimensions 4-28
Chained Linear Dimensions 4-30
Chamfers 2-115
Circle by Three Points 2-13
Circle Center Length, Gap, and Extension 4-22
Circle Center Marks 4-39
Circles 2-1, 2-11
by diameter 2-11
by radius 2-11
by three points 2-11
choosing a method for drawing circles 2-11
circle drawing modes 2-11
circles, concentric 2-14
Circular Duplication 5-16
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Clear 5-9, A-3
Clone button 9-21
Close A-1
Color Picker 3-8, 3-21
Color Table 3-6
column width 9-14
Command Key B-2
Constrained Drawing 2-28, 2-63
Constrained lines 2-1, 2-2
constrained line tool 2-1
Constrained Resizing 8-11
Constraining Line Segments 2-31
Constraining the Movement of Objects 5-2
cookie cutter 2-110
Copy 5-3, A-2
Copying Attributes 3-52
Count 9-8
Create a New Document 1-11
Creating a Report 9-2
Creating New Layers 7-18
Criteria 9-4
criteria bar 9-11
Cropping B-3
Cross Cursor A-6
Cursor Mod 1-43
Cursor Position 6-9
Curve Tools 2-65
Curves
Bezier 2-1
Customizing Patterns 3-15
Cut 5-2, A-2
cutter 2-111

D
data fields 2-121
DATA MENU A-8
datum point 2-75
Decimeters 6-20
Default Attributes 3-3
default datum point 7-8
Defaults 1-20
Application Defaults 1-24
default settings 2-1
Overriding Defaults 1-25
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Set Defaults 1-21
degree symbol 4-26
Degrees, Min. & Secs. 6-21
Deleting a Report 9-19
Deleting Handles 2-103
Deleting Layers 7-26
Deleting Symbols 7-14
Dialog Boxes A-12
diameter dimension 4-39
diameter symbol 4-26
Dimension End Marks 4-26
Dimension Format 4-17
Dimension Format Attributes 4-25
Dimension Label 4-26
Dimension lines 4-14
annotating your drawing 4-14
Associative
editing 4-28
associative 4-15
point-to-point 4-14
standards
attributes 4-21
Dimension Palette 4-15
Dimension Standard Attributes 4-21
Dimension Standards and Formats 4-17
Dimension Text Gap 4-21
Dimension Type 4-25
Dimensions 4-14
angular dimensions 4-40
annotating your drawing 4-14
formats 4-17, 4-23
horizontal dimensions 4-29
linear dimensions 4-28
perpendicular dimensions 4-35
radial dimensions 4-37
slope dimensions 4-34
standards 4-17, 4-18
vertical dimensions 4-33
Disassembling objects 2-106
Displaying Palettes 1-33
Document
document size 2-1
Document Scale & Units A-14
Document Window 1-28
drafting formats 4-14
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drag 5-1
Drawing 2-1
drawing mode 2-1
drawing procedures 2-1
drawing tool 2-1
Drawing Aids 6-1
Drawing Area 1-30
Drawing Layout 8-1
Drawing Size 8-4
Duplicate A-3
Duplicate command 5-10
Duplication A-3
Duplication in Concentric Circles or Arcs 5-19
Duplication in Two Directions 5-14
DXF Export Issues C-3
DXF File Exchange C-2
DXF Import Issues C-4

E
Edit Color A-5
Edit Datum A-4
Edit Field Names 2-121
edit handle 2-81
Edit handles
major edit handles 2-31
minor edit handles 2-31, 2-32
minor handles
using minor edit handles 2-32
edit handles 4-29
EDIT MENU A-2
Edit Object Info 2-121
Edit Pattern 3-16, A-5
Editing Colors 3-6
Editing Symbols 7-6
Ellipses
choosing a method for creating an ellipse 2-26
diagonal 2-26
creating a centered ellipse 2-27
elliptical arcs 2-20
End Marks 3-46
end marks for dimension objects 4-26
English Units 6-17
Enhanced PICT 8-10
evenly spaced objects 5-10
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Excel® 9-20
Export C-1
Extend function
Extending Lines Toward a Reference Line 2-100
Extending Lines Toward an Existing Line on Your Dra 2-102
Extend tool 2-1
Extending Lines 2-99
Extension 4-21
Extrude Tool 2-44
Extruding Lines 2-44
Extruding Parallel Lines 2-44
Eye Dropper Tool 3-25

F
Field Names 2-121
field names 9-7
fields 2-120
FILE MENU A-1
File Menu 1-12
Fill
drawing arcs with a fill 2-17
Fill and Line Indicator Boxes 3-2
Fill and Line Indicators 1-29
Fill Color 3-9
Fill Color/Pattern 3-2
Fill Indicator 1-29
Fillets 2-1, 2-112
fillets 2-112
Find and Replace 5-48
Finger Tool 3-25
Flip Horizontal Tool 3-23
Flip Vertical Tool 3-23
Flipping Objects 5-34
Font A-4
font 4-9
Formats 4-23
Formats for dimensions 4-23
formats of dimension objects 4-17
frame 4-25
freehand objects 2-61
Function Rows 9-9
Functions 9-4, 9-8
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G
Glue 2-105
Grid 2-61
grid lines 2-1
grid snap 2-1
Snapping Diagonal Lines Along Their Lengths 6-12
Grid Lines 6-10
Grid Snap 6-10
Grid snap
diagonal lines 6-12
Grouping Objects 5-26

H
Hand Tool 3-27
handle 2-81
Handles 2-32
handles 4-29
Hardware and Software Requirements 1-1
Height 9-8
Hexagons 2-33
Hidden Layers 7-16
Hide Area 4-49
Hide Line Styles A-5
Hide Text A-4
Hiding a Palette 1-33
Hiding All Text 4-7
Hiding Layers 7-20
Hiding Metric Units 6-21
horizontal and vertical dimension tools 4-29
Horizontal Dimension Objects 4-29
Horizontal Dimensions 4-29

I
I-beam Pointer 1-50
I-beam pointer 4-5
Import C-1
Inactive layers 7-16
Indicators, Fill and Line 1-29
Inserting Text 4-8
Install 1-1
Intersection Points 2-99
Invert Tool 3-22

J
Justification 4-13, A-4
justification of a cell 9-14
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K
Key Combinations B-3
Keyboard Command Equivalents 1-31
keyboard move 5-5
Keys B-1

L
Label 4-26
Layer Button 7-19, 7-20
Layer Setup 7-16
Layer Tool 7-20
Layers 7-15
slide shows 7-27
Leader 4-25
Leader Length 4-21
leader line 4-21
leading 4-11
Length 9-8
Library Palette 7-12
Line Gap 4-21
Line Indicator 1-29
Line Indicators 1-29
Line Spacing A-4
line spacing 4-11
Line Styles 3-41
Edit 3-44
Linear dimension 4-16
Linear Dimensions 4-28
Linear Duplication 5-11
Lines 2-1, 2-3, 2-59
changing the length of a line 2-4
choosing line tools 2-1
constrained diagonal line tool 2-1
constrained line tool
drawing a constrained line 2-2
line drawing modes 2-1
line pop-up menu 2-1
unconstrained diagonal line tool 2-1
unconstrained line tool
drawing an unconstrained line 2-3
Link All 9-21
Link Results 9-21
Linking Reports 9-20
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Load Layer A-1, C-1
Loading a Report from Another Drawing
Loading Layers 1-12
Lock and Unlock 5-38
lowercase 4-10

9-18

M
Major Handles 2-32
Master Slides 7-30
Menu Bar 1-30
Menus A-1
Merging Layers 7-26
Metapolygons 2-110
Meters 6-20
Metric Units 6-20
Millimeters 6-20
Mirror Tool 5-35
mistake 2-125
Miter Joints 2-44
Move A-3
Move Back One 5-25
Move Forward One 5-25
Moving aPalette 1-33
Moving Area Calculation Values 4-49
Moving Layers Backward One Level 7-24
Moving Layers Forward One Level 7-23
Moving Objects 5-1
Moving objects B-1
Moving Text 4-12

N
names 2-120, 9-1
Naming Symbols 7-5
New 1-26, 2-1, A-1
NewSymbol-# 7-4

O
Object Fill Color 3-9
Object Fill Patterns 3-28
Object information 2-120
object information 2-123, 7-6, 9-1, 9-9
Octagons 2-33
Offset Arcs 2-24
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Offset Circles 2-14
Offset Lines 2-59
Open 1-26, 7-3, A-1
Opening documents 1-26
Orientation 8-3
Outside Line Length 4-22
Overlay Tool 3-22

P
Page Setup 8-1, A-2, A-12
pages by column 8-6
Paint Bucket Tool 3-26
Palettes 1-32
Paper Type 8-3
paragraph text 4-1
Parallel Fill Color 3-11
Parallel Fill Pattern 3-30
Parallel Lines 2-1, 2-35
Alignment of Parallel Lines 2-36
Drawing Parallel Lines 2-35
Drawing Polygons and Polylines With Parallel Lines 2-39
Dynamic Editing of Parallel Polygons and Polylines 2-40
Editing a Pair of Parallel Lines 2-36
Line Joints 2-43
Miter Joints 2-44
parallel lines 2-35
Paste 5-2, 5-3, A-2
Pen Color 3-3, 3-12, 3-19
pen model 1-29
Pen Pattern 3-32
Pen Styles
Round 3-35
Pencil Tool 3-24
Pentagons 2-33
Perimeter 9-8
perpendicular dimension 4-29
Perpendicular Dimension Objects 4-35
Perpendicular Dimensions 4-35
PICT 1-20, 8-10
Picture Backgrounds 3-58
Opaque 3-59
pixel maps
Resize 2-85
Places 6-19
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Play button 7-31
Pointer Mode 1-44
polygon 2-75
Polygon Drawing 2-28
Polygons 2-1
changing the shape of a polygon 2-31
constrained drawing mode 2-31
hexagons 2-33
octagons 2-33
pentagons 2-33
polylines
changing the shape of a polyline 2-31
regular polygons 2-33
triangles 2-33
using minor edit handles 2-32
polygons 2-28
polyline 2-75
polylines 2-28
Pop-UpMenus 1-34
Position Command 5-7
PREFERENCE MENU A-5
Print A-2, A-13
Print Report 9-11
Print Report To 9-12
Print Specia 7-32
Print Special A-2
Printing 8-1
Printing in Reverse Order 8-6
PrintingSlides 7-31, 8-12

Q
Quit 1-28

R
R, D Symbol 4-26
Radial Dimension Objects 4-37
Radial Dimensions 4-37
Radial dimensions 4-16
radius dimension 4-38
radius or diameter symbo 4-26
Rectangle Drawing 2-4
Rectangles 2-1, 2-4
Rectangle Drawing Modes 2-4
square-corner rectangles 2-4, 2-5

Index

11

drawing a rectangle from its corner 2-5
square-corner rectangle pop-up menu 2-4
square-corner rectangle tool 2-5
Redo 2-126
Reduced to Fit 7-32
reference points 4-29
Regular polygons 2-33
hexagons 2-33
octagons 2-33
pentagons 2-33
triangles 2-33
regular text 4-1
Rename 7-5
Renaming a Report 9-18
Renaming Layers 7-17
Repeated Paste 5-3, 7-13, A-3
Replace 5-48
Report Formats 9-2
Report from Another Drawing 9-18
Reports 9-1
Report’s Appearance 9-13
Reshape 2-73, A-4
Resize 2-79
bitmaps 2-85
pixel maps 2-85
Resizing Bitmap Images 8-10
Resizing Groups 5-26
Reverse Order 8-6
Reversing Changes 2-125
Revert 2-127, A-1
Revert to Standard 4-23
rotated text 4-6
Rotation Units 6-21
Round Off 4-25
Rulers 6-6
Rulers’ Zero Points 6-7

S
Save A-1
Save As A-1
Saving 1-14
Scale 2-1, 3-17, 4-14
scale for each layer 7-25
Scale Rulers 6-6
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Scaled and Unscaled Symbols 7-14
scales 6-22
scissors 2-118
Select 1-43
Select All A-3
Select All Text 4-7, A-4
Select Point button 2-81
Select Special 1-51
Selecting All Objects 1-49
Selecting Layers 7-16
Selecting Multiple Objects 1-46
Selecting Objects 1-44
Selecting Text 1-50, 4-4
Selection Using the Shift-Click Method 1-46
Send to Back 5-25
Sending a Layer to the Back 7-23
Set Defaults A-2
Set Grid 6-10
sharp points 2-74
Shift Key B-1
Show Area 4-48
Show Size 6-1
Show Size With Drawing Tools 6-1
Show Size With Rotation 6-5
Showing and Hiding Fills 3-14
Single 4-28
single dimensions 4-28
Size
size units
hiding metric units 6-21
Size Units 1-4, 6-16
Slide Shows 7-27
Slide shows 7-27
slope dimension 4-29
Slope Dimension Objects 4-34
Slope Dimensions 4-34
Smooth 2-74
Snap 6-10
Snap to Object 6-16
Snapping Edges and Lines Along Their Lengths 6-12
Software Requirements 1-1
Space Bar B-3
Special Line Tools 2-50
Special Usage of Keys B-1
spline 2-65

Index

13

Spline Curves 2-65
Standard Rulers 6-6
Standards 4-18
Stationery 1-16
Subtract Tool 2-110
symbol libraries 7-1
Symbol’s Object Information 7-6

T
Tag Image File Format C-1
Tangent
between objects
drawing a tangent between objects 2-57
choosing a method for drawing tangents 2-52
to a point 2-52
tangent lines 2-52
text 4-1
text attributes 4-10
Text Centered 4-25
Text Display 4-25
Text Framed 4-25
Text Gap 4-21
text labels 9-14
The purpose of the PC Draft User Guide is to provi
TIFF File Loading C-1
title format 4-10
Tol. 1, Tol. 2 4-26
Tolerance 4-26
Tolerance Space Scale 4-22
Tolerance Text 4-22
tolerances 4-26
Triangles 2-33
Trim 2-118
Trim Function 2-118

U
Unconstrained diagonal lines
unconstrained diagonal line tool 2-1
Unconstrained Editing 2-14, 2-28
Unconstrained lines 2-3
drawing an unconstrained line 2-3
Undo 2-125
Undo/Redo A-2
Unglue 2-106
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Ungrouping Objects 5-28
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What's New?
New Features
PC Draft & MacDraft File Compatibility
PC Draft now includes the ability to save a MacDraft (.md60) document, that will
allow you to share the designs you have created in PC Draft with someone else
who is using MacDraft. What’s more, is that they can then make edits and save
the file on the Mac, send it back to you and you can reopen it in PC Draft. This
allows you to share and collaborate with all your deigns no matter what version of
the software is being used.

PC Draft
MacDraft
By default PC Draft will save your new documents in the new .md60 format,
however rest assured that your old PC Draft .mdd files are still compatible. Use
the Open or Save As features to take a look at all of PC Draft's file compatibilities.
Updated Interface
PC Draft underwent an interface change for version 6.0 and offers a ribbon system
which holds all of the tools and options you need to use the application. As well
as the ribbon system, PC Draft uses a document tab system, centered document
window, scroll bars, rulers and the familiar palettes from previous versions. All of
PC Draft 6 Addendum
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these features will be what you see when you first launch PC Draft so lets look at
these new features in a bit more detail.
The Ribbon

The revolutionary ribbon system helps you get the most out of the PC Draft
application. The very top of the ribbon shows, the file information and below that
are the titles for the different tabs that can be accessed along the ribbon. 'File' will
be selected by default when you first open the application.
Clicking any of the tabs will reveal a sub menu with many options and tools
below it.
Top Tip - Familiarise yourself with the tab system so you can work out the best way to
tackle your next design project

The File Tab

New Document : Creates a new document, adding a
new document tab to the bottom of the application.

Open : The open dialog appears and allows you to
select and open an existing document.
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Load Layer : Allows you to load particuar layers
from an existing document into the current
document.

Open Recent : Selecting this will populate a list of
your recently saved documents, allowing you to
open one.

Save : Saves the current state of the document.
If this is the first time you are saving you will be
prompted to name the file.

Save As : Saves the file but as a copy, allowing you
to change the file name and/or file type.

Revert : You can eliminate any unsaved changes
by reverting back to the last saved version of the
current document.

Import Image : Allows you to import an image into
the active document.

PC Draft 6 Addendum
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Export Report : If you have created a report you can
export it as a text file.

Export File : Allows you to export an image of your
active document.

Set Defaults : Set the document and application
defaults. Here you can change default fonts, colors
and behaviors for your document and PC Draft.

Page Setup : Change the paper size and orientation
of your document.

Print : Print your document from screen to
paper.

Print Special : You can choose to print just the active
layer or to print your drawing as slides.
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Quit : Closes all documents (prompting you to save
if necessary) and closes PC Draft.
The Edit Tab

The Edit tab is used to change details of a shape or line such as making it bigger
or smaller, creating copies or applying attributes.
Paste Options : Pastes the object, image or text
from the clipboard. Choose to paste unscaled or use
repeated paste to paste more copies.
Cut, Copy & Paste : All 3 of these options are
separate buttons. Cut will remove the selected item
from the document and add it to the clipboard. Copy
will copy the selected item to the clipboard leaving
the original intact and Paste will paste the item
currently on the clipboard into the document
Clear : Clears all objects, images and text from your
clipboard.

Copy Attributes : Copies the stroke and fill settings
of the selected object

PC Draft 6 Addendum
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Apply Attributes : Applies the attributes copied
(using copy attributes) to the selected object.

Attribute Options : Allows you to select which
attributes you would like to copy and apply using
the Copy Attributes and Apply Attributes tools.

Duplicate : Creates a duplicate of the selected
object, image or text slightly offset from the
original.

Linear Duplication : Used to create a number
of duplicates of the selected object in a linear
arrangement.

Circular Duplication : Used to create a number
of duplicates of the selected object in a circular
arrangement.

Select All : Selects all unlocked objects, text and
images in the active layer.
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Select None : Deselects all currently selected
objects, text and images in the active layer

Select Special : Define specific characteristics you
want to select E.g. Set Object Fill to Red to select all
objects in the active layer that have a red fill.

Move : Lets you set exact coordinates to move the
selected object to.

Expand : Allows you to increase the X & Y
dimensions of the selected object

Contract : Allows you to decrease the X & Y
dimensions of the selected object.

Reshape : Smooth or Unsmooth freehand lines.

PC Draft 6 Addendum
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Edit Datum : Edit the datum point of the
selected object.

The Text Tab

The Text Tab is used for, you guessed it, editing and arranging your text. These
options can be used within a single text box or across multiple text boxes.
Font Select : Change the font of the selected
text.

Justification Left : Justifies the selected text to
the left.of its text box.

Justification Center : Justifies the selected text
to the center of its text box.

Justification Right : Justifies the selected text
to the right of its text box..
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Vertical Positon Top : Vertically aligns the
selected text to the top of the text box.

Vertical Position Middle : Vertically aligns the
selected text to the Middle of the text box.

Vertical Position Bottom : Vertically aligns the
selected text to the Bottom of the text box.

Line Spacing Single : Sets the space between
the lines of the selected text as single.

Line Spacing 1.5 : Sets the space between the
lines of the selected text as 1.5.

Line Spacing Double : Sets the space between
the lines of the selected text as double.

PC Draft 6 Addendum
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Upper Case : Sets all characters in the selected
text to UPPER CASE.

Lower Case : Sets all characters in the selected
text to lower case.

Title Case : Sets the first character of each
sentence to Upper Case.

Lower Case : Sets all characters in the selected
text to lower case.

Hide Text : Hides all text on the active layer.
Click again to show the hidden text.

The Options Tab
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Border Positon Inside : Sets the drawing
position of the selected object as inside.

Border Position Center : Sets the drawing
position of the selected object as center.

Border Position Outside : Sets the drawing
position of the selected object as outside.

Blade Pen Style : Sets the pen style for lines
and objects as blade (straight edges).

Round Pen Style : Sets the pen style for lines
and objects as rounded (round edges).

Zoom Line Weights : Magnifies line weights in
proportion to the current zoom factor.

PC Draft 6 Addendum
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Hide/Show Line Styles : Hide or Show line
styles such as dashed lines.

Edit Line Styles : Allows you to edit an
existing line style to make a custom line style.

New Color : Allows you to create a new color.
It will be added to the color swatch in the
properties tab.

New Gradient : Allows you to create a new
gradient. It will be added to the gradient/
pattern swatch in the properties tab.

New Pattern : Allows you to create a new
pattern. It will be added to the gradient/pattern
swatch in the properties tab.

Edit Colors : Change a color. That color will
be updated in the swatch in the propeties tab.
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Edit Patt/Grad : Change an existing pattern
or gradient. Patterns and gradients will be
updated in the properties tab.

Duplicate Patt/Grad : Duplicate an existing
pattern or gradient. Patterns and gradients will
be updated in the properties tab.

Hide/Show Fills : Hide or show fills such as
patterns or gradients.

Cross Cursor : Show or Hide the cross cursor.

Tools Options : Select to view special options
from certain tools such as the regular polygon
tool.

Top Tip - You can also hold down the ALT key when clicking a tool to view its special
options.

PC Draft 6 Addendum
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The Arrange Tab

Bring to Front : Brings the selected object to
the front of the document (on top of all other
objects).

Send to Back : Sends the selected object to
the back of the document (behind all other
objects).

Move Forward : Brings the selected object one
level forward on the document.

Move Back : Sends the selected object one
level back on the document

Group : Groups the selected objects, text and
images together to create a single selection.
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Ungroup : Ungroups the selected grouped
objects, text and images breaking them back
up to their individual selections.

Rotate : Allows you to rotate the selected
object freely.

Rotate to Zero : Rotates an already rotated
object back to its original (zero) position.

Rotate Options : Brings up a dialog showing
advanced rotate options for the selected object.

Flip Horizontal : Flips the selected object
horizontally.

Flip Vertical : Flips the selected object
vertically.

PC Draft 6 Addendum
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Align Bottom edges of selected objects

Align Top edges of selected objects

Align Vertical centers of selected objects

Align Left edges of selected objects

Align Right edges of selected objects

Align Horizontal Centers of selected objects

Distribute objects Horizontally by their center

Distribute objects Horizontally by their datum

Distribute objects Vertically by their center

Distribute objects Vertically by their datum
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Align Again : Use on another object to apply
the same align settings you used a previous
object.

Align Options : Set specific alignment options
E.g. align to grid, for selected objects.

Distribute on Line : Manually draw a line you
want the selected objects to be aligned across.

Lock : Locks the selected object making it
uneditable.

Unlock : Unlocks the locked object making it
editable again.

The Data Tab

PC Draft 6 Addendum
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Edit Field Names : Edit the data field names
(titles) that can be applied to objects.

Edit Object Info : Edit the data fields currently
assigned to the selected object.

Find & Replace : Look for and replace an
object (or object data) with another.

Report Formats : Create, Load, Delete and Edit
reports.

Print Report : Select one of your saved reports
to print.

Update Link : Updates links from report
formats to excel files.
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Break Link : Breaks the link between report
formats and excel files.

The Layout Tab

Set Scale & Units : Choose what scale (1:1)
and units (mm, inches etc) you would like to
use throughout the document.

Set Grid : Change the grid snapping
(increments you snap to) for the active
document.

Set Angle Snap : Change the angle at which
your objects (e.g lines) snap to when drawn.

Hide/Show Rulers : Turn the visibility of the
rulers on or off.
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Scale Rulers : Adjusts the rulers relative to the
scale you have set on the active layer.

Standard Rulers : Shows the stand rulers
relative to your paper size (doesnt take scale
into account).

Snap to Object : Allows you to snap to an
existing objects anchor points when drawing
or moving an object.

Hide/Show Grid Lines : Turns the dotted/
dashed grid lines on and off.

Hide/Show Page Breaks : Turns the lines
which display a break between 2 pages on and
off.

Drawing Size : Allows you to add or remove
pages from the active document.
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Position : Use to adjust the position of all
objects within the drawing space.

The View Tab

Zoom : Allows you to zoom in or out to 2x or
4x zoom level.

Restore Previous Zoom : Reverts back to the
last zoom level you used.

Home View : Restores the zoom level to 1x
and positions the screen to the top left of the
document.

Tool Palette : Shows / Hides the Tool Palette.
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Dimension Palette : Shows/ Hides the
Dimension Palette.

Accessory Palette : Shows/Hides the
Accessory Palette.

Show Size Palette : Shows/Hides the Show
Size Palette.

Library Palette : Shows/Hides the Library
Palette.

Layers Palette : Shows/Hides the Layers
Palette.

The Window Tab
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Hide/Show All Palettes : Allows you to show
or hide all of the currently open palettes.

Tool Palette : Shows/Hides the Tool Palette.

Dimension Palette : Shows/ Hides the
Dimension Palette.

Accessory Palette : Shows/Hides the
Accessory Palette.

Show Size Palette : Shows/Hides the Show
Size Palette.

Library Palette : Shows/Hides the Library
Palette.
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Layers Palette : Shows/Hides the Layers
Palette.

Cascade : Turns the active document tabs
into document windows within the PC Draft
application, the document windows will sit on
top of each other.
Tile : Turns the active document tabs into
document windows within the PC Draft
applilcation, the document windows sit neatly
next to each other in a grid.

Arrange Icons : Arranges minimized document
windows neatly at the bottom of the PC Draft
main window.
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The Properties Tab

Fill Color/Pattern: The first pop up allows you to change the
fill color or pattern of the selected object. The second pop up
allows you to change the opacity.

Parallel Line Fill/Pattern : The first pop up allows you to
change the fill color or pattern of the selected parallel line
object. The second pop up allows you to change the opacity.

Stroke : The first pop up allows you to change the stroke (line)
color or pattern of the selected object or text. The second pop
up allows you to change the opacity.
Line Weight : Adjust the thickness of
your lines.
Line Style : Change the style of your
lines from solid to dashed.
End Marks : Apply end marks such
as arrow heads to your lines.
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Absolute : Use to edit the desired
dimensions of the selected object
Relative : Use to add a desired
value to the existing dimensions of
the selected object
Width/Height : Use to edit the width
and height of the selected object, note
that this option only appears if you have
an object selected in the document.
X Y Position : Use to edit the X/Y
coordinates (position) of the selected
object, note that this option only
appears if you have an object selected
in the document.

26

PC Draft 6 Addendum

The Centered Document

A

The PC Draft document is centered on your screen with a grey zone around it.
Having the document centered in the window gives you much more control over
its content and the positioning of objects on the art board. Zooming is also much
easier to control when working with complex drawings.

Document Tabs
When you create a new document in PC Draft it will be displayed as a tab across
the bottom of the application window.
The tab shows vital information for the document it represents. It shows the
Document Name (Tutorial),
the currently selected Layer
(Layer-1) and the scale of
that Layer (1:50). This can
be seen in the image below.
Top Tip - The Document name will be "Untitled-X" until it has been saved as something
different
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Custom Scales
You’ll find a whole set of useful default scales to use, in both English and Metric
units under the Layout Tab via 'Set Scale & Units'.

You can use 1:1, 1:50, 1/4 inch = 1 foot and many, many more. All of which have
been created to help standardize your drawings. If you can’t find the scale you are
looking for from the default list, you could always create your own custom scale.
Any new scale you create will be added to the bottom of the list of default scales.
All custom scales can be used to control the whole document or individual layers
for added flexibility.
To create a custom scale:
1. Select the Layout Tab
2. Click the Set Scale & Units button
3. The Scale & Units Dialog appears

Create a custom scale here >
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5. Click Apply
6. Click OK to close the dialog

Increased Drawing Size
We have increased the maximum drawing size of PC Draft to bring it in line
with the Mac version (MacDraft). The new maximum drawing size is 178 x 178
inches. This gives you full control over more complex and larger designs, making
it easier for you to produce much larger drawings.
To Increase your document drawing size follow the steps below:
1. Click the Layout Tab on the Ribbon
2. Select the “Drawing Size” option
3. The Drawing Size Dialog appears

4. The pages you have selected will be highlighted (black)
5. Click OK once you are happy
Top Tip - You can also change the page numbering here for when you come to print. You
can choose if you want page numbers to be listed vertically or horizontally

PC Draft 6 Addendum
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The maximum drawing size of PC Draft is 178” x 178” or if you are using an A4
paper size 23 pages wide x 17 pages high. Your choice of paper size of course
dictates the amount of pages you will have at your disposal in the Drawing Size
dialog.

Linear & Circular Gradients
Gradients are at the heart of any graphical or vibrant layout. PC Draft now has
support for the creation and management of Linear and Radial gradients. Create
vibrant color blends for use in vector illustration, colorful floor and garden plans
and much more. The gradients can be stored, edited and duplicated making it
easier for you to manage your swatches and share them throughout all your
drawings.

A gradient can be applied as a fill or a stroke and can be applied to objects, lines,
parallel lines and text.
Applying a Gradient
1. Select the object in the document (for example a rectangle)
2. Click on the Properties Tab
3. Click on the Fill icon (the red pop up box below)

4. A selection of colors and fills appear
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Solid Colors >

Patterns >

Gradients >
5. Select a Gradient and your rectangle will now be filled

Creating a New Gradient
Whether you want to create a linear gradient or a radial gradient, they are handled
in the same area of PC Draft.
1. Go to the Options Tab and select 'New Gradient'.
2. The Gradient Dialog appears.
PC Draft 6 Addendum
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Gradient Type

Gradient Preview

Color 1
Apply to
Selected Object
Confirm Gradient

Color 2
Angle of Gradient
Cancel Gradient

Click on the White (Color 1) square and a color picker will appear, choose a new
color and do the same (picking a different color) with the Black (Color 2) square.
You can also click anywhere between Color 1 and Color 2 to add new colors. To
remove a color simply drag it off of the color bar and release the mouse.

You can change the gradient from Linear to Radial at any point using the pop up
option at the top of this dialog. Select Radial and the preview will update.
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You will notice that the 'Rotation' option has disappeared, this is only available on
linear gradients.
At this stage you can click OK to add the gradient to your color options or you
can click Apply to Selected to apply it to the object you selected before creating
this gradient.

New Gradient
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Editing a Gradient
You can edit any of the preset patterns or gradients along with any new ones you
have created too. In the options tab you will see the 'Edit Patt/Grad' button.
1. Go to the Options Tab and select Edit Patt/Grad
2. The fill options dialog appears
3. Select the gradient you want to edit (right)
4. The gradient dialog appears
5. Change the angle of rotation to 45o
6. Change the Left Green Color to Red

7. Click OK
8. Go to the Options Tab and select the Fill icon
34
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Edited Gradient
You will notice that the gradient has changed to show your edits!
Top Tip - Select the Preview button in the gradient dialog to see the gradient change on the
drawing (if the gradient is applied to an object)

Duplicating a Gradient
You might find that you want to create a gradient similar to an
existing one. The best thing to do in this scenario is duplicate the
existing one and edit it. To do this click on the Duplicate Patt/
Grad button on the Options menu and select a gradient.
The gradient dialog will appear loading a copy of the existing gradient. Make
your edits and once you are happy click OK to confirm. The new gradient will be
added to the end of the gradients in the color swatch, the original gradient will
also be there but will not have been edited.

Create New Colors
PC Draft now allows you to create new colors, gradients and patterns. You no
longer have to replace the existing swatches, you can create your own new ones.
In addition, if a color gradient or pattern is attached to an object and stored in the
new Library palette, when you add that item to any document, the new swatch
will be added to that document for use with any object.
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To Create a New Color
1. Go to the Options Tab and select the New Color button
2. The Color Picker will appear

3. Select the Color you want
4. Click OK to confirm
The new color will appear at the end of the solid color options.
To Edit an Existing Color
1. Go to the Options Tab and select the Edit Colors button
2. The PC Draft Color Options will appear

We will edit this one
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4. The Color Picker Appears
5. Change the color and notice the new and original colors in the top left of the
dialog

6. Click OK. You will now see that the original color has been edited.

Original Color

Edited Color

Creating New Patterns
You can create new pixel patterns in PC Draft as well as colors
and gradients. The pixel patterns are repeatable and are created
using a square pixel grid via the Options Tab New Pattern Button.
Go to the Options Tab and Select the New Pattern Button, the
Pattern Dialog will appear. Below is a break down of its features.
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Invert
Fill Pattern

Flip Horizontal

Clear

Flip Vertical
Pencil
Paint Bucket

Preview

Blend
Move/Pan

Grid
Size

Black & White
Color

Scale

Other Color

Revert
Undo

OK

Cancel

Clear : Removes all pixels and leaves you with a blank pattern dialog.
Preview : Shows a small repeatable preview of your pattern.
Grid Size : The pattern grid can be set to 8x8, 16x16 or 32x32 grid squares.
Scale : If the scale box is turned off as the grid size is increased or decreased, the
pattern currently in the preview will be replicated to fill the new area. If the scale
box is turned on as the grid size is increased or decreased the pattern in the preview will remain the same but will be divided into more or less squares.
Revert : Will revert the pattern back to how it was at the start. If you chose New
Pattern it will now be blank, if you are editing an existing pattern it will revert
back to the original pattern.
Fill : Fills the entire pattern with the current color.
Pattern : Loads an existing pattern into the pattern dialog.
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Invert : This inverts the color of all pixels in the pattern. For example all black
will become white and all white will become black. If a color is being used it will
change to a color on the opposite end of the color spectrum.
Flip Horizontal : This is used to flip the pattern in the pattern dialog around the
vertical axis.
Move Vertical : This is used to flip the pattern in the pattern dialog around the
horizontal axis.
Pencil : The Pencil is used to change the color of individual pixels within
the pattern dialog. You can also click and drag to draw as you would with the
freehand tool.
Blend : The Blend tool is used to blend together the current color and the color of
any pixel in the pattern dialog.
Paint Bucket : This is used to fill a section of the pattern dialog. The section filled
will be any corresponding and attached pixel to the one you selected.
Hand : The Hand tool is used to move the pattern within the boundaries of the
pattern dialog.
Black & White : If you have created a colorful pattern, clicking this will change it
to a black and white version of the created pattern.
Color : Allows you to choose a color from the existing color swatch, including
any of your newly created colors.
Other Color : Allows you to choose a new color from the color picker pop up.
Undo : Will go back one step, removing the last action you made in the pattern
dialog.
OK : Confirms the changes and saves the new or edited pattern.
Cancel : Cancels the changes and does not save the new or edited pattern.
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To Create a New Pattern
1. Go to the Options Tab and Select New Pattern
2. Click to place black pixels or click the color option to change your color
3. When you are happy with your pattern click OK

Once the pattern is saved you will be able to see it in the fill options and apply it
to an object.

To Edit an Existing Pattern
1. Go to the Options Tab and Select Edit Pattern
2. Choose the Pattern you wish to Edit

We will edit this one
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4. Make edits however you like, we will add a color to make it obvious

5. When you are happy, click OK to save
The pattern will be saved over the original in the position of the original in the
color swatch.
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To Duplicate a Pattern
If you want to create a new pattern based on an existing one, choose Duplicate
Patt/Grad from the Options Tab.
This will open the Edit Pattern Dialog for you to edit that pattern but will save a
new version of it rather than saving over the original.

Fill & Stroke Opacity
Control all of your fills, strokes and parallel line fills with an opacity, giving you
the ability to create overlays, blends and much more. In addition, you’ll be able to
control the opacity of text elements, giving you more control over how your fonts,
labels and markups are displayed.
Opacity is controlled by a percentage. 0% will make an object translucent (clear)
and 100% will make an object opaque (solid).
Object Fill
Parallel Line Fill

Opacity

Stroke (line) Fill
To Change the Opacity of an Object, simply select it and click the corresponding
Opacity box in the Properties Tab. If you want to edit a Parallel Line use the
Parallel Line Opacity, for the Fill of an object use the Object Fill Opacity and for
the stroke of an object (or a line) use the Stoke (line) Fill Opacity. Clicking any of
them will prompt the Opacity Dialog to appear.
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Use the slider to adjust the opacity of the selected object. The example below
shows different levels of Opacity on a filled circle.

0%

25%

50%

75%

A

100%

The Star Tool
The Star tool allows you to create custom Star shapes in your document, it
also offers options for the control of the attributes within the star such as how
many points and thickness of star. Stars are a great way to create badges, labels,
markups and even arrows if you want to.
To Draw a Star
1. Select the Star Tool from the Tool Palette
2. Click in the drawing and drag the mouse
3. Once you are happy, release the mouse and the default star will be placed

There are also tool options available which allow you to define the number of
sides on your star and the thickness of those points.
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To Draw a Custom Star
1. Select the Star Tool from the Tool Palette
2. With the Tool selected, go to the Options Tab and select 'Tool Options'
3. The Star Tool Dialog appears

4. Change the number of sides and/or star thickness
5. Click OK and the Custom Star will be placed

In addition you can ungroup the drawn star and edit the handles yourself to create
more custom and complex shapes. The star shapes can then be controlled with
color fills and strokes.
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The Library palette allows you to create, store and manage all of your library
items in one place. You no longer have to worry about drawing those commonly
used symbols over and over again, you can simply draw them once and store them
in a custom library catalog. You can then share your custom libraries with other
PC Draft users, allowing you to collaborate with your colleagues, friends and
family with any design. The Library palette works on a drag and drop basis, make
it easier and faster for you to use.
To open the Library Palette, go to the Window tab on the ribbon and select
'Library'. The Library palette will appear.
Close

Libraries

Scroll Bar
Library Items

Options

Zoom
Search

Close : Click this to close the Library Palette
Libraries : This is where your different libraries are saved. Think of them as a
folder full of library items
Library Items : These are the individual items within a Library. Simply drag them
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out of the palette and on to your drawing
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Scroll Bar : If you have more items than can fit in the preview window then you
can scroll up or down to see all items
Options : Click this to bring up the options New Library, Open Library and
Rename Item
Search : Manually type in the name of the library item you want and it will appear
in the preview above
Using the Library Palette
The Library Palette stores your created items. Its use is for you to drag and drop
those items onto your drawing, saving you precious drawing time.
1. Open the Library Palette via the Window Tab on the ribbon
2. Select the Library your item is stored in
(For Example Home Plan Graphics)
3. Scroll to find or search for your item
4. Click to select it
5. Drag it from the library palette to the
document
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To Create a New Library
1. Open the Library Palette via the Window Tab on the ribbon
2. Click on the Options button in the Library Palette
3. Click New Library

4. Name your library and click OK
5. The library (we named it Example) will appear in the Library Palette

You can now add items to your own library.
To Add an Item to your Library
Any item can be added to the library palette, text, lines, shapes and groups.
Top Tip - Group items before adding them to the library. Selecting multiple objects may add
multiple items to the library palette.

1. Open the Library Palette via the Window Tab on the ribbon
2. Select the Library you would like to add an item to
3. Select the item you would like to add to the library
4. Hold the Alt key and drag the item into the preview area of the library
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5. You will see a preview of the item
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6. Release the mouse and the item is now added
7. Select the item within the library (The item will highlight)
8. Click on the Options button and select 'Rename'
9. Name the item

Top Tip - You can also name your items by selecting them and going to Data > Edit Object
Info, this will set your items a name before you add it to the library.
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The Layers Palette
Layers are now managed using a fully functioning Layers palette. You can
create, move, delete and manage all of your layers in one place. In addition you
can choose to use different scales for individual layers. With the all new Layers
palette you will find managing your drawings faster and more efficient, giving
you a single place to control all of your drawing components.

Merge Layers

Layer Options

Locked Layer
Active Layer

Object Count

Layer Visibility
Add New Layer

Layer Scale
Layer Name

Delete Selected Layer

Merge Layers : Use to merge two or more layers of the same scale into a single
layer
Locked Layer : The padlock symbol represents a locked layer, any content on this
layer cannot be edited in any way until activated
Active Layer : The Layer with a Green Tick is the active layer. Any content on
this layer can be freely edited
Layer Visibility : A layer with the eye icon means the content is visible. A layer
with the greyed eye icon means the content is greyed out (outlines only). A layer
with no symbol at all means the content on the layer is completely hidden
Add New Layer : Use to Add a new layer to the active document
Remove Selected Layer : Use to Delete the selected layer from the document
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Layer Options : Use this to access all options. New layer, delete layer, rename
layer, show layer, hide layer, grey layer and merge selection.
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Object Count : Displays the total number of objects on that specific Layer
Layer Scale : Use to change the scale of the selected Layer. A single document
can have many different scales on different layers
Layer Name : This is the name of the layer. Double click the layer name to edit it
Adding & Removing Layers
When you first run PC Draft the Layers Palette will start with a single layer. You
can add more layers using the + symbol at the top of the layers palette. This will
add a single new layer below at the same scale that your document is set to.

To remove an existing layer you must have more than 1 layer available. Select the
layer you want to remove by clicking the layer name. Then click the - button at
the top of the Layers Palette to remove the selected layer.

Showing & Hiding Layers
The point of using layers is to help you differentiate between different parts of a
drawing. PC Draft allows you to show or hide different layers so you can see what
you want, when you want, on the document screen.
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There are 3 different visibility levels for layers;
visible, outlines and hidden. These are represented by the
icon, it will be solid grey,
light grey or hidden respectively. In the image to the right you can see that the first layer
(Floor Plan) is set to outlines, the second (Text)
is visible and the third (Border) is hidden.
Renaming a Layer
When you add a new layer it will automatically name that layer "Layer-X" the
X representing the layer number (Layer-2, Layer-3, etc). There are two different
ways to rename a layer.
•

Double click the name of the layer to initiate the I-Beam cursor and start
typing to change the name.

OR
•

Select the layer and then click the Options button in the top right of the layer
palette. From here, choose 'Rename Layer' and then type to change the name.
Using Scale with Layers
Not only do layers allow you to show and hide different
content on your drawing they also let you work at different
scales on different layers.
Open the Layers Palette via the Window Tab on the ribbon
1.

Add a new layer via the + button

2.

Click in the scale box on Layer-2

3.

Change the scale to 1/4" = 1'

4.

The layer scale will now change

This allows you to keep layer-1 at 1:1 while also allowing
you to create accurate drawings on Layer-2 which you can
rest assured will print correctly on a single sheet of paper.
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Arranging Layers
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Layers can be rearranged into any order simply by clicking and dragging them
above or below a different layer.
Merging Layers
The Merge Layers button at the top left of the layers palette will merge all of the
selected layers into one single layer. This will only work with layers of the same
scale.
1. Select multiple layers of the same scale
2. Click the Merge Layers button
3. Layers will be merged into a single layer called "Merged Layer-1"

Loading Layers from Another Document
PC Draft lets you load a layer (or multiple layers) from an existing PC Draft /
MacDraft document into the active PC Draft document. When you load a layer,
the layer’s contents and scale information are imported to the active PC Draft
Document. To do this, follow the steps below:
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1. Open the document you want to add layers to or create a new document
2. Click Load Layer from the File Tab on the Ribbon
3. The Open dialog will appear
4. Locate and select the file you want to load layers from
5. Click the Open button
6. A dialog box listing the layers in the selected document will appear
7. Select the layer you want to load
8. Click the load button
9. The Layer will now appear in your existing document

Undo & Redo
As of version 6.0 PC Draft boasts an almost unlimited undo tree. Meaning you
can use CMD + Z (undo), CMD + Shift + Z (redo) or the undo buttons next to
the save icon at the top of the ribbon to go backwards and forwards through your
design process.
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