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Welcome to
PC Draft

Introduction

Installing PC
Draft

Hardware and
Software
Requirements

The purpose of the PC Draft User Guide is to provide you with detailed
information about the features and capabilities of PC Draft. The manual is

structured so that you can refer directly to a particular feature and obtain

detailed instructions about its use. Topics in the manual include instructions
on creating, editing, moving, and arranging objects on a drawing.

Before you proceed, you should be comfortable with terms such as click,
drag, select, and choose. You should also be familiar with the general

methods used in most Windows® applications to move, resize, and scroll a

window.

PC Draft is designed to run under Windows® 95 or later and Windows® NT.

Your PC Draft program will run on any PC computer with Pentium®

processor.  PC Draft requires a minimum of 6 MB application memory (free
RAM) to operate, ten megabytes (10 MB) is recommended.  The program

takes up about 10 MB of hard disk space.

You must run PC Draft from a hard disk. The following instructions describe

how to install PC Draft on the hard disk.

To install PC Draft onto your hard disk, follow these steps:

1. Insert the PC Draft Install CD into a CD drive.

2. Find the file icon for the Installer software and double click on
it.  Once the installation program starts, follow its instructions.

The PC Draft program and its supplemental files will be installed where you

specify on your hard disk.

The installer will create a shortcut folder that you can open by selecting the

Start Menu and Programs option.
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The first time you launch PC Draft you must enter a name and valid serial

number to enable the software.

To enable Microspot PC Draft:

1. Double-click on the PC Draft application icon to launch the
software.

2. Enter a name and valid serial number (the organization name
is optional) into the dialog that appears.

3. The serial number must be valid for the version you are using.
This will be supplied with the program or upgrade when
purchased.

4. Only when you have typed in your serial number the OK
button will be available.

Click on this button to open the application.

If you click on the Demo button, the application will run in demo mode and
some of the features and menu options will be disabled.

Enabling
Microspot PC
Draft Personal
Edition
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The Help menu is used to open the PC Draft manual, product registration

and upgrade information.

The PC Draft Manual in pdf format will be included on disk with the

application. The manual will be installed on your hard drive during the
installation process.

Choose PC Draft Manual from the Help menu and Acrobat Reader will

launch and open the manual. You can then navigate through and read the
manual on screen or print sections for your reference.

The Help Menu
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Setting the Size
Units

Getting Started
with a Drawing

PC Draft’s greatest strength as a drafting and design tool is the way it

enables you to define your drawing environment. Using simple menu
commands and palette choices, you can specify the default scale, drawing

units, and page setup you need for the drawing.

The scaled environment automatically keeps track of the size and area of the

objects you draw. You can display their dimensions using the Show Size

feature (see Chapter 6), the various dimension tools (see Chapter 4), or the
onscreen rulers (see Chapter 6).

With PC Draft you can draw using either English units (feet and inches) or
metric units. PC Draft offers the most commonly used English-unit metric

scales. Once you choose a unit system for your drawing, you can define the

scale you want to use.

To set the units for a drawing:

1. Open the Layout menu and choose Set Scale/Units.

The Document Scale & Units dialog box will appear.

2. Click on the English or Metric radio button, depending on the
type of units you want to use in the document.

Whether you use the English or Metric system, you can choose the basic

units for the drawing: Decimal Inches, Decimal Feet & Inches, Decimal

Feet, Fractional Inches, or Fractional Feet & Inches in English drawings;
and Millimeters, Centimeters, Decimeters, or Meters in Metric drawings
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3. If necessary, change the units in the Units pop-out menu.

NOTE: In metric drawings, you can choose “Hide Metric Units,” which
will prevent the unit abbreviations (“mm,” “cm,” and so on) from appearing

when dimensions are displayed on the drawing. You can also control the

number of places displayed behind the decimal point in both metric and
English decimal drawings; see Chapter 4 for more information.

Before starting a drawing, you need to determine the sizes of the objects and

the paper you are going to use. For large drawings it is impractical to draw
objects at their actual sizes; it is necessary to reduce them, yet still maintain

their proper proportions.

A scale, the ratio of the object’s size on the drawing to its size in the real

world, accomplishes this. For example, if you choose a scale ratio of one-

quarter inch equals a foot (1/4" = 1'), a line drawn ten inches long on a

Setting the Scale
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Setting the
Drawing Size
and Layout

drawing would represent a 40-foot line in the real world.

NOTE: When you paste an existing object into a drawing with a different

scale, the object will automatically adjust in size to conform to the scale of

the new drawing.

To specify the default scale:

1. Make sure the Document Scale & Units dialog box is open.

2. Point on the combo box beside the label, Default Scale.

3. Press the left mouse button.

The Scale pop-up menu will appear, displaying the scales available for the
chosen unit system.

4. Click the wanted scale to choose it.

The new scale will be displayed in the Default Scale combo box.

5. Click on the OK button to close the dialog box and apply the
changes.

Depending on your needs, you can set a drawing’s page size, page
orientation, and total size. Page size is simply the size of the paper you will

be printing, and orientation is whether each page is printed vertically or

horizontally.

If necessary, you can create a drawing that will print over several sheets of

paper. The maximum drawing size is approximately 17 x 17 inches (43.18x
43.18 cms), depending on which page size and orientation you choose.

The choice of page size is subject to the page sizes available with the
currently active printer or printing device; for example, if the printer you’ve

selected only supports letter-size and legal-size paper, you cannot print to

larger or smaller sheets. (See Chapter 8 for more information.)
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To set your drawing’s page size and orientation:

1. Choose the File menu’s Page Setup command.

The Page Setup dialog box will appear.

2. Select the paper size you want for printing your drawing.

3. Select the page orientation (horizontal or vertical) you want for
printing your drawing.

4. Click the OK button.

The Page Setup dialog box will disappear. Your drawing will now have the

desired page size and orientation assigned.

To set the size of your drawing:

1. Open the Layout menu and choose Drawing Size.
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A dialog box will appear, displaying the current total drawing size in the

form of a block diagram.

This diagram represents the maximum drawing size available; each block

represents a single page. The blocks that are darkened indicate the current
drawing size. You can control the overall size and shape of the drawing by

clicking in the diagram.

To change the drawing size:

2. Position the tip of the pointer on one of the activated page
blocks and press the left mouse button.

3. Holding down the left mouse button, drag until you have
activated the number of page blocks required for the drawing
size you want.

4. Release the left mouse button.

5. Click the OK button.

The PC Draft drawing window generally shows only a portion of the

overall drawing. Therefore, when you change the drawing size it might not

be noticeable in the window until you zoom out or scroll to another area of
the drawing (see Chapter 2 for information about scrolling and zooming).



Getting Started With PC Draft 1 - 9

Rulers and the
“Crosshair”

PC Draft’s onscreen rulers can help you draw and position objects in precise

locations on your drawing. They appear along the top and left sides of the
drawing window, and reflect the current position of the window during

scrolling. At magnified views (zoomed in or out), they change size

accordingly.

The rulers are especially useful in conjunction with PC Draft’s “crosshair”

drawing cursor. This looks like a large pair of crosshairs that extend
horizontally and vertically across the window, into the rulers, when a

drawing tool is active.

The rulers can show either on-screen sizes (Standard Rulers) or values that
match the current scale and units. For example, on a 1/8" = 1' scale, the

major scale ruler divisions will be in increments of eight (8 ft., 16 ft., and so

on).

To display PC Draft’s rulers:

• Open the Layout menu and choose Show Rulers.

The rulers will be displayed, and a check mark will appear by the Show

Rulers command in the Layout menu.
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Starting a
Drawing

To Create a New
Document

To Create
Multiple New
Documents

Document
Handling

To display scale rulers (if Show Rulers is checked):

• Open the Layout menu and choose Scale Rulers.

To display standard rulers:

• Open the Layout menu and choose Standard Rulers.

To activate the crosshair cursor:

• Choose Cross Cursor from the Preference menu.

The cursor will now appear, when a drawing tool is selected, as a large pair
of crosshairs. A checkmark will appear by the Cross Cursor command in the

View menu.

With these settings in place, you’re ready to start drawing in earnest. The

settings you defined—units, scale, page setup, drawing size, rulers, and

drawing cursor—will remain active until you change them.

For details on using PC Draft’s drawing tools, see Chapter 2 (basic

drawing), Chapter 3 (changing the appearance of objects), and Chapter 4
(annotation, including text objects and dimension objects).

• Open PC Draft from the Start Menu.

In a few seconds a new untitled document will open on the desktop. You will

be able to name this document the first time you save it.

1. Open the File menu and choose the New command.

Once you have made your choice, a new untitled document will appear in

front of any opened documents. Each time you choose “New,” a new untitled

document will be opened. Change the window sizes and positions as you
need to. To activate any opened document, just click on it.

You can find  it from the Explorer.  Right click on Start Menu and left click
Explorer Option.  As soon as you find the document on the right side,  double

click it.

To Find an
Existing
Document



Getting Started With PC Draft 1 - 11

1. Choose Open from the File menu.
A dialog box will appear listing all PC Draft-compatible documents in the
current directory.

2. Select the title of the document you want to open by clicking on
it.

3. Click the Open button in the dialog box.

In a few seconds the document will be open and ready for you to use.

The available types of documents that may be opened by current version of

PC Draft are listed below:
 - PC Draft/MacDraft Drawings (*.mdd)
 - PC Draft v.4.x Drawings (*.drf)
 - PC Draft Symbol Libraries (*.dsy)
 - PC Draft Stationeries (*.drs)
 - PC Draft 1.0 (WinDraft) Drawings (*.dft)
 - Windows Bitmaps (*.bmp)

The Save function allows you to save a new document or any changes you

have made to an existing document. You can save a copy of the whole

document onto the disk you are using, or onto any other disk you might want
to use for storage.

Using Open
From the File
Menu

Saving a
Document
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When you first create a new document, it will have the name “Untitled-#,”
where “#” is the number of new documents you’ve opened since starting PC

Draft.

To name and save the document:

1. Open the File menu and choose Save or Save As.

The Save dialog box will appear.

2. Type a name for the new document.

You may use any character or symbol on the keyboard. You can also use

uppercase or lowercase characters, with spaces between words.

3. Click the Save button.

If there is not enough room on the disk to save your document, a message will
appear informing you that the disk is full. To save the document onto a floppy

disk if that happens, eject the current floppy disk (if any), insert a new one,

then click the Save button. To save the document onto another disk, select the
location next to Save in until the name of the volume you want is displayed,

then click the Save button.

After making changes to a previously saved document, you should save it so

that the document on your disk will contain those changes.

Saving and
Naming an
Untitled
Document

Saving Changes
Made to a
Previously Saved
Document
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To save changes made to a previously saved document:

• Open the File menu and choose Save.

Once you have done so, the document on the disk will be updated to
incorporate the changes.

If you want to save a document onto a different disk, or if you want to make a
document available for someone else, you may want to save it onto another

disk.

1. Open the File menu and choose Save As.

A dialog box will appear. The dialog box will display the

PC Draft document titles and the name of the current directory.

2. Insert the disk on which you want to save the document into the
floppy disk drive. (If you want to save your document on a file
server or another hard disk, go on to the next step.)

3. Use the directory list to open the disk and folder in which you
want to save the document.

4. Type a new name for the document if you want it to be saved
under a different name; otherwise it will be saved under the old
name.

5. Click the Save button in the dialog box.

By using the Save As command you can modify an existing document and

save it as a new document with a different name, thereby preserving the
original version of that document.

To save a copy of the document:

1. Open the File menu and choose Save As.

A dialog box will appear.

2. Type a name for the new version so that you can distinguish it
from the old version.

Saving a Copy of
the Document

Saving a
Document Onto
a Different Disk

To Save a
Document Onto
a Different Disk:
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 3. Click the Save button.
 The document will then be saved with the new name, along with any changes
that you have made.

PC Draft lets you save stationery files, which act as templates for new
documents. For example, you can create a file containing certain images, text

and settings, then save it as a stationery file. When you open that stationery

file, PC Draft will give you a new untitled drawing containing the images,
text and settings, which you can then embellish as required for a specific

situation.

It’s as if you create a pad of stationery, perhaps featuring a company logo at a

particular scale, then “tear off” sheets of paper to use as the basis for new

drawings.

Settings that are saved in a stationery document include the scale, units, grid

snap, fill patterns and colors in the document.

To save a document as stationery:

1.     Open the File menu and choose Save As.

A dialog box will appear.

2. Click the Save As type combo box.

The Save As type pop-up menu will appear.

3. Choose Stationery.

4. Type a name for the file.

5. Click the Save button.

To “tear off” a piece of stationery to use the defined settings in a new
document:

•  Double-click on

       the stationery icon.

Saving a
Document as
Stationery
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A new untitled document will appear. The new document will contain the
settings and objects defined for the stationery.

Windows®  provides for integration between various software packages.
Information can be transferred between programs using the Copy and Paste
method. For example, you can insert charts into a word-processing program,
or bitmap images into PC Draft. However, the Copy and Paste method is not
always convenient.

To help solve this problem Microsoft® developed a standard file format
called the BMP format. Saving a document in the Windows Bitmap format
allows you more flexibility in transferring images to other software programs
that support the BMP format.
The major benefits of using the BMP format are that it makes it easier to use
graphics with certain page layout programs.

To save a document in the BMP format:

1. Open the File menu and choose Save As.

After you have made your choice, the following dialog box will be displayed:

The default format for a document to be saved in is the PC Draft/MacDraft
format.

Saving a
Document in the
BMP Format
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2. Point on the Save as type combo-box.

The Save as type pop-up menu will appear.

  

3. Choose Windows Bitmap (BMP) format.

4. Click the Save button.

The BMP format icon has a different appearance than a PC Draft drawing

icon. The different icons are to help you distinguish between standard PC
Draft drawings and BMP documents.
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You can  open a PC Draft file saved in the Windows Bitmap format using
Open or Load Layer option from File Menu.

1. Choose Open from the File menu.

The Open dialog appears.

2. Point on the File Format combo box, then press and hold the
mouse button.

The Format pop-up menu will appear.

If you want to view only the Windows Bitmap documents in the current

directory:

3a. Choose Windows Bitmap, then release the mouse button.

If you want to view all the documents in the current directory:

3b. Choose All, then release the mouse button.

4. Choose the needed file from the list.

5. Click the Open button.

PC Draft opens the BMP files as regular raster images.

NOTE: Some other applications, such as many word processors and page

layout products, can open Windows Bitmap files directly.

Many times you may want to close a document you've been workng on, and

open another document without quitting the application and returning to the

desktop.

To close the current document;

1. Choose Close from the File menu.

If the document contains unsaved changes, a dialog box will appear, asking

if you want to save changes made to your document before closing it.

Opening a
Document That
Has Been Saved
in the Windows
Bitmap Format

Closing One
Document and
Opening Another
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2a. Click the Yes button to close the document and save  the
changes.

Or,

2b. Click the No button to close the document without saving  the
changes.

The PC Draft menu bar will appear above an otherwise blank screen.
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The Window menu gives you a quick method for moving to any open
drawing or symbol library.

NOTE: The Window menu will display more Windows items if you have

more than 9 documents opened.

To switch to a different drawing or symbol library:

1. Open the Window menu.

The Window menu will display all currently open PC Draft documents,

with the active (topmost) drawing or library indicated by a checkmark.

The currently active drawing or

library appears in the Window
menu with a checkmark. You

can switch to a different

drawing or library just by
opening the Window menu and

choosing a document name.

The Window
Menu
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• Choose Exit from the File menu.

If the document contains unsaved changes, a dialog box will appear, giving

you the chance to save changes made to your document before exit.

Your options and their results are as follows:

Yes Click on this button to save the changes

before exit.

No Click on this button to exit PC Draft without saving

changes.

Cancel Click on this button to void the Exit command and

return to the current document.

2. Choose the name
of the drawing or
library you want
to work on

The drawing or library you

choose will become active

and will be displayed in
front of the other document

windows.

To Exit PC Draft
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The PC Draft document window allows you to access your document for
viewing, creating, and editing the drawing area. It is designed to offer you a

drawing area with all of the essential features of PC Draft within easy grasp

of your mouse.
When you open the PC Draft application, a screen like the following will be

displayed:

As you can see, the window has several parts to it, and as you read on, each

part will be described in detail. The various elements of the screen, as well as

illustrations and descriptions of the tools within the palette, will also appear
in the pages that follow.

The two small boxes in the lower left-hand   corner of the window are
the Fill and Line Indicators. The Fill Indicator, the box on the left, shows you

the current fill. The current fill is the color, shade of gray, or pattern that will

be used to fill the objects you draw. The Line Indicator, the box on the right,
shows you the current line attributes. The attributes associated with lines and

borders are collectively referred to as the “pen model” or simply, the “pen.”

The pen includes such attributes as line style, line weight, end marks, and pen
color, pattern, or shade of gray. The Line Indicator shows you how these

attributes will be used to draw lines and object borders. (See  Chapter 3 for

more information.)

Fill Indicator box Line Indicator box

Fill and Line
Indicators

The PC Draft
Document
Window
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The drawing area is the part of the PC Draft window that displays dotted line
divisions. These divisions are called grid lines. In English units, the distance

between the grid lines represents one inch; in decimal feet, one tenth of a

foot; and in metric units, one centimeter. You can use the grid lines as visual
aids to assist you in your drawing.

When you create a new document, PC Draft automatically establishes a
document size based on a single sheet of paper for the current output device.

However, you can change the size of your document at any time to

accommodate multiple pages, allowing you to create very large drawings.
For information on how to change the size of your document, refer to the

section titled, “Defining the Drawing Size” in Chapter 8.

When you first open your document, the initial view will be that of the upper-

left corner of the total drawing area (unless you have adjusted the Document

Defaults to display a different region).
The menu bar appears across the top of the screen, and contains the titles of

the PC Draft pull-down menus available for your use.

The menus hold menu items. Most menu items are commands that you can

choose in order to perform various functions on your drawing.

You choose items from menus by clicking and dragging, as in other Windows

applications.

PC Draft uses hierarchical menus: pull-down menus that contain submenus.

The submenus list options associated with particular menu items. For

example, the Border Position submenu in the Preference menu contains
border positions list (see Chapter 3).

A rightward-pointing triangle beside a menu item indicates that more options

related to that menu item are available.
To choose an option from a submenu:

1. Open the pull-down menu that contains the submenu you want
to access.

2. Move to the menu item used to access the submenu.

The Drawing
Area

The Menu Bar

Using
Hierarchical
Menus



Getting Started With PC Draft 1 - 23

A submenu will appear.

3. Move horizontally across the menu item to the submenu.

4. Move down the submenu until the item you want is highlighted.

5. Release the left mouse button.

Certain menu items can be chosen directly from the keyboard without using

the mouse. You can choose these menu items by holding down the Control
key, then pressing the key for the character beside the Control key. For

example, to choose Duplicate (from the Edit menu), you hold down the

Control key and press “D” (uppercase or lowercase) while continuing to hold
down the Control key.

For more information on the various menus and the functions accessed from

them, refer to Appendix A, “Menus and Dialog Boxes.”

Using Keyboard
Control
Equivalents
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PC Draft’s most important tools appear in three floating palettes: the Tool
Palette, the Dimension Palette and the Alignment palette. The Attribute,

Resize and Alignment palettes control various attributes of the objects

created using the other palettes. They are called “floating” palettes because
they can move freely around the screen. They float above the drawing area,

allowing you to draw “beneath” them.

You can move a palette around the screen to place it in convenient locations.

To move a palette:

1. Position the pointer on the top or left part of the palette, or any
other part that doesn’t hold an icon.

2. Press down the left mouse button.

3. Holding the left mouse button down, drag the palette to the
desired location.

4. Release the left mouse button.

You can hide a palette when you no longer need it.

The Palettes

Tool Palette

Dimension
Palette

Resize Palette

Attribute
Palette

Alignment palette

Moving a Palette
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To hide a palette:
• Click on the palette's close box in the  top right corner the

palettes window, or

• Select the palette's name from the Palettes submenu in the
View menu, or

• Select the palette's name from the Window menu, or

• Select the palette's name from the popup menu at the bottom
left of the document window.

The palette will disappear, and the check mark beside the palette's name in

the list will be removed.

To display a palette:

• Select the palette's name from the Palettes submenu in the
View menu, or

• Select the palette's name from the Window menu, or

• Select the palette's name from the popup menu at the bottom
left of the document window.

The palette will appear, and a check mark will appear against its name in

the list. Check marks appear beside the names of palettes that are currently

displayed.

Each palette holds icons that represent certain tools or functions. Some tools
and functions have more than one option associated with them. The options

for each function and tool are accessed by means of a pop-up menu.

Icons used to access pop-up menus have clipped corners (which appear blue

on color monitors). Unlike pull-down menus, which are opened by pressing

on a word in the menu bar, pop-up menus are opened by pressing on an icon
in the palette.

To select an option from a pop-up menu:

Pop-Up Menus

Hiding a Palette

Displaying
Palettes



1 - 26 Getting Started With PC Draft

1. Position the cursor on the appropriate icon in the palette.

2. Press down the left mouse button.

A pop-up menu will appear on the screen.

3. Holding down the mouse button, drag to the menu item that
represents the desired option.

As you drag, the menu items will be highlighted.

4. When the desired menu item is highlighted, release the left
mouse button.

The pop-up menu will disappear, and the tool icon will change to show you
the current option.

The palettes function like boxes of tools that you can use to enter text, draw
different objects and lines, and change objects. To draw any of the objects

associated with the tools, you must first activate (select) the appropriate tool

icon. The tools are represented by icons on the palettes. Many of the tools
have options associated with them. The options are related to either how the

objects are created or to some fundamental differences in the nature of the

objects. For example, the square-corner rectangle options are related to how
you create a rectangle—either from a corner or from its center. On the other

hand, the rounded-corner rectangle options are related to the characteristics

of the rectangles’ corners. That is, you can draw proportional, constant, or

Using the Palette
Tools
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elliptical rounded-corner rectangles.

The drawing icons on the palettes show you the current drawing option, or

“current option,” for each object. When you start out using PC Draft, each

object has a default current option listed on the palette. If you want to change
the current option for an object, you have to make a choice from a pop-up

menu that lists the options associated with the object. (See the above section

on pop-up menus for information about choosing options.)

The icon will become highlighted immediately after you choose it. This

highlighting shows that it is activated and you can proceed to draw the object
associated with the icon.

You can activate other tools on a palette by positioning the pointer on the
icon and clicking the left mouse button. As long as the icon is highlighted,

you will be able to draw the object or perform the action associated with the

tool.

Following are brief descriptions of the tools available on the Tool and

Dimension palettes.
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Tool palette

Pointer tool

Use to move and change the shape of objects, make menu choices and

activate palette functions.

Rotation tool

Use to rotate a selected object.

Selection tool

Use to select objects by drawing a selection rectangle around them.

Hand tool

Use to change the position of a drawing as an alternative to using the scroll

bars.

Pointer tool

Selection tool

Line tool

Square-corner
rectangle tool

Regular polygon tool

Circle tool

Polygon tool

Parallel line tool

90º rotation tool

Zoom tool

Rotation tool

Hand tool

Special line tool

Text tool

Rounded-corner
rectangle tool

Arc tool

Freehand tool

Marker symbol tool

Attribute tool

1:1 tool
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Line tool

Use to draw straight lines at any angle (unconstrained lines) or lines that are

restricted to a certain angle (constrained lines).

Special line tool

Use to draw lines that are perpendicular to, tangent to or offset from some
other object, or lines that start at the mid, end or center point of an existing

object.

Square-corner rectangle tool

Use to draw squares and rectangles with square corners.

Text tool

Use to add text to a drawing or edit existing text.

Regular polygon tool

Use to draw symmetrical objects with from 3 to 16 equal sides, such as

triangles, hexagons, and octagons.

Rounded-corner rectangle tool

Use to draw rounded-corner rectangles or squares.

Circle tool

Use to draw circles by diameter (D), by radius (R) or by three (3) points;

and concentric circles.

Arc tool

Use to draw arcs by radius (R) or three points (3); elliptical arcs (E); and

offset arcs.
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Polygon tool

Use to draw objects with two or more sides.

Freehand tool

Use to draw freehand lines and shapes, including Bezier and spline curves.

Parallel line tool

Use to draw parallel line figures (both single segments and open or closed
parallel polygon figures) and extrudes pairs of lines from straight edges.

Marker symbol tool

Use to draw a standard marker symbol.

90º rotation tool

Use to rotate selected objects by 90º.

Attribute tool

Use to copy and assign object attributes.

Zoom tool

Use to zoom in or out on areas of a drawing.

1:1 tool

Select to return to a single magnification view of the current drawing area.
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Horizontal dimension tool

Use to draw horizontal dimension lines.

Vertical dimension tool

Use to draw vertical dimension lines.

Slope dimension tool

Use to draw sloped dimension lines.

Perpendicular dimension tool

Use to draw dimension lines perpendicular to straight lines and edges.

Diameter dimension tool

Use to draw diameter dimension objects.

Radial dimension tool

Use to draw radial dimension objects.
Circle center mark tool

Dimension
palette

Horizontal dimension

Slope dimension

Diameter dimension

Circle center mark

Vertical dimension

Perpendicular
dimension

Radial dimension

Angular dimension
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Use to draw center mark for circles, arcs and ellipses.

Angular dimension tool

Use to draw angular dimension objects.
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Activating the
Pointer Mode

Selecting Objects

Remember, you must always select an object before you can make any
changes to it. Two fundamental principles of using PC Draft are as follows:

First, you select an item.

Second, you choose what to do to the item you have

selected.

For example, if you want to change the pattern of an object, you first select it,

then choose a command to change it.

You can select a single object which you want to change, or (for some

operations) you can select multiple objects in order to make the same change

to each selected object simultaneously.

Once you have selected an object, small black squares will appear on its

borders or at each end. These squares are called edit handles. For example, a
selected rectangle will have eight edit handles, and a selected line will have

one handle at each endpoint. The following procedures will show you various

ways of selecting objects on your drawing.

Before you can select an object on your drawing, you must first activate the

pointer. The pointer is used to resize, edit, and move objects on a drawing.

To activate the pointer:

1. Position the cursor on the Pointer icon on the palette.

When you move the cursor onto the palette, the cursor will temporarily turn

into the arrow pointer to allow you to select a tool.

2. Click the left mouse button.

You can also return to the pointer mode by clicking on a unused area of the

drawing (except when the Text tool is active).

An object is anything that you have created, including rectangles, circles,

lines, arc, freehand shapes, and text.

Selecting
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1. Return to the pointer mode by clicking on the Pointer icon, or
by clicking on a blank area of your drawing.

2. Position the tip of the pointer on the object.

3. Click the left mouse button. (Handles should appear on the
object.)

1.     Return to the pointer mode.

2. Position the tip of the pointer exactly on the edge of the object.

                 3. Click the left mouse button.

NOTE: If the pointer tip is not exactly on the edge of the object, you might

miss the intended object and accidentally select an object behind the non-
filled object.

1. Return to the pointer mode.

2. Position the tip of the pointer on the line.

3. Click the left mouse button. (An edit handle should now appear
at each end of the line.)

1. Position the pointer on the hidden object’s estimated location.

2. Click the left mouse button twice (once to select the front object,
and then once again to select the object hidden behind it).

To Select a Non-
Filled Object

To Select a Line

To Select Objects
Hidden Behind
Other Objects

To Select a Filled
(Solid) Object
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You should now see the handles of the hidden object showing through the

object in front of it, as shown in the following figure.

  

There are two ways to select multiple objects. If you want to select objects

that are far apart (or that are separated by other objects you don’t want to

select), you can use the Shift-click selection method. If you wanted to select
objects that are close together, you can use the selection rectangle to select

them.

1. Return to the pointer mode.

2. Select the first object by clicking on it.

3. Press and hold the Shift key down.

4. Select the other objects you want by clicking on them.

5. Release the Shift key.

You can also use the Shift-click method to deselect selected objects. This

capability allows you to exclude a specific object from a selection without

deselecting all the selected objects.

To Select Objects
That Are Far
Apart—Selection
Using the Shift-
Click Method

Selecting
Multiple Objects

Deselecting
Objects with the
Shift-Click
Method

Once the handles appear, you can move the
hidden object, or you can choose “Bring To

Front” from the Arrange menu to make it appear

in front of other objects.
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To deselect an object:

1. Return to the pointer mode.

2. Press and hold down the Shift key.

3. Click on the object you want to deselect.

4. Release the Shift key.

The edit handles will no longer appear on the object you Shift-clicked on.

This shows that the object is no longer selected.

The selection box is used to select multiple items on a drawing. The selection

box appears when you press down the left mouse button (while in the pointer
mode) and drag.

To select objects using the selection box:

1. Return to the pointer mode.

2. Position the pointer above and to the left (for example) of the
objects to be selected.

 

3. Press and hold down the left mouse button.

4. Drag diagonally across until you have enclosed all the objects
you want to select in the selection box.

To Select
Multiple Objects
Close Together—
Selection Using
the Selection Box
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Notice that the cursor is now a little hand, indicating that the selection box is
active.

5. Release the left mouse button.

NOTE: To select multiple objects that lie within the boundary of a larger,

filled object that is already selected, you must begin the selection box
outside the boundary of the already-selected object.

The select-touching method allows you to select objects by simply bringing
the selection box in contact with each object.

To select objects using the select-touching method:

1. Return to the pointer mode.

2. Position the pointer above and to the left (for example) of  all the
objects that you want to select.

Using the Select-
Touching
Method
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 3. Press and hold down the Alt key.

4. Press and hold down the left mouse button.

5. Drag diagonally across until you have created a box that
touches all the objects to be selected.

Notice that the hand now has a little symbol above it, indicating that Select/
Touching is active.

6. Release the left mouse button and the Alt key.

NOTE: To select multiple objects that lie within the boundary of a larger,

filled object that is already selected, you must begin the selection box
outside the boundary of the already-selected object.

To select all objects on the drawing:

• Open the Edit menu and choose Select All.

Notice that all objects and text on the drawing are selected.  If you choose

Select All while you are in the text mode and have an insertion point selected

in a text block, the entire text block will be selected.

Selecting All
Objects on the
Drawing
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The two techniques for selecting text are using the I-beam pointer (the text
cursor) to select all or part of a piece of text, and using the arrow pointer to

select a whole text object. The steps for each are outlined below:

Using the I-beam Pointer to Select Text

1. Activate the Text icon in the palette by clicking on it.

2. Position the I-beam pointer on either side of the text you want to
select.

3. Press and hold down the left mouse button.

         

4. Drag the cursor through the character(s) until all the text you
want to select is highlighted.

See Chapter 4 for more information on selecting text using the I-beam
pointer.

Using the Arrow Pointer to Select Text

1. Position the tip of the pointer on a text object.

2. Click the left mouse button.

Notice that edit handles appear around the text.

Selecting Text on
Your Drawing
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The Export File command in the File menu can be used to export files in
any format supported by QuickTime Graphic Exporters, for example JPEG

and BMP formats.

To export files:

1. Select Export File from the File menu.

A standard dialog appears.

2. Select the appropriate file format from the Format popup
menu at the bottom of the dialog.

The relevant extension will be added to the file name and the file will be

exported in that format. See your QuickTime documentation for further
details.

Exporting a
document
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Creating
and Editing
Objects

Fundamentals of
Drawing an
Object

Drawing Lines

When you open a new document in PC Draft, the following characteristics
are preset (unless you use stationery or defaults):

- All rectangles, circles, arcs, polygons, and freehand objects will
be shaded with a white fill (for closed objects) or no fill (for
open objects).

- The document size will be a single sheet of paper.
- All lines and borders of objects will be drawn with a one-pixel,

solid-black line weight.
- Scale will be set at 1:1 (one inch equals one inch).
- Grid lines will be displayed on the drawing area.
- Snap Grid will be turned on.

Any of these conditions can be changed before or after you draw an object.

For more information on these default settings, refer to Chapter 1, and the

sections “Using the Scale Function” and “Determining the Size of Your

Document” in Chapter 6.

To draw any object, you must be in a drawing mode. To enter a drawing

mode, you must first activate the icon in the Tool palette that identifies the
drawing tool that you want to use. The drawing procedure for most objects

is very similar: activate the tool, decide on a starting point, press down the
left mouse button, then drag to create the object.

Although the drawing procedures are nearly the same for most objects, the
drawing procedures for polygons, arcs, and curves are somewhat different.

Step-by-step instructions on how to draw and change the size of each type

of object are provided in the following pages.

PC Draft offers you two types of line tools: a constrained line tool and an

unconstrained line tool. When you use the constrained line tool, the line you
draw will snap into alignment at a specified angle. You can use the uncon-

strained line tool to draw a straight line at any angle.

Constrained diagonal lines can drawn be at angles of 5°, 15°, 30°, 45°, and

90°.
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Choosing Line
Tools

To Draw a
Constrained Line

3. While holding down the
mouse button,  drag
until the type of line you
want (unconstrained or
a line constrained to a
certain angle) is high-
lighted.

4. Release the left mouse
button.

You can also constrain the unconstrained line tool to increments of 45° by

holding down the Shift key as you draw.

You choose the line tool you want from the Line pop-up menu on the Tool

palette.

To choose the line tool you want:

1. Point on the Line icon on the Tool palette.

2. Press down the left mouse button.

The Line pop-up menu will appear.

The icon representing your choice will appear on the Tool palette.  If you

choose a line constrained to a certain angle, the chosen angle of constraint
will appear on the palette along with the line icon.

1. Choose the angle of constraint you want from the Line pop-up
menu on the Tool palette.

Notice that the line icon is now highlighted.  This indicates that the tool is

activated.

2. Position the cursor in the drawing area at the point where you
want the line to begin.

3. Press down the left mouse button.
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To Draw an
Unconstrained
Line

4. Holding down the left mouse button, drag until you have
created a line that is the length you want.

5. Release the left mouse button.

The diagram illustrates the results of this operation.

1. Choose the Unconstrained icon (no angle given) from the Line
pop-up menu in the Tool palette.

 

2. Position the cursor where you want the line to begin in the
drawing area.

3. Press down the left mouse button.

4. Holding down the left mouse button, drag in any direction
until you have created a line that is the length you want.

5. Release the left mouse button.
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Choosing a
Method for
Drawing
Square-Corner
Rectangles

Rectangle
Drawing
Modes

Constrained
Drawing Mode

To Change the
Length of a Line

Snapping Along
the Length

If you hold down the Shift key as you are drawing an unconstrained line,

the line will snap at 45-degree angles. This can be useful when you need

one horizontal or vertical line, but don’t want to switch to the 90° line tool.

If you hold the Alt key down as you draw a line, its length will change by

the increment controlled by the Set Grid submenu.

1. Return to the pointer mode.

2. Select the line you want to change.

3. Position the tip of the pointer on one of the line’s handles.

4. Press and hold down the left mouse button.

5. Holding down the left mouse button, drag until the line is the
length you want.

6. Release the left mouse button.

PC Draft allows you to draw rectangles with square, rounded, or elliptical

corners.

PC Draft lets you draw square-corner rectangles in two ways: from the
corner (“Diagonal”), or from the center (“Centered”). You can specify the

method you want to use by making a choice from the Square-Corner

Rectangle pop-up menu.
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Drawing a
Rectangle From
Its Corner

The Square-Corner Rectangle pop-up
menu will appear.

3. Holding down the left mouse
button, drag until either
Diagonal or Centered is
highlighted.

Diagonal activates the tool used to draw a

rectangle from one of its corners.

To choose a method for creating square-corner rectangles:

1. Point on the Square-Corner Rectangle icon on the Tool palette.

2. Press down the left mouse button.

Centered activates the tool used to draw a rectangle from its center.

4. Release the left mouse button.

When you choose the diagonal mode for drawing square-corner rectangles,
you can define the position of one corner of the rectangle, then project the

rest of the rectangle from that corner point.

To create a rectangle from its corner:

1. Choose Diagonal from the Square-Corner Rectangle pop-up
menu.

2. Point where you want one corner of the rectangle to appear on
the drawing.

3. Press down the left mouse button.

4. Holding down the left mouse button, drag in any direction
until you have a rectangle with the size and position you want.

5. Release the left mouse button.
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Drawing a
Rectangle From
Its Center

Constrained
Drawing Mode

Changing the
Size of a
Rectangle

4. Press down the
left mouse button.

5. Holding down the
left mouse button,
drag until the
rectangle is the
size you want.

When you choose Centered from the Square-Corner Rectangle pop-up

menu, you can center rectangles around a specific point on the drawing.

To draw a rectangle from its center:

1. Choose Centered from the Square-Corner Rectangle pop-up
menu.

2. Point where you want the center of the rectangle to appear on
the drawing.

3. Press down the left mouse button.

4. Holding down the left mouse button, drag until you have a
rectangle of the size you want.

5. Release the left mouse button.

If you hold down the Shift key while drawing a rectangle, it will restrict the

shape of the rectangle to a square.

To change the size of a rectangle:

1. Return to the pointer mode.

2. Select the rectangle you want to resize.

3. Position the tip of the pointer on one of the edit handles.

 

6. Release the left mouse button.
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Unconstrained
Editing Mode

Rounded-Corner
and Elliptical-
Corner
Rectangles

About
Proportional-
Size Rounded-
Corner
Rectangles

About Constant-
Size Rounded-
Corner
Rectangles

If you hold down the Control key while editing a rectangle, it will be

released from any active grid snap.

With PC Draft, you can draw rounded-corner rectangles with proportional
(P) or constant (C) corners.  In constant-corner rectangles, the radius of the
corner arcs remains the same regardless of the rectangle’s size.  In propor-

tional-corner rectangles, the radius increases or decreases in proportion to

the rectangle’s size.
You can also draw rectangles with elliptical (E) corners.

You can change the corner style by choosing the style you want from the
Rounded-Corner Rectangle pop-up menu.

When you draw a rounded-corner rectangle, you will probably want the
corners to be proportional to the size of the rectangle.

For example, if you draw a large rectangle with large corners in the con-

stant-corner mode, and you reduce the size of the rectangle, the corners will
become too large in relation to the size of the rectangle.  This may make the

rectangle assume an unwanted elliptical shape.  In the proportional-corner

mode, rounded-corner rectangles will never become distorted, regardless of
size.

When you draw rectangles with constant corners, the corners will always
have the same radius regardless of the size of the rectangle.
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About
Rectangles With
Elliptical
Corners

Choosing a
Rectangle
Corner Style

2. Press down the left mouse
button.

The Rounded-Corner Rectangle pop-up

menu will appear.

When you draw a rectangle with elliptical corners, the major and minor

axes of the elliptical arcs that form the corners are determined by the size of
the rectangle.  Therefore, the size of the elliptical arcs on the corners grows

or shrinks in proportion to the rectangle’s size.

To choose the corner style you want for rounded-corner

rectangles:

1. Point on the Rounded-Corner Rectangle icon on the Tool
palette.

3. Holding down the left mouse button, drag through the menu
until the corner style you want is highlighted.

4. Release the left mouse button.

The character representing the Alt you selected (“P” for proportional, “C”
for constant, or “E” for elliptical) will appear on the palette.
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To Draw a
Rectangle With
the Chosen
Corner Style

Constrained
Drawing Mode

Changing the
Shape of the
Corners on
Rounded-Corner
Rectangles

1. Choose the type of corner you want from the Rounded-Corner
Rectangle pop-up menu.

2. Position the cursor where you want one corner of the rectangle
to appear in your drawing.

3. Press down the left mouse button.

4. Holding down the left mouse button, drag in any direction
until the rectangle is the size you want.

5. Release the left mouse button.

If you hold the Shift key down as you are drawing a rounded-corner

rectangle, it will restrict the shape of the rectangle to a rounded-corner

square.

A selected rounded-corner rectangle has an additional edit handle called the

corner-edit handle, normally inside and near the upper left corner of the
rectangle.  It is used to change the shape of the corners.  With proportional-

and constant-corner rectangles, you can drag the corner-edit handle in a

diagonal direction to change the radius of the corner arc and reshape the
rectangle.

To change the shape of the corners on proportional- and constant-corner
rectangles:

1. Return to the pointer mode.

2. Select the rectangle you want to change.

3. Position the tip of the pointer on the corner-edit handle.

4. Press down the left mouse button.

Notice that as you drag the handles, the corner shape changes.
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Changing the
Shape of
Corners on
Elliptical-Corner
Rectangles

5. Holding down the left mouse
button, drag downward to
the right to increase the
radius of the corners; drag
upward to the left to de-
crease the radius.

6. When the corners are the shape you want, release the left
mouse button.

When you create a rectangle with elliptical corners, the elliptical arcs at the
corners cover 90 degrees.  By dragging the corner-edit handle, you can

change the X- and Y-radius of the arcs that form the corners of the rect-

angle, thereby changing the shape of the corners.  When you reshape the
corners, the arcs will remain 90 degrees.

To reshape the corners:

1. Return to the pointer mode.

2. Select the elliptical-corner rectangle you want to change.

3. Position the tip of the pointer on the corner-edit handle.

4. Press down the left mouse button.

5. Holding down the left mouse button, drag until the corners are
the shape you want.

6. Release the left mouse button.

Unlike in other rectangles with rounded corners, you can drag the corner-
edit handle on elliptical-corner rectangles in any direction. The direction in

which you drag the handle determines the shape of the corners. The figures

below show how you can use the corner-edit handle to reshape the corners.

If you hold down the Control key while editing a rounded-corner rectangle,

it will be released from any active grid snap.
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Circle
Drawing
Modes

To Choose a
Method for
Drawing Circles

If you drag the handle to the extreme upper

left corner, the corners will appear almost
square.

If you drag the handle to the center, the entire
rectangle will appear as an ellipse.

3. Holding down the left
mouse button, drag
through the menu
until the option you
want is highlighted.

4. Release the left mouse
button.

You can draw a circle by its radius, by its diameter, by three points, or as a

concentric offset of an existing circle.  Drawing by diameter is the default
option for circles.

You can specify how you want to create circles by choosing the option you
want from the Circle pop-up menu.

1. Point on the Circle icon in the Tool palette.

2. Press down the left mouse button.

The Circle pop-up menu will appear.

The character representing the method you chose — by radius (R), by

diameter (D), or by three points (3) — will appear in the circle icon on the
palette.
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Changing the
Size of a Circle
Drawn by Radius
or by Diameter

To Draw a
Circle by
Diameter

To Draw
a Circle by
Radius

Constrained
Drawing Mode

5. Release the left mouse button.

1. Choose Diameter from the Circle pop-up menu.

2. Position the cursor where you want to begin drawing the circle.

3. Press down the left mouse button.

4. Holding down the left mouse button, drag until you have
created a circle that is the size you want.

5. Release the left mouse button.

1. Choose Radius from the Circle pop-up menu.

2. Position the cursor where you want the center of the circle to
be in your drawing.

3. Press down the left mouse button.

4. Holding down the left mouse button, drag until you have
created a circle that is the size you want.

If you hold down the Shift key while drawing a circle by radius or diameter,

it will restrict the radius or diameter to horizontal, vertical, or 45-degree
increments.

After you have drawn a circle by radius or by diameter, you can change its

size by dragging one of its edit handles.

To change the size of a circle drawn by radius or by diameter:

1. Return to the pointer mode.

2. Select the circle you want to change.

3. Position the tip of the pointer on one of its handles.

4. Press down the left mouse button.
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To Draw a Circle
by Three Points

Changing the
Size of a Circle
Drawn by Three
Points

5. Release the left mouse
button.

6. Without pressing down
the left mouse button,
move the cursor to the
third point through
which you want the circle
to pass.

5. Holding down the left mouse button, drag the handle until the
circle is the size you want.

6. Release the left mouse button.

You can use the Circle by Three Points tool to draw a circle that passes
through three specific points on your drawing.

To draw a circle by three points:

1. Choose 3 Points from the Circle pop-up menu on the Tool
palette.

2. Position the cursor on the first point through which you want
the circle to pass.

3. Press down the left mouse button.

4. Holding down the left mouse button, drag to the second point
through which you want the circle to pass.

7. Click the left mouse button.

Three edit handles will appear on the circle.  The edit handles correspond to

the three points used to define it.

You can change the size of a circle drawn by three points by moving the

edit handles.

To change the size of a circle drawn by three points:

1. Return to the pointer mode.
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Offset Circles

Unconstrained
Editing Mode

2. Select the circle you want to resize.

3. Point on one of the edit handles.

4. Press down the left mouse button.

5. Holding down the left mouse button, drag until the circle is the
size you want.

6. Release the left mouse button.

When you release the left mouse button, PC Draft will redraw the circle to
pass through the three points represented by the edit handles.

If you hold down the Control key while editing any circle, it will be
released from any active grid snap.

With PC Draft’s Circle Offset tool, you can create new circles, concentric

with existing circles. The offset circle will be of the same type and have the

same line weight, line style, and pen model as the original circle.

Offset circles can be created from any circle. Once drawn, an offset circle is

an independent circle that can be edited, moved, or otherwise manipulated

as required.

NOTE: The “parent” circle for the offset circle must be in place before you

choose the offset circle tool.

Drawing an offset circle from an existing circle requires two steps: selecting

the source circle, then clicking to specify the offset distance.
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1. Choose the Offset Circle
icon from the Circle Tools
pop-up menu.

To draw an offset circle from an existing circle:

The cursor now reads “Click Circle,” to let you know that you need to select

a circle.

2. Click on the circle.

The cursor now reads “Anchor” and appears near a dotted copy of the
source circle, helping you locate the offset.
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Arc Drawing
Modes

To Choose the
Type of Arc You
Want to Draw

3. Move the cursor to the point where you want the offset to lie.

As you move the cursor, the dotted sketching circle gets larger or smaller.

4. Click the left mouse button.

The offset circle is done. The cursor returns to “Click Circle,” enabling you

to create more offsets.

To exit the offset cursor mode, click the Pointer icon in the Tool Palette.

As mentioned earlier, the offset is a circle of the same type as the original.
You can edit or alter it as needed, or even use it as the base for another

offset circle.

With PC Draft you can draw both circular and elliptical arcs.  Circular arcs

specify three points on the drawing through which you want the arc to pass.

With elliptical arcs, you define an ellipse that is a certain size, then project
an elliptical arc that is the length you want.

The arc by radius mode is the default for drawing arcs. You can choose the
type of arc you want to draw by choosing an option from the Arc pop-up

menu on the Tool palette.
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2. Press down the left
mouse button.

The Arc pop-up menu will

appear.

To Draw an Arc
by its Radius

1. Point on the Arc icon on the Tool palette.

3. Holding down the left mouse button, drag through the menu
until the  option you want is highlighted.

4. Release the left mouse button.

The character representing the type of arc you choose, (“R” for arcs by

radius, “3” for arcs by three points, or “E” for elliptical arcs) will appear on

the palette.

NOTE:  When an arc is drawn with a fill, it will appear as an object shaped

like a piece of pie.  To draw the arc line only, you must make sure that no
objects are selected, then choose “N” (for No fill) from the Fill Pattern or

Fill Color submenu before you draw the arc.

1. Choose Radius from the Arc pop-up menu.

2. Position the cursor where you want to begin the radius of the
arc.

3. Press down the left mouse button.



2 - 18 Creating and Editing Objects

Constrained
Drawing Mode

To Change the
Length of an Arc

Changing the
Size of an Arc
Created by its
Radius

4. Holding down the left mouse button, drag in any direction
until you have created a line that represents the radius you
want.

5. Release the left mouse button.

6. Without pressing the left mouse button, move the cursor away
from the end of the radius line until you have created an arc
that is the length you want.

If you drag outside the border of the arc, a leader line extending from the
arc’s border to the cursor will be projected.  This leader line allows you to

align the ending point of the arc with other points on your drawing.

7. Click the left mouse button.

If you hold the Shift key down while you define the arc’s radius, it will

restrict the definition of the arc’s radius to 45-degree increments.

You can change the size of an arc either by changing the length of the

radius, or by changing the length of the arc.  The following steps and
diagrams will show you both methods, as well as their effect on the shape of

the arc.

1. Return to the pointer mode.

2. Select the arc you want to change.

3. Position the tip of the pointer on the small handle in the middle
of the arc’s border.
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To Draw an Arc
by Three Points

4. Press down the left mouse button.

5. Holding down the left mouse button, drag until the arc is the
length you want.

6. Release the left mouse button.

Sometimes, you may not know the length of the radius of an arc, but do

know that the arc passes through three different points in a drawing.  You

can create an arc that passes through the three known points by following
these steps:

1. Choose 3 Points from the Arc pop-up menu.

2. Position the cursor on the first point through which you want
the arc to pass.

3. Press down the left mouse button.
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Changing the
Size of an Arc
Drawn by Three
Points

To Draw an
Elliptical Arc

4. Holding down the left mouse button, drag to the second point.

5. Release the left mouse button.

6. Without pressing the left mouse button, move the cursor to the
third point.

7. Click the left mouse button.

NOTE:  You  cannot create a complete circle using the arc tool.  If you

drag past the beginning of the arc, it will collapse back to a shorter length.

You can change the size of a three-point arc by moving any one of the three

handles that represent the three points originally used to define the arc.

1. Return to the pointer mode.

2. Select the arc you want to resize.

3. Position the tip of the pointer on whichever handle you want to
move.

4. Press down the left mouse button.

5. Holding down the left mouse button, drag the handle to a new
location on the drawing.

6. Release the left mouse button.

NOTE:  You may have trouble drawing extremely shallow arcs because the

length of the radius may become too great.  Likewise, you cannot draw an
arc that is absolutely flat (that is, you cannot use the arc tool to draw a

straight line) because the radius of such an arc would be virtually infinite.

You can use the Elliptical Arc tool to create elliptical arcs of a specific size
and length.  When you create an elliptical arc, you first project an ellipse,

then define an arc representing a portion of the ellipse.  The actual size of

the arc is determined by the size of the ellipse, and the arc’s length is
determined by the number of degrees you project it during creation.
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1. Choose Ellipse from the Arc
pop-up menu.

2. Point on the desired center
point of the ellipse that will be
used to define the arc.

3. Press down the left mouse
button.

4. Holding down the left mouse
button, drag until you have
created an ellipse that is the size
you want.

A line will be attached to the

cursor.  The line will extend from
the center of the ellipse to the

cursor.  This line is used to define

the ending angle of the arc.  If you
drag outside the ellipse, a leader

line extending from the ellipse’s

border to the cursor will be
projected.  This leader line allows

you to align the ending angle of the

arc with other points on your
drawing.

7. Click the left mouse
button.

The elliptical arc will appear on the

screen.

To draw an elliptical arc:

5. Release the left mouse button.

6. Without pressing down the left mouse button, move the cursor
until you have projected an arc that is the length you want.
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Changing the
Starting Angle of
an Elliptical Arc

Changing the
Shape of an
Elliptical Arc

Editing an
Elliptical Arc

Part of the process of defining elliptical arcs involves defining the starting

angle of the arc.  The starting angle’s position is determined by where you
release the left mouse button after you have projected the ellipse used to

define the arc.  Normally, you define the size of the ellipse and the starting

angle of the arc at the same time.  However, by using the Shift key to
constrain the size of the ellipse, you can change the position of the starting

angle without changing the size of the ellipse.

To change the starting angle of the arc:

1. Define the arc as you normally would.  (That is, choose Ellipse
from the Arc pop-up menu, press down on the center point,
and drag to project the ellipse.)

2. When the ellipse is the size you want, without releasing the left
mouse button, hold down the Shift key.

3. Drag the line that marks the starting angle to a new position.

The line marking the starting angle of the arc will follow the cursor’s
movement, but the ellipse will not be resized.

4. Release the left mouse button and the Shift key when the line is
where you want the starting angle of the arc to appear.

5. Continue to define the arc.

There are two ways you can edit an elliptical arc:   you can change its
length, and you can change its shape.  When you change its length, you

either increase or decrease the number of degrees that make up its length.

When you change its shape, you change the major and minor axes of the
arc.

By dragging the edit handle in the middle of the arc’s border, you can
change the arc’s shape without changing its length.

To change the shape of an elliptical arc:

1. Return to the pointer mode.

2. Select the elliptical arc you want to change.
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Changing the
Length of an
Elliptical Arc

3. Position the tip of the pointer on the edit handle located in the
center of the arc’s border.

4. Press down the left mouse button.

5. Holding down the left mouse button, drag until the elliptical
arc is the shape you want.

6. Release the left mouse button.

You can use the edit handles on the end points of an elliptical arc to change
its length

To change the size of an elliptical arc:

1. Return to the pointer mode.

2. Select the elliptical arc you want to resize.

3. Position the tip of the pointer on one of the edit handles located
at the end of arc border.

4. Press down the left mouse button.

5. Holding down the left mouse button, drag the handle until the
ellipse is the size you want.

6. Release the left mouse button.
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Drawing Offset
Arcs

With PC Draft’s Arc Offset tool, you can create new arcs, concentric with

existing circular arcs. The offset arc will be the same type (radial or three-
point) and have the same line weight, line style, and pen model as the

original arc.

Offset arcs can be created from any circular arc. Once drawn, an offset arc
is an independent object that can be edited, moved, or otherwise manipu-

lated as required.

The offset arc will snap to the active grid snap (see Chapter 6) along its

radius. If you want to change the increment, choose a different value from

the Layout menu’s Set Grid submenu.

NOTE: The “parent” arc for the offset arc must be in place before you

choose the offset tool.

Drawing an offset arc from an existing arc requires two steps: selecting the

source arc, then clicking to specify the offset distance.

To draw an offset arc from an existing arc:

1. Choose the  Offset Arc icon from the Arc Tools pop-up menu.
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3. Move the cursor to the
point where you want the
offset to lie.

As you move the cursor, the dotted

sketching arc gets larger or smaller.

The offset arc is done. The cursor

returns to “Click Arc,” enabling you to

create more offsets.

The cursor now reads “Click

Arc”, to let you know that you
need to select an arc.

2. Click on the arc.

The cursor now reads “Anchor” and appears near a dotted copy of the

source arc, helping you locate the offset.

4. Click the left mouse button.
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Ellipse
Drawing
Modes

3. Holding down the left mouse
button, drag until the method you
want is highlighted.

4. Release the left mouse button.

To exit the offset cursor mode, click the Pointer icon in the Tool Palette.

As mentioned earlier, the offset is a normal circular arc of the same type as

the parent arc. You can edit or alter it as needed, or even use it as the base

for another offset arc.

PC Draft lets you draw two types of ellipses:  diagonal and centered.  The
two types of ellipses differ in the way they are created.  You can use the

Ellipse pop-up menu to choose the method you want to use to create

ellipses.

To choose the method you want to use to create an ellipse:

1. Point on the Ellipse icon on the Tool palette.

2. Press down the left mouse button.

The Ellipse pop-up menu will appear.

The icon representing the chosen method will appear inside the Ellipse icon

on the Tool palette.
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Creating
a Centered
Ellipse

Creating
a Diagonal
Ellipse

3. Press down the left
mouse button.

4. Holding down the left
mouse button, drag in
a diagonal direction
until the ellipse is the
size you want.

3. Press down the left
mouse button.

4. Holding down the left
mouse button, drag
until the ellipse is the
size you want.

When you create a diagonal ellipse, the ellipse is projected as you press

down on a starting point and drag to define the extent of the ellipse.  (In
effect, you define a rectangle whose edges are tangent to the ellipse.)

To create a diagonal ellipse:

1. Choose Diagonal from the Ellipse pop-up menu.

2. Point where you want the starting point of the ellipse’s bound-
ing rectangle to appear.

5. Release the left mouse button.

When you create a centered ellipse (an ellipse drawn from its center), you

first define the center point of the ellipse, then its overall size and shape.

The ellipse is projected from the specified center point.

To create a centered ellipse:

1. Choose Centered from the Ellipse pop-up menu.

2. Point where you want the ellipse’s center to appear.

5. Release the left mouse button.
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Constrained
Drawing Mode

Changing the
Size of an Ellipse

Unconstrained
Editing Mode

Polygon
Drawing
Modes

4. Press down the left mouse
button.

5. Holding down the left
mouse button, drag the
handle to a new location
on the drawing.

If you hold the Shift key down while creating an ellipse, it will restrict the

shape of the ellipse to a circle.

When using PC Draft, you change the size of an ellipse using the same

technique you would use to change the size of a rectangle:  dragging one of
the eight edit handles.

To change the size of an ellipse:

1.  Return to the pointer mode.

2.   Select the ellipse you want to resize.

3.  Position the tip of the pointer on one of the edit handles.

6. Release the left mouse button.

 If you hold down the Control key while editing an ellipse, it will be

released from any active grid snap.

You can draw two types of multisided shapes:  closed polygons and open
polylines.

A polygon is a closed object made of three or more sides.  It can be a
complex, irregularly shaped object made up of many straight line segments.

A polyline is an open object made of at least two straight line segments.

The line segments used for either type of object can be any length and
oriented at any angle.

The type of multisided shape you draw depends on the item you choose
from the Polygon pop-up menu.
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3. Holding down the left mouse
button, drag until the Polygon or
Polyline icon is highlighted.

4. Release the left mouse button.

Drawing a
Polygon or a
Polyline

Choosing the
Polygon or the
Polyline Drawing
Mode

To choose the polygon or the polyline mode:

1. Point on the Polygon icon on the Tool palette.

2. Press down the left mouse button.

The Polygon pop-up menu will appear.

To create a polygon or polyline, you merely move to the starting point you

want for the object; press the left mouse button; drag to create the first side;

then release the left mouse button.  Then you move the cursor to the next
point and click.  Continue moving and clicking until you have created the

shape you want for the object.  If you make a mistake as you draw the

polygon, you can easily edit the last side drawn by using the Dynamic
Editing feature, detailed in the next section.

To draw a polygon or a polyline, follow these steps:

1. Choose either Polygon or Polyline from the Polygon pop-up
menu.

2. Place the cursor where you want to begin drawing the object.

3. Press down the left mouse button.

4. Holding down the left mouse button, drag until you have
created a line segment that is the length you want (the first side
of the object).
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5. Release the left mouse button.

6. Without pressing the left mouse
button, move the cursor until the
second line segment is the length
you want.

7. Click the left mouse button.

8.    Without pressing the left mouse
button, move the cursor until the
third line segment is the length you
want.

9. Click the left mouse button.

Sometimes you may decide that you want to

change a line segment after you have clicked

the left mouse button to define its end point.
You can change the length and orientation of

the last line segment drawn by using the

Dynamic Editing feature.

10. If you want to change a line
segment, move the cursor back to
the last defined point and click on
it.

Once you have clicked on this point, the
previous line will reattach to the cursor,

allowing you to move the end of that older line

to a new position on the drawing.

11. Move the cursor to a new position
on the drawing and click the left
mouse button.
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Once you have clicked the left mouse button, the line will be drawn to the

new position, and you can then continue to draw the rest of the object.

12. Move the cursor to the next point, then click the left mouse
button twice quickly.

If you press and hold down the Shift key as you are drawing a polygon or
polyline, the current line segment will snap at 45-degree angles.

If you hold the Alt key down as you draw a polygon or polyline, the current
line segment will change by the increment controlled by the Set Grid

submenu.

Polygons and polylines, like all objects, display handles when they are

selected.  Unlike most objects, though, they have two different kinds of

handles:  major, (the handles on the vertex points or corners) and minor,
(the handles in the middles of the line segments).

This double-click action completes
the object.  If you are drawing a

polygon, PC Draft will automatically

close the object.  The last point you
clicked on will be connected to the

starting point of the polygon by  a

straight line, and the polygon will be
shaded with the current fill.

If you are drawing a polyline object,
however, PC Draft will leave the

object open and selected.

Snapping Along
the Length

Constraining
Line Segments

Changing the
Shape of a
Polygon or a
Polyline
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The major handles are used to move the end points of lines, which could

change both the length and angle of the lines connected to that handle.  The
minor handles are used to move a line segment without changing its length

or angle.

1. Return to the pointer mode.

2. Select the polygon or polyline you want to change.

3.     Position the tip of the pointer on one of the major handles.

4. Press down the left mouse button.

5. Holding down the left mouse button, drag the handle to a new
location on the drawing.

6. Release the left mouse button.

As the following illustration shows, when you move the handle, the

connecting lines will follow.  As soon as you release the left mouse button,
both lines will be redrawn to the new handle location.

1.  Position the tip of the pointer on one of the minor handles.

2. Press down the left mouse button.

Using the Major
Handles

Using the Minor
Handles
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As you drag the minor handle, the line will also move.  By using the minor

handles, you can move a line and still maintain its original length and angle.

If you hold down the Control key while editing a polygon or polyline, the

current handle will be released from any active grid snap.

PC Draft’s Regular Polygon tool allows you to draw closed polygon figures

with sides and angles of equal length. You can preset the tool to draw

figures with from 3 to 16 sides.

The number of sides can be set before drawing the object by holding down

the Alt key while clicking the Regular Polygon tool icon.

To draw a regular polygon:

1. Choose the desired tool from the Regular Polygon pop-up
menu.

Depending on which variation

of the tool you select, you can
draw a regular polygon from

edge to edge or vertex; center

to edge; vertex to vertex or
edge; center to vertex

(corner).

3. Holding down the left
mouse button, drag the
line to a new location.

4. Release the left mouse
button.

Unconstrained
Editing Mode

Drawing a
Regular
Polygon
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Notice that when you release the left mouse button, the polygon is grouped
to itself. If necessary, you can use the Arrange menu’s Ungroup Control to

ungroup the polygon for reshaping, breaking, and so on. Changing fills and

line attributes and resizing can be performed while the object is still
grouped.

If you hold the Shift key down as you are drawing a regular polygon, the
diameter or radius will snap at 45-degree angles.

To set the number of sides before drawing a regular polygon:

1. Make sure that nothing is selected on the drawing.

2. Press and hold down the Alt key.

3. Click on the Regular Polygon icon on the Tool palette.

The Regular Polygon dialog box will appear.

4. Type the number of sides desired, then press the OK button.

2. Press down where you want the
center, edge, or vertex of the
polygon.

3. Holding down the left mouse
button, drag until the polygon
is the size you want.

Optional
Constrained
Drawing Mode

Changing the
number of sides
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PC Draft’s Parallel Lines tool allows you to draw single sets of parallel

lines or polygons and polylines with double lines.  You can use parallel
lines to create drawings of such things as walls, beams, and frames.

There are three Alts associated with parallel lines.  You can use parallel
lines to draw a single set of straight lines, polylines, or polygons.  You

choose the type of shape you want to draw by using the Parallel Lines pop-

up menu.

To choose the type of parallel line shape you want:

1. Point on the Parallel Line icon on the Tool palette.

2. Press down the left mouse button.

The Parallel Line pop-up menu will appear.

4. Release the left mouse button.

An icon representing your choice will appear on the palette.

To draw a single set of parallel line segments:

1. Choose the Single-Line icon from the Parallel Line pop-up
menu.

2. Press down where you want the parallel lines to start.

3. Holding down the left mouse button, drag until the lines are
the length you want.

3. Holding down the left
mouse button, drag
until the type of shape
you want is high-
lighted.

Using Parallel
Lines

Drawing a Pair
of Parallel Lines
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4. Release the left mouse button.

If you hold down the Shift key while drawing a single set of parallel lines or
a polygon or polyline shape with double lines, the lines will snap at 45-

degree angles.

If you hold the Alt key down as you draw a parallel line it will change by

the increment controlled by the Set Grid submenu.

To edit parallel lines:

1. Return to the pointer mode.

2. Select the parallel lines you want.

3. Point on one of the edit handles.

4. Press down the left mouse button.

5. Holding down the left mouse button, drag in any direction
until the lines are the length you want and oriented the way
you want them.

6. Release the left mouse button.

There are three alignment choices for parallel lines:  left, center, and right.
Alignment controls how lines, polylines, and polygons are drawn and how

they can be edited.  Specifically, the alignment option determine what the

leading edge is and what part of the shape is active.  As an example of what
active means, when align left is the current option, the left line will be

drawn on the grid, and edit handles will appear on the left line when the

parallel lines are selected.

Snapping Along
the Length

Constrained
Drawing Mode

Editing a Pair of
Parallel Lines

Specifying the
Alignment of
Parallel Lines
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To choose the alignment option you want to use to create parallel lines:

1. Make sure that nothing is selected on the drawing.

2. Press and hold down the Alt key.

3. Click on the Parallel Lines icon on the Tool palette.

The Parallel Line Setup dialog box will appear.

The alignment option are represented by three icons at the top of the dialog

box.  The small arrow indicates what part of the line is active.

4. Release the Alt key.

5. Click on the icon that represents the option you want.

To change the alignment of existing lines:

1. Select the lines you want to change.

2. Choose the alignment option you want from the Parallel Line
Setup dialog box.
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Align Center

When Align Center is active, the cursor

appears between the lines during creation.
The center of the two lines will lie on the

grid.  When the set of parallel lines is

selected, two edit handles will appear
between the ends of the lines.

Align Left

The Align Left option is used to specify
which of the parallel lines is active.

The active line is the one that lies on the

grid and is used to edit the parallel lines.
If you draw parallel lines while the Align

Left option is active, the active line is

determined by the direction you first drag
during the creation of the shape.  In

general, if you drag up, the left line is

active; if you drag down, the right line is
active.

Align Right

As with Align Left, the Align Right option
determines which of the two lines is

active.  When the Align Right option is

active, the direction in which you first
drag during creation determines which line

is active.  In general, if you drag up, the

right line is active; if you drag down, the
left line is active.

How the
Alignment
option Affect
Parallel Lines
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These general principles apply to polygons and polylines drawn with

parallel lines.  This means that the active line in the object depends on what
the current alignment option is and the direction in which you initially drag

during creation.

The difference between a polygon and a polyline is that a polygon is a

closed object, and a polyline is an open object.  When you draw a polygon

and specify the end of the object, PC Draft automatically closes the object
by drawing two line segments between the starting and ending points.  If

you draw a polyline object, the object will remain open unless you close it

yourself.

 To draw a polygon or a polyline, follow these steps:

1. Make sure that nothing is selected on the drawing.

2. Choose the alignment option you want from the Parallel Lines
Setup dialog box.

3. Choose either Polygon or Polyline from the Parallel Line Setup
pop-up menu.

4. Position the cursor where you want to begin drawing the
object.

5.    Press down the left mouse button.

6. Holding down the left mouse button, drag until you have
created a side that is the length you want.

7. Release the left mouse button.

8.    Without pressing down the left
mouse button, move the cursor
until the second side is the length
you want.

9. Click the left mouse button.

10.  Without pressing the left mouse
       button, move the cursor until the
       third side is the length you want.

Drawing
Polygons and
Polylines
With Parallel
Lines
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By double-clicking the left mouse button, you specify that the object is

complete.

The active alignment option determines how the parallel lines pivot around

each ending point.  When you define the ending point for a side, the end
point of the active line (or the center of the two lines in the case of center

alignment) is used as the ending point of the side.  The inactive line pivots

around the ending point, following the movement of the mouse.

As with normal polygons and polylines, you can edit parallel polygons and

polylines (that is, polygons and polylines drawn with parallel lines) during
creation.

To edit a parallel polygon or polyline during creation:

1. Without pressing down the left mouse button, move the cursor
back to the last vertex point.

An edit handle will appear at the last defined vertex point to help you locate
it.

2. Click the left mouse button.

The line segment will reattach to the cursor, and you can change the length

and angle of the line segment without having to redraw the entire object.

You can continue going back and clicking on previously defined vertex

points to edit the object.

11.  Click the left mouse button
twice.

Dynamic Editing
of Parallel
Polygons and
Polylines
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You can edit parallel polygons and polylines the same way as you would

normal polygons and polylines.  Both parallel polygons and polylines have
major and minor handles.

1. Select the polygon or polyline object you want to change.

2a. Drag one of the major handles to change the lengths and angles
of two sides.

or,

2b. Drag one of the minor handles to change the position of a side
without changing its length and angle.

You can specify the distance between parallel lines either before or after

you draw them.  The values you enter for the distance are real-world values

that reflect the current size units.  For example, suppose you were working
on a document in which Fractional Feet & Inches and the scale 1/4" = 1'

were currently defined.  If you entered “6” as the distance, the distance

between the lines would represent 6 feet in the real world.

To specify the distance between parallel lines before you draw them:

1. Make sure that nothing is selected on the drawing.

2. Alt-click on the Parallel Line icon on the Tool palette.

The Parallel Lines Setup dialog box will appear.

3. Double-click in the text box.

4. Type the distance you want between the lines.

5. Click the OK button.

6. Click on the Parallel Line tool.

7. Draw the parallel lines.

Editing Parallel
Polygons and
Polylines

Specifying the
Distance
Between Parallel
Lines
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Parallel lines drawn without end

caps.

Changing the
Distance
Between Existing
Parallel Lines

Choosing End
Caps for Parallel
Lines

To Draw Parallel
Lines With End
Caps

To change the distance between existing parallel lines:

1. Select the parallel lines you want to change.

2. Specify the distance you want between the lines in the Parallel
Line Setup dialog box.

NOTE:  You can use patterns and colors to fill the gap between parallel

lines.  For instructions on how to do this, see the section titled “Filling the

Gap Between Parallel Lines” in Chapter 3.

You can draw a single set of parallel lines and polylines with butt end caps,

that is, with line segments between the end points of parallel lines.  You can

choose to draw parallel lines with no end caps, with an end cap at either
end, or with end caps at both ends.

1. Make sure that nothing is selected on your drawing.

2. Alt-click on the Parallel Lines icon on the Tool palette.

The Parallel Line Setup dialog box will appear.

3. Click on the icon that represents the end cap option you want.

4. Click on the OK button.

5. Draw parallel lines

The following figures show how the end cap option affect the parallel lines

you draw.
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End caps at the starting end of
the parallel lines.  (That is, the

end at which you pressed down

the left mouse button and started
to draw the lines.)

Changing End
Caps for Existing
Parallel Lines

Drawing a
Parallel Polygon
or Polyline With
a Line Joint

End caps at the starting end of

the parallel lines. (That is, the
end at which you pressed down

the left mouse button and started

to draw the lines.)

End caps at both ends of the

parallel lines. End caps at the

ending points of the lines. (That
is, the end at which you released

the left mouse button and

finished drawing the line.)

To change the end caps on existing parallel lines:

1.  Select the parallel lines you want to change.

2.  Choose the end caps you want from the Parallel Line Setup
dialog box.

You can choose to draw polygons and polyline shapes that have line joints

at the corners. When you choose to draw polygons and polyline shapes with

line joints, PC Draft automatically draws a line between the inside and
outside lines where the sides meet. (This feature can be used to indicate

miter joints.)
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To draw parallel lines with line joints:

1. Make sure that nothing is selected on the drawing.

2. Alt-click on the Parallel Line icon on the Tool palette.

The Parallel Line Setup dialog box will appear.

To draw parallel lines without line joints:

• Click on the Plain Line icon.

To change the option for existing polygons or polylines:

1. Select the polygon or polyline you want to change.

2. Click on either the Plain Line icon or the Line Joint icon in the
Parallel Line Setup dialog box.

PC Draft’s Parallel Extrude tool allows you to draw pairs of lines from

existing straight-edged objects, such as lines, rectangles, or polygons.
Although the extruded lines are actually separate line segments, they give

the appearance of parallel lines.

3. Click on the icon with
the line joint.

Extruding
Parallel Lines



Creating and Editing Objects 2 - 45

The attributes of extruded
lines (distance between lines,

alignment, and so on) are

controlled before drawing
using the same setup dialog

box as parallel lines.

2. Choose the single-line
extrude icon.

Extruding Lines
from an Edge or
Line

Lines can be extruded from parallel-line objects, provided that the parallel

objects are first separated into single lines or polygons by breaking the
source objects. This is useful in adding interior walls to a floor plan, for

example.

Both single lines and connected polylines can be extruded. The icons for

these tools are in the Tool palette’s Parallel Lines pop-out menu.

To add extruded lines to a straight-edged object or line:

1. Open the Tool palette’s Parallel Lines pop-out menu.
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3. Place the cursor over the edge you wish to extrude from.

4. Press the left mouse button and drag so that the extruded lines
reach the desired endpoint, then release the left mouse button.

The  new extruded line segment pair will appear on the drawing.

The new segment pair is added to the earlier object as a pair of line seg-

ments.  This makes the earlier object into either an open polyline (if you
started with a closed shape) or two open polylines (if you started with an

open shape).

NOTE:  Holding down the Alt key will constrain the extrusion to be

perpendicular to the original edge and make its length snap to the currently

active grid-snap distance (see Chapter 6)

Sometimes it’s necessary to add jointed segments to a figure. The Extrude

tools Polyline option allows this.

To add extruded polylines to an edge or line:

1. Open the Tool palette’s Parallel Lines pop-out menu.

3. Place the cursor over the edge you wish to extrude from.

4. Press the left mouse button and drag so that the first extruded
segment reaches the desired point, then release the left mouse
button.

The first extruded segment will appear on the drawing.

5. Move the cursor to the next point, then click the left mouse
button.

The next segment will appear.

2. Choose the polyline extrude
icon.

Extruding
Multiple Lines
(Polylines) from
an Edge or Line
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Extruding Lines
from a Parallel
Object

6. Repeat step 5 until you have all the segments you need, then
double-click the left mouse button.

The new extruded polyline will appear on the drawing.

To extrude parallel lines or polylines from a parallel-line object

1. Choose the Extrude parallel line or Extrude parallel polyline
tool from the Parallel line tools pop-up menu in the Tool
palette.

2. Position the cursor over the parallel line object you wish to
extrude the parallel lines or polylines from, then press and
hold down the mouse button.

An alert appears asking if you wish to break the parallel line
object into individual lines.

3. Click the Break Up button to break up the parallel line object
and continue drawing the extruded parallel line or polylines.

The dialog will close and you will return to the drawing with
the Extrude parallel line or  Extrude parallel polyline tool still
active.

4. Position the cursor over the line you wish to extrude the
parallel lines or polylines from, then press and hold down the
mouse button.

5. Continue drawing as for extruded lines.

Extrude parallel line

Extrude parallel polyline
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The Marker
Symbol

To set the parallel-line attributes before drawing an extruded segment pair:

1. Make sure that nothing is selected on the drawing.

2. Alt-click on the Parallel Line icon on the Tool palette.

The Parallel Line Setup dialog box will appear.

3. Change the settings as needed.

4. Click the OK button.

Any extruded lines you draw will now match the settings you just specified.

PC Draft’s Marker Symbol tool lets you add a registration-type marker to a

drawing in one simple step.

     

You can select the Marker tool, then click on the drawing one or more times

to add as many markers as you need; each marker is centered on the point

where you click. You can exit the Marker Symbol mode by holding down
the Alt key and clicking on a blank area of the drawing, or by clicking the

Pointer tool in the Tool palette.

Once a marker symbol is drawn, it exists as a group. You can ungroup it

into a circle and two crossed lines.

To add Marker Symbols to a drawing:

1. Select the Marker Symbol icon in the Tool palette.

2. Place the cursor where you want the marker to appear on the
drawing, then click the left mouse button.

The marker symbol appears.

Setting the
Parallel
Attributes of
Extruded
Lines
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3. If you want to add more markers, repeat step 2 as many times
as necessary.

4. When you are done adding markers, click the Pointer icon or
hold down the Alt key and click on the drawing.

PC Draft has a tool for drawing lines perpendicular to existing lines or to
the edges of polygons, circles, circular arcs, or square-cornered rectangles.

Once a perpendicular line is drawn, it becomes a normal unconstrained line.
You can edit and resize it, or even move it away from its original position if

necessary.

NOTE:  The “anchoring” object for the perpendicular must be in place

before you choose the perpendicular tool. The end of the line can be at any

point on the drawing, even inside an object.

Drawing a perpendicular line from an existing object to a point includes two

steps: selecting the object, then clicking the point.

To draw a perpendicular line from an existing object:

1. Choose the  Perpendicular icon from the Special Line Tools
pop-up menu.

2. Click on the line or edge.

Drawing
Perpendicular
Lines

The cursor now reads
“Click Line/Arc”, to let

you know that you need

to select a line, circular
arc, or edge of an object.
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3. Move the cursor to the point where you want the perpendicu-
lar to end.

The perpendicular line’s starting point slides along the edge or line you
selected as you move the cursor.

NOTE:  You can actually draw a perpendicular from a point not on the
original shape, but on an invisible line or circle extended from it.

4. Click the left mouse button.

The perpendicular line is done.

The cursor now reads
“Click Point”, meaning

that you need to select

an endpoint for the
perpendicular line.
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Snapping Along
the Length

As mentioned earlier, the perpendicular is a normal unconstrained line,

which you can edit or alter as needed. You can even use it as the base for a
new perpendicular line.

If you hold the Alt key down as you draw a perpendicular line, it will
change by the increment controlled by the Set Grid submenu.

PC Draft has two ways to draw tangent lines from circles and circular arcs.

One tool draws a tangent from a circle or arc to any point outside the circle

or arc, and the other draws a tangent from one circle or arc to another. Both
of these tools are controlled by the Special Line Tools pop-up on the tool

palette.

You can specify how you want to draw tangents by choosing the option you

want from the Special Line Tools pop-up menu. Each tool gives you a

special cursor for selecting the objects you want the tangent drawn from.

Once a tangent is drawn, it becomes a normal unconstrained line. You can

edit and resize it, or even move it away from its original position if neces-
sary.

NOTE:  The circles or arcs for the tangent must be in place before you
choose a tangent tool.

1. Point on the Special Line Tools icon in the Tool palette.

2. Press down the left mouse button.

4. Release the left mouse button.

To Choose a
Method for
Drawing
Tangents

Tangent Line
Tools
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Midpoint,
Endpoint and
Center Point
Lines

The icon representing the method you have chosen — from a circle or arc to

any point, or  from one circle or arc to another circle or arc— appears on the
Tool palette, and the cursor changes to let you know that you need to select

a circle or arc.

Three line tools in PC Draft are:  Midpoint, Endpoint and Center line tools.

These enable lines to be drawn from the midpoint or endpoint of an existing

straight edge or circular arc, or from the center of an existing object.  These
tools are located in the Special Line Tools popout in the Tool Palette.

Once a line is drawn with the Midpoint, Endpoint or Center line tool, it
becomes a normal unconstrained line and can be edited, resized and moved.

The Midpoint and Endpoint line tools can be used with straight edged
objects (lines, polylines, polygons and square-corner rectangles) and

circular arcs.  Any of these objects can be part of a group.

The Center line tool can be used with any individual shape.

Midpoint, endpoint and center lines are drawn in the same way as perpen-
dicular lines.  See the User Guide for details.

NOTE:  As with other line tools, the line being drawn can be constrained to
increments of the active grid snap by holding down the  Alt key, or to 45º or

90º increments by holding down the Shift key while drawing.

Now available in PC Draft is the ability to snap the final points of line to the
midpoint or endpoint of an existing straight edge or circular arc, or to the

center of an  existing object.  This is done by holding down the "M," "E" or

"C" key while drawing a line.

The midpoint and endpoint snap keys, "M" and "E," can be used when

drawing lines to straight-edged objects (lines, polygons and square-corner
rectangles) and circular arcs.Any of these objects can be part of a group.

The center snap key, "C," can be used with any shape, including shapes
within groups except for text objects, dimension objects, and bitmaps or

pixel maps.

Line Snapping
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Note:  These snap keys work with any unconstrained lines, including lines

drawn with the Special Line popout's Center, Midpoint, Endpoint, or
Tangent-to-Point tools.

To draw a line to the midpoint of an existing edge, line, or arc;

1. Choose a line tool from the Tool Palette and begin drawing the
line.

2. Press and hold down the "M" key. The cursor will read
"Mid?"

3. Holding down the "M" key, bring the cursor near the desired
edge, arc, or line.

4. The ghost "sketcher" line will snap to the midpoint of the
existing edge, near to the cursor.

5. Finish the line by releasing the mouse button or by clicking
once
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Drawing a
Tangent from a
Circle or Arc to
a Point

6. The line will appear on the drawing between the starting point
and the midpoint specified.  The cursor will revert to the line
tool, enabling another line to  be drawn if needed.

Draw a line to an endpoint of an existing edge, line, or arc or to the center

of an existing object in the same way, but holding down the "E" or "C" key
instead of the "M" key.

Drawing a tangent from a circle or arc to a point includes two steps:
selecting the object, then clicking the point.

Normally, the tangent will be drawn clockwise away from the arc or circle.
You can draw the tangent counterclockwise by holding down the Alt key

while clicking the tangent’s endpoint.

To draw a clockwise tangent from a circle or arc:

1. Choose Tangent to Point from the Special Line Tools pop-up
menu.
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2. Click on the circle or arc. (If the object has no fill, you need to
click its edge.)

The cursor now reads “Click Point,” meaning that you need to select an
endpoint for the tangent line.

3. Move the cursor to the point where you want the tangent to
end.

The tangent’s starting point slides around the circle or arc as you move the
cursor.

NOTE:  With an arc, you can actually draw a tangent from a point not on
the visible arc, but on its “invisible circle.”

4. Click the left mouse button.

The cursor now reads “Click Circle/Arc,”

to let you know that you need to select a

circle or arc.
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The tangent line is done.

To draw a counterclockwise tangent:

1. Choose Tangent to Point from the Special Line Tools pop-up
menu.

The cursor now reads “Click Circle/Arc.”

2. Click on the circle or arc. (If the object has no fill, you need to
click its edge.)

The cursor now reads “Click Point.”

3. Press and hold the Alt key.

The prospective tangent now projects counterclockwise away from the

circle or arc.

4. Still holding the Alt
key, move the cursor
to the point where you
want the tangent to
end.

5. Click the left mouse
button.
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1. Choose Tangent Between
Objects from the Special Line
Tools pop-up menu.

Drawing a
Tangent
Between
Circles or Arcs

Drawing a tangent from a circle or arc to another circle or arc includes two

steps: selecting the first object, then clicking the second object.

The tangent’s final position depends on which half of each object you click.

To draw a tangent from a circle or arc to another circle or arc:

The cursor now reads “1st Circle/Arc,” to let you know that you need to

select a circle or arc.

2. Click the desired starting point on the circle or arc. (If the
object has no fill, you need to click its edge.)

The cursor now reads “2nd Circle/Arc,” meaning that you need to select

another object.

3. Move the cursor to the half of the other object where you want
the tangent to end, then click the left mouse button.
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Drawing
Offset Lines With PC Draft’s Line Offset tool, you can create single lines parallel to

existing straight lines or edges. (To create parallel line objects, use the
Parallel Line tools, described earlier in this chapter.) The offset line will

have the same length, angle, line weight, line style, and pen model as the

original line or edge.

Offset lines can be created from any straight line or from any edge of a

polygon, polyline, or square-cornered rectangle. Once drawn, an offset line
is an independent straight line object that can be edited, moved, or other-

wise manipulated as required.

The offset line’s distance from the original line or edge normally snaps to

the X-Y grid as you drag to an anchor point. You can override the grid and

constrain the offset’s perpendicular distance to even increments by holding
down the Alt key as you drag.

NOTE: The “parent” object for the offset line must be in place before you
choose the offset line tool.

Drawing an offset line from an existing object includes two steps: selecting

the source line or edge, then clicking to specify the offset distance.

To draw an offset line from an existing object:

1. Choose the  Offset Line icon from the Special Line Tools pop-
out menu.
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The cursor now reads “Click

Line/Edge”, to let you know
that you need to select a line

or straight edge of an object.

2. Click on the line or
edge.

The cursor now reads “Click Point” and appears near a dotted copy of the

source line, helping you locate the offset.

3. Move the cursor to the point where you want the offset to lie.

4. Click the left mouse button.

To exit the offset cursor mode, click the Pointer icon in the Tool Palette.

To draw an offset line constrained by the active grid snap:

1. Choose the  Offset Line icon from the Special Line Tools pop-
up menu.

The cursor now reads “Click Line/Edge,” to let you know that you need to

select a line or straight edge.

2. Click on the line or edge.

A dotted copy of the source line appears with the “Click Point” cursor.
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3 . Hold down the Alt key and move the  cursor.

Movement will “snap” to grid increment distances away from the original
edge.

NOTE: If you want to change the increment, choose a different value from
the Layout menu’s Set Grid submenu.

4. Click the left mouse button.

The offset line is done.

As mentioned earlier, the offset is a normal unconstrained line, which you

can edit or alter as needed. You can even use it as the base for a new offset
line.

At times you may want to draw an object that has a shape different from
those provided for you in the Tool palette.  For this reason, PC Draft lets

you draw four types of freehand objects:  freehand lines, closed freehand

shapes, Bezier curves, and spline curves.

The Freehand Shape tool allows you to draw closed freehand objects.

When you use this tool, PC Draft draws a line connecting the starting and
ending points of the object, and fills the object with the current fill.  If you

happen to make a mistake as you are drawing either type of freehand object,

you can erase it and then continue drawing.

A spline is a curve that is fitted to a series of defined points on your

drawing.  With a spline curve, the curve passes through all the defined
points, or “control points.”

A Bezier curve is a curve that is defined by four control points.  The curve
itself passes through only two of the control points.  The two control points

that appear off the curve define the shape of the curve.

You can draw either an open freehand line, a closed freehand shape, a

spline curve, or a Bezier curve by first choosing the appropriate item from

the Freehand pop-up menu on the Tool palette.

Freehand
Drawing Modes
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To choose the type of freehand object (either an open freehand line, a closed

freehand shape, a Bezier curve, or a spline curve) you want to draw:

1. Point on the Freehand icon on the Tool palette, then press
down the left mouse button.

The Freehand pop-up menu will appear.

2. Choose a tool.

1. Choose the type of object from the pop-up menu.

2. Position the cursor where you want to begin drawing.

3. Press down the left mouse button.

4. Holding down the left mouse button, drag the cursor in any
direction, creating a line just as you would with a pencil.

5. When you have completed the freehand line or shape, release
the left mouse button.

Closed Freehand
Shape

Open Freehand
Shape

Choosing a
Freehand
Drawing Mode

To Draw a
Freehand Object
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If  you are drawing a closed freehand, PC Draft will draw a line between the

starting and ending point of the object when you release the left mouse
button.  If you are drawing an open freehand, PC Draft will leave the object

open.

When you are using a freehand drawing tool, you can erase portions of the

shape that you are drawing by using the Shift key.  If you want to erase part

of a freehand object while you are drawing it:

1. Continue to hold the left mouse button down, but stop drawing
the line by ceasing to move the mouse.

2. Press and hold down the Shift key.

An inverted pencil with an eraser will appear at the end of your freehand

line.

4. Release the Shift key to continue drawing the object.

The constrained drawing mode for a freehand tool allows you to draw

straight line segments as part of a freehand object.  Each time you hold the
Alt key down, a straight line will be drawn from the point where you

initially press the key, to the point where you release it.  To do this, follow

these steps:

1. Choose the freehand drawing mode you want from the Free-
hand pop-up menu.

3. Using the
mouse to move
the eraser,
retrace the
portion of the
line that you
want to remove.

Dynamic Editing
of a Freehand
Object

Constrained
Drawing Mode
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2. Start drawing the object.

3. Press down the Alt key.

4. Holding down the Alt key, drag the cursor in any direction
until you have created a straight line that is the length you
want.

 

You can drag the edit handles on a freehand object to change its shape.

To change the shape of a freehand object:

1. Return to the pointer mode.

2. Select the freehand object you want to change by clicking on it.

3. Position the tip of the pointer on one of its edit handles.

4. Press down the left mouse button.

Continue to move each handle until you have obtained the shape that you
want.

5. Holding down the left
mouse button, drag the
handle until you have
created the shape you
want.

6. Release the left mouse
button.

5. Release the
Alt key.

Changing the
Shape of a
Freehand Object
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6. Without pressing down
the left mouse button,
move the cursor to the
next point you want the
curve to pass through
and click the left mouse
button.

Choosing Curve
Tools

Spline Curves

To choose the type of curve you want to draw:

1. Point on the Freehand icon on the Tool palette.

2. Press down the left mouse button.

The Freehand pop-up menu will appear.

3. Drag until either Spline or Bezier is highlighted.

4. Release the left mouse button.

An icon representing the chosen type of curve will appear on the palette.

PC Draft lets you draw a type of curve that passes through a series of

defined points on your drawing.  This type of object, called a spline, allows

you to pick a series of points on a drawing and fit a curve to the points.

To draw a spline:

1. Choose Spline from the Freehand pop-up menu.

2. Position the cursor where you want the spline to start on your
drawing.

3. Press down the left mouse button.

4. Holding down the left mouse button, drag until you reach one
of the points through which you want the curve to pass.

5. Release the left mouse button.

A straight line will appear between the starting point and the cursor to show
you the slope of the curve segment.
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A curve will be fitted to the three points defined so far.

8. When you reach the last point, double-click the left mouse
button.

To make the spline a closed object:

• Double-click on the starting point.

You can change the shape of a spline by dragging its control points.

To change the shape of a spline:

1. Select the spline you want to edit.

2. Point on one of the edit handles.  (The edit handles represent
the control points that were used to define the curve.)

3. Press down the left mouse button.

The completed spline curve will
appear.  It will contain the current

fill, and edit handles will appear

on the control points you used to
define it.

7. Continue moving the
cursor and clicking the
left mouse button until
you have defined all the
points to be fitted.

Changing the
Shape of Splines
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4. Holding down the left mouse button, drag to reposition the
control point and modify the curve.

5. When the curve is the shape you want, release the left mouse
button.

PC Draft allows you to draw Bezier curves using the Bezier curve tool.
Bezier curves give you a great deal of flexibility in creating original designs

that feature elegant S-shapes and loops.

A Bezier curve is a type of curve defined at each vertex by four points,

called “control points.”  Two control points define the end points of the

curve, the other control points define the direction in which the curve is
projected.  When you select a Bezier curve, the four control points are

represented by edit handles on the screen:  two handles appear on the end

points of the curve, and two middle handles appear on either side of the
curve.  The two handles on the end points are called “end point handles,”

and the other two handles are called “direction point handles.”   You can

move the handles to modify and change the size of the Bezier curve.

Bezier Curves



Creating and Editing Objects 2 - 67

Creating Bezier
Curves

When you create a Bezier curve, direction lines are used to indicate the

slope and direction of the curves you draw.  A direction line is a line
between two direction control points that is tangent to an end point.

You can draw a series of Bezier curves using the Bezier curve tool.  Each
individual curve actually passes through only the two end control points.

The direction lines define the overall shape of the curve.  When you draw a

series of curves, the curves are connected at “joints,” or end control points
that are shared by two curves.

To create a Bezier curve:

1. Choose Bezier from the Freehand pop-up menu.

2. Point where you want the curve to begin.

3. Press down the left mouse button.

This defines the first end control point of the curve.

 

A line with two handles will be projected in opposite directions from the
curve’s beginning point.  This line is called a “direction line.”  One of the

handles will be attached to the cursor.  By dragging the handle, you indicate

the direction and slope of the curve.  For example, if you drag the handle
down all the way to the lower right corner of the screen, a curve sloping

toward the lower right corner will result.

5. Release the left mouse button.

The point at which you release the left mouse button defines the first

direction point.

4. Holding down
the left mouse
button, drag in
the direction
you want to
project the
curve.
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6. Without pressing down the left mouse button, move the pointer
to where you want the second end control point to appear.

7. Press down the left mouse button.

8. Holding down the left mouse button, drag to define the curve’s
second direction point, as well as the first direction point of the
next curve.

The first direction point of the next curve is associated with the handle
attached to the cursor.  The second direction point of the first curve is

associated with the handle at the opposite end of the direction line.

As you drag, the curve will appear on the screen.  The curve’s shape will

change as you define the second direction point.

9. Release the left mouse button.

With PC Draft, you can join a series of Bezier curves together.  The curves

are joined at the end points.  When you define the second direction point for

a curve, you also define the first direction point of the next curve you draw.

10. To continue drawing curves, repeat steps 8 and 9 above.

11. When you have defined the control handle  for  the curve’s
final point, double-click to complete the shape.

You can also draw straight lines in the midst of Bezier curves by clicking

instead of dragging.

To create a straight line segment after you have drawn at least one complete

curve and you are still in the Bezier curve drawing mode:

Drawing Straight
Line Segments
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1. Without pressing down the left mouse button, move the cursor.

2. Click the left mouse button.

The resulting line will be curved, but the next line will be straight.

3. Without pressing down the left mouse button, move the cursor
to where you want the end point of the line to appear.

4. Click the left mouse button.

Continue moving the cursor and clicking the left mouse button to create a

series of straight line segments.

You can create unique designs by dragging the edit handles to modify the

Bezier curve.  Edit handles appear on Bezier curves that are selected.  When

you move the end point handles, you drag part of the curve along with the
handle.  When you drag a direction handle, it exerts a “pull” on the curve

closest to it.

To select a Bezier curve:

1. Return to the pointer mode.

2. Position the tip of the pointer on the curve you want to change.

3. Click the left mouse button.

Edit handles will appear on the selected curve.

To move the end point handles:

1. Point on one of the end point handles on the Bezier curve.

2. Press down the left mouse button.

3. Holding down the left mouse button, drag the handle to a
different point on the drawing.
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The end of the curve will follow the movement of the handle.

To move the direction handles:

1. Point on one of the direction handles.

2. Press down the left mouse button.

3. Holding down the left mouse button, drag until the curve is the
shape you want.

4. Release the left mouse button.

As you drag, the curve will be reshaped.

When you move a direction handle, the curve may come to a sharp corner at
that point. To keep the curve smooth, you can constrain the direction

handles so that each pair will move in concert.  Pressing the Shift key will

produce this constraint.

To constrain the direction handles:

1. Press and hold the Shift key.

2. While holding the Shift key, point on one of the direction
handles.

3. Press down the left mouse button.

4. Holding down the left mouse button and the Shift key, drag
until the curve is the shape you want.

4. Release the
left mouse
button.
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The direction handle and its opposite will pivot around the
handle on the curve.

5. Release the left mouse button and the  Shift key.

NOTES: When you constrain with the Shift key and drag an
edit handle on a joint (that is, a point at which two end points
meet), you change the shape of the two curves controlled by
that end control point and its opposite.

When you drag an edit handle on the end point of a straight
line segment, you reshape the straight line segment, causing it
to become curved.

You can create sharp corners on a Bezier curve by pulling both
direction handles to one side, or by dragging the direction
handles of a direction line on top of an end control point.

There may be occasions when you want to reshape an object
from straight lines and sharp corners to curved lines and
rounded corners, the straight lines of an object to smooth lines,
or vice versa.  You can accomplish this conversion by using the
Reshape submenu in the Edit menu.

The objects that the Reshape Control can modify include
polygons, polylines, and freehand shapes.

Reshaping
Objects
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To reshape an object:

1. Select the object you want to reshape.

2. Open the Edit menu and drag until Reshape is
highlighted.

The Reshape submenu will appear.

3. Select Smooth or Unsmooth (detailed explanations of the
choices follow).

 4. Release the left mouse button.

After you make your choice, the object will be reshaped.  You
can edit the reshaped object by using the edit handles.

The Reshape Control’s Smooth and Unsmooth Options affect
different shapes in different ways.

A freehand can be smoothed to a curve that lies close to the
original object, passing near the original vertices (the new edit
handles appear at the old vertices).  In addition, this new curve
can be smoothed repeatedly until the desired effect is obtained.

Reshape Option
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A polyline can be smoothed to a curve that intersects the
midpoints of each line segment of the original object, except
for the segments closest to the ends.  That is, the curve will
skip over the first and last midpoints of the original polyline.

NOTE:  A polygon or polyline can be smoothed only once.

Each object in PC Draft has a datum point, which is a reference
point used when you paste the object, rotate it, or manipulate it
in other ways.  PC Draft lets you change the location of the
datum point for any object.

Each type of object has a default datum point.  For example,
the default datum point for a rectangle is the upper left vertex.

A polygon can be smoothed to a curve
that lies inside the original object
(intersecting the midpoints of each line
segment).  When the smoothed polygon
is selected, its original shape appears as a
ghost outline.

Editing an
Object’s Datum
Point
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Rotate 90° Tool The PC Draft Tool Palette now includes a Rotate by 90°tool:

Select an object in the PC Draft drawing then click on the Rotate 90° tool.
The object will be rotated 90° anti-clockwise around its center.

Select the object again, hold down the Alt key, and click on the Rotate 90°

tool. The object will be rotated 90° anti-clockwise around its datum point.
(In this example, the object’s datum point is on the point of the shape.)

In addition to the manual resizing possible when you drag an object’s edit

handles, PC Draft includes a method for resizing objects by typing exact

size values. This gives you more precise control over the size of objects on
your drawing.

Keyboard resizing is controlled from the Resize palette. You can display the
Resize palette using the Window menu. The Resize palette can remain

visible indefinitely, and can be dragged anywhere on screen as needed,

displaying the size values of the currently selected object.

Different types of objects are resized in different ways. For example, you

can resize a rectangle by specifying the exact height and width of the
rectangle, whereas resizing an arc includes entering various angle values

and a radius length.
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The Resize
Palette

As you select different objects, the types of values displayed in the Resize

palette will change automatically to match your selections.

For most objects, there are two approaches to keyboard resizing: you can

enter the values for the whole object, or select a point on the object,
specifying either that the point will be shifted by the changed values or that

the point will be moved to a specific drawing location. The effects the two

different methods each have on different object types are detailed on
following pages.

In general terms, to resize an object by changing its size values:

1. Open the Window menu and choose Resize, or

2. Choose Resize from the pop-up placed at the bottom left of the
document window.

The Resize palette will appear. If an object or group is selected, the palette
will display the current size of the object; if nothing is selected, the palette

will not show any values.

2. If necessary, select the object you want to resize.

3. Enter the new size values (such as Height or Width) you want
for the object.

4. Click on the Apply button.

The new size will be applied to the object.
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To resize an object by editing a single edit handle

1. Make sure the Resize palette is displayed.

2. Select the object you want to resize.

 4. Click the Select Point button.

A special gunshot cursor will appear on the drawing.

5. Click the cursor on the point (edit handle) you want to resize.

The Resize palette will display either the location of the point or the size

values for the object.
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6. Enter the new values or location for that edit handle in the
Resize palette, then click the Apply button.
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The new values or location will be applied to that edit handle, resizing the
object.

NOTE: If the resize operation requires the object to be enlarged beyond the
drawing area, a system beep will sound and an alert wil appear..

This section describes the resizing option for the various types of objects
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Select Point

Object Types
and the Resize
Palette

Length & Angle

and the information you can enter to resize each type of object.

NOTE: If you select multiple objects, the Resize palette will reflect (and

affect) the object selected most recently.

Changes the desired length and angle of the line. The specified angle is
measured relative to the X-axis, and the last point drawn on the line — the

“finishing point” — will normally be the one that moves.

Enables you to select which endpoint of the line will move when you apply

a new length or angle value.

NOTE: If you change the angle of a constrained line, it will become an

unconstrained line.

Lines and
Parallel Lines
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Percent

Width &
Height

Select Point

Change the width and height of a rectangle. For example, to enlarge a 1" x

1" rectangle to 3" x 3", enter 3" in both fields. A diagonally drawn rectangle

will normally resize by shifting its bottom edge or right-hand edge (or
both).

Enables you to select which edge or corner of the rectangle will move when
you apply a new width or height (or both). For example, if you click Select

Pt, then select the rectangle’s top middle handle, then enter a new height,

the top edge will move up.

Change size of the group proportionally by percentage. Values larger than

100% will increase its size; values smaller than 100% will reduce it.

Normally, the lower right corner will move as the group becomes larger or
smaller.

Enables you to select which corner of the group will move when you apply

Square-Corner
Rectangles

Groups
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a new percentage. For example, if you click Select Pt, then select the

group’s top left handle, then enter 200%, the top edge will move up and the
left edge will move left.

NOTE: Bitmap and pixel map objects can be made “palette resizable” by
grouping them to themselves. For example, if you paste in a bitmap or load

in a TIFF image, you can make it proportionally resizable by selecting it,

then choosing Group.

Change the width and height, as with square-corner rectangles, and the

radius of the corner arc. Normally, the width and height values will resize
the rectangle by shifting its bottom edge or right-hand edge (or both).

Enables you to select which edge or corner of the rectangle will move when
you apply a new width or height (or both). For example, if you click Select

Pt, then select the rectangle’s top middle handle, then enter a new height,

the top edge will move up.

Select Point

Width, Height,
& Radius

Select Point

Rounded-Corner
Rectangles
(Proportional
and Constant)
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Select Point

Diameter &
Radius

Width, Height,
X-Radius,
& Y-Radius

Change the width and height, as with square-corner rectangles, and the

vertical and horizontal radii of the elliptical corner arc. Normally, the width

and height values will resize the rectangle by shifting its bottom edge or
right-hand edge (or both).

Enables you to select which edge or corner of the rectangle will move when
you apply a new width or height (or both). For example, if you click Select

Pt, then select the rectangle’s top middle handle, then enter a new height,

the top edge will move up.

Change the diameter or radius of the circle. A circle drawn by diameter will

normally move the last point drawn, as with rectangles; a circle drawn by
radius will normally change size so that its center doesn’t move.

Elliptical-Corner
Rectangles

Circles Drawn by
Diameter or
Radius
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X & Y
Locations

Select Point

Select Point Changes the radius or diameter distance for the selected handle. For

example, if you click Select Pt, then select a radial circle’s center handle,

then enter a new radius, the center handle will move as the circle assumes
its new size.

Change the X and Y coordinates for the circle’s three edit handles. The
absolute coordinates you specify are measured from the zero origins of the

rulers.

Same effect.

Circle Drawn by
Three Points
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Select Point

Width &
Height

1st A°

Change the width and height of an ellipse. A diagonally drawn ellipse will

normally resize by shifting its bottom right edit handle.

Enables you to select which corners of the ellipse will move when you

apply a new width or height (or both). For example, if you click Select Pt,

then select the ellipse’s top middle handle, then enter a new height, the top
will move up.

Change the angle of the arc’s starting point, measured in relation to the X-
axis.

Change the angle of the arc’s ending point, measured in relation to the X-
axis.

Ellipse

Arcs Drawn by
Radius

End A°
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Radius

X & Y
Locations

Select Point

Select Point

Change the radius of the arc.

Same effect.

Change the X and Y coordinates for the arc’s three edit handles. The
absolute coordinates you specify are measured from the zero origins of the

rulers.

Same effect.

Elliptical Arcs

Arcs Drawn by
Three Points
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1st A°

End A°

Select Point

Change the angle of the arc’s starting point, measured in relation to the X-

axis.

Change the angle of the arc’s ending point, measured in relation to the X-

axis.

Change the horizontal or vertical radius of the arc.

Same effect.

Because of the complexity of these objects, you can only edit them using

the Select Point cursor.

For example, if an object has a half-dozen or more edit handles, each handle
cannot be shown in the Resize palette. Instead, you use the Select Point

button to select a single handle, then give it a new absolute location on the

drawing.

Polygons and
Polylines
(including
Parallel
Polygons)
Freehands, and
Curves
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Select Point Change the X and Y coordinates of the location where you want the

selected handle to appear. The coordinate values are measured from the zero
origins of the rulers.

NOTE: The Resize palette treats the direction handles on Bezier curve
objects like any other edit handles.

Changes the size of the metapolygon proportionally by a percentage of its

current size. Absolute values larger than 100% or positive relative values

will increase its size; absolute values smaller than 100% or negative relative
values will reduce it. Normally, the lower right corner will move as the

metapolygon becomes larger or smaller.

Changes the width and height of the metapolygon. A metapolygon will

normally resize by shifting its bottom edge or right edge (or both).

Enables you to select which corner of the metapolygons bounding frame

will move when you resize it. For example: if you click Select Pt and select

the metapolygon’s top left handle, then enter an absolute percentage value
of 200%, the top edge will move up and the left edge will move left.

Percentage

Select Point

Width and
Height
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1st A°

End A°

Angular
Dimensions

Length

Select Point

Change length of the dimension object. Normally, the first reference point
(the left end of a diameter or the center of a radius) will remain fixed.

Enables you to select which reference point will move when you apply a
new length.

Change the angle of the dimension’s starting point, measured in relation to

the X-axis.

Change the angle of the dimension’s ending point, measured in relation to

the X-axis.

Linear and
Radial
Dimensions
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Radius

Select Point

Resize Units

Change the radius of the dimension object.

Same effect.

The Resize palette uses the scale and units of the current layer. When you
select an object with the Resize palette visible, the values shown will be to

scale. When you enter values to resize an object, you should use values

appropriate to the current scale.

WARNING: If you enter unscaled units in a scaled drawing (for example, a

width “ 4" ” in a 1/8"=1' drawing), you may get unexpected results (in that
example, the four inches would appear in the drawing as 1/24 of an inch on

screen and on paper).

If you don’t specify units with the values you enter, PC Draft will interpret

the values according to the document’s current size units. (You set the size

units using the Document Scale & Units dialog box).

Below are some examples of valid size and coordinate entries for some of

the available types of size units.

Decimal Feet and Inches

12.0' 110.3'

10' 10 in

12.3 is interpreted as 12.3'

Fractional Feet & Inches

23" = 1’11" 1 3/4"

1' 10-3/8"

Fractional Inches

1" 123-3/4"15 1/2
1/2 2-1/4

You can enter values greater than 12 inches if fractional inches are the
current size units.
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Moving Using
The Arrow Keys

Moving Using
The Resize
Palette

The Resize Palette has two modes, Normal and Expanded. When the palette

is Expanded, it can be used to move a single object or group within the
current drawing. Expand the palette by clicking on the Expand/Contract box

at the top right of the palette.

The Resize palette’s Position X and Y fields move the selected object or
group to an absolute position on the drawing or by relative horizontal and

vertical distances. All movement is defined in the units and scale of the

drawing.
Set the mode to relative or absolute by clicking on the Relative or Absolute

button at the top of the palette. Change a selection’s position by entering

values in the Position X and Y fields, then clicking Apply or pressing the
Enter key.

For relative movement, positive distance values will move items to the right

(in the ∆X field) or downward (in the ∆Y field). Negative values will move
items to the left or upward.

Selected objects and groups can be moved using the arrow keys on the
keyboard. When a grid is active (see Chapter Six of the User Guide), each

press of an arrow key will move (or “nudge”) the current selection one grid

increment in the appropriate direction: left, right, up, or down. If no grid is
active, the selection will move one screen pixel (1/72 of an inch) for each
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keystroke. Hold down the Control key and press an arrow key to release the

selection from an active grid and allow the selection to be moved one pixel
at a time.

All PC Draft objects can be increased or reduced in size by multiplying or

dividing the object’s dimensions by specified values. You can choose
whether or not to maintain the object’s proportions. The Expand and

Contract commands in the Edit menu are used to resize objects in this way.

To resize an object using the Expand command:

1. Select the object to be expanded.
2. Select Expand from the Edit menu.

The Expand dialog displays.

3. To maintain the object’s proportions, ensure that the Linked
checkbox is checked.

4. To change the object’s proportions, uncheck the Linked
checkbox.

5. Enter a value to multiply the X dimension of the object by.

NOTE: If the Linked checkbox is checked, the same value will

automatically be entered in the Y field.

6. Enter a different value to multiply the Y dimension of the
object by, if necessary.

7. Click on the OK button.
8. The dimensions of the object are multiplied by the specified

values and the object is expanded around its center point.

Expanding and
Contracting
Objects

Expanding
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Contracting

NOTE: The screen shot below shows a copy of the original shape in front of

the expanded shape.

To resize an object using the Contract command:

1. Select the object to be contracted.
2. Select Contract from the Edit menu.

The Contract dialog displays.

3. To maintain the object’s proportions, ensure that the Linked
checkbox is checked.

4. To change the object’s proportions, uncheck the Linked
checkbox.

5. Enter a value to divide the X dimension of the object by.

NOTE: If the Linked checkbox is checked, the same value will
automatically be entered in the Y field.
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6. Enter a different value to divide the Y dimension of the object
by, if necessary.

7. Click on the OK button.
8. The dimensions of the object are divided by the specified

values and the object con-tracts around its center point.

NOTE: The screen shot below shows a copy of the original shape behind

the contracted shape.

If  you do something unintentionally, or want to correct a mistake, PC Draft
lets you reverse certain actions.  The Undo Control reverses execution of the

last action; the Redo Control executes the previously reversed action; and the

Revert Control returns you to the last saved version of the document.

If you choose a Control or perform an action and then change your mind, in
most cases you can choose Undo to reverse the action or the effects of the

Control.

To undo an action or Control:

• Open the Edit menu and choose Undo.

If the action or Control is “Undo-able,” the Control will be listed beside

Undo in the Edit menu (Undo Delete after a deletion, for example).

Reversing
Changes: Undo,
Redo, and Revert

Undo
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Redo

If the action or Control is not Undo-able, Undo will appear dimmed in the

Edit menu.

You can use Redo to re-execute an action or Control that you just reversed
using Undo.  By using Undo and Redo together, you can experiment with

your drawing and PC Draft’s features.   For example, you could delete an

object, observe the effect on your drawing, and choose Undo to reverse the
deletion.  If you then decided that the deletion produced the desired effect,

you could choose Redo and the same object would be re-deleted.

To redo an action or Control:

• Open the Edit menu and choose Redo.

The name of the Control you reversed by previously choosing Undo will be

listed in the Edit menu.
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Revert

NOTE:  In most cases, in order to undo or redo a Control, you must choose

Undo or Redo before you perform any other action.  However, there is an
exception to this rule.  You can switch back and forth between documents,

performing actions on the various open documents, and PC Draft will

“remember” the last action performed in each document.  This allows you
to return to an open document and undo or redo the last action you

performed in it.

If you execute a Control that is not Undo-able, or you make changes you are

unable to delete but do not wish to save, you can eliminate any unsaved
changes by reverting to the last saved version of your document.  You

should use this Control with caution, since it will obliterate anything that

has not been saved.

To revert to a previously saved version of your document:

1. Open the File menu and choose Revert.

A dialog box will appear to confirm that you want to proceed.  The dialog

box will show you the date and time when the document was last saved.

To revert to the last saved version of the document:

2a. Click on the Revert button.

To return to the current version of your document:



2 - 96 Creating and Editing Objects

2b. Click on the Cancel button.

WARNING:  If you revert to a previously saved version of the document,
all changes made since the last save will be deleted.

PC Draft offers various features for changing the view of your drawing.

Using these features you can move the drawing in the document window so

that you view a different part of the drawing, or you can zoom in or out on a
portion of the drawing to see it in more detail or to see an overall view. Any

view can be saved.

To change the position of the drawing within the document window, you

can scroll the drawing, use the Hand tool or use the arrow keys on the

keyboard.

NOTE: You can easily return to the top left corner of your drawing by

using the Home View command (see Home view on page 2-140).

Scrolling in PC Draft drawings is accomplished just as it is in other PC

windows by using the scroll bars at the edges of the windows. See your
system documentation for details.

The Hand tool provides an alternative method of moving the drawing within
the document window.

To use the Hand tool:

1. Click on the Hand tool in the Tool palette.

The cursor will change to a hand.

Changing the
position of the
drawing in the
document
window

Drawing views

Scrolling

The Hand tool

Pointer tool

Hand tool



Creating and Editing Objects 2 - 97

2. Position the cursor over the drawing area and press the mouse
button.

3. Holding down the mouse button, drag in any direction.

The view will move with the hand.
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4. Release the mouse button when the desired section of the
drawing is displayed in the document window.

NOTE: You can also access the hand tool by pressing the space bar while

the Pointer tool is active.

When you work with a large document you may need to see the entire

drawing at one time. Or, you might need to obtain a close up view of a

particular area so that you can add small details. PC Draft gives you the
ability to change the view of your drawing in either of these cases by

providing features that allow you to zoom in or out on an area of the

drawing. Zoom controls are provided via the Zoom tool in the Tool palette,
by commands in the View menu and by a popup menu at the bottom of the

document window.

PC Draft usually allows you to magnify a drawing up to 32 times, or down

to -8 times its normal size.

NOTE: The current magnification of the drawing view is shown at the

Zooming In or
Out on a
Drawing
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bottom of the document window.

NOTE: If you zoom out several consecutive times, and have text on your

drawing, the text will become too small to be displayed and only its edit

handles will display.

Click on the Zoom tool in the Tool palette to select it.

NOTE: You can also activate the Zoom tool by holding down the Shift key

and clicking on the Pointer tool at any time.

To use the Zoom tool to zoom in on an area of the drawing:

1. Select the Zoom tool.

The cursor will change to a magnifying glass with a plus sign inside it to

show that you are about to increase the magnification of the drawing.

2. Position the cursor over the area of the drawing you wish to
zoom in on and click the mouse button.

Using the Zoom
tool

Zoom In
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The magnification of the drawing view will be increased one level, and the

view will be centered around the position of the cursor.
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3. Continue to click the mouse button to zoom in further.

To use the Zoom tool to zoom out on an area of the drawing:

1. Select the Zoom tool.

2. Press and hold down the Alt key.

The cursor will change to a magnifying glass with a minus sign inside it to
show that you are about to decrease the magnification of the drawing.

3. Position the cursor over the area of the drawing you wish to
zoom out on and click the mouse button.

The magnification of the drawing view will be decreased one level, and the

view will be centered around the position of the cursor.

4. Continue to click the mouse button to zoom out further.

Zoom Out
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The Zoom tool can also be used to perform marquee zooms.

To use the Zoom tool to perform a marquee zoom:

1. Select the Zoom tool.

The cursor will change to a magnifying glass with a plus sign inside it to

show that you are about to increase the magnification of the drawing.

2. Position the cursor over the drawing.

3. Press and hold down the mouse button, and drag over the area
you want to zoom in on.

The inner rectangle shown in the screen shot above is the area selected with

the Zoom tool. The outer rectangle represents the actual area that will be
displayed in the document window when the mouse button is released.

Marquee Zoom
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4. Release the mouse button to display the portion of the
document selected.

The Zoom commands are found in the Zoom submenu in the View menu.

NOTE: You can choose Zoom commands several consecutive times, each

time further increasing or decreasing the level of magnification of your

view.

To use the Zoom out commands:

• Select Zoom Out 2X or Zoom Out 4X from the Zoom submenu
in the View menu.

Zoom
Commands

Zoom Out
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The magnification of the drawing view will be decreased by the specified

amount.

To use the Zoom in command:

1. Select Zoom In 2X or Zoom In 4X from the Zoom submenu in
the View menu.

The view finder box and a cross cursor will appear on your drawing. This

gives you a visual indication of the portion of your drawing that will be
included in the magnified view.

2. Move the cursor to position the view finder over the area of the
drawing you want to zoom in on.

3. Click the mouse button.

Zoom In
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The magnification of the drawing view will be increased by the specified

amount, and the selected portion will display in the document window.

NOTE: If the complete zoomed in view will fit in the document window,
the view finder will not be displayed; the new view will be displayed

immediately.

The current magnification of the drawing view is shown at the bottom of the

document window. If you click on this area, a magnification popup menu

will display.

Magnification
Popup Menu
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• Select a magnification value from this popup menu to zoom in
or out on your drawing.

The Restore Previous Zoom function allows you to return to the previous
magnification of your drawing, regardless of the current magnification.

To return to the previous magnification:

• Select Restore Prev. Zoom from the View menu.

The view will zoom in or out to the previous magnification.

NOTE: You can use this command to alternate between two magnification

levels. For example, you could do some detailed editing at high
magnification, use Restore Previous Zoom to examine the whole image,

then use Restore Previous Zoom again to zoom back in and continue the

detail work.

The view which appears on the screen when you first open a PC Draft
document is called the Home View. This view displays the an unmagnified

view of the upper left corner of the document.

To display the home view:

• Select Home View from the View menu.

An unmagnified view of the upper left corner of the document is displayed.

Restore Previous
Zoom

Home view
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You can easily return to an unmagnified view of the current area of the

document by using the 1:1 tool in the Tool palette. This is useful if you
have zoomed in on a detail and now want to see it at single magnification,

but don’t want to return to the upper left corner of the drawing as when

using the Home View command (see Home view on page 2-156).

To return to an unmagnified view of the current working area:

• Click on the 1:1 tool on the Tool palette.

The view will change to an unmagnified view of the current area.

1:1 tool

1:1 tool
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In many drawings, you may want to change the appearance of objects to

help differentiate between them. You can change their appearance by filling
objects with washes (solid fills) and patterns; by drawing lines and object

borders with different colors, patterns, line weights, line styles and pen

styles; by drawing lines with different end marks; and by choosing different
positions for object borders.

You can define attributes for fills and lines that will be applied to all objects
you draw or you can change the attributes of existing objects.

When the application is launched, the default values are white fill, black
pen, no pattern, line weight 1 point, plain line style.

Most attributes are chosen from various pop-up menus on the Attributes
palette or the indicator boxes at the bottom left of the document window.

Others are chosen from the Preference menu.

Displaying the Attributes palette

To open the Attributes palette:

• Choose Attribute from the Window menu, or
• Choose Attribute from the pop-up menu at the bottom left of

the document window.

Selecting attributes using the Attributes palette

Selecting attributes is discussed in detail in later sections of this chapter, but

Changing the
Appearance of
Objects

Object Attributes

The Attributes
palette

 Line weight

End marks

Fill color
Parallel line fill

Pen fill

Fill pattern

Parallel line pattern

Pen pattern

Line style
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in general:

• Change the attributes of existing objects by selecting the
object, opening the appropriate menu in the Attributes palette,
then making your choice.

• Change the drawing's default attributes (the fill, line weight
and so on that will be applied to all new objects you draw) by
making sure nothing is selected, then opening the appropriate
menu and choosing an attribute.

The fill and line indicator boxes offer an alternative method of selecting

some attributes.

The default attributes for the fill color or pattern and the line weight are

shown in the Fill and Line indicator boxes in the lower left corner of the
document window.

Selecting attributes using the fill and line indicator boxes

The Fill and Line indicator boxes can be used to select attributes by

accessing the appropriate pop-up menu and selecting the desired attribute.

Opening the attribute pop-up menus from the fill and line indicator boxes

To open the Fill color and pattern pop-up menus:

• Click the Fill color/pattern box.
• Hold down the Control key and click on the Fill color/pattern

box to display the alternate popup menu..

To open the Parallel line fill color and pattern pop-up menus:

• Position the pointer on the Fill color/ pattern box, holding
down the Alt  key press left mouse button.

• Hold down the Alt and Control keys and click the Fill color/

The Fill and Line
Indicator Boxes
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pattern box to open the alternate pop-up menu.

To open the Pen color and pattern pop-up menus:

• Hold down the Shift key and click the Fill color/pattern box.
• Hold down the Control and Shift keys and click the Fill color/

pattern box to open the alternate pop-up menu.

To open the Line weight pop-up menu:

• Click the Line weight box.

To open the Line style pop-up menu:

• Hold down the Alt key and click the Line weight box.

The attributes that you can select for objects before you draw them are Fill

color and pattern, and Parallel line fill color and pattern. The pen attributes

(that is, the attributes associated with lines and object borders) that you can
define for objects before you draw them include pen style, color and pattern,

line weight (thickness), line style (solid and dashed lines), end marks

(symbols at the ends of lines), and border position. The option for each of
these attributes that is currently active is called the `default attribute'.

The current default fill and pen attributes appear on the lines and borders of
the objects you draw.

NOTE: You cannot apply both a fill color and fill pattern to an object unless
you define a colored fill pattern.

When nothing is selected on the drawing, the default attributes are shown

on the Attributes palette. When an object is selected, the Attributes palette
shows the attributes of that object.

Setting default attributes:

To change the current default attributes for fills and lines

Default
Attributes
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1. Activate the Pointer tool on the Tool palette.

NOTE: Make sure that nothing is selected on the drawing.

2. From the pop-up menus on the Attributes palette (or the fill
and line indicator boxes), choose the fill and/or line attributes
you want to apply to all objects you create.

The attributes you choose will automatically be applied to all objects until

you make other choices for the default attributes.

You can change the fill and line attributes for selected objects without

affecting the default fill and line attributes.

To define the fill and/or line attributes for selected objects:

1. Select the object or objects you want to change.

2. From the pop-up menus on the Attributes palette (or the fill
and line indicator boxes), choose the fill and/or line attributes
you want to apply to the selected objects.

The chosen attributes will be applied only to the selected objects. The

default attributes will not be changed.

Selecting
Attributes for
Specific Objects
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With PC Draft you can use color in a variety of ways: to fill objects with

solid colors, to fill objects with color patterns, to draw the borders of objects
and to color text. The use of solid colors is referred to as a "wash," and the

use of colors to draw lines and object borders is referred to as the "pen

color." The color you choose for the pen is applied to text as well. You can
also use colors in fill patterns and to fill the gaps between parallel lines.

A Windows® color system is capable of reproducing over 16 million colors,
but the number of colors you can display depends on the amount of video

RAM (Random Access Memory) in your computer, and on the specification

of your monitor.

There are certain trade-offs to be aware of in choosing the number of colors

to set your monitor to display. If you choose to display millions of colors,
the rate at which the screen is redrawn will be slowed down. If you choose

to display fewer colors, the screen redraw will be faster, but there will be

fewer color choices available to you, and the system may not be able to
display all of the colors used in an existing document. The system will

attempt to display all the colors used in an existing document by using a

process called `dithering'. With dithering, the system clumps together pixels
of different colors to simulate the specified color.

To set the number of colors to display

The display choices available to you will be determined by the

specifications of your monitor and the system software you are running.
Refer to the system software documentation for details of setting the

number of colors to display on your monitor.

NOTE: If you want to use only grayscale, but you have a color or true

monochrome monitor, you will still be able to access color items, such as

Edit Colors, but in 256 shades of gray.

The color table contains the colors used in a document. Each new document

contains a number of preset colors, which you can edit. The preset colors

and the colors you edit or create are stored in the document's color table.

Using Color

Choosing the
Number of
Colors to Display
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The color table is represented on your screen as a submenu that shows all

the preset colors and all the colors that have been used in the document.

 

The colors in the color table can be chosen from the Attributes palette, the

Fill indicator box and the Edit Colors command in the Preference menu.

NOTE: When you paste objects from a different document that has colors

that are not present in the target document's color table, the colors from the

source document are preserved in the objects that are pasted, but are not
added to the target document's color table.

You can edit the existing colors in the color table to add your own colors.

When you edit an existing color, the existing color is replaced with the new

color in the color table.

NOTE: If you edit a color that has been used in the document, the objects

that contain the edited color will be updated with the new color.

To edit a color in the color table:

1. Choose Edit Colors from the Preference menu.

The color table appears.

2. Holding down the mouse button, drag through the table until
the color you want to edit is highlighted.

The Color Table

Editing Colors
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3. Release the mouse button.

The Pick a Color dialog appears.

NOTE: You cannot edit the No fill (N), the solid white or the solid black
colors. If you try to edit one of these colors, the Color Picker dialog will not

open, and an alert will inform that you are unable to modify this fill.

4. Use the controls in the Pick a Color dialog to choose a new
color.
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NOTE: The Pick a Color dialog is specific to the operating system. For full

details on how to use it refer to the operating system documentation.

5. When you have chosen a new color, click the OK button to
close the Pick a Color and return to PC Draft.

The new color you chose replaces the color you selected to edit.

You can use a solid color to fill the interiors of objects. Filled objects are
opaque and you can select them by clicking their borders or anywhere

within them. If a filled object is on top of another object, it hides the object

beneath it from view.

To select the fill color:

1. Open the Fill Color pop-up menu in the Attributes palette.

2. Drag until the fill color you want is highlighted.

Object Fill Color

Selecting the Fill
Color
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3. Release the mouse button. The selected fill color will be shown
on the Attributes palette.

NOTE: If you choose "N" (for No fill) from the Fill Color submenu as the

current fill color, the objects you draw will be wire frame shapes.

You can change the fill color before or after you draw the object.

To draw an object with a selected fill color:

1. Return to the pointer mode. (Make sure that nothing on the
drawing is selected.)

2. Select the desired fill color from the Fill Color pop-up menu in
the Attributes palette.

3. Draw an object.

The object will be drawn with the specified fill color.

The Fill Color Indicator box in the lower left corner of the window will

change color to indicate the color you chose.

NOTE: The chosen fill color will be used for objects until you choose

another fill color as the default.

Drawing an
Object With a
Selected Fill
Color
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To change the fill color of an existing object:

1. Select the object to change the fill color of.

2. Choose the desired fill color from the Fill Color pop-up menu
in the Attributes palette.

The fill of the selected object will be changed to reflect the chosen fill color.

PC Draft's parallel-line objects (single parallel lines, open parallel polylines
and closed parallel polygons) can include fill colors (including No Fill)

between their component edges.

NOTE: In addition to parallel fills, parallel objects can also have pen

colors, patterns and object fills.

To select the parallel fill color:

1. Open the Parallel Fill color pop-up menu in the Attributes
palette.

2. Drag until the parallel fill color you want is highlighted.

Parallel Fill
Color

Changing the Fill
Color of an
Existing Object

Selecting the
Parallel Fill
Color
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3. Release the mouse button. The selected parallel fill color will be
shown on the Attributes palette.

You can change the parallel fill color before or after you draw the parallel

line object.

To draw a parallel line object with a selected fill color:

1. Return to the pointer mode. (Make sure that nothing on the
drawing is selected.)

2. Select the desired parallel fill color from the Parallel Fill color
pop-up menu in the Attributes palette.

3. Draw a parallel line object.

The object will be drawn with the specified fill color.

NOTE: The chosen parallel fill color will be used for objects until you
choose another parallel fill color as the default.

Drawing a
Parallel Line
Object With a
Selected Fill
Color
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To change the fill color of an existing parallel line object:

1. Select the parallel line object to change the fill color of.

2. Select the desired parallel fill color from the Parallel Fill color
pop-up menu in the Attributes palette.

The fill of the selected parallel line object will be changed to reflect the

chosen fill color.

This section describes how to use colors to draw lines, borders and text. You

use the Pen Color pop-up menu in the Attributes palette to choose pen

colors.

You can use different pen colors to help distinguish between objects.

To select the pen color:

1. Open the Pen Color pop-up menu in the Attributes palette.

2. Drag until the pen color you want is highlighted.

Pen Color

Selecting the Pen
Color for Lines,
Borders and Text

Changing the Fill
Color of an
Existing Parallel
Line Object
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3. Release the mouse button. The selected pen color will be shown
on the Attributes palette.

NOTE: If you choose "N" (for No ink) from the Pen Color submenu as the

current pen color, the lines, borders or text you draw will be invisible. Edit
handles appear on selected objects drawn with no ink, but the lines, borders

or text will not appear on the screen or on printed drawings.

You can change the pen color before or after you draw the object or enter
the text.

To draw a line or object, or enter text, with a selected pen color:

1. Return to the pointer mode. (Make sure that nothing on the
drawing is selected.)

2. Select the desired pen color from the Pen Color pop-up menu
in the Attributes palette.

3. Draw a line or object or enter the text.

The line, object or text will be drawn with the specified pen color.

NOTE: The chosen pen color will be used for lines, borders and text until

you choose another pen color as the default.

Drawing a Line
or Object, or
Entering Text,
With a Selected
Pen Color
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To change the pen color of an existing line, object or piece of text:

1. Select the line, object or text to change the pen color of.

2. Choose the desired pen color from the Pen Color pop-up menu
in the Attributes palette.

The line or border of the selected object, or the selected text, will be

changed to reflect the chosen pen color.

Fill patterns provide an effective way to distinguish between objects. Two
reasons you might want to use different fill patterns within a drawing would

be to improve its esthetics or to add meaningful information to the drawing.

In a technical drawing, an architect or engineer might use a variety of fill
patterns and inks to differentiate between various object types or textures

within the drawing. PC Draft offers a menu selection of standard fill

patterns to complement your drawing. You can use the existing patterns,
customize them or create your own. You can have up to 64 patterns in each

PC Draft document.

The Edit Patterns feature allows you to change the patterns available in the

pattern fill submenus from the Attributes palette. When a pattern is edited,

the pattern fill submenus will be updated to show the new pattern, and the
new pattern will be saved with the document. If a pattern that has been used

to fill objects is edited, the objects will be changed to reflect the revised

pattern.

Using Patterns

Customizing
Patterns

Changing the
Pen Color of an
Existing Line,
Object or Piece
of Text
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To open the Edit Pattern dialog:

1. Open the Preference menu and drag until Edit Patterns is
highlighted.

The Edit Patterns submenu appears.

2. Holding down the mouse button, drag until the pattern you
want to edit is highlighted and release the mouse button.

The Edit Pattern dialog appears.

 

NOTE: You cannot edit the No Fill ("N"), the solid white or solid black

patterns. If you try to do so, the Edit Pattern dialog will not open, and an
alert appears informing that the selected pattern may not be edited.

The edit pattern field

The large box in the center of the Edit Patterns dialog is the edit pattern

field. It shows a magnified view of the bits that make up the pattern. The

pattern is edited within this field.

The Edit Pattern
Dialog

Opening the Edit
Pattern Dialog
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The box in the upper left corner of the Edit Pattern dialog shows a preview

of the pattern as it appears on the drawing. It is updated as the pattern is
edited in the Edit Pattern field.

The pattern grid can be defined as 8 x 8, 16 x 16 or 32 x 32 grid squares.

To specify the pattern grid:

• Click the 8 x 8, 16 x 16, or 32 x 32 buttons on the left of the
Edit Pattern dialog.

NOTE: 16 x 16, or 32 x 32 patterns will not be printed on some printers or

output devices.

Scale turned off

Grid size increased

If the Scale box is turned off, as the grid size is increased, the pattern is

replicated to fill the new area.

For example: In the dialogs below, the grid size is increased from 8 x 8 to

16 x 16, then to 32 x 32. At each stage, four copies of the contents of the
Edit Pattern field are used to fill the new grid. Notice that although the

contents of the Edit Pattern field change, the Pattern Preview field remains

the same.

 

Grid size decreased

If the Scale box is turned off, as the grid size is decreased, the pattern is
divided and applied to the new area.

Pattern Preview

The Pattern Grid

Scale
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For example: In the dialogs below, the grid size is decreased from 32 x 32 to

16 x 16, then to 8 x 8. At each stage, the contents of the top left quarter of
the Edit Pattern field are used to fill the new grid.

Grid size increased

If the Scale box is on, as the grid size is increased, the pattern in the Edit

Pattern field remains the same, but is divided up into more squares.

For example: In the dialogs below, the grid size is increased from 8 x 8 to

16 x 16, then to 32 x 32. At each stage, the contents of the Edit Pattern field
remain the same, but the pattern is divided into more grid squares. Notice

that the contents of the Pattern Preview field are scaled up at each stage.

 

Grid size decreased

If the Scale box is on, as the grid size is decreased, the pattern in the Edit

Pattern field remains the same but is divided into less grid squares. Colors
are averaged out in this process.

For example: In the dialogs below, the grid size is decreased from 32 x 32 to
16 x 16 then to 8 x 8. At each stage, as four grid squares are combined to

make one new grid square, the average color of the four squares is used for

the new square. Notice that the contents of the Pattern Preview box are
scaled down at each stage.

Scale On
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Patterns can be edited in two modes: black and white, and color/grayscale.

If you have a monochrome system, color options will still be available in
the Edit Pattern dialog, but as colors/grayscales cannot be seen, they cannot

be used effectively. In this case, patterns will consist of black and white bits,

the black bits representing the pattern design and the white bits the
background. If you have a color system, you can edit patterns using an

unlimited number of colors.

You can work with only one color at a time while editing patterns. The
selected color is called the current color and is displayed in the small box
on the right of the dialog, above the Other button. This box is also a button
used to access the Pattern Color menu.

To change the current color:

1.  Click on the Current Color button and hold down the mouse
button.

The Pattern Color pop up menu will appear:

Color Mode

The Current
Color Button
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2. Hold down the mouse button, drag to select the color you want
to use, and release the mouse button.

The selected color will display on the Current Color button. This color will
be used for pattern editing until another color is chosen.

NOTE: The current color is always black when you operate in black and
white mode.

The Other button allows you to select colors that are not available in the

Pattern Color menu.

To choose a color which is not available in the Pattern Color menu:

1.  Click on the Other button. The Pick a Color dialog box will
appear.

Choosing a Color
Which is Not
Available in the
Pattern Color
Menu
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2. Select a color from the Pick a Color.

3. Click OK to close the Pick a Color dialog box and return to the
Edit Pattern dialog box.

The color selected from will be displayed on the Current Color button.

At times, you may want to clear all the bits from the Edit Pattern field and

start afresh rather than alter an existing pattern.

To clear all the bits from the Edit Pattern field:

•  Click on the Clear button

The field will be cleared.

If you need to fill the entire field with the current color you can do this with

one mouse click using the Fill button.

To fill the entire field:

• Click on the Fill button.

The entire Edit Pattern field will be filled with the current color.

Filling the Entire
Field

Clearing the
Current Pattern
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Pattern editing tools

The tools at the right of the pattern edit field are used to edit the current

pattern.

The Overlay tool is used to apply a pattern over the one in the Edit Pattern

field.

To apply a pattern over the one in the Edit Pattern field:

1. Click the Overlay tool and hold down the mouse button.

The Fill Patterns submenu appears.

2. Holding down the mouse button, drag the cursor over the
pattern you wish to apply, and release the mouse button

The selected pattern will be applied over the current contents of the Edit

Pattern field using the current color.

 

The Invert tool is used to invert the color of the bits in the Edit Pattern field.
In black and white mode, this action will change all the black bits to white

and all the white bits to black. If color bits are included in the pattern, when

the Invert tool is used, each bit will be changed to the color on the opposite
side of the color wheel to the original color, and the brightness will also be

inverted. For example, a light pink color will become a dark green/blue,

while a dark red will become a light green/blue.

To invert the color of the bits in the Edit Pattern field

• Click the Invert tool.

The Invert Tool

The Overlay Tool
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The color of the bits in the Edit Pattern field will be inverted

 

The Flip Horizontal tool is used to flip the pattern in the Edit Pattern field
around the vertical axis.

To flip the pattern in the Edit Pattern field around the vertical axis:

• Click the Flip Horizontal tool.

The pattern will be flipped.

 

The Flip Vertical tool is used to flip the pattern in the Edit Pattern field
around the horizontal axis.

To flip the pattern in the Edit Pattern field around the horizontal axis:

• Click the Flip Vertical tool.

The pattern will be flipped.

 

The Flip
Horizontal Tool

The Flip
Vertical Tool
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The Pencil tool is used to add or delete individual bits or series of bits, or to

draw lines in the Edit Pattern field.

To add bits to the Edit Pattern field one at a time:

1. Click the Pencil tool and move the cursor over the Edit Pattern
field.

2. Click the Edit Pattern field to add a square of the current
color.

To add a series of bits:

1. Click in the Edit Pattern field and drag, holding down the
mouse button.

2. Bits showing the current color will be added to the pattern as
you drag.

3. Release the mouse button when you are finished.

To draw lines:

• Constrain the movement of the Pencil tool to a horizontal or
vertical direction by holding down the Shift key while you
drag.

To delete black bits in Black and White mode:

• Select the Pencil tool and click the black bits you want to
delete.

To delete color bits in the Color mode:

• Hold down the Control key, then click the color bits to be
deleted.

The Pencil Tool
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The Eye dropper tool

You can use the Alt key to change the pencil tool to an eye dropper, and use

this to choose the color of any bit in the Edit Pattern field as the current

color.:

1. Select the Pencil tool, hold down the Alt key and move the
pointer into the Edit Pattern field.
The pointer will change to an Eye Dropper tool.

2. Click the Eye Dropper tool on the bit of the color you require
to be the current color.

The current color will be changed to reflect your choice.

The Finger tool is used to blend together the current color and the color of
any bit in the Edit Pattern field, or the colors of adjacent bits in the Edit

Pattern field.

To blend the current color with the color of any bit in the Edit Pattern field:

1. Select the Finger tool.

The Finger cursor shows the current color, which is the first of the two

colors to be used in the blending process.

2. Move the cursor over the Edit Pattern field and click the bit
with which you want to blend the current color.

The bit clicked will change to a new color that is the average of the Finger

cursor color and the color of the bit clicked. The Finger cursor color will
also be updated to show the new color.

To blend the colors of a series of bits:

1. Select the Finger tool.

2. Click in the Edit Pattern field and, holding down the mouse
button, drag the Finger cursor across bits of varying colors.

The Finger Tool
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The average of the color values of the Finger cursor color and the bits

dragged across will be calculated, and applied to the bit.

NOTE: If you hold down the Shift key while dragging, the movement of

the Finger cursor will be constrained to a horizontal or vertical direction.

 

When you release the mouse button, the Finger cursor shows the color last
applied to a bit. To reset the Finger cursor color to the current color, click

the Finger tool icon again. To reset the Finger cursor color to a color in the

pattern, hold down the Alt key and click one of the colors in the pattern.

NOTE: The Finger tool can be selected in Black and White mode, but the

mode is automatically changed to color.

The Paint Bucket tool is used to change bits in the Edit Pattern field to the

current color.

To change bits in the Edit Pattern field to the current color:

1. Click the Current Color button and choose the color from the
Pattern Color pop-up menu.

2. Click the Paint Bucket icon and then click a bit in the Edit
Pattern field.

The bit clicked and all bits of the same color connected to it, are changed to

the current color.

3. If you hold down the Alt key with the Paint Bucket tool
selected, the tool will be changed to the Eye Dropper tool. Click
a bit in the Edit Pattern field with the Eye Dropper tool to
select the color of that bit as the current color.

The Paint
Bucket Tool
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The Hand tool is used to move the pattern within the Edit Pattern field.

To move the pattern within the Edit Pattern field:

1. Click the Hand tool and move the cursor over the Edit Pattern
field.

2. Holding down the mouse button, drag the pattern to reposition
it within the Edit Pattern field, and release the mouse button.

The B&W button is used to convert patterns to black and white.

 To convert patterns to black and white:

• click the B&W button.

Any bits used in the pattern that are more than 50% saturated will be

changed to black. Bits that are less than 50% saturated will be changed to
white.

Revert

• Click the Revert button to return to the pattern you originally
selected to edit. Any changes you have made will be lost.

The Hand Tool

The B&W button
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Undo

• Click the Undo button to remove the effects of your last action
only.

Cancel

• Click the Cancel button to close the Edit Pattern dialog and
return to your PC Draft drawing without making any changes
to the fill patterns.

OK

• Click the OK button to close the Edit Pattern dialog and
return to your PC Draft drawing accepting the changes you
have made to the selected fill pattern. The Fill Pattern pop-up
menu will be updated to show the new pattern, and the new
pattern will be saved with the document. If a pattern that has
been used to fill objects is edited, the objects will be changed to
reflect the revised pattern.

You can use a pattern to fill the interiors of objects. Filled objects are

opaque and you can select them by clicking their borders or anywhere
within them. If a filled object is on top of another object, it hides the object

beneath it from view.

To select the fill pattern:

1. Open the Fill Pattern pop-up menu in the Attributes palette.

2. Drag until the fill pattern you want is highlighted.

Object Fill
Patterns

Selecting the Fill
Pattern
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3. Release the mouse button. The selected fill pattern will be
shown on the Attributes palette.

NOTE: If you choose `N `(for No fill) from the Fill Pattern submenu as the

current fill pattern, the objects you draw will be wire frame shapes.

You can change the fill pattern before or after you draw the object.

To draw an object with a selected fill pattern:

1. Return to the pointer mode. (Make sure that nothing on the
drawing is selected.)

2. Select the desired fill pattern from the Fill Pattern pop-up
menu in the Attributes palette.

3. Draw an object.

The object will be drawn with the specified fill pattern.

The Fill Pattern Indicator box in the lower left corner of the window will

change to indicate the pattern you chose.

NOTE: The chosen fill pattern will be used for objects until you choose

another fill pattern as the default.

Drawing an
Object With a
Selected Fill
Pattern
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To change the fill pattern of an existing object:

1. Select the object that you want to change.

2. Select the desired fill pattern from the Fill Pattern pop-up
menu in the Attributes palette.

The fill of the selected object will be changed to reflect the chosen fill

pattern.

PC Draft's parallel-line objects (single parallel lines, open parallel polylines

and closed parallel polygons) can include fill patterns (including No Fill)

between their component edges.

NOTE: In addition to parallel fills, parallel objects can also have pen colors

and patterns, and object fills.

To select the parallel fill pattern:

1. Open the Parallel Fill Pattern pop-up menu in the Attributes
palette.

2. Drag until the parallel fill pattern you want is highlighted.

Parallel Fill
Pattern

Changing the Fill
Pattern of an
Existing Object

Selecting the
Parallel Fill
Pattern
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3. Release the mouse button. The selected parallel fill pattern will
be shown on the Attributes palette.

You can change the parallel fill pattern before or after you draw the parallel

line object.

To draw a parallel line object with a selected fill pattern:

1. Return to the pointer mode. (Make sure that nothing on the
drawing is selected.)

2. Select the desired parallel fill pattern from the Parallel Fill
pattern pop-up menu in the Attributes palette.

3. Draw a parallel line object.

The object will be drawn with the specified fill pattern.

NOTE: The chosen parallel fill pattern will be used for objects until you

choose another parallel fill pattern as the default.

Drawing a
Parallel Line
Object With a
Selected Fill
Pattern
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To change the fill pattern of an existing parallel line object:

1. Select the parallel line object that you want to change.

2. Choose the desired parallel fill pattern from the Parallel Fill
pattern pop-up menu in the Attributes palette.

   

The fill of the selected parallel line object will change to reflect the chosen

fill pattern.

This section describes how to use patterns to draw lines and borders. Use

the Pen Pattern pop-up menu in the Attributes palette to choose pen

patterns. You can use different pen patterns to help distinguish between
objects.

To select the pen pattern:

1. Open the Pen Pattern pop-up menu in the Attributes palette.

2. Drag until the pen pattern you want is highlighted.

Pen Pattern

Changing the Fill
Pattern of an
Existing Parallel
Line Object

Selecting the Pen
Pattern for Lines
and Borders
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3. Release the mouse button. The selected pen pattern will be
shown on the Attributes palette.

NOTE: If you choose `N `(for No ink) from the Pen Pattern submenu as the

current pen pattern, the lines and borders you draw will be invisible. Edit

handles appear on selected objects drawn with no ink, but the lines or
borders will not appear on the screen or on printed drawings.

You can change the pen pattern before or after you draw the object.

To draw a line or object with a selected pen pattern:

1. Return to the pointer mode. (Make sure that nothing on the
drawing is selected.)

2. Choose the desired pen pattern from the Pen Pattern pop-up
menu in the Attributes palette.

3. Draw a line or object.

The line or object will be drawn with the specified pen pattern.

NOTE: The chosen pen pattern will be used for lines and borders until you
choose another pen pattern as the default.

Drawing a Line
or Object With a
Selected Pen
Pattern



3 - 33Changing the Appearance of Objects

To change the pen pattern of an existing line or object:

1. Select the line or object that you want to change.

2. Choose the desired pen pattern from the Pen Pattern pop-up
menu in the Attributes palette.

The line or border of the selected object will be changed to reflect the
chosen pen pattern.

You can choose to hide fills, including colors and patterns, on your drawing.
When you turn fills off, only the borders of filled objects appear.

To hide fills:

• Open the Preference menu and choose Hide Fills.

Objects appear as wire frame shapes, and a checkmark appears next to the
Hide Fills command.

To show fills:

• Open the Preference menu and choose Hide Fills again.

Changing the
Pen Pattern of an
Existing Line or
Object

Showing and
Hiding Fills
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Objects will be drawn with their respective fills, and the checkmark

disappears from next to the Hide Fills command.

The attributes that define the appearance of lines and borders are sometimes
referred to as the `pen model' or simply, the `pen'. The attributes for the pen

include pen style, line weight, line style and end marks. The border

position of an object can also be specified. The various options for each
attribute are selected using pop-up menus in the Attributes palette or, in the

case of pen style and border position, from the Preference menu.

Pen color or pattern are discussed in other sections of this chapter.

NOTE: Many of the pen model attributes you choose do not affect only
lines, they also affect the borders of objects. For example, when you select a

certain line weight and color, these attributes will be applied to line

segments used to draw rectangles, circles, polygons and so on.

Line weight refers to the thickness of lines and borders. Line weight is

measured in pixels (picture elements).

There are eleven different line weights. They vary in size from hairline to

13 pixels. The numbers beside the line weights indicate the number of
pixels that make up the line weight.

NOTE: Although the hairline, 0.5 and 0.75 line weights appear as one point
thick on the screen, they will print at their designated weights on any printer

with a resolution of 300 dpi or more.

To select the line weight:

1. Open the Line Weight pop-up menu in the Attributes palette.

2. Drag until the line weight you want is highlighted.

Line and Border
Attributes

Line Weight

Selecting Line
Weights
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3. Release the mouse button. The selected line weight will be
shown on the pop-up menu.

You can change the line weight before or after you draw the line or object.

To draw a line or object with a selected line weight:

1. Return to the pointer mode. (Make sure that no objects on the
drawing are selected.)

2. Choose the desired line weight from the Line Weight pop-up
menu in the Attributes palette.

3. Draw a line or object.

The line or object will be drawn with the specified line weight.

NOTE: The chosen line weight will be used for lines and borders until you

choose another line weight for the default line weight attribute.

To change the line weight of an existing line or object:

1. Select the line or object to change the line weight of.

2. Choose the desired line weight from the Line Weight pop-up
menu in the Attributes palette.

Drawing a Line
or Object With a
Selected Line
Weight

Changing the
Line Weight of
an Existing Line
or Object
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The line or border of the selected object will be changed to reflect the
chosen line weight.

NOTE: For information about how to make line weights appear either
magnified or at their normal size while in a zoomed in view.

The term `line style' refers to whether a line is solid or one of an assortment

of dashed lines. You can use the preset line styles provided with PC Draft or
customize them to make your own. You can use line styles in object

borders and straight lines.

To select the line style:

1. Open the line style pop-up menu in the Attributes palette.

2. Drag until the line style you want is highlighted.

Blade Round

Line Style

Selecting Line
Styles
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3. Release the mouse button. The selected line style will be shown
on the pop-up menu.

You can change the line style before or after you draw the line or object.

To draw a line or object with a selected line style:

1. Return to the pointer mode. (Make sure that no objects on the
drawing are selected.)

2. Choose the desired line style from the line style pop-up menu in
the Attributes palette.

3. Draw a line or object.

The line or object will be drawn with the specified line style.

NOTE: The chosen line style will be used for lines and borders until you

choose another line style for the default line-style attribute.

Drawing a Line
or Object With a
Selected Line
Style
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To change the line style of an existing line or object:

1. Select the line or object to change the line style of.

2. Choose the desired line style from the line style pop-up menu in
the Attributes palette.

The line or border of the selected object will be changed to reflect the

chosen line style.

End marks are symbols on the ends of lines that are used for annotating

drawings. You can make end marks appear on lines by using a set of end

marks in combination with the Line tools, the Polyline tool, the Freehand
Line tool, the Bezier curve tool or the Spline tool.

NOTE: The end marks you can use for the above objects are separate from
the end marks you use for dimension lines .

Changing the
Line Style of an
Existing Line or
Object

End Marks



3 - 39Changing the Appearance of Objects

To select end marks:

1. Open the end marks pop-up menu in the Attributes palette.

2. Drag until the desired end marks are highlighted.

• Drag down the left side of the pop-up menu to choose a left end
mark; it appears at the beginning of a line.

• Drag down the right side of the pop-up menu to choose a right
end mark; it appears at the end of a line.

• Drag down the centre of the pop-up menu to choose both left
and right end marks; these appear at each end of a line.

3. Release the mouse button. The selected end marks will be
shown on the pop-up menu.

You can change the end marks before or after you draw the line or object.

Selecting End
Marks
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Drawing a line or object with selected end marks

To draw a line or object with selected end marks:

1. Return to the pointer mode. (Make sure that no objects on the
drawing are selected.)

2. Choose the desired end marks from the end marks pop-up
menu in the Attributes palette.

3. Draw a line or object.

The line or object will be drawn with the specified end marks.

NOTE: The chosen end marks will be used for lines and borders until you
choose other end marks for the default end marks attribute.

Changing the end marks of an existing line or object

To change the end marks of an existing line or object:

1. Select the line or object to change the end marks of.

2. Choose the desired end marks from the end marks pop-up
menu in the Attributes palette.

The end marks wiil be chended to shosen from pop-up.
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There are three types of border position: Line Inside, Line Centered and

Line Outside. The border position options apply to objects only, not to lines.

All three border positions affect objects differently, these differences are

discussed later in this chapter. In general though, border position is

important with regard to how objects are aligned. PC Draft uses the position
of an object's edit handles to align objects. It is important to keep this in

mind when you align objects, as border position controls the position of the

edit handles relative to the width (that is the line weight) of the border .

Border position applies only to square-corner and rounded-corner

rectangles, parallel line objects, circles and arcs. You can draw these objects

with a certain border position or change the border position of selected
objects.

Border Positions
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To select a border position:

1. Open the Border Position submenu in the Preference menu.

2. Drag until the desired border position is highlighted.

3. Release the mouse button. A checkmark appears next to the
selected border position on the submenu.

You can change the border position before or after you draw the line or

object.

To draw an object with a selected border position:

1. Return to the pointer mode. (Make sure that no objects on the
drawing are selected.)

2. Choose the desired border position from the Border Position
submenu in the Preference menu.

3. Draw an object.

The object will be drawn with the specified border position.

NOTE: The chosen border position will be used for objects until you

choose another border position as the default.

To change the border position of an existing object:

1. Select the object to change the border position of.

2. Choose the desired border position from the Border Position
submenu in the Preference menu.

Selecting Border
Positions

Drawing an
Object With a
Selected Border
Positions

Changing the
Border Positions
of an Existing
Object
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The border of the selected object will be changed to reflect the chosen

border position.

How border position affects objects

Border position determines the location of the edit handles on the border of

an object, and as PC Draft uses the edit handles as reference points for
alignment and size calculations, border position affects the alignment and

size readings of objects.

Line Inside

When you draw an object with the border position

Line Inside, the border of the object appears between

the cursor and the object during creation. When you
select an object created with the border position Line

Inside, the edit handles appear on the outside of the

object. When Show Size is on, the size shown
represents the entire object, including its borders.

Line Centered

When you draw an object with the border position

Line Centered, the cursor appears centered within
the object's borders during creation. When you select

an object created with the border position Line

Centered, the edit handles appear in the center of the
object's borders. When Show Size is on, the size

shown is the size of the object measured from the

center of the object's borders.
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Line Outside

When you draw an object with the border position

Line Outside, the border of the object appears

outside the cursor during creation. When you select
an object created with the border position Line

Outside, the edit handles appear on the inside of the

object. When Show Size is on, the size shown is the
size of the object's interior, excluding the object's

borders.

An object's graphic attributes (fill, pen color or pattern, line weight and line

style etc.) and object information can be copied and applied to another
object using either the Attributes tool or the Copy Attributes and Apply

Attributes commands in the Edit menu. The Apply Attributes command can

be used to apply changes to all of the objects selected, while the Attributes
tool applies changes only to the object clicked.

Any settings for applying attributes will be stored only while the application
is running.

The default options for applying attributes are to apply only graphic
attributes, not object information.

To copy attributes using the Attributes tool:

1. Click the Attributes tool in the Tool palette

2. Click an object.

The default attributes will be applied to the object.

3. With the Attributes tool still selected, hold down the Alt key
and click an object.

Copying
Attributes

Copying
Attributes Using
the Attributes
Tool
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The cursor turns into an empty eye dropper.

The object's pen and fill attributes will be copied

4. Release the Alt key, the cursor turns into a full eye dropper.

5. Click another object to apply the copied pen and fill attributes
to it.
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NOTES:

•      Attributes will be applied only to the object clicked, even if that object
is part of a group.

•      The apply action can be undone by selecting Undo Eye Dropper from

the Edit menu immediately after the apply action.
•      Hold down the Alt key and click in the drawing window with the

Attributes tool, and the tool reverts to the Arrow tool.

Checking and changing attributes before applying them

You can check and, if necessary, change copied attributes before applying

them. There are two ways of doing this when you use the Attributes tool.
The first is to use the Apply Attributes dialog, in which case any changes

will be applied to that action only. The second is to use the Attributes

Options dialog, in which case the settings remain as specified until changed
or until the application is closed.

To open the Apply Attributes dialog before applying attributes to an object:

1. Select the Attributes tool and hold down the Shift key.

The full eye dropper icon is followed by three dots to show that the Apply
Attributes dialog will appear when an object is clicked.

2. Click an object.

The Apply Attributes dialog appears.

Using the Apply
Attributes Dialog
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3. Click the Object Fill, Pen Model, Object Information and
Parallel Fill boxes to specify that these attributes should be
applied to the object you have clicked. Any changes made to
the Apply Attributes dialog relate to this apply action only.

To open the Attributes Options dialog:

1. Hold down the Alt key and click the Attributes tool, or select
the Attributes tool and choose Tool Options from the
Preference menu.

The Attribute Options dialog appears.

2. Click the Object Fill, Pen Model, Object Information and
Parallel Fill boxes to specify that these attributes should be
applied to objects. Settings remain as specified until changed
or until the application is closed, rather than just for the next
use of the tool.

To copy attributes using the Edit menu:

1. Select the object from which you want to copy attributes.

2. Open the Edit menu and choose Copy Attributes.

Using the
Attributes
Options Dialog

Copying
Attributes Using
the Edit Menu
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The object's graphical attributes and object information will be stored.

3. Select the object or objects to which you want to apply these
attributes.

4. Open the Edit menu and choose Apply Attributes.

The copied attributes will be applied to the selected object or objects.
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NOTE: The apply action can be undone by choosing Undo Apply Attributes

from the Edit menu immediately after the apply action.

As when using the Attributes tool, there are two ways of checking and

changing the attributes before applying them when you use the Edit menu.

You can use the Apply Attributes dialog, or use the Attributes Options
dialog.

To open the Apply Attributes dialog before applying attributes to an object:

1. Hold down the Shift key when you choose the Apply Attributes
command in the Edit menu.

The Apply Attributes dialog appears.

2. Click the Object Fill, Pen Model, Object Information and
Parallel Fill boxes to specify that these attributes should be
applied to the selected object or objects. Any changes made to
the Apply Attributes dialog relate to this apply action only.

To open the Attributes Options dialog:

1. Choose Attributes Options from the Edit menu.

The Attributes Options dialog appears.

2. Click the Object Fill, Pen Model, Object Information and
Parallel Fill boxes to specify that these attributes should be
applied to objects. The settings remain as specified until
changed or until the application is closed, rather than just for
the next use of the Apply Attributes command.

There may be occasions when you position a picture object on top of

another object, and want the lower object to show through the background
of the foremost object. PC Draft allows you to do this using the Fill Pattern

pop-up menu in the Attributes palette.

Checking and
Changing the
Attributes Before
Applying Them

Picture
Backgrounds

Using the
Attributes
Options Dialog

Using the Apply
Attributes Dialog
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To make the background of a superimposed picture transparent:

1. Select a superimposed picture.

In the example below, a stylized picture of the sun has been placed on top of

a picture of the world map. Note that the opaque white background of the
sun picture is obscuring part of the map.

2. Choose 'N' (for `No Fill') from the Fill Color pop-up menu, or
`N' (for `No Fill') from the Fill Pattern pop-up menu in the
Attributes palette.

The background of the foremost picture becomes transparent, allowing the

picture beneath to be shown through.

Transparent
Picture
Backgrounds
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The background of a picture can be given a colored or patterned fill in the

same way as other objects. Select the picture and choose a color from the
Fill Color submenu or a pattern from the Fill pattern submenu in the

Attributes palette.

Opaque Picture
Backgrounds
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Annotation describes or gives information about an object in a drawing.  In

PC Draft, annotation is of three kinds:   text, area calculation, and
dimension objects.  Text, in a PC Draft document, consists of all letters,

punctuation, and numbers.  Once text is created, it is recognized as a single

object and you can then use most functions with it, such as moving and
duplicating.

The Text function allows you to use a variety of fonts, styles, and character
sizes.  You can arrange text lines with single spacing, one and a half spacing,

or double spacing.  Text can also be justified to the left, center, or right within

each individual text block.

You can enter text in two ways:  using the regular text mode or the

paragraph text mode.  In the regular text mode, you click on the drawing to
define an insertion point, then type in the text.  You define  the end of a line

of text by pressing the Enter key.  In the paragraph text mode, you drag to

define a text rectangle of a certain size (either with the Text tool or another
drawing tool), and the text you enter into the rectangle automatically

“wraps” when it reaches the side of the rectangle.

To enter regular text, that is, text that does not automatically “wrap”:

1. Activate the Text icon in the palette by clicking on it.

You will notice that when you activate the text icon and then move the cursor

onto the drawing area, the cursor changes into an I-beam pointer.  The I-beam
pointer indicates that you are in the text insertion mode.

2. Position the I-beam pointer where you want to begin inserting
text.

3. Click the left mouse button.

A flashing vertical bar will appear at the point where you clicked to show that

you can now begin typing.

4. Enter the text by typing on the keyboard.

Annotating Your
Drawing

Entering Text

Entering Regular
Text
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You can continue to enter text in various places on your drawing by moving

the I-beam pointer to the desired place, clicking the left mouse button, and
typing.

If you make a typing mistake as you are entering text, simply use the Delete
key to remove the error and then type the correct character.  To  start a new

line in the same text block, just press the Enter key and continue to type.

5. After you have finished entering text, click on the Pointer tool.

On many occasions, you may wish to enter a paragraph of text and restrict it
to a certain rectangular shape, such as a column.  PC Draft’s paragraph text

feature allows you to define a rectangle of any size, then type text into it.  As

you enter the text into the rectangle, the words will automatically wrap
around to the next line when the letters reach the edge of the rectangle.  If you

type to the bottom of the rectangle, the text will scroll within the rectangle to

keep the line you are typing visible.  Paragraph text cannot extend beyond the
drawing edge.

You can define the paragraph text rectangle by drawing a rectangle with the
Text tool, by drawing a rectangle or other object, or by selecting an existing

rectangle or other object.  (If you draw or select a non-rectangular object and

start typing, the text will appear in a rectangle superimposed over the object.)

To use the paragraph text feature with the Text tool:

1. Activate the Text tool.

2. Position the I-beam pointer where you want to begin entering
text.

3. Press down the left mouse button.

4. Holding down the left mouse button, drag in a diagonal
direction until you have defined a rectangle that is the size you
want.

Entering
Paragraph Text



Annotating Your Drawing 4 - 3

7. When you are done, click on the Pointer tool to end the text
entry.

To use the paragraph text feature with the Rectangle tool (or other drawing

tool):

1. Activate the Rectangle tool (or other drawing tool).

2. Position the pointer where you want to begin entering text.

3. Press down the left mouse button.

4. Holding down the left mouse button, drag in a diagonal
direction until you have defined an object that is the size you
want.

5. Release the left mouse button.

NOTE:  The text and the object you drew to locate the text are separate
objects; you can move and reshape them separately.

To use the paragraph text feature with an existing rectangle or other shape:

1. Select the object.

2. Start entering text from the keyboard.

6.     Start entering text from the
keyboard.

7.      When you are done, click on
 the  Pointer tool to end the text
 entry.

5.     Release the left mouse
button.

6.     Start entering text from the
keyboard.
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Selecting Text
for Editing

Reshaping a
Block of
Paragraph Text

3. When you are done, click on the Pointer tool to end the
text entry.

NOTE:  The text and the object you selected to locate the text are separate

objects; you can move and reshape them separately.

Once the paragraph of text is entered, you can reshape the paragraph using

the edit handles.  To reshape the paragraph:

1. Return to the pointer mode.

2. Select the paragraph of text by clicking on it.

Edit handles should appear on the text block.

3. Position the tip of the pointer on one of the edit handles.

Sometimes you will want to edit text you have previously entered on your

drawing.  PC Draft has three ways to edit text:  replacing an existing word or

line of text by selecting it and retyping in its place; inserting characters or
words at any selected point in the text; and backspacing to delete text.

Before you can edit a piece of text, you must select it.  You can select text by
using the pointer while in the pointer mode, or by using the I-beam pointer.

(When you select text using the pointer mode, any changes you make will

affect the entire text block.)

4.     Press down the left
mouse button.

5.     Holding down the left
mouse button, drag
until the paragraph
is the shape you want.

 6.    Release the left mouse
button.
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Using the I-Beam
Pointer

Selecting a Word

Extending the
Selection of  Text

Selecting a
Range of Text

To select text using the I-beam pointer:

1. Click on the Text tool icon in the palette.

2. Position the I-beam pointer to either side of the text you want to
change.

3. Press down the left mouse button.

Notice that the text becomes highlighted as you drag through it.  Using this

method of selecting allows you to select a single character or an entire block
of text.

You can select an individual word by double-clicking on it.

To select a word:

1. Position the I-beam pointer on the word you want to select.

2. Double-click the left mouse button.

Once you have double-clicked on a word, you can extend the selection to

include other words in the text block by following these steps:

1. After the second click, hold the left mouse button down.

2. Drag through the text until all the words you want to select are
highlighted.

3. Release the left mouse button.

You can select a range of text in a block, including multiple lines of text, by
using the Shift-click method.

4.     Holding down the left mouse
button, drag through all the text
you want to  edit.

5.     Release the left mouse button.
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Using the Arrow
Pointer to Select
Text

Selecting Rotated
Text for Editing

To select a range of text:

1. Position the I-beam pointer at the starting point for the range.

2. Click the left mouse button.

3. Press down the Shift key.

4. Position the I-beam pointer on the ending point for the range.

5. Holding down the Shift key, click the left mouse button.

6. Release the left mouse button and the Shift key.

The text between the specified starting and ending points will be selected.

To select text using the arrow pointer:

1. Position the pointer tip on the block of text that you want to
select.

2.  Click the left mouse button.

Notice that a rectangle and/or a set of edit handles appears around the text,

indicating that it is selected.  This method of selecting text allows you to

change the text attributes (including the font, size, and style) of the selected
text block.

To select rotated text:

1. Activate the Text tool in the palette.

2. Click on the block of rotated text you want to edit.

The text will temporarily be rotated to zero degrees (horizontal orientation) to
allow you to edit it.



Annotating Your Drawing 4 - 7

Selecting All
Text

Hiding All Text

Redisplaying All
Text

When you are through editing the text:

3. Click on the Pointer tool.

Once you click on the Pointer tool, the text will return to its rotated position.

NOTE:  If you print rotated text on most printers that are not PostScript®-

compatible, the text will print out at the resolution of the printer hardware.

You can select all the text on the active layer if you want to make a global

change to text attributes.  This feature is useful if you change the scale of the

drawing and then want to change the size of the text to make it  conform with
the new scale.

To select all the text on the drawing:

1. Return to the pointer mode.

2. Open the Text menu and choose Select All Text.

At times, you may want to temporarily remove the display of all text from the
document.  If you choose to hide the text and then print or plot the document,

the text will not appear on the output.  You might use this feature to hide all

the text before you generate a test plot of a drawing to shorten the plotting
time.  If you are working on a complex drawing with many elements, you

could use this feature to minimize the amount  of time it takes to redraw the

screen after you scroll or zoom.

To hide all text:

• Open the Text menu and choose Hide Text.

All the text on the drawing will be temporarily removed from the screen and
from any output until you choose to re-display the text.  A check mark will

appear beside Hide Text in the Text menu.

When you want to make the text appear on the screen and on your output, you

can choose the Hide Text command again.
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Replacing
Existing Text

Inserting Text
Into Existing
Text

Deleting Selected
Text

To redisplay all text:

• Open the Text menu and choose Hide Text (with the check
mark).

The check mark will disappear from beside Hide Text in the Text menu, and

the text in the drawing will be visible.

Once you have selected any portion of text, you can immediately replace it by

simply typing in the new text.  As soon as you begin typing, the old text will

disappear.  As you enter the new text, all of the non-selected text in the line
will automatically adjust to make room for the text you are entering.

On many occasions you will want to insert a single character, a word, or a
sentence into an existing piece of text.

To insert text:

1. Activate the Text tool in the palette by clicking on it.

2. Position the I-beam pointer on the desired insertion point.

3. Click the left mouse button.

4. Type in the character or words that you wish to insert.  (Keep in
mind that you can press the Delete key to backspace over
characters or words.)

In this mode, you can continue to pick insertion points in other pieces of text
on your drawing and edit them as well.

Once you have completed all the editing that you want to do:

5. Click on the Pointer icon in the palette.

There are two simple ways to delete text that you have selected.  You can

either:

•  Open the Edit menu and choose Cut or Clear
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or,

•   Press the Delete key

You can choose the way you want to present text either prior to entering the

text, or by changing the text after it has been entered.  There are many options
to choose from to obtain the effect that you desire.  PC Draft allows you to

use many different font types, sizes, and styles for text.

To define attributes for text before you enter it:

• Make sure that no text is selected on the drawing before you
make each choice.

To define the font, size and style:

1. Open the text menu and select Font.

Changing the
Appearance of
Text

Determining
Font, Style, and
Size Before Text
Entry
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Changing the
Appearance of
Existing Text

Changing the
Case of Text

2.  Select the font, size and style that you want.

3. Click on the OK button.

After you have made your choices for text:

1. Activate the Text icon in the palette by clicking on it.

2. Position the I-beam pointer where you want to add text.

3. Click the left mouse button.

4.  Enter the text on your drawing.

You can change the font, size, and style of any existing text.  You can check

to see which attributes a given piece of text possesses by selecting the text

and the submenu associated with the attribute of interest.

To assign an attribute to text on the drawing:

1. Select the text you wish to change.  (You can select and change
single characters using the Text tool’s I-beam cursor, or all the
words in a text block using the pointer.)

2. Choose the text attributes you want from the Text menu’s Font.

Each time you make a choice from the Text menu, the selected text will

change to reflect that choice.

On some occasions you may enter a piece of text in one case, such as

lowercase, and then decide that you want it in uppercase or in title format.

You could clear the text and re-enter it; however,  PC Draft offers you the
ability to change the case of existing text.

To change the case of text:

1. Select the text that you want to change by clicking on it.

2. Open the Text menu’s Case submenu.
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3. Drag until the case option you want is highlighted.

The results of each choice are as follows:

UPPERCASE: Converts all selected text to uppercase.

lowercase: Converts all selected text to lowercase.

Title Text: Capitalizes the first character of each word in
selected text.

PC Draft offers you flexibility in choosing line spacing (also called
“leading”) options to suit your needs.  You can have one, one and a half, or

two spaces between lines of text.  You can choose the line spacing attribute

prior to entering text, or you can change the spacing on existing text.

To choose the line spacing prior to entering text:

1. Make sure that no text is selected on the drawing.

2. Choose Line Spacing from the Text menu.

The Line Spacing submenu will appear.

Choosing Line
Spacing

Choosing the
Line Spacing
Before Entering
Text
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Changing the
Line Spacing of
Existing Text

Moving Text

3. Drag  the cursor until the line spacing you want is highlighted.

4. Click the left mouse button.

5. Enter text as you would normally.

To change the line spacing of existing text:

1. Select the block of text to be changed by clicking on it.

2. Choose Line Spacing from the Text menu.

The Line Spacing submenu will appear.

3. Drag the cursor until the line spacing you want is highlighted.

4. Click the left mouse button.

Once you have created a block of text, you can move it to a different location

on your drawing if you want.  Notice that when you create a line of text and

then click anywhere else, the text becomes surrounded by a box or edit
handles.  This indicates that PC Draft recognizes the piece of text as an

object.  You can move the text just as you would move any other object.

To move a piece of text:

1. Point on the text block.

2. Press down the left mouse button and hold it until the white
arrow pointer appears.
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Aligning Text

Justifying Text
During Text
Entry

Aligning Text as
an Object

3. Drag the text to its new position.

4. Release the left mouse button.

There are two ways to align text:  justifying a line of text with another line
during text entry; and aligning text with an object or another piece of text that

is treated as an object.

To justify text as you enter it:

1. Make sure that no text is selected on the drawing.

2. Open the Text menu’s Justification submenu.

3. Drag until the type of justification you want (Left, Center, or
Right) is highlighted.

4. Click the left mouse button.

5. Activate the Text tool by clicking on it.

6. Click where you want the text to appear.

7. Begin typing.

Notice that each time you press the Enter key, the next line of text is justified
according to your choice (Left, Center, or Right).

You can change the justification of an existing text block by selecting the text
block and then choosing the justification option you want from the Text

menu’s Justification submenu.

To align text with another piece of text or an object:

1. Select the piece of text to be aligned by clicking on it.

2. Choose  Alignment from the Window menu to open the
Alignment palette.
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Dimensions

3. Once the Alignment palette is displayed, choose the alignment
method you want.

5. Click on the object with which you want the  text block aligned.

Once you have clicked on one of the text blocks, all selected text and objects

will snap into alignment with the text on which you clicked according to the

specified alignment attribute.

For more information on using the Alignment palette, see the section called

“Aligning Objects,” beginning in Chapter 5.

PC Draft’s Dimension tools allow you to add dimension lines to your

drawing so that you can display and print the sizes of (or distances between)
various lines and objects.  Dimensions display sizes and distances in real-

world units according to the scale of the drawing.

Dimension lines in PC Draft show the distance between two points on the

drawing.  If you change the length of the dimension line, the value

associated with it will be updated to reflect the new length, according to the
current scale.

In addition, PC Draft can show and print the size of an angle. Angular
dimensions appear in degrees of arc, regardless of the scale of a drawing.

Like dimension lines, angular dimension objects display updated values

after editing.

PC Draft’s dimensions are specialized objects that can incorporate a range

of recognized drafting formats and standards, including witness lines,
extension gaps, and so on.

The dimension objects are created and controlled using the tools and popout
menus of the Dimension Palette. The Dimension Palette can be displayed

using the Window menu.

The dimension tools can create linear (horizontal, vertical, sloped, or

perpendicular), radial (radius or diameter), and angular dimensions.

Types of
Dimension
Objects
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Linear dimensions can consist of a single dimension span, as shown below.

Linear dimensions are created independently of existing objects, but can use
existing vertices, corners, and so on as their points of reference. If the Snap

to Object feature is active, the dimension tools will snap the reference

points to existing corners and handles.

Radial dimensions appear as straight lines (like linear dimensions), but

measure the radius or diameter of an existing circle, ellipse, or arc.

Angular dimensions measure the angle of arc between any two straight lines

or edges of square-cornered rectangles, polygons, or polylines (single-line

or parallel). The lines or edges need not intersect.

In addition to the three types of dimension tools, PC Draft includes a Circle

Center mark tool, for marking the center of a circle, arc, or ellipse.
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PC Draft’s dimension objects include linear (horizontal, vertical, sloped, or

perpendicular), radial (radius or diameter), and angular dimensions.  The
creation of each type is detailed over the following pages.

Once created, dimension objects can be independently resized and edited
much like other PC Draft shapes. In addition, their attributes, such as color,

line style, text font, and so on can be controlled in the standard fashions.

Different components of a dimension object can be treated independently
once the object is disassembled using the Accessory palette’s Break tool.

PC Draft’s linear dimension tools (horizontal, vertical, slope, and
perpendicular) let you display and print distances between points.

The user-defined reference points for linear dimensions can be either part of

existing objects (on corners or edges) or independent points on the drawing.

To show an object’s size precisely, it’s usually necessary to put the

dimension’s reference points on the object’s corner points (or other edit
handles).

The horizontal and vertical dimension tools create dimension lines that are
constrained to horizontal or vertical orientations. When edited, moved, or

resized, horizontal and vertical dimension objects retain their original angles

of orientation.

Drawing
Dimension
Objects

Linear
Dimension
Objects
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To create a single horizontal dimension line:

The cursor will now read “1st point.”

2. Click the first point for the dimension line (on an object's
corner, if desired).

The cursor will now read “2nd Point.”

3. Click the second point for the dimension line.

The cursor will now read “Anchor,” and include an outline of the

dimension’s text box.

The slope dimension tool can create dimension

lines running in any direction on a drawing.
Slope dimensions can be edited, moved, or

resized to any angle.

The perpendicular dimension tool creates

dimensions perpendicular to lines or to the

edges of square-cornered rectangles, polygons,
and polylines (single-line or parallel). When

edited, moved, or resized, perpendicular

dimension objects retain their original angles
of orientation.

Horizontal
Dimension
Objects

1. Select the horizontal dimension
tool from the Dimension palette.
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4. Click on the drawing where you want the text value to appear.

The dimension object will be complete, with the horizontal distance

between the two points displayed where you specified.

To create a single vertical dimension line:

The cursor will now read “2nd Point.”

3. Click the second point for the dimension line.

The cursor will now read “Anchor,” and include an outline of the

dimension’s text box.

4.  Click on the drawing where you want
     the text value to appear.

The dimension object will be complete, with the vertical distance between

the two points displayed where you specified.

To create a single slope dimension line:

1. Select the slope dimension tool from the Dimension palette.

The cursor will now read “1st point.”

Vertical
Dimension
Objects

1.    Select the vertical dimension tool from
the Dimension palette. The cursor will
now read “1st point.”

2.    Click the first point for the dimension
line.

Slope Dimension
Objects
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The cursor will now read “2nd Point.”

3. Click the second point for the dimension line.

The cursor will now read “Anchor,” and include an outline of the
dimension’s text box.

4. Click on the drawing where you want the text box to appear.

The dimension object will be complete, with the distance along the slope

between the two points displayed where you specified.

PC Draft has a specific tool for creating dimension lines perpendicular to
existing lines or to the edges of square-corner rectangles, polygons, or

polylines (single-line or parallel).

To create a perpendicular dimension line:

1.    Select the perpendicular dimension
                     tool from the Dimension

palette.

Perpendicular
Dimension
Objects

2. Click the first  point for the
dimension line.
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The cursor will now read “Click Line/Edge.”

2. Click the line or edge for the first point of the dimension line.

The cursor will now read “2nd point.”

3. Click the second point for the dimension line.

The cursor will now read “Anchor,” and include an outline of the

dimension’s text box.

4. Click on the drawing where you want the text box to appear.

The dimension object will be complete, with the perpendicular distance
from the edge of the object to the point you chose displayed.
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NOTE: If you hold down the Alt key while drawing a perpendicular

dimension line, its length will be constrained to increments of the current
snap-grid distance.

If you move, edit, or resize the perpendicular dimension line, it will retain

its original orientation (its “perpendicularity”).

PC Draft’s radial dimension tools let you display and print the radius or
diameter of a circle, arc, or ellipse.

To apply a radial dimension to an object:

1. Select the radial dimension tool from the Dimension palette.

         

Radial
Dimension
Objects

The cursor will now read “Click Circle/

Arc.”

2.  Click the circle, arc, or ellipse.
The cursor will now read “Anchor,” and
include an outline of the dimension’s text

box.
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NOTE: To constrain the angle of the dimension line to 45° increments,

hold down the Shift key after selecting the circle, while clicking the anchor
point where the dimension text is to appear.

3. Click on the drawing where you want the text value to appear.

The dimension object will be complete, with the radial distance displayed

where you specified.

Diameter dimensions are drawn in much the same manner.

 To create a diametric dimension:

NOTE: To constrain the angle of the dimension line to 45° increments,

hold down the Shift key after selecting the circle, while clicking the anchor

point where the dimension text is to appear.

1.  Select the diameter dimension tool
from the Dimension palette.
The cursor will now read “Click Circle/

Arc.”

2.  Click the circle, arc, or ellipse.
The cursor will now read “Anchor,” and
include an outline of the dimension’s text

box.

Diameter
Dimensions
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3. Click on the drawing where you want the text box to appear.

The dimension object will be complete, with the diametric distance

appearing where you specified.

PC Draft includes a special tool for indicating the center of circles, ellipses,
and arcs. It appears in the Dimension palette.

NOTE: Circle Center marks cannot be applied to ellipses and elliptical arcs
that have been rotated.

To apply a Circle Center mark:

1. Select the Circle Center Mark tool in the Dimension palette.

The Circle Center mark will appear over the object

Circle Center
Marks

The cursor will read “Click Circle/Arc.”

2.  Click the circle, arc, or ellipse.
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PC Draft’s angular dimension tool lets you display and print the angles

between different lines or edges, whether they intersect or not. You can
apply an angular dimension object to any pair of straight lines or edges of

square-cornered rectangles, or polygons or polylines (single-line or

parallel).

To create an angular dimension:

1. Decide which two lines or edges you want to apply a dimension
object to.

The cursor will now read “1st Line/Edge.”

3. Click the first line or edge.

The cursor will now read “2nd Line/Edge.”

4. Click the second line or edge.

The cursor will now read “Anchor,” and include an outline of the

dimension’s text box.

5. Click on the drawing where you want the text value to appear.

Angular
Dimension
Objects

2     Select the angular
dimension tool from the
Dimension palette.
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The dimension object will be complete, with the angle between the two

edges displayed where you specified.

NOTE: To display the obtuse rather than acute angle between two lines or

edges, hold down the Alt key after selecting the second edge, while clicking

the point where the dimension text is to appear.

PC Draft’s automatic Area Calculation feature can determine and display the

area of a selected object for you.  If you later change the size of the object, the

displayed size is changed automatically.

This feature can calculate the areas of simple objects, like rectangles and

circles, or complex objects, such as complex polygons and freehand shapes.
When the area of an object is calculated, it always reflects the current scale

and units of the drawing.

There are two ways to use this feature:  to calculate the areas of individually

selected objects, or to obtain the net area of several overlapping objects.

These two methods are explained below.
1. Select the object whose area you want to determine.

2. Open the View menu and choose Show Area.

Area Calculation

Calculating the
Area of
Individual
Objects
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Once you have made your choice, the area will be displayed approximately in
the center of the object.

There might be occasions when you will want to calculate the net area of
objects that overlap.  Selecting each object and choosing Show Area will only

calculate the areas of the individual objects — and totalling those figures

would yield a larger value than the actual net area.  To obtain the net area of
overlapping objects, you need to trace the borders of the area to be calculated

using either the polygon or freehand drawing tool.  (What you are actually

doing is creating a shape that overlays your existing set of objects.)  PC Draft
will treat the resulting traced shape as an individual object.  By choosing

Show Area for this object, you can obtain the net area of all of the

overlapping objects.

To calculate the net area using the Polygon tool to trace the boundary, follow

these steps:

1. Activate the Polygon icon in the palette.

2. Trace the outermost borders of the overlapping objects.

Once you have finished tracing the boundaries of the overlapping objects, the
polygon will be complete.  It should already be selected.  If it is not, click on

the polygon to select it.

3. Open the View menu and choose Show Area.

After you have done so, the polygon will appear like the figure below.

Calculating the
Net Area of
Overlapping
Objects
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The area value displayed will be the net area, and the portions of the objects

that overlap will be compensated for.  If you want to see the individual

objects that are currently hidden by the polygon, choose N (for No fill) from
the Fill Pattern submenu before you trace the boundary.

NOTE:  If the overlapping objects contain reshaped objects, you will have
to use the freehand drawing tool or one of the curve tools to trace them,

thereby obtaining an approximation of their net area.

To hide the Area Calculation display:

1. Select the object with the area display you wish to hide.

2. Open the View menu and choose Hide Area.

There may be many occasions when you will want to have control over the
appearance and/or positioning of area values.  PC Draft uses the current font

attributes for such values.  These attributes include the current attributes for

the font type and size.  PC Draft uses the Windows system font (usually 12-
point Arial) as the preset font and size when you create a new document.

There may be times when this font size is inconvenient, such as when you are

displaying area values on small objects, and the size of the text value
overwhelms the size of the object.

For this reason, PC Draft gives you the flexibility to change the values of font
type and size.  In addition, it allows you to separate the values from their

related objects and move them to any location on your drawing.  In the case

of small objects with area values, you can move the displayed values away
from the object.  If you want to tidy up your drawing, you can move these

values into an information table.  Remember, if you change the size of an

object, the calculated value in the table will automatically be updated to
reflect the object’s or line’s new size.

Hiding the Area
Calculation
Display

Modifying or
Moving Area
Calculation
Values
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1. Return to the pointer mode.  (Make sure that no objects on the
drawing are selected.)

2. Open the Text menu’s Font submenu and choose the font, size
and style you want.

1. Select the area value you want to change.

2. Open the Font submenu and choose the font you want.

3. Open the Size submenu and choose the size you want.

NOTE:  If you are a PostScript printer user, you can choose a laser printer
font to obtain a high-quality output.

You can move or detach the text of area values from objects.  The Ungroup

command will detach area calculation values completely, and the  Shift key
can be used to move area calculation values away from objects.

By selecting the object and then choosing Ungroup, you can detach the text
value and move it to a different location on the drawing, where it will remain

even if you move the object.  This unique feature offers an extreme level of

flexibility, especially if you want to place the values into an information
table.

By holding down the Shift key, you can move the area calculation value away
from an object.  If the object is then moved to a different location on the

drawing, the text will move with the object and maintain the same position

relative to the object.  For example, suppose you detached area value from a
rectangle, then moved the value one grid division above the rectangle.  If you

dragged the rectangle to the left, the value would follow the rectangle’s

movement, but it would still remain one grid above it.

To Change the
Font Attributes
for Existing Area
Calculation
Values

Moving Area
Calculation
Values

To Change the
Font Attributes
Before You Use
Show Area
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To move or detach text values by ungrouping the text from an object:

1. Select the area value you want to move.

2. Open the Arrange menu and choose Ungroup.

3. Click on a blank part of the drawing to deselect the object and
value.

4. Position the tip of the pointer on the text value.

5. Press and hold down the left mouse button.

6. Holding down the left mouse button, drag the text to the desired
location (into an information table, for example).

7. Release the left mouse button.

Now if you move the object with a calculated area, the value will remain
where you placed it.  The value will remain associated with the object.  This

means that if you change an object’s area, the value in the table will be

automatically updated to reflect the new area.

To move an area value using the Shift key method:

1. Position the tip of the pointer on the area value.

2. Press down the Shift key.

3. Press and hold down the left mouse button.

4. Release the Shift key.

5. Holding down the left mouse button, drag the value to the
desired location.

6. Release the left mouse button.

Using the Shift
Key Method to
Move Values

Using Ungroup
to Detach and
Move Values
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If you want to constrain the movement of the value to a horizontal or vertical

direction, keep the Shift key down as you drag.



Chapter 5

Moving and
Arranging

Objects





Moving and Arranging Objects                     5 - 1

Moving Objects

Using the Select
and Drag
Method

Be careful not to position the pointer on an edit handle when you move an

object.  Edit handles are for changing the size and shape of an object.

When you drag objects, ghost images of the objects will be visible as you

drag them.  When you drag an object or group of objects, the original stays in

place until you release the left mouse button.

3. Press and hold down the left
mouse button until the white
arrow pointer appears.

4. Holding down the left mouse
button, drag the object to the
new position.

5. Release the left mouse button.

Often you may create an object, then decide to move it to a new location on
your drawing.  PC Draft allows you to move lines and objects to any location

within your drawing.  There are four methods you can use to move objects:

selecting and dragging; cutting or copying, then pasting; the Move command;
and the Position command.

To move an object using the select and drag method:

1. Select the object you want to move by clicking on it.

2. Point on the object.
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Constraining the
Movement of
Objects

Using Cut, Copy,
and Paste

To Cut and Paste
an Object

If you drag an object beyond the borders of the drawing area, the drawing will
automatically scroll to keep the object visible.

If you want to move multiple objects or grouped objects, simply select the
objects or group you want to move, then drag the objects or group to a new

position.

If you hold down the Shift key while you are moving objects, the object's

movement will be restricted to a horizontal or vertical direction.

By using the Cut and Paste functions, you can remove objects from one

location of your drawing, then paste them in a different location.  The Cut
function deletes selected objects from the drawing and places them on the

Clipboard.  The Copy function makes a copy of selected objects and places

the copy on the Clipboard, while leaving the original objects in place.  You
can place several objects on the Clipboard as long as they are selected and cut

or copied at the same time.  The objects are stored on the Clipboard until you

use Cut or Copy on a different object.

1. Select the object you want to move.

2. Open the Edit menu and choose Cut.

Notice that the selected object is removed from the drawing.

3. Position the pointer where you want to paste the
cut object.

4. Click the left mouse button.

5. Open the Edit menu again and choose Paste.
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To Copy and
Paste an Object

Using the
Repeated Paste
Function

Once you have chosen Paste, the object will reappear where you clicked on
the drawing. (Or, if you didn’t click anywhere, in the center of the drawing

window.)

The Copy and Paste functions allow you to make a copy of an object and

paste the copy into another area of the drawing without affecting the status of

the original.

To copy an object and paste the copy into a different location:

1. Select the object you want to copy.

2. Open the Edit menu and choose Copy.

A copy of the object will then be stored on the Clipboard for your use.

3. Position the pointer where you want to paste the copy, then click
the left mouse button.

4. Open the Edit menu again and choose Paste.

The object will be pasted into this new location.

You can continue to paste objects that have been cut or copied into as many

areas on your drawing as you like by simply selecting the insertion point, and
choosing Paste from the Edit menu.  The objects will remain on the Clipboard

until you cut or copy a different object on your drawing, at which time the

first object will be erased from the Clipboard and replaced with the new
object.

You may often want to use an object within your drawing in more than one
location.  To accomplish this you can use either the Copy and Paste functions,

as described above, or the Duplicate function.  These functions will save you

the time of re-drawing the object again and again.

You can use the Repeated Paste function, accessed from the Edit menu, to

paste multiple copies of the same object into various locations on a drawing.
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To use the Repeated Paste function:

1. Copy the object you want.

2. Open the Edit menu and choose Repeated Paste.

When you choose Repeated Paste, the pointer changes to an “X,”  and any

object on the Clipboard (that is, the object you cut or copied) is pasted into

the drawing at each point you click on.  While in this mode, you can scroll the
window and continue to paste objects.

3. Click where you want the object to appear.

4. Repeat the last step until you’ve pasted as many copies of the
object as you want.

A copy of the object will appear at each point you click on the drawing.  The
object’s datum point will be used as the reference point for the paste

operation.

5. Click on the Pointer tool when you are done pasting.

PC Draft allows you to cut/copy and then paste all or part of a drawing into

another PC Draft document.

To cut or copy part of a drawing:

1. Select all or part of the drawing you wish to move.

Using cut/copy
and paste to
transfer items
from one PC
Draft document
to another
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2. Open the Edit menu and choose Cut or Copy.

The selected objects will be stored on the Clipboard.

To paste objects into a different PC Draft document:

1. Open the document where you wish to paste the objects stored
on the Clipboard.

2. Point where you want to paste the objects into the drawing.

3. Click the left mouse button.

4. Open the Edit menu and choose Paste.

The objects that you cut or copied will be pasted into the specified area.

NOTE:  When you cut or copy objects from one drawing and paste them

into another drawing, the objects that you pasted will automatically take on
the scale of the new drawing.  For example, if you were to cut or copy an

object from a drawing with a scale of 1" = 20', and then paste it into a

different drawing with a scale of 1" = 10', the object would appear twice as
large as it did on the original drawing.  In reality, the object is still the same

size, but it is represented at the new scale.

With the Edit menu’s Move command, you can move objects or groups

with great precision by entering values from the keyboard. The coordinates
of the selected objects are shown in the current layer’s scale and units.

The “Move a Copy” option sends a copy of the selection to a particular
location while leaving the original in place.

The datum point of the selected object or group (see Chapter 2 for
information about datum points) is used as the reference for moving.

Therefore, to move an object, you specify the desired location (the X and Y

coordinates) of the object’s datum point. If you select multiple objects or
groups, PC Draft will use the datum point of the top left item as the

reference.
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To move objects or groups to a particular location on the drawing:

1. Select the objects or groups you want to move.

2. Open the Edit menu and choose Move.

The Move dialog box appears, displaying the current location of the

selection (for example, 2 3/4" from the top edge of the drawing and 2 1/16"
from the left).

3. Type in the X and Y coordinate values for the new location.

4. If you want to leave the original in place, moving only a copy,
check Move a Copy.

5. Click on the Move button.

The selection is moved to the new location.

The default zero origin for both rulers (the point where X=0 and Y=0) of

the coordinate system is the upper left corner of the window. The rulers

along the top and left sides of the window are used to control the zero
origins. In this default coordinate system, X values increase from left to

right and Y values increase from top to bottom.

You can change the zero origins of the rulers. For instructions on how to do

this, see “Setting the Rulers’ Zero Points” in Chapter 6.
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NOTE: If the move operation requires the object to be moved beyond the

edge of the drawing, an error message will appear.

Objects can be removed from the drawing using the Clear function.  Clearing

an object deletes it permanently.  However, it can be recalled by using Undo

before you perform any other action.

1. Select the object to be deleted from the drawing by clicking on
it.

2. Open the Edit menu and choose Clear.

The selected object will be erased from the drawing.

1. Select the objects to be deleted from the drawing by Shift-
clicking on them, or by using the selection rectangle.

2. Open the Edit menu and choose Clear.

There might be times when you want to throw away all the contents of the

drawing and start over again.  To accomplish this:

1. Open the Edit menu and choose Select All.

Notice that all the objects on the active layer are now selected.

2. Open the Edit menu again and choose Clear.

NOTE:  You can also press the Delete key to delete selections.

The Duplicate command makes an exact copy of any object or line you have

created.  The duplicate object is placed on top of the original in a slightly
offset position, and is selected.  You can then drag the duplicate into position

on your drawing.

To duplicate an object:

Using the Clear
Function

To Clear a Single
Object

To Clear
Multiple Objects

To Clear the
Entire Contents
of a Drawing

Duplicating
Objects
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1. Select the object you want to duplicate.

To make a second or third duplicate, simply choose the Duplicate command
again, and again.  Each new duplicate will appear on top of the previous one

in a slightly offset position.

If you want to create a row or column of identical, evenly spaced objects, the

Duplicate function incorporates an auto-spacing feature that allows you to

determine the distance and angle you want between objects.  You can then
make new duplicates that will be automatically placed at that distance and

angle.

To automatically distribute duplicates during creation:

1. Select the object to be duplicated.

2. Open the Edit menu and choose Duplicate.

3. Position the pointer on the selected duplicate.

4. Holding down the left mouse button, drag the duplicated object
to the desired position, relative to the original.

5. Release the left mouse button.

6. Open the Edit menu and choose Duplicate again.

Notice that the second duplicate is automatically placed. Keep choosing

Duplicate to produce as many duplicates as you need.

Auto-Spacing of
Duplicate
Objects
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NOTES:

•    Hold down the Shift key and choose the Duplicate command to create
duplicate with no offset. Use this option to create a duplicate that is placed

directly on top of the original.

•    Hold down the Control+Alt key to avoid duplicating locked objects. All
other objects in the selection will be duplicated.

You can use the commands in the Arrange menu to manipulate the positions

of objects.  You can perform the following actions using the commands in
the Arrange menu:  align objects, flip objects, group and ungroup objects,

send objects to the back, bring objects to the front, move objects forward

and backward, lock and unlock objects, and distribute objects on a line.  The
commands in the Arrange menu affect the objects on the drawing.

When you create multiple objects on the drawing, the newest object created

appears on the top plane, while the oldest object appears on the bottom plane:

each new object appears on the plane above the last object.  At times, you
might want to move an object in front of or behind other objects on the

drawing.  The functions that allow you to do this are Bring to Front, Send to

Back, Move Forward One, and Move Back One.

If an object is currently behind other objects, you can move it in front of the

other objects by using the Bring to Front function.

To bring an object to the front:

1. Select the object you want to move to the
foreground.

2. Open the Arrange menu and choose Bring to Front.

Arranging
Objects

Bring to Front
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To reposition an object behind all other objects on the drawing:

1. Select the object you want to move to the background.

2. Open the Arrange menu and choose Send to Back.

To move an object forward one level:

1. Select the object you want to move forward.

2. Open the Arrange menu and choose Move Forward One.

To move an object back one level:

1. Select the object you want to move back one level.

2. Open the Arrange menu and choose Move Back One.

Sometimes you might create an image that includes several individual
objects.  In such instances, you might want to group the individual objects

together so that you can treat them as a single object.  When objects are

grouped together, most functions you choose thereafter will be performed on
the entire group just as though it were a single object.

To group several objects together:

1. Select all objects that you want in a group.

Move Forward
One

Move Back One

Send to Back

Grouping
Objects
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2. Open the Arrange menu and choose Group.

Notice that the objects are now surrounded by a single set of edit handles.
This indicates that all objects within the edit handles are part of this group

and will be treated as a single object.  You can perform any function on the

group, such as move, duplicate, or fill, and the entire group will respond to
that command.  Once you have grouped several objects, you cannot

reposition or edit any individual object or piece of text within the group

unless you first ungroup the objects.

There may be times when you would like to enlarge or reduce the size of a

group of objects (objects that have been grouped together using the Group
function).  PC Draft gives you the ability to change a group’s size

proportionally or non-proportionally  (vertically or horizontally).

By changing the size of a group proportionally, you can maintain the original

shapes of the individual objects within the group.  Objects within the group

will become larger or smaller without becoming distorted.

To proportionally resize a group of objects:

1. Select the group you want to resize.

2. Position the tip of the pointer on one of the edit handles on the
corners of the group.

3. Press down the left mouse button.

4. Holding down the left mouse button, drag until the group is the
size you want.

5. Release the left mouse button.

Resizing Groups
of  Objects
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The grouped object will change in size proportionally to its original size.

To resize a group of objects non-proportionally:

1. Select the group you want to resize.

2. Position the tip of the pointer on one of the edit handles on the
corners of the group.

3. Press down the left mouse button.

4. Holding down the left mouse button, press the Alt key.

5. Holding down the left mouse button and the Alt key, drag until
the group is the size you want.

6. Release the left mouse button and the Alt key.

There are some unique advantages that you should know about when you

change the size of a group.  Because several of PC Draft’s features are
automatic, they are conveniently active when you change the size of a group.

If any of the objects in the group contain an area calculation display, the area

of each of those objects will be recalculated automatically to reflect the new

size of the object.

If any of the objects in the group are dimension lines, the numerical value of

the dimension line will automatically change to reflect the new length.

Effects of Group
Resizing on
Automatic
Features

Automatic Area
Calculation

Dimension Lines
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If the Show Size window is displayed, it will indicate the overall size of the
group.

If you no longer require a set of objects to be grouped, or if you need to edit
one of the individual objects, you can use the Ungroup function to return the

objects to their individual status.

To ungroup objects:

1. Select the group of objects by clicking on one of the objects.

2. Open the Arrange menu and choose Ungroup.

Notice that each object has its own set of edit handles again.  This is an

indication that the objects are no longer part of a grouped set, and that you

can now select and edit each object individually.

The Alignment palette provides tools for you to carry out the most common

alignments without having to access the Alignment Options dialog.

To display the Alignment palette:

• Choose Alignment from the Window menu, or

• Choose Alignment from the popup menu at the bottom left of
the document window.

Show Size

Ungrouping
Objects

Alignment
palette



5 - 14 Moving and Arranging Objects

NOTE: The remaining buttons are used to distribute objects along a line.

To use the Alignment palette:

1. Select the objects to be aligned.

2. In the Alignment palette, click on the desired alignment button.

The Click Reference Object will appear.

3. Click on the object to align the other object(s) with.

The objects will be aligned according to your specifications.

Objects can be positioned and aligned along a defined line. This can be

done using the Distribute On Line command or using options in the

Alignment palette.

The Distribute on Line function allows you to position and align selected
objects along a line that you define. The objects are distributed according to

their level on the drawing, i.e. the object farthest back will appear on the

distribution line first, and the foremost object will appear last. By default,
the objects will automatically align themselves along their centers, and will

be equally spaced apart on the line. You can also choose to align the objects

according to their datum points.

To distribute objects on a line:

Align Horizontal Centers

Align Bottom Edges Align Top Edges Align Vertical Centers

Align Left Edges  Align Right Edges

Distributing
objects

Distribute on line
command
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1. Select the objects to be distributed.

2. Open the Arrange menu and choose Distribute on Line.

3. Move the pointer to the point on your drawing where you
would like to place the first object.

4. Press down the left mouse button.

5. Hold down the mouse button and drag in the direction you
want to distribute the objects.
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6. Release the left mouse button.

The objects will be distributed along the line you specified. Their center
points will be spaced equally apart along the line.
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NOTES:

• To align objects according to their datum points, press and hold down the
Alt key after you open the Arrange menu and choose Distribute on Line.

• To constrain the line the objects are to be distributed along, hold down the

Shift key as you define the line and it will snap to 45-degree increments.

The distribute controls in the Alignment palette distribute objects in the

same way as the distribute command, but the line is defined for you.

To display the Alignment palette:

• Select Alignment from the Window menu, or

• Select Alignment from the popup menu at the bottom left of
the document window.

To use the distribute controls in the Alignment palette:

1. Select the objects on the drawing to be distributed.

2. Click on the appropriate button to distribute the objects
horizontally or vertically by center or by datum point.

The objects will be distributed along an line in the manner specified.

Alignment
palette

Distribute horizontally

by center

Distribute horizontally

by datum

Distribute vertically

by center

Distribute vertically

by datum
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Sometimes you may want to display the reverse image of an object.  For this
reason, PC Draft offers the Flip function.  The Flip function allows you to

flip both horizontally and vertically to achieve a variety of effects.

You can duplicate an object and then use the Flip function to create the other

side of that object for the sake of symmetry, as well as convenience.

To flip an object horizontally:

1. Select the object you want to flip.

2. Open the Arrange menu and choose Flip Horizontal.

To flip an object vertically:

1. Select the object that you want to flip.

2. Open the Arrange menu and choose Flip Vertical.

Once you have made your choice, the object will be flipped

vertically.

Flipping an
Object Vertically

Flipping Objects

Flipping an
Object
Horizontally
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When more than one user has access to the same document, you may want to
protect your work from being changed by mistake.  You may also want to

ensure that an object isn’t accidentally moved once it is in its proper position.

In these circumstances, you can use PC Draft’s Lock feature to make sure
certain objects remain unchanged.

Objects locked on the drawing cannot be edited, moved, copied, pasted, or
deleted.  None of PC Draft’s functions will affect locked objects.

1.  Select the objects you want to lock.

2.  Open the Arrange menu and choose Lock.

Notice that the edit handles are dimmed, indicating that the objects are
locked.

1.  Select the locked objects you want to unlock.

2.  Open the Arrange menu and choose Unlock.

PC Draft provides several tools and commands that can be used to rotate
objects freely or by specified amounts.

The PC Draft Tool palette includes a Rotate by 90°tool:

Lock and
Unlock

To Lock
Objects

To Unlock
Objects

Rotating objects

Rotate by 90°
tool
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To rotate an object 90° anti-clockwise around its center:

• Select an object in the drawing then click on the Rotate 90° tool.

      

To rotate an object 90° clockwise around its center:

• Select an object in the drawing, hold down the Shift key, then click on the

Rotate 90° tool.

      

To rotate an object 90° anti-clockwise around its datum point:

• Select an object in the drawing, hold down the Alt key, then click on the

Rotate 90° tool. In this example the datum point is marked by a small circle.
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The Rotate tool and Rotate command allow you to rotate objects by any

angle you want.

You can rotate objects in various increments using the mouse; to enter a

specific value via the keyboard, use the Rotate Options.

You can rotate single objects, multiple objects, or grouped objects. Unless

you specify otherwise, selected single or multiple objects will rotate around
their individual centers. If you wish you can also specify the center of

rotation for selected objects.

To enter rotation mode:

•  Select Rotate from the Arrange menu, or

• Click on the Rotate tool in the Tool palette

To exit rotation mode:

• Click on the Pointer tool.

Rotating an object

To rotate an object in five-degree increments (the default):

1.  Select the object to be rotated.

2.  Select the Rotate tool or choose Rotate from the Arrange
menu.

3. Position the cursor in the window and press down the mouse
button.

The cursor will change into a rotation indicator.

4. Hold down the left mouse button, drag in a circular direction
until you have rotated the object the desired number of
degrees, and release the mouse button.

Rotate tool and
Rotate command
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To see the exact number of degrees an object is being rotated, open the

Show Size window.

To rotate an object in one-degree increments:

• Press and hold down the Control key while rotating an object.

To rotate an object in minutes or decimal fractions:

1. Press and release the Shift key while rotating an object.

2. Continue to drag the mouse in a circular direction to rotate the
objects in minutes.

The number of degrees will remain fixed.

To rotate an object in seconds:

1. Press and release the Shift key twice while rotating an object.

2.  Continue to drag the mouse to rotate the objects in seconds.
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As you rotate the object in seconds, the number of degrees and minutes are

constrained.

You can return to the previous rotation units (from seconds to minutes, and

minutes to degrees) by using the Control key.

To return to the previous rotation units:

• Press the Control key while in the rotation mode.

When rotating multiple objects, by default each object rotates around its

individual center.

When rotating a grouped object, all the objects in the group rotate around

the center of the group, unless you specify a different center of rotation.

The rotation feature works exactly the same way when you rotate a text

block as it does when you rotate other objects.

Bitmaps cannot be rotated.

Objects are usually rotated about their centers, however you can also

specify any point on the drawing as the center of rotation.

To rotate objects around a specified point:

1.  Select the objects you want to rotate.

2.  Select the Rotate tool or choose Rotate from the Arrange
menu.

3. Position the cursor on the point you want to use as the center
of rotation.

You can use the scroll controls to move to a part of the drawing that is

outside your current view.

4. Press down the Alt  key.

Rotating
grouped objects

Rotating
multiple objects

Returning to
previous rotation
units

Choosing the
centre of rotation

Rotating text
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5.  Press down the mouse button.

6. Hold down the mouse button and the Alt key, drag in a
circular direction until you have rotated the object the desired
number of degrees.

7. Release the mouse button and the Alt key.

The Rotate to zero command allows you to return an object to its original

angle of rotation.

To return an object to its original angle of rotation:

1. Select a rotated object.

Rotate to zero
command



Moving and Arranging Objects                     5 - 25

2.  Choose Rotate to Zero from the Arrange menu.

The object will be returned to its original angle of rotation.

You can use the keyboard to directly enter the rotation values in degrees,

minutes, and seconds, via the Rotate Options dialog.

To display the Rotate Options dialog:

1. Select the object or objects you want to rotate.

2. Choose Rotate Options from the Arrange menu.

The Rotate Options dialog will appear.

Rotate options

The Rotate
Options dialog
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The fields available to enter the rotation amount will vary depending on the

Angular Display option selected in the Document Scale and Units dialog.
The above screen shot shows the field that will display when decimal

degrees is selected as the unit of angular display.

To enter an amount for rotation, double-click in the appropriate field and

type in a value.

The default direction for rotation is counterclockwise. To rotate an object in

a clockwise direction, click on the Clockwise checkbox.

The default center of rotation is the center of the selected object or objects.

To rotate objects about their datum points, click on the Datum of object(s)
radio button. To rotate objects about a specified reference point, click on the

A reference point radio button.

If the A reference point radio button is checked, the Rotate Options dialog

will disappear and the Rotation cursor will display over the drawing.

Position the cursor at the point you want to use as the center of rotation and

click the left mouse button.

To rotate an object or objects:

1. Select the object or objects you want to rotate.

Amount of
rotation

Direction of
rotation

Center of
rotation
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2. Choose Rotate Options from the Arrange menu.

The Rotate Options dialog will appear.

3.  Enter the desired angle of rotation.

4. Specify the direction and center of rotation.

5.  Click on the Rotate button.

6. Specify the reference point to rotate about if necessary.
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The selected object or objects will be rotated the specified number of

degrees, minutes, and seconds around the requested center of rotation.
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Using Drawing
Aids

Show Size

PC Draft offers several useful features that make your drawing tasks much

easier.  This chapter discusses these Drawing Aids in detail.

PC Draft is a precision drawing application program designed to help you
create detailed drawings.  The Show Size function makes it easier to draw

objects precisely because it can display the size of each object on your

drawing.  Show Size gives you a continuous display of an object’s size as you
draw or resize it.  It also displays the degree of rotation as you rotate objects

(angles of rotation range from zero to 360 degrees, moving counterclockwise

from a rightward-pointing — “due East” — orientation).

The units displayed in the Show Size window are determined by the current

options chosen in the Document Scale & Units dialog box.  For more
information, see the section in this chapter titled “Setting the Size Units.”

To display the Show Size window:

1. Select Show Size from the Window menu, or

2. Select Show Size from the popup menu at the bottom left of the
document window.

The Show Size window will appear.

The Show Size window displays the length (“X=”) and height (“Y=”) of the
rectangle you use to define the block for paragraph text.

The Show Size window for the line tools (including the Perpendicular,

Tangent, Parallel, and Extrude tools) displays the length of the line and the

angle at which the line is drawn.  (“X=” represents the length; “A˚=”
represents the angle.)

Using Show Size
With Drawing
Tools

Text Tool

Line Tools
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The palette displays the “X” and “Y” values for a square-corner rectangle.

The X value represents the width of the rectangle, and the Y value represents

its height.

When you draw a rounded-corner rectangle, the palette shows you the radius
(“R=”) of the corners, the height (“Y=”), and the length (“X=”) of the

rectangle.  The palette shows the major and minor radii of the arcs on the

corners of Elliptical-Corner Rectangles.

PC Draft allows you to draw circles three ways:  by their diameter, by their
radius, and by three points.

Square-Corner
Rectangles

Rounded-Corner
and Elliptical-
Corner Rectangles

Circles by Diameter
and by Radius
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BY DIAMETER

When you draw a circle by its diameter, the Show Size window displays

“D=” to represent the size of the circle’s diameter.

BY RADIUS

When you draw a circle by its radius, the palette displays “R=” to represent
the size of the circle’s radius.

As you drag to create the radius of an arc, the Show Size window displays
both the length of the radius (“R=”) and the starting angle (“A˚=”).  The

starting angle is the angle between the line attached to the cursor and the X-

axis.

Once you release the left mouse button and move the mouse to create the arc,

the Show Size window changes to display two different readings:  the delta

angle (“∆A˚=”) and the angle (“A˚=”).  The delta angle is the difference

Arcs by Radius
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between the starting angle and the ending angle of the arc.  The delta angle is

the actual number of degrees through which the arc passes.  The angle
reading represents the angle between the ending angle (shown on-screen by

the line attached to the cursor) and the X-axis.

 

As you create an arc by three points, the Show Size window will not become

active until you are moving from the second to the third point in the arc.  At
that time, it will become active and display the entire arc angle.

 

When you start drawing an elliptical arc, the palette shows you the height
(“Y=”) and width (“X=”) of the ellipse used to define the size of the arc.  It

also shows you the starting angle (“A˚=”),  which is the angle between the

Arcs by Three Points

Elliptical Arcs
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Using Show Size
With Rotation

Hiding the Show
Size palette

line attached to the cursor and the X-axis.  When you finish defining the size

and the starting angle of the arc, the palette shows you the delta angle
(“∆A˚=”) and the angle.  The delta angle is the difference between the

starting angle and the ending angle.  The delta angle is the actual number of

degrees through which the arc passes. The angle (“A˚=”) represents the angle
between the ending angle (shown on-screen by the line attached to the cursor)

and the X-axis.

The Show Size window for ellipses displays both the “X” and “Y” diameters

of the ellipse.  The “X” represents the width of the ellipse, and the “Y”
represents the height of the ellipse.

The Show Size window for polygons functions in the same way as the Show

Size indicator for lines.  The palette displays the length of the line (“X”) and
the angle (“A˚=”).  The palette displays this information for each side of the

polygon as it is drawn.

During rotation, the Show Size function shows you how much you have

rotated an object.  You can rotate objects in degrees, minutes, and seconds or

in degrees and decimal fractions. See the section titled “Using the Rotate
Function” in Chapter 5 for information about rotating objects.

To remove the Show Size window from the screen:

1. Click on the window's close box, or

Ellipses

Polygons
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Scale Rulers

Rulers

Standard Rulers

2. Choose Show Size from the Palettes submenu in the View
menu, or

3. Choose Show Size from the Window menu, or

4. Choose Show Size from the popup menu at the bottom left of
the document window.

The Show Size window will be removed from the screen, and there will no
longer be a checkmark against its name in the Palettes submenu etc.

Rulers are used as drawing aids to help you position objects in precise
locations on your drawing.  Rulers appear along the top and on the left side

of the drawing window.  The displayed rulers reflect the current position of

the window during scrolling, and their scale reflects the current
magnification level.  PC Draft offers two types of rulers:  standard and

scale.

To display PC Draft’s rulers:

• Open the Layout menu and choose Show Rulers.

The rulers will be displayed, and a check mark will appear by the Show

Rulers command in the Layout menu.

Standard Rulers are the type of rulers with which you are probably familiar.

To display standard rulers:

• Open the Layout menu and choose Standard Rulers.

Scale Rulers reflect the current drawing scale of your document.  For

example, on a 1/8" = 1' scale, the major ruler divisions will be in increments

of eight (8 ft., 16 ft., and so on).  Scale rulers display measurement divisions
according to the current size unit settings.  For instance, if “decimal feet” is

the current setting, the scale rulers will be displayed in decimal feet,

matching to the current drawing scale.
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Setting the
Rulers’ Zero
Points

Setting the Zero
Points of the
Rulers
Independently

For more information about size units, refer to the section titled “Setting the

Size Units” in this chapter.

To display scale rulers (if Show Rulers is checked):

• Open the Layout menu and choose Scale Rulers.

Below is an example of scale rulers with a scale of 1/8" = 1' and size units set

at fractional feet and inches.

There may be occasions when you want to change the zero point of the rulers

from the upper left corner of your drawing to some other convenient point on

your drawing.  For instance, you may want to set the zero point of the rulers
to one edge of an object so that you can position other objects relative to that

particular point.  For this reason, PC Draft allows you to change the zero

point of the ruler.

When you change the zero point of one or both of the rulers, the positioning

of the new zero point is dependent upon the grid snap.  You can change the
zero point of either the top or left ruler independently, or change the zero

points of both rulers at the same time.

To change the zero point of either the top or the left edge ruler independently

of the other:

1. Position the tip of the pointer on the ruler where you want the
new zero point to appear.
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Setting the Zero
Points of Both
Rulers
Simultaneously

Resetting the
Zero Points of
the Rulers
Independently

2. Click the left mouse button.

This method of changing the zero point works the same for both the top and
the left rulers.

To change the zero point of either the top or the left edge ruler back to the
upper left corner:

1. Hold down the Control key.

2. Position the tip of the pointer on the ruler.

3. Click the left mouse button.

The zero point for that ruler will revert to the upper left corner, while the

other ruler’s zero point will be unchanged.  This method of resetting the zero

point works the same for both the top and the left rulers.

You can change the zero points of both rulers simultaneously by using the

cursor.  In this way, you can easily align the zero points of both rulers to a
point on your drawing.

To set the zero points for both rulers at the same point:

1. Position the tip of the pointer in the box where the two rulers
cross at the upper left corner of the drawing window.

2. Press down the left mouse button.

3. Holding down the left mouse button, drag diagonally downward
and to the right until the cursor is positioned on the new zero
point you want for both rulers.

4. Release the mouse button.
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Resetting the
Zero Point of
Both Rulers
Simultaneously

Cursor Position
Indicator

Activating the
Cursor Position
Indicator

To reset the zero point to the upper left corner of your drawing:

• Click in the small box where the two rulers cross at the upper
left corner of the drawing window.

The Cursor Position Indicator is designed to inform you of the position of the

cursor (that is, the crosshair cursor, the arrow pointer, and the various other

pointers) on your drawing.  This allows you to accurately determine the
starting and ending points of an object, and also gives you the ability to make

inquiries about the position of any point on your drawing.

Like all of PC Draft’s automatic features, the Cursor Position Indicator

conforms to the environment of your drawing.  The X/Y display of the

cursor’s position is displayed to the scale of the drawing and in the size units
that are currently selected.

The Cursor Position Indicator shows the absolute position of the cursor in
regards to the zero origin.  The zero origin of the cursor position (X=0, Y=0)

is determined by the zero points on the rulers.  Therefore, if you move the

zero points on the rulers, the zero origin of the Cursor Position Indicator will
also change.  This feature is very useful, especially when you want to make

measurements relative to a specific point on your drawing.

To activate the Cursor Position Indicator:

• Open the View menu and choose Show Cursor Position.

Once you have made your choice, the X/Y position of the cursor will be
displayed on the bottom left edge of the document window as shown in the

following figure.
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Choosing a New
Grid Snap

Grid Snap and
Grid Lines

Hiding the
Cursor Position
Indicator

Now as you move the cursor around on your drawing, the display will inform

you of the cursor’s X/Y position relative to the zero points of the rulers.

The default zero origin on the rulers is always the upper left corner of your

drawing.  To change the zero origin of the Cursor Position Indicator, you

must change the zero points on the rulers.

If you do not want the cursor position displayed, follow this step:

• Open the View menu and choose Show Cursor Position.

The cursor position will disappear, and the check mark will be removed from

the Show Cursor Position command.

The grid snap feature (accessed from the Set Grid command in the Layout

menu) lets you superimpose an invisible grid over your drawing so that

objects can be drawn, moved, or resized precisely with little effort.  Whereas
grid lines provide visual guidelines that assist you in drawing, the grid snap is

an invisible network of “magnets” that affects the drawing and placement of

objects.

You should set the grid snap to the smallest length you need in or between

objects in your drawing.  For example, if you wanted to draw a line that is
5-3/4 inches long, you should set the grid snap to one-quarter inch.  With the

grid snap set this way, the cursor will snap to every quarter-inch increment as

you draw the line.

Values displayed in the Set Grid submenu will always be expressed in the

current scale and unit system.  For more information, see the section in this
chapter titled “Setting the Size Units.”

Before you set the grid snap, you should choose a scale to be used for your
drawing.  The grid snap setting should be appropriate for that scale.  (See the

section in this chapter titled “Using the Scale Function” for information about

setting scales.)
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Using the Grid
Snap Function

To choose a new grid snap:

1. Open the Layout menu and drag until Set Grid is highlighted.

The Set Grid submenu will appear.

The Set Grid submenu shows the grid spacing choices for the current scale.

Each scale has its own set of possible grid spacings.  For example, a scale of

1:1 (1"=1") in fractional units will have increments as small as 1/64th of an
inch and as large as 1/4 of an inch.

2. Drag through the submenu until the grid snap you want is
highlighted.

3.  Click the left mouse button.

If you open the Set Grid submenu again, you will see that a check mark
appears beside the chosen grid snap.  The check mark indicates the

document’s current grid snap.

When a grid snap other than “None” is chosen, any object you draw or move

will automatically be positioned to the nearest grid position.  You will not be

able to begin or end a draw or move action between the grid snap positions.

For example, if you were moving an object with the grid spacing set at 1/4

inch, the object would move in quarter-inch increments.

You can activate or deactivate the grid snap to suit your needs at the time.
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To Deactivate the
Grid Snap

To Activate the
Grid Snap

Releasing
Objects From the
Grid Snap

Snapping Edges
and Lines Along
Their Lengths

At times you may want to turn off the grid snap when you draw or move

objects.  To turn off the grid snap:

1. Open the Layout menu and drag until Set Grid is highlighted.

The Set Grid submenu will appear.

2. Drag until None is highlighted.

3. Click  the left mouse button.

1. Open the Layout menu and drag until Set Grid is highlighted.

The Set Grid submenu will appear.

2. Drag until the grid spacing you want is highlighted.

3. Click the left mouse button.

You can temporarily suspend the grid snap function by holding down the

Control key as you move or draw an object.  This technique allows you to

position an object on a location that does not happen to fall at a grid point.

For example, if you press and hold down the left mouse button as you are

drawing the side of a polygon, the line will be released from the grid snap.

WARNING:  Be advised that if you deactivate the grid snap while drawing

or moving an object, that object will be removed from the grid.  This means
that it will be difficult for you to draw lines or borders tangent to the object,

or align the object with other objects.  In order to place the object back on

the grid, you will have to use the Align to Grid function, which is described
below.

If you draw an object with the grid snap on, its edges will get longer by

small increments or jerks. You can apply the current grid snap to a line by
holding down the Alt key as you draw. For example, if the current grid snap

is 1/4" and you draw a 30˚ line while holding the Alt key, the line will grow

in quarter-inch increments.



Using Drawing Aids 6 - 13

You should set the angle snap to the angle you need in or between objects in

your drawing. For example, if you wanted to draw a line at an angle of 14º,
you should set the angle snap to 2º. With the angle snap set this way, the

cursor will snap to two degree increment as you draw the line.

Setting the angle snap

To choose a new angle snap:

1. Open the Layout menu and drag until Set Angle Snap is
highlighted.

The Set Angle Snap submenu will appear. A check mark indicates the
document's current angle snap.

The Set Angle Snap submenu shows the possible angle choices.

2. Hold down the mouse button, drag through the submenu until
the angle snap you want is highlighted, and release the mouse
button.

The angle snap remains as set until it is changed again.

Angle Snap
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Using the angle snap function

When an angle snap other than None is chosen, objects you draw (to which

angle is relevant) will automatically be positioned to the nearest angle snap

position. You will not be able to draw lines between the angle snap
positions.

You can activate or deactivate the angle snap to suit your needs at the time.

Turning the angle snap off and on

At times you may want to turn off the angle snap when you draw objects.

To turn off angle snap:

1. Open the Layout menu and drag until Set Angle Snap is
highlighted.

The Set Angle Snap submenu will appear.

2. Hold down the mouse button, drag until None is highlighted,
then release the mouse button.

To turn on angle snap:

1. Open the Layout menu and drag until Set Angle Snap is
highlighted.

The Set Angle Snap submenu will appear.

2. Hold down the mouse button, drag until the angle snap you
want is highlighted, then release the mouse button.

Releasing objects from the angle snap

You can temporarily suspend the angle snap function by holding down the

Shift key as you draw an object. This technique allows you to draw an

object at an angle that is not an angle snap line.
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You can choose to make one object snap to another object in the drawing.

When Snap to Object is on, the cursor will snap to the vertices of existing
objects.  For example, you could draw a line and make one of its end points

coincide precisely with a corner of a rectangle.

By default, the Snap to Object function is active when you open a new PC

Draft document.

To turn off the Snap to Object feature:

• Open the Layout menu and choose Snap to Object On.

The check mark will be removed from the command, and the feature will be
deactivated.

To turn on the Snap to Object feature:

• Open the Layout menu and choose Snap to Object On.

The check mark will be added the command, and the feature will be

activated.

The Size Units function lets you determine the units in which you want to

work.  The specification of units affects the Show Size window, the grid snap
spacing, the scale options, the units of rotation,  and the display of the scale

rulers.  The unit size options are accessed from the Layout menu.

To specify the units:

1. Open the Layout menu and choose Set Scale/Units.

The  Document Scale & Units dialog box will appear.

Snap to Object

Setting the Size
Units
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2. Click on the button beside English or Metric, depending on the
type of units you want to use in the document.

To use English units in your drawing:

1. Open the Layout menu and choose Set Scale/Units.

Once you’ve done so, the Document Scale & Units dialog box will be

displayed.

2. Click on the button beside the title, English.

If you use English units, you can choose from the following units options:

Decimal Inches

Decimal Feet & Inches
Decimal Feet

Using English
Units
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Fractional Inches

Fractional Feet & Inches

To make your units choice:

3. Click the Unit Size combo box located beside the English and
Metric buttons.

The Unit Size pop-up menu will appear.

The pop-up menu shows you the various unit size options that are available

when you are working in English units.  For instance, if you were to choose

“decimal feet,” the Show Size window, the grid lines and snaps, the
numerical values of the scale rulers, and the dimension and area calculations

would all be presented in decimal feet.

4. Drag until the type of size units you want is highlighted.

5. Click the left mouse button.

PC Draft provides you with the capability of selecting the number of decimal

places that you desire in numerical displays.  You can choose either one, two,

three, or four places behind the decimal point, as well “None” (no places) to
display integers only.  The values will be rounded off to the selected number

of decimal places.  The default number of places behind the decimal is two.

Choosing the
Number of
Decimal Places
for Calculation
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In larger scales, the number of decimal places allowed for display may be

reduced automatically.

The decimal places option is only available when you are working in Metric

units or decimal English units.

To change the number of decimal places, follow these steps:

1. Open the Layout menu and choose Set Scale/Units.

Once you have done so, the Document Scale & Units dialog box will be

displayed.

2. Point on the Places combo box.

3. Click the left mouse button.

The decimal places pop-up menu will appear.

4. Drag through the pop-up menu until the desired number of
decimal places is highlighted.

5. Click the left mouse button.
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When you are done making your choices from the dialog box:

• Click on the OK button to close the dialog box and apply the
changes.

Once you have made your choice, all numerical displays, including

dimension lines and area calculation displays, will be rounded off to the

selected number of decimal places.  All new displays of values will also
reflect your choice.

When you want to work in metric units:

1. Open the Layout menu and choose Set Scale/Units.

The Document Scale & Units dialog box will be displayed.

2. Click the Metric radio button.

If you use Metric units, you can choose from the following units options:

Millimeters
Centimeters

Decimeters

Meters

To make your choice:

1. Click the places combo box.

The Metric Unit Size pop-up menu will appear.

If you were to choose “Centimeters,” the Show Size window, the grid lines
and snaps, the numerical values of the scale rulers, and dimension and area

calculations would ALL be presented in centimeters.

2. Drag until the type of units you want is highlighted.

3. Click the left mouse button.

4. Click on the OK button.

Using Metric
Units
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Once you’ve made your choice, all objects will be converted to the new units,

and the numerical values for any objects drawn afterwards will display the
new units (unless the Hide Metric Units feature is active — see below).

In many metric drawings, displaying the units is unnecessary. PC Draft
allows you to hide the unit names so that areas and dimensions are shown in

numerals only.

To hide metric units:

1. Open the Layout menu and choose Set Scale/Units.

The Document Scale & Units dialog box will be displayed.

2. Click the Metric radio button.

3. Click the Hide Metric Units checkbox.

The box will be checked, and the units will not be displayed with the

drawing’s dimension line and area values.

The Angular Display choice lets you decide the units in which you want

rotation and angular dimensions displayed and calculated. You can choose
whether rotation appears in decimal degrees (for example, 63.58˚) or in

degrees, minutes, and seconds (for example, 47˚ 22' 30").

To specify the rotation units:

1. Open the Layout menu and choose Set Scale/Units.

The Document Scale & Units dialog box will appear.

2. Click the Decimal Degrees or Degrees,
Min. & Secs. radio button, depending on the type of units you
want to use in the document.

See Chapter 5 for information on rotating objects, and Chapter 4 for

information on using angular dimensions.

Hiding Metric
Units

Setting the
Rotation Units
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Before starting a drawing, you need to determine the sizes of the objects and

the paper you are going to use.  For large drawings it is impractical to draw
objects at their actual sizes; it is necessary to reduce them, yet still maintain

their proper proportions.

A scale accomplishes this.  A scale is the ratio of the object’s size on the

drawing to its size in the real world.  For example, if you choose a scale ratio

of one inch equals ten feet (1" = 10'), a line drawn ten inches long on a
drawing would represent a 100-foot line in the real world.  (To save yourself

the trouble of calculating the size of each object to the scale of the drawing,

you should use the Show Size function.)

PC Draft offers 25 different Feet & Inches scales and 20 Metric scales for

your use.  This versatility allows you to create a drawing at one scale, and
then have it automatically converted to a different scale.

You can also have up to four drawings, all at different scales, displayed on
the screen at the same time.  This makes it easy for you to copy and paste

between drawings.  When you paste an object into a drawing with a different

scale, the object will automatically adjust in size to conform to the scale of
the new drawing.

To specify the default scale:

1. Open the Layout menu and choose Set Scale/Units.

The Document Scale & Units dialog box will appear.

2. Click  the radio button beside English or Metric, depending on
the type of units you want to use in the document.

3. Click the Default Scale combo box.

Using the Scale
Function

Setting the Scale



6 - 22 Using Drawing Aids

The Scale pop-up menu will appear.

4. Drag the mouse cursor, drag until the scale you want is
highlighted.

5. Click the left mouse button.

The new scale will be displayed in the Default Scale pop-up menu.

6. Click on the OK button to close the dialog box and apply the
changes.

The dialog box will disappear and your drawing will now reflect the new

scale.  If you create a drawing at one scale, and then decide later to change to
a new scale, simply follow the steps outlined above to choose a new scale.

The appearance of the objects on the drawing will either grow or shrink,

depending on the new scale chosen.
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If you change the scale of a document that contains text, an alert displays

asking if you want to scale the text or not.

• Click Yes if you want the text to be resized according to the
new scale, or

• Click No if you wish the text to continue to display at the size it
currently is on screen.

The Angular Display choices let you specify the units in which you want

rotation and angular dimensions to be displayed and calculated.

You can choose to display the rotation units in decimal degrees (e.g.

63.58º), in degrees and minutes (e.g. 51º 14'), in degrees, minutes and

seconds (e.g. 47º 22' 30"), or in user defined units.

To specify the rotation units:

• In the Document Scale & Units dialog, click on one of the radio
buttons in the Angular Display section, depending on the type
of units you want to use in the document.

User defined units

If you click on User defined units, you can specify the number of units to a

circle by typing a value in the Units to a circle field.

Scaling text

Angular display

Setting the
Rotation Units
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With a value of 16 units to a circle, at one decimal place, 90º will be

displayed as 4.0.

Decimal places

If you choose decimal degrees or user defined units for the units of angular

display, you can also select the number of decimal places you would like to

display for angular values.

To change the number of decimal places:

1. Click on the Places button.

The decimal places popup menu will appear.

2. Holding down the mouse button, drag through the popup
menu until the desired number of decimal places is highlighted,
then release the mouse button.

Once you have made your choice and closed the dialog, all angular displays

will be rounded off to the selected number of decimal places.
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Using Symbol
Libraries

Symbol libraries give you the ability to save, catalog, and reuse standard

images, or symbols.  You can take previously created symbols out of symbol
libraries and put them directly onto your drawing.  With on-line symbol

libraries you can create electrical and architectural symbols, or commonly

used images, like logos, notices, and figures.  You can then store them in an
easy-to-access library document, and insert the symbols into various

drawings.  The symbols in the libraries retain all their drawing attributes,

such as their scale, rotation, and object information fields.

You use the Open command in the File menu to open symbol libraries stored
on disk.  Once a symbol library is open, you can paste objects into it from

your drawing, or copy symbols in the library and paste them into your

drawing.

To open a symbol library stored on disk:

1. Choose the Open command from the File menu.

A dialog box will appear.

2. Choose Symbol Library from the Files of type pop-up menu.

The list box will display the available symbol libraries in the current
directory.

If the symbol library you want is stored in another folder or on another disk:

3. Select the folder or drive as necessary to view the contents of the
folder that contains the symbol library you want.

4. Select the name of the symbol library.

5. Click on the Open button.

The symbol library window will appear on the screen.

You can open symbol libraries created with  PC Draft only.

Opening an
Existing Symbol
Library
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Inserting Objects
Into a Symbol
Library

NOTE: The new PC Draft supports the symbol libraries created using this

version 4.3 or later.  You will recognize these by the suffix* .dsy.

You can use PC Draft’s drawing tools to create objects and then insert them
into a symbol library:

1. Cut or copy the object on your drawing that you want to insert
into a library.

2. Open a symbol library.

3. Paste the object into the library.

When you insert a new symbol into a library, the default name “NewSymbol-
#” (where “#” is a number that increases as new symbols are added to the

library) is assigned to the symbol.   You can change the default name.  The

symbol names appear in a list box, and the current symbol is displayed in a
viewing area at the bottom of the symbol library window.

            

List Box

Name Field

Object Info.
Fields

Viewing
Area
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The following text provides in-depth instructions on how to insert an object

into a library:

1. Select the objects you want on the drawing.

If several objects are selected, they will be pasted as one symbol into a

library.

2. Open the Edit menu and choose Cut or Copy.

3. Open a symbol library.

If an existing symbol library is open, click on its window to make it active.

If no library is open, create a new library or open an existing library.

When the symbol library you want is open and active,

4. Open the Edit menu and choose Paste.

The symbol you cut or copied in PC Draft will appear in the symbol library.

The name “New-Symbol-#” (where “#” is a number that increases as new

symbols are added) will appear in the name box and the list box.  Both
entries will be highlighted.

To change the name for a symbol in the library:

1. Use the scroll controls beside the list box to display the name
you want to change, if necessary.

2. Click on the symbol name you want to change.

3. Type a new name in the name box.

4. Click on the Rename button.

NOTE: Pressing Enter after typing the new name will not preserve the

name; you must click the Rename button.

The new name will appear in the symbol library’s list box in alphabetical

order.

Naming Symbols
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Searching for
Symbols by
Their Names

NOTE: The name assigned to a symbol in a library file is preserved as part

of its object information when it’s pasted into a drawing.

If you have a large number of symbols in a library, you might find it

convenient to search for symbols by name.

To search for a symbol by name:

1. Type in the name of the symbol you want to find.

NOTE:  You do not have to enter the complete name.  If you enter part of

the name, PC Draft will try to match what you enter with the appropriate

symbol name.

2. Click on the Find button.

PC Draft will attempt to locate the name you specified.  If a name that

matches is found, PC Draft will highlight the symbol’s name in the list box

and display the symbol in the viewing area.

When a symbol is in a library, you cannot change its appearance directly

(though you can paste it into a drawing at any time and resize, ungroup, or
otherwise edit it, then paste it back into the library). You can, however,

change a symbol’s object information and datum point.

In addition to the symbol’s name, the symbol library window includes text

boxes for the other five fields of object information allowed in PC Draft Full

Edition. You can add or edit object information with the symbol library
window open.

Changing a
Symbol’s Object
Information

Editing Symbols
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To add object information to a symbol:

1. Use the scroll controls beside the list box to display the symbol
you want to add object information to, if necessary.

2. Click on the name of the symbol you want to add object
information to.

3. Click in one of the object information fields and type the object
information.

NOTE: As in a drawing, the maximum length for object information is 25
typed characters.

4. Click on the Rename button.

NOTE: Pressing Enter after typing the new object information will not

preserve it; you must click the Rename button.

5. Repeat steps 3 and 4 as needed with the other object
information fields.

To change a symbol’s object information:

Object Info.
Fields
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1. Use the scroll controls beside the list box to display the symbol
you want to change, if necessary.

2. Click on the name of the symbol you want to change.

3. Click in one of the object information fields and edit the object
information.

4. Click on the Rename button.

NOTE: Pressing Enter after editing the object information will not preserve
the changes; you must click the Rename button.

5. Repeat steps 3 and 4 with the other object information fields, if
necessary.

NOTE: If you paste a group or object that already has object information

into a library, the object information is pasted along with the item and will
appear in the library window’s object information fields; it can then be

edited if necessary. In any case, a symbol’s object information will stay

with the symbol if you paste it into another drawing.

PC Draft lets you change the location of the datum point for each symbol.  A
datum point is a reference point on an object.  The datum point is important

because you can use it as a reference point when you paste symbols into a

drawing.

Each type of object has a default datum point.  For example, the default

datum point for rectangles is the upper left vertex.  The default datum point

for a grouped object (most symbols are grouped before pasting into a library)
is the default datum point of the object at the back of the group.

Assigning a New
Datum Point to a
Symbol
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To assign a new datum point to a symbol:

1. Open the symbol library that contains the symbol whose datum
point you want to change.

2. Click on the name of the symbol you want in the symbol library
list box.

3. Click on the Datum button.  (You can also accomplish steps 2
and 3 by double-clicking on the symbol’s name.)

The edit handles associated with the symbol will appear.  The datum point is

represented by an “X” marker on the symbol.

4. If necessary, use the size box to display the entire symbol.

5. Click inside the bounding box (represented by the edit handles)
to define the new datum point.

The “X” marker will appear where you clicked to mark the new datum point.
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To place the datum point in the center of the symbol:

• Click on the Center button.

NOTE:  The symbol’s center is defined as the center of the symbol’s

“extent.”  The extent is the overall size of the symbol.

To apply the datum point change to the symbol:

• Click on the Done button.

You can also finish editing the symbol’s datum point by clicking on the name
of another symbol.

Technical Notes:  If you click near a vertex point (that is, a point where two
edges meet, shown on screen by a major edit handle), the datum point marker

will snap to that vertex.  You can place the datum point anywhere within the

bounding box.  (The bounding box is the overall extent of the symbol or
group.)  However, a datum point located at the center of the object, or on a

vertex point, has some special attributes of which you should be aware.  This

type of datum point, called a “fixed datum point,” retains the same relative
position on the symbol even if you reshape or resize the symbol after you

have pasted it onto a drawing.  However, if you resize a symbol that has a

“free datum point” (a datum point that doesn’t appear on a vertex point or the
center of a symbol) in such a way that you make the datum point appear

outside the symbol’s bounding box, the datum point will revert to the default

datum point position that applies to the object or the group.  This change only
applies to the symbol on the drawing.  The original symbol in the library will

not be affected.

As an example, suppose you

assigned a fixed datum point to the
lower right vertex on a rectangle,

copied the symbol, and then

pasted it into a drawing.
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You then reshaped the rectangle by dragging the handle associated with the

lower right vertex toward the upper left corner of the drawing, as shown in
the following figure.

Since a fixed datum point was assigned to the lower right vertex, the datum

point will still appear on the lower right vertex.

However, suppose you had assigned a free datum point that appeared in the
lower right corner of the rectangle, but not on a vertex point.  In this case, if

you reshaped the rectangle in the same way as in the above example, the

datum point on the symbol on the drawing would revert to the default datum
point for rectangles, which is the upper left vertex.  This would occur because

the reshape operation moved the free datum point outside the symbol’s

bounding box.

When you want to insert a symbol into a drawing, you select the symbol you

want from a list containing the names of the symbols in the current library.
PC Draft lets you preview a symbol before you paste it into your drawing.

The symbol you choose from the list of symbols appears in a viewing area at

the bottom of the symbol library window. You can get symbol into a drawing
by pasting it or placing it.

To paste a symbol into a drawing:

1. Open the symbol library that contains the symbol you want to
paste into your drawing.

2. Click on the symbol name.  (If necessary, use the scroll controls
to display the name of the symbol you want in the list box.)

The chosen symbol will appear in the viewing area.

Inserting
Symbols Into
Drawings
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3. Open the Edit menu and choose Copy.

4. Activate the drawing you want by clicking on it.

5. Click on the drawing where you want the symbol to appear.

6. Open the Edit menu and choose Paste.

The chosen symbol will appear where you clicked on the drawing.  The

symbol’s datum point will be used as the reference point for the paste
operation.  This means that the object’s datum point will appear where you

clicked.

NOTE:  If the symbol you have selected is too large to fit in a drawing, you

won’t be able to paste it in. In such cases, you might try re-scaling the

drawing to make room for the symbol.

If you need to insert many symbols, or many copies of one symbol into a

drawing, it may be easiest to put the library window into its “palette” mode.
When library is in palette mode, you can rapidly place symbols directly into

the drawing.

To shrink the symbol library window to palette mode:

• Click the arrow check box at the upper right of the window.

The library window will shrink to palette size. The list of symbols will appear

as a popout menu.

To place a symbol in a drawing:

1. Use the library’s popout menu to choose a symbol by name.

Placing Symbols
from the Library
Palette
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2. Click the Place button.

The pointer will change to an “X-shaped” cursor.

3. Move the cursor over the drawing.

4. Click where you want the symbol to appear.

A copy of the symbol will appear at each point you click on the drawing (the

symbol’s datum point will be aligned under the cursor at each click).
To exit from the Place mode:

• Click on the Pointer icon.

WARNING: When the library appears as a palette, you cannot use the
usual Cut, Copy, or Paste commands with it. To use those commands with a

library, or to edit symbols’ datum points, names, or object information, you

must click the arrow check box at the upper right of the palette to put it back
in “full window” mode.

You can use the Repeated Paste function, accessed from the Edit menu, to

paste multiple copies of the same symbol onto various locations on a

drawing.

To use the Repeated Paste function with symbols:

1. Copy the symbol you want.

2. Activate a drawing window by clicking on it.

Using the
Repeated Paste
Function
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3. Open the Edit menu and choose Repeated Paste.

When you choose Repeated Paste, you enter a special mode.  In this mode, an

object on the Clipboard (in this case the symbol you copied) is pasted onto
the drawing at each point on which you click.  While in this mode, you can

scroll the window and even activate different layers and continue to paste

symbols.

4. Click where you want the symbol to appear.

A copy of the symbol will appear at each point you click on the drawing (the

symbol’s datum point will be aligned under the cursor at each click).

To exit from the Repeated Paste mode:

• Click on the Pointer icon.

When you insert an object into a symbol library, PC Draft lists the units and

scale in which the symbol was created at the top of the list box.  This

information is stored with each symbol.  (You can find out the scale and units
that are associated with a particular symbol by clicking on the symbol’s name

and then reading the information at the top of the list box.)  If you put a

symbol into a drawing whose scale is different from the symbol’s, the symbol
will seem to grow or shrink to match the scale of  the drawing.  However, you

can choose to paste an unscaled symbol into drawings.  When you paste an

unscaled symbol into a drawing, the symbol appears the same physical size
on the drawing as in the library.

To paste unscaled symbols onto a drawing:

1. Click on the name of the symbol you want to paste.

2. Click on the check box beside “Unscaled.”

3. Copy and Paste or Place the symbol into a drawing.

The symbol will appear in its original size on the drawing.  The “Unscaled”

check box acts as a toggle.  When it is checked, all symbols you copy and
paste onto drawings will be unscaled until you uncheck it.

Using Scaled and
Unscaled
Symbols



Symbol Libraries and Layers 7 - 13

To delete a symbol:

1. Open the symbol library that contains the symbol you want to
delete.

2. Click on the symbol name.

3. Open the Edit menu and choose Clear or Cut.

The symbol will be deleted from the library.

To close a  symbol library:

• Click in the symbol library’s close box.

or,

• Open the File menu and choose Close.
If you insert any objects into a new symbol library and then close the library,

a dialog box will appear asking if you want to save the changes.

To save the library and its contents:

• Click on the Yes button.

When you click on the Yes button, a dialog box will appear. (See the section
titled “Saving a Symbol Library” in this chapter for more information.)

To close the library without saving the library or its contents:

• Click on the No button.

You can shrink the symbol library window down to palette size by clicking

the arrow check box at the right-hand end of the title bar.

Deleting Symbols
From Symbol
Libraries

Closing a Symbol
Library

Shrinking the
Library Window
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With the palette version, you can quickly place symbols into a drawing.

You can assign a name to a symbol library to help organize your collection of
symbols.  For example, an architect might maintain a separate library for

architectural symbols, or  a desktop publisher might maintain libraries for

logos and figures.

To save a symbol library under a certain name:

1. Open the File menu and choose Save As.

A dialog box will appear.

2. Type in a name.

3. Use the directory list to specify the folder in which you want to
save the library, if appropriate.

4. Click on the Save button.

The symbol library will be saved under the specified name in the specified
folder or on the specified disk.

Saving a Symbol
Library
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Drawing Layout
and Printing

Defining Your
Page Setup

Using PC Draft, you can create drawings of up to 56.88 inches high by 56.88
inches wide. You can define the desired drawing size by using the Page Setup

choices in conjunction with the Drawing Size feature.  The Page Setup dialog

box, accessed through the Page Setup command in the File menu, determines
the size of the individual pages that make up the overall drawing area.  The

Drawing Size feature, accessed from the Layout menu, has a graphical

interface that lets you select the number of pages needed to achieve the
desired overall size of the drawing.

Before you define the overall size of your drawing using the Drawing Size
feature, you should specify the type of output device you will use, and the

Page Setup dialog box to specify information about the page setup.

You can configure your Printer Driver directly from the Page Setup dialog

box.

To do so, click the Printer button and choose the printer from the pop up
menu beside Name.

The Page Setup command allows you to choose how you want your
document to appear on the printed page.  The page setup depends on the type

of printer you select.  (See “Printing a Document” in this chapter for

information about choosing printers.)
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Properties Normally, the choices of properties include Paper, Graphics and Device Op-
tions.

Your properties options are dependent  on the particular printer you will use,
such as HP®, Xerox®, or Epson®. The type of printer is  also very important
in defining the maximum size and the type of media that you will be able to
use (for example Inkjet, Laser, Dot Marix, etc.).

To select your Paper Option:

• Open the File menu and choose Page Setup

• Click the Printer button from the Page Setup dialog box

• Choose your printer and click Properties button

The following dialog box will be displayed so that you can choose  your
various paper size.
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Paper Size

Orientation

Graphics
Options

You will notice that there are a variety of paper types offered in the dialog
box.  Each paper type has its own block size.  The block size refers to the

physical page size of the pages in the PC Draft drawing area.

Normally the printer drivers offer the standard sizes of papers. Below  are the

most  common paper sizes for  desktop printers:

• Click the icon to choose the paper size.

Letter 8.5” x 11”

Legal 8.5” x 14”

Executive 7.25” x 10.50”
A4 8.26 x 11.69”

A5 5.83 x 8.26”

B5 7.17” x 10.13”

Some printers include Envelope and Custom sizes.

The Printer Drivers offer a number of special printing features.  These

features allow you to set the orientation of the pages on the drawing area and
control the way a drawing can be printed.

The available page orientations are Portrait and Landscape.  Select Portrait
orientation to print objects vertically on the page, or Landscape orientation to

print objects horizontally on the page.

_______________________________________________________________
NOTE: PC Draft will get the page orientation from the printer driver. We

recommend setting up your printer driver as the default printer, even if PC

Draft allows you to change your printer on the fly.
________________________________________________________________

Resolution:

Under Resolution,  you will find different options for  setting up the print
quality. Some drivers display the Resolution options as pop up menus

expresed in dots per inch (dpi), others offer different Quality options that



8 - 4 Drawing Layout and Printing

Defining Your
Drawing Size

Device Option

indicate the resolution (for example maximum or minimum resolution). The
number of dpi will depend on the printer.

Dithering:

The printer driver can offer Dithering options to print  bitmap, vectors, or to

get  good quality output for different types of media.

Some drivers will give an intensity option enabling you to make the image

either darker or lighter.

You may also have the option, depending on your driver, to set up the number

of copies desired.

This option is part of some printer drivers. If your driver has this option,  it

will allow you to setup the Printer features.

__________________________________________________________________

NOTE: You may find an option giving you a choice to either print in
Postscript or not.  We recommend to not use the Postscript options with PC

Draft.

__________________________________________________________________

Once your page setup is complete, you are ready to define the overall size of

the drawing.

To set the size of your drawing:

• Open the Layout menu and choose Drawing Size.

A dialog box will appear, displaying the current total drawing size in the form

of a block diagram.
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You can see the diagram is divided into blocks.  This diagram represents the

maximum drawing size available, and each of the blocks represents a single
page.  The blocks that are darkened indicate the current drawing size.

To change the drawing size:

1. Position the tip of the pointer on one of the activated page
blocks.

2. Press down the left mouse button.

3. Holding down the left mouse button, drag until you have
activated the number of page blocks required to make up the
drawing size you want.

4. Release the left mouse button.

5. Click on the OK button.

As you know, the PC Draft drawing window generally shows only a portion

of the overall drawing.  Therefore, when you change the drawing size it won’t
be noticeable until you zoom out or scroll to another area of the drawing.
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PC Draft
Printing Options

Specifying How
Pages Are
Numbered

Printing in
Reverse Order

Printing a
Document

Choosing Your
Printer

PC Draft lets you make choices that affect how pages are printed out.  For
example, you can specify the way pages in a document are numbered, and the

order in which they are printed.

You can choose to number pages by column or by row.  In either case, page

one will appear in the upper left corner of the document.

To number pages by column, in ascending order from top to bottom, or by

row (from left to right:):

1. Open the Layout menu and choose Drawing Size.

The Drawing Size dialog box will appear.

2. Click on the button to the left of the page numbering option you
want.

To print the pages in the document from the last page to the

first page (for printers that produce pages face up):

•       Click on the check box beside Print Last Page first in the
Drawing Size dialog box.

After your drawing is complete, you can print it on any printer.

Before you print, make sure that you have chosen the printer you want to use.

To choose a printer:

• Open the Start menu and choose Printers from the Settings
submenu.

A dialog box will appear displaying the available printers.
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To Setup your default printer:

• Right click the printer icon

• Holding down the left mouse button, drag until the "Set as
Default" is highlighted and release the button.
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Number of
Copies

The Print dialog box for the laser printers provides you with a number of

printing options.  You can specify the number of copies you want to print, the

range of pages, the source for the paper, and whether or not you want to print
out information about the print job.
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If you want to print only some of the pages in the document, you can specify

the range of pages you want to print by doing the following:

1. Click in the box beside Pages From, then type the number of the
first page in the range you want to print.

2. Click in the text box beside To, then type the number of the last
page in the range.

Page Range
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Opening BMP
Files with Other
Applications

Resizing Bitmap
Images

Resizing in One
Direction

To Transfer
Objects to Other
Applications
Using BMP

1. Select the object or objects you want to move.

2.    Open the Edit menu and choose Copy.

3. Switch to another application, which accepts graphics.

Once you leave PC Draft, all graphic objects on the Clipboard will be
converted to the BMP format.

4. Open the Edit menu and choose Paste.

The objects in the Clipboard will appear as a BMP image in the application’s
window.

Many applications, including some word processors and page layout
programs, can open BMP files directly, treating them as graphics inserted in

text documents.

(To learn about saving documents in the BMP format, see Chapter 1.)

In many word processing and page layout programs, you can manipulate
BMP images (by cropping, resizing,  or panning) just as you can any other

imported graphics.

There may be occasions when you want to enlarge, reduce, or even distort the

shape of a bitmap image produced from a program such as Paint®.  PC Draft

allows you to enlarge or reduce the size of a bitmap image without distorting
the image.  PC Draft also allows you to change the size of a bitmap image in

one direction at a time.

To resize a bitmap image in one direction only:

1. Select the bitmap image you want to resize.

2. Position the tip of the pointer on one of the edit handles in the
middle of the bitmap’s bounding box, (that is, the handles on the
top, bottom, left and right sides).

3. Press down the left mouse button.
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Constrained
Resizing

Resizing the
Height and
Width
Separately

4. Drag until the bitmap image is the size you want.

5. Release the left mouse button.

If you stretch a bitmap from one of its corner edit handles, you will be able to

resize the bitmap image’s size in a proportional manner, (that is, the height-

to-width ratio will be maintained).

To resize a bitmap image while maintaining its proportions:

1. Select the bitmap image you want to resize.

2. Choose Group from the Arrange menu.

3. Point on one of the edit handles on the corners.

4. Press down the left mouse button.

5. Drag until the bitmap image is the size you want.

6. Release the left mouse button.

You can use the handles on the corners with the Alt key to change the bitmap

image’s horizontal and vertical size independently.  This method allows you
to change the image’s proportions while resizing it.  (This means that the

height-to-width ratio of the image will not be maintained.)

To resize a bitmap image while changing its proportions:

1. Select the bitmap image you want to resize.

2. Point on one of the corner edit handles.

3. Press down the left mouse button.

4. Press down the Alt key.

5. Holding down the left mouse button and the Alt key, drag until
the bitmap image is the size you want.

6. Release the left mouse button and the Alt key.
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APPENDIX  A    Menus and Dialog Boxes

New

Open

Close

Save

Save As

FILE MENU

Creates a new untitled document or symbol

library.  The document’s size will be one

page.  The dimension of the drawing area is
determined by the paper type (U.S. Letter,

U.S. Legal, and so forth).

Opens the directory of existing PC Draft

documents on the disk.  This command also

gives you the option of opening other disks
that contain PC Draft documents.

Imports bitmaps such as BMP, TIFF.

Closes and puts away a document.  Prior to

closing, a dialog box will ask if you want to
save the changes made to the document.

Closes and puts away all documents.  Prior to
closing each one, a dialog box will ask you to

save the changes made to the document.

Saves the contents of your drawing to the

disk and leaves the drawing open.

Saves a copy of the current drawing.  You

will be asked to name the document,  and

then a copy of the drawing with its new name
will be saved onto the disk.

Reverts to the last saved version of the
document.

Exports PC Draft document as a graphic
image.

Import

Revert

Close All

Export File
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Print

Exit

Undo/Redo

Cut

Copy

Paste

Repeated
Paste

Clear

Paste Unscale

Copy
Attributes

Determines the print format, such as paper
size, page orientation, pagination, and

reduction factor.

Prints out the drawing in a specified quality

mode (on some printers).  The print dialog

box enables you to set the page range, the
number of copies of the print-out, and

whether the drawing will be printed on

continuous or cut sheet paper.

Exits from the application.

EDIT MENU

Undo reverses the last operation performed.

Redo performs the operation that was

reversed by Undo.

Removes a selected object from the drawing

and places it on the Clipboard.

Copies a selected object on the drawing and

places it on the Clipboard.

Pastes an object from the Clipboard onto the

drawing at the point where you click the left
mouse button.

Pastes an object without scale.

Deletes a selected object from the drawing.

Enables you to repeatedly paste an object

onto a drawing.

Copies the item's object information and

graphic attributes.

Page Setup
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Select All

Duplicate

Move

Apply
attributes

Attributes
Option

Select None

Applies the attributes to one object.

Displays the attribute options dialog box.

Enables you to duplicate selected objects on
the drawing, either one at a time.

Selects all the objects on the drawing.

Deselects all objects in a document.

Displays a dialog box that enables you to

move or copy selected items to precise

locations on the drawing.

Displays a dialog box that enables you to

increase the size of selected object by
multiplying the object's dimensions by

specifyed values.

Displays a dialog box that enables you to

reduce the size of selected object by dividing

the object's dimensions by specified values.

Displays a submenu that lets you smooth and

unsmooth several types of objects.

Expand

Contract

Reshape
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Select All
Text

Hide Text

Border Inside

Border
Position

Border
Centered

Justification

Line Spacing

Case

TEXT MENU

The Text menu contains various choices for

defining text attributes, such as text font,
size, style, line spacing, case, and so on.

Lists the font sizes and styles installed on
your system.

Justifies text horizontally and vertically
inside the text block.

Displays a submenu that lists the following
line spacing options for text.

Controls the case (UPPERCASE, lowercase,
or Title Text) of text.

Selects every text object in the current
drawing document.

Hides text on the drawing.  When this item is
checked, text is omitted from hardcopy

output as well.

PREFERENCE MENU

Displays a submenu that lists the following

options for border position.

Includes all the object’s border in the

measurement of its overall extent.

Includes only the center of the object’s

border in the measurement of its overall

extent.

Font
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Border
Outside

Edit Patterns

Excludes the object’s border from the
measurement of its overall extent.

Displays the available colors.  After you
choose the color you want to edit, a dialog

box used to modify the chosen color is

displayed.  (Edit Color is only active when
you run the program on a color system.)

Displays the available patterns.  After you
choose the pattern you want to edit, a dialog

box used to edit the chosen pattern is

displayed.

Activates and deactivates the large,

crosshair-style drawing cursor.

Displays  dialog boxes  with options to set up

the Parallel Line Tool and the Regular
Polygon Tool.

VIEW MENU

This submenu’s commands increase or
decrease the current magnification by a
factor of two or four.

Changes the view back to the most recent
level of magnification.

Changes view to upper left corner of
drawing, with no magnification.

Displays the X and Y coordinate position of

the cursor.  The preset (0,0) position is the

upper left corner of the document.

Calculates and displays or hides the area

values of selected objects.

Cross Cursor

Tool Options

Home View

Zoom

Restore Prev.
Zoom

Show Area,
Hide Area

Show Cursor
Position

Edit Colors
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ARRANGE MENU

Moves selected objects to the front of the

drawing.

Moves selected objects to the back of the

drawing.

Moves selected objects forward one level on

the drawing.

Moves selected objects back one level on the

drawing.

Combines two or more objects so that they

can be treated as a single object with a single
set of edit handles.

Converts grouped objects to their original
state with their own individual set of edit

handles.

Lets you rotate a selected object or group.

Lets you return rotated objects or groups to

their original orientations.

Flips selected objects horizontally on the
drawing.

Flips selected objects vertically.

Displays a dialog box showing the various

alignment options.

Distributes selected objects along a straight

line, and spaces them equally about their
centers or datum points.

Move Back
One

Bring  to
Front

Move
Forward One

Group

Ungroup

Send to Back

Rotate

Rotate to
Zero

Flip
Horizontal

Flip Vertical

Rotate
Options

Distribute on
Line
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Restricts objects on the drawing so they
cannot be changed by any of PC Draft’s

functions such as move, edit, fill, and so on.

Returns locked objects to their original

condition so they can be moved, edited, and

so on.

LAYOUT MENU

Displays the dialog box that lets you choose

the units, default scale, and dimension
standards for a drawing.

Displays a submenu that enables you to
choose from the various grid snaps available

in English or metric scales. The grids will

reflect the current scale and size units chosen.

Displays submenu with options to  choose

angle snaps available in English  or Metric
scales.

Displays the rulers on the top and left sides of
the drawing.

Displays rulers based on the current scale of
the drawing.  The scale rulers also reflect the

current size units.

Displays the standard rulers in which the

major ruler divisions are spaced one inch

apart.

When Snap to Object is active, objects you

draw or move will snap to the vertices of
nearby objects on the drawing.

Lock

Unlock

Set Scale/
Units

Set Grid
Snap

Show Rulers

Set Angle
Snap

Scale Rulers

Standard
Rulers

Snap to
Object On/
Off
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Turns grid lines off.

Turns page boundary lines on or off.

Displays a dialog box that enables you to set
the size of the drawing.

WINDOW MENU

Shows/hides  all  the palettes

Shows/hides the Tool palette.

Shows/hides the Attribute palette.

Shows/hides the Dimension palette.

Shows/hides the Show Size palette.

Shows/hides the Resize palette.

Shows/hides the Alingment  palette.

Shows/hides the Status Bar

Arranges multiple opened windows in a

overlapped fashion.

Vertically arranges multiple opened

windows in a non-overlapped fashion.

Arranges icons for minimized windows at the

bottom on the main window.

Hide Page
Breaks

Drawing Size

Hide Grid
Lines

Arrange
Icons

Show/Hide
All Palettes

Tool

Attrrbute

Dimension

Show Size

Resize

Alingment

Cascade

Tile

Status Bar
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HELP MENU

Displays the Online Application  Manual

with brief information about the most
important issues.

This option connects you to the Online
Registration page.

This option connects you to the Microspot
Web site.

PC Draft
Online
Manual

Register
Information

Update
Information
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Dialog Boxes

Page Setup/ Printer Properties

The Page Setup dialog boxes allow you to choose options for the different

paper types.  There is a different Page Setup dialog box for the various types
of available printers.  Each paper type corresponds to a particular page size.

The Page Setup dialog box allows you to specify how the pages on the

drawing are oriented.  Page orientation allows you to print your document
with the drawing oriented either horizontally or vertically on the page.
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Print

The print dialog boxes let you make choices about the printout of your
drawing.  You can select the number of copies of the document to be printed

from this dialog box, and in some Printer Drivers you can specify whether the

paper feed is continuous (Automatic) or on individual sheets (Hand Feed).
You can also specify a paper cassette or manual feed as the paper source.

The Properties button allows you to set up options for the printer.

Alignment

The alignment option allows objects to be horizontally aligned by their tops,

centers, or bottoms.  Objects can be vertically aligned by their left, middle, or

right sides.  Objects can be centered on top of each other, aligned with a
specified part of the selected object(s) or to a specified part of a reference

object, aligned to a reference point, or aligned to a datum point.  You can

align objects using either the alignment icon or the labeled buttons.  This
dialog box also allows you to align objects to the grid.



A - 12 Appendix A - Menus and Dialog Boxes

Document Scale & Units

The Document Scale & Units dialog box, accessed using the Set Scale/Units

item in the Layout menu, sets up your drawing environment.  Through this
dialog box, you can define the drawing scale, the size and angular units, and

in the case of metric and decimal English units, the number of places behind

the decimal for size values.

Drawing Size
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This dialog box is used to add or remove the page blocks that make up the

overall drawing size.  Clicking on the unfilled blocks adds additional sheets

of paper to the drawing area.  Clicking on the filled blocks close to the upper
left corner of the block diagram removes sheets from the drawing area.  As

the number of sheets of paper is increased, the total drawing size is calculated

and displayed to the left of the diagram.  You can also use this dialog box to
specify the order in which pages are printed.

Symbol Library

The Symbol Library dialog box lets you store and retrieve commonly used

objects.   To locate a symbol in a library, type in the name of the symbol you
want, and then click on the Find button.  To select a symbol, click on its

name.  The symbol will appear in the viewing area at the bottom of the

window.  To rename a symbol, select the symbol, type in a new name, and
then click on the Rename button.  To paste symbols into a scaled drawing at

the same physical size as they appear in the library, click on the box beside

Unscaled before you copy the symbol.  You can also use this dialog box to
edit the datum points and object information of selected symbols.
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Rotate Options

The Rotate Options dialog box lets you specify the number of degrees and

decimal fractions of a degree (or degrees, minutes, and seconds) you want to
rotate selected objects.  To open the Rotate Options dialog box, choose

Rotate Options in the Arrange menu.  To specify the desired amount of

rotation, double-click in the appropriate text box and type in a value.  To
specify clockwise rotation, click on the button beside clockwise.   To rotate

around the datum point of the object, click on the check box beside “Datum

of Object(s)”.  After you have made your choices, click on the Rotate button.
To rotate objects around a certain point on the drawing, click on the button

beside “A reference point,” click on the Rotate button, then click on the

desired reference point on the drawing.

Move Object
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The Move Object dialog box, accessed using the Move item in the Edit menu,

enables you to move selected objects or groups to a location you type in.

Through this dialog box, you can move or copy the selected object to any
location in any layer of the current drawing.
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APPENDIX B              Special Usage of Keys

Hold down the appropriate key to achieve the following results.

(Normally constrains an action)

Constrains lines to snap at 45-degree increments.

Constrains the shape to a square.  (Applies to rounded-corner, square-corner,
and elliptical-corner rectangles.)

(by Radius or by Diameter)  Constrains the line used to define the radius or
diameter to snap at 45-degree increments.

Arcs by Radius:  Constrains the line used to define the radius to snap at
45-degree increments.

Elliptical Arcs:  Constrains the size of the ellipse that is used to define
the arc and allows you to change the starting angle of the arc without

changing its size.

Constrains the line segments to snap at 45-degree increments during creation.

Activates the eraser, allowing you to delete part of the freehand shape during
creation.

Changes the rotation units.  The first press of the Shift key activates rotation
in minutes; the second press activates rotation in seconds.

When held down after dragging begins, constrains movement of objects to a
horizontal or vertical direction.  With multiple objects, pressing Shift before

dragging moves one object independently of other selected objects.

Extends the selection to include non-selected objects you click on.  Also

deselects the selected objects you click on.

Constrains the line used to define the distribution of objects to snap at 45-

degree increments.

Shift Key

Line tool:

Rectangle tool:

Arc tool:

Polygon tool:

Freehand tool:

Rotation:

Moving objects:

Circle tool:

Selecting objects:

Distribute On
Line:
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Tool Icons:

Pattern Editor
dialog box:

Constrains the movement of the pointer and the Finger-Painting tool to a 90-
degree angle.

Activates the alternate Zoom cursor (magnifying glass).

(Normally releases a constraint)

Allows rotation in one-degree increments.  Also returns to the previous

rotation units; takes you from rotation-in-seconds to rotation-in-minutes, and
from minutes to degrees.  Also, returns you to the pointer mode when you

click on the drawing.

Returns you to the pointer mode when you click on the drawing.

(Normally activates an optional mode of operation)

When you choose Distribute On Line from the Arrange menu,  objects are

distributed on a line according to their datum points.

(in Pattern Editor dialog box)  resets the Finger-Painting tool color to the

color you click on.

Activates the Zoom Out mode.

Activates the Delete Handle mode.

Selects all the objects that are inside or touching the rectangle.

Aligns selected objects to one element in a group, rather than to the group as a
whole.

Opens the optional dialog boxes for certain drawing tool icons: Parallel lines,
Regular Polygons, Attribute Options, Rotate Options.

Control Key

Pointer tool:

Rotation:

Zoom:

Alt Key

Distribute On
Line:

Finger-Painting
tool:

Add/Delete
Handle:

Zoom:

Selection
rectangle:

Align Objects:
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While drawing, snaps the length of lines, polygon segments, polyline
segments, parallel lines, parallel polygon segments, parallel polyline

segments, and perpendicular lines, and the offset distance of offset lines, to

the currently active grid snap increment.

Activates the Pan feature when you drag while in the pointer mode.  This

allows you to scroll horizontally and vertically at the same time.

Shift-space bar constrains panning to 90-degree movement when pointer tool

is selected.

Shift-Alt constrains Bezier handle pairs to move in tandem.

Shift-Control-A deselects any selected objects.

Within a text block, Control-A selects all text characters.

Shift-Alt permits cropping of a bitmap or pixel map by dragging a corner edit

handle.

Key
Combinations

Pan feature:

Pointer tool:

Line, Polygon,
Parallel, Offset,
and Perpendicu-
lar tools:

Deselect All:

Bezier curves:

Select All Text
(In Open Text):

Cropping:
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Importing and Exporting Files with PC Draft

PC Draft can import image document files from the formats listed below.
This appendix details the conversion issues involved in retrieving each type
of image with PC Draft.

• TIFF format files, such as scanned images
• MacDraft files
• BMP format files

TIFF stands for “Tag Image File Format.”  It’s a standard format for high-
resolution images, and is often used to save images stored with scanning
devices.

PC Draft will load certain TIFF images (from files compatible with the
TIFF 5.0 format) into drawings via the Import command.  To be compatible
with PC Draft, the file must have a file type of “TIFF.”

 The images will appear as pixel-map objects.  You can move such objects
to other layers using the Cut or Copy and Paste commands.

To load a TIFF file into PC Draft:

1. Choose Import from the File menu.

The Open dialog box will appear.

2. If necessary, open the Format pop-up menu and choose All or
TIFF.

Both the All and TIFF format choices will list TIFF documents.

3. Use the directory list to display the TIFF file you want to open.

4. Double-click on the title of the file.

The image or images will be loaded into a drawing.

TIFF images, like other pixel-map objects, can be resized by dragging
handles.  Unlike bitmaps, some pixel maps do not resize proportionally.
However, you can get around this by selecting a pixel map and choosing
Group from the Arrange menu.  That will group the object to itself (put it in
a “group of one”).  It can then be resized proportionally like other PC Draft
groups (see Chapter 5 of the PC Draft Reference section for more
information about resizing groups).

File Import and
Export in PC
Draft

TIFF File
Loading

APPENDIX C
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PC Draft can export files in the following formats: BMP, JPEG, MaxPaint,
PhotoShop, PICT, PNG, QuickTime Image, SGI Image, TGA, TIFF. See
Apple, QuickTime documentation for details.

PC Draft also supports files created with PC Draft 1.5, WinDraft 1.2 and
MacDraft for Windows. The suffix for these files is .dft.

Using MacDraft 4.2.1 or later you will be able to save your files as PC Draft
1.5, WinDraft or MacDraft for Windows format.

To open the .dft files just place the files into your PC computer, open your
File menu from PC Draft, select the Open option and choose PC Draft 1.5
Drawing (.dft) from type of file.  Select the file from the list and click the
Open button.

Opening old
MacDraft files
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Index

A

Align Left 2-38
Align Right 2-38
Aligning Text 4-13
Alignment palette 1-24
Angular Dimension Objects 4-24
Angular Dimensions 4-24
Angular dimensions 4-14, 4-15
Angular Display 6-20
Annotation 4-1

annotating your drawing
with dimension lines 4-14

Apply button 2-75
Arcs 2-1

arcs by radius 2-18
changing the size of an arc by radius 2-18
drawing an arc by radius 2-17

drawing arcs with a fill 2-17
elliptical arcs

editing an elliptical arc 2-22
arcs, concentric 2-24
Area Calculation 4-25
ARRANGE MENU A-6
Arranging Objects 5-9
Attributes Palette 3-1
Attributes Tool 3-44

B

Bezier curves 2-66
Bitmap Images 8-10
bitmaps 2-81
Border Position A-4
Border Positions 3-41, 3-42
Borders 2-1
Bring to Front 5-9

C

Calculating the Area 4-25, 4-26
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Case A-4
case 4-10
Centimeters 6-19
Circle by Three Points 2-13
Circle Center Marks 4-23
Circles 2-1, 2-11

by diameter 2-11
by radius 2-11
by three points 2-11
choosing a method for drawing circles 2-11
circle drawing modes 2-11

circles, concentric 2-14
Clear 5-7, A-2
Close A-1
Color Picker 3-8, 3-20
Color Table 3-6
Control Key B-2
Constrained Drawing 2-28, 2-62
Constrained lines 2-1, 2-2

constrained line tool 2-1
Constrained Resizing 8-11
Constraining Line Segments 2-31
Constraining the Movement of Objects 5-2
Copy 5-3, A-2
Copying Attributes 3-44
Create a New Document 1-10
Cropping B-3
Cross Cursor A-5
Cursor Position 6-9
Curve Tools 2-64
Curves

Bezier 2-1
Customizing Patterns 3-14
Cut 5-2, A-2

D

datum point 2-73
Decimeters 6-19
Default Attributes 3-3
default datum point 7-6
Degrees, Min. & Secs. 6-20
Deleting Symbols 7-13
Dialog Boxes A-12
diameter dimension 4-22
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Dimension lines 4-14
annotating your drawing 4-14
Associative

editing 4-16
associative 4-14
point-to-point 4-14

Dimension Palette 4-14
Dimensions 4-14

angular dimensions 4-24
annotating your drawing 4-14
horizontal dimensions 4-17
linear dimensions 4-16
perpendicular dimensions 4-19
radial dimensions 4-21
slope dimensions 4-18
vertical dimensions 4-18

Displaying Palettes 1-25
Document Scale & Units A-13, A-14
Document Window 1-21
drafting formats 4-14
drag 5-1
Drawing 2-1

drawing mode 2-1
drawing procedures 2-1
drawing tool 2-1

Drawing Aids 6-1
Drawing Area 1-22
Drawing Layout 8-1
Drawing Size 8-4
Duplicate A-3
Duplicate command 5-7

E

Edit Color A-5
edit handle 2-76
edit handles 4-16
EDIT MENU A-2
Edit Pattern 3-15, A-5
Editing Colors 3-6
Editing Symbols 7-4
Ellipses

choosing a method for creating an ellipse 2-26
diagonal 2-26

creating a centered ellipse 2-27
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elliptical arcs 2-20
End Marks 3-38
English Units 6-16
evenly spaced objects 5-8
Export C-1
Extend tool 2-1
Extrude Tool 2-44
Extruding Lines 2-44
Extruding Parallel Lines 2-44
Eye Dropper Tool 3-24

F

FILE MENU A-1
File Menu 1-11
Fill

drawing arcs with a fill 2-17
Fill and Line Indicator Boxes 3-2
Fill and Line Indicators 1-21
Fill Color 3-8
Fill Color/Pattern 3-2
Fill Indicator 1-21
Fillets 2-1
Finger Tool 3-24
Flip Horizontal Tool 3-22
Flip Vertical Tool 3-22
Flipping Objects 5-18
Font A-4
font 4-9
freehand objects 2-60

G

Grid 2-60
grid lines 2-1
grid snap 2-1
Snapping Diagonal Lines Along Their Lengths 6-12

Grid Lines 6-10
Grid Snap 6-10
Grid snap

diagonal lines 6-12
Grouping Objects 5-10

H

Hand Tool 3-26
handle 2-76
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Handles 2-32
handles 4-16
Hardware and Software Requirements 1-1
Hexagons 2-33
Hide Area 4-27
Hide Text A-4
Hiding a Palette 1-25
Hiding All Text 4-7
Hiding Metric Units 6-20
horizontal and vertical dimension tools 4-16
Horizontal Dimension Objects 4-17

I

I-beam Pointer 1-39
I-beam pointer 4-5
Import C-1
Indicators, Fill and Line 1-21
Inserting Text 4-8
Install 1-1
Invert Tool 3-21

J

Justification 4-13, A-4

K

Key Combinations B-3
Keyboard Command Equivalents 1-23
keyboard move 5-5
Keys B-1

L

leading 4-11
Library Palette 7-10
Line Indicator 1-21
Line Indicators 1-21
Line Spacing A-4
line spacing 4-11
Line Styles 3-36
Linear dimension 4-15
Linear Dimensions 4-16
Lines 2-1, 2-3, 2-58

changing the length of a line 2-4
choosing line tools 2-1
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constrained diagonal line tool 2-1
constrained line tool

drawing a constrained line 2-2
line drawing modes 2-1
line pop-up menu 2-1
unconstrained diagonal line tool 2-1
unconstrained line tool

drawing an unconstrained line 2-3
Lock and Unlock 5-19
lowercase 4-10

M

Major Handles 2-32
Menu Bar 1-22
Menus A-1
Meters 6-19
Metric Units 6-19
Millimeters 6-19
mistake 2-93
Miter Joints 2-44
Move A-3
Move Back One 5-10
Move Forward One 5-10
Moving aPalette 1-24
Moving Area Calculation Values 4-27
Moving Objects 5-1
Moving objects B-1
Moving Text 4-12

N

Naming Symbols 7-3
New 2-1, A-1
NewSymbol-# 7-2

O

Object Fill Color 3-8
Object Fill Patterns 3-27
object information 7-4
Octagons 2-33
Offset Arcs 2-24
Offset Circles 2-14
Offset Lines 2-58
Open 7-1, A-1



Index 7

Orientation 8-3
Overlay Tool 3-21

P

Page Setup 8-1, A-2, A-12
pages by column 8-6
Paint Bucket Tool 3-25
Palettes 1-24
Paper Type 8-3
paragraph text 4-1
Parallel Fill Color 3-10
Parallel Fill Pattern 3-29
Parallel Lines 2-1, 2-35

Drawing Parallel Lines 2-35
Drawing Polygons and Polylines With Parallel Lines 2-39
Miter Joints 2-44

parallel lines 2-35
Paste 5-2, 5-3, A-2
Pen Color 3-3, 3-12, 3-18
pen model 1-21
Pen Pattern 3-31
Pencil Tool 3-23
Pentagons 2-33
perpendicular dimension 4-17
Perpendicular Dimension Objects 4-19
Perpendicular Dimensions 4-19
Picture Backgrounds 3-49

Opaque 3-51
pixel maps

Resize 2-81
Places 6-18
Pointer Mode 1-33
polygon 2-72
Polygon Drawing 2-28
Polygons 2-1

constrained drawing mode 2-31
hexagons 2-33
octagons 2-33
pentagons 2-33
regular polygons 2-33
triangles 2-33

polygons 2-28
polyline 2-73
polylines 2-28



8 Index

Pop-UpMenus 1-25
PREFERENCE MENU A-4
Print A-2, A-13
Printing 8-1
Printing in Reverse Order 8-6

R

Radial Dimension Objects 4-21
Radial Dimensions 4-21
Radial dimensions 4-15
radius dimension 4-21
Rectangle Drawing 2-4
Rectangles 2-1, 2-4

Rectangle Drawing Modes 2-4
square-corner rectangles 2-4, 2-5

drawing a rectangle from its corner 2-5
square-corner rectangle pop-up menu 2-4
square-corner rectangle tool 2-5

Redo 2-94
reference points 4-16
Regular polygons 2-33

hexagons 2-33
octagons 2-33
pentagons 2-33
triangles 2-33

regular text 4-1
Rename 7-3
Repeated Paste 5-3, 7-11, A-2
Reshape 2-71, A-3
Resize 2-74

bitmaps 2-81
pixel maps 2-81

Resizing Bitmap Images 8-10
Resizing Groups 5-11
Reverse Order 8-6
Reversing Changes 2-93
Revert 2-95, A-1
rotated text 4-6
Rotation Units 6-20
Rulers 6-6
Rulers’ Zero Points 6-7

S

Save A-1
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Save As A-1
Saving 1-11
Scale 2-1, 3-16, 4-14
Scale Rulers 6-6
Scaled and Unscaled Symbols 7-12
scales 6-21
Select 1-33
Select All A-3
Select All Text 4-7, A-4
Select Point button 2-76
Selecting All Objects 1-38
Selecting Multiple Objects 1-35
Selecting Objects 1-33
Selecting Text 1-39, 4-4
Selection Using the Shift-Click Method 1-35
Send to Back 5-10
Set Grid 6-10
Shift Key B-1
Show Area 4-26
Show Size 6-1
Show Size With Drawing Tools 6-1
Show Size With Rotation 6-5
Size

size units
hiding metric units 6-20

Size Units 1-4, 6-15
slope dimension 4-17
Slope Dimension Objects 4-18
Smooth 2-72
Snap 6-10
Snap to Object 6-15
Snapping Edges and Lines Along Their Lengths 6-12
Software Requirements 1-1
Special Line Tools 2-49
Special Usage of Keys B-1
spline 2-64
Spline Curves 2-64
Standard Rulers 6-6
Stationery 1-14
symbol libraries 7-1
Symbol’s Object Information 7-4

T

Tag Image File Format C-1
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Tangent
between objects

drawing a tangent between objects 2-56
to a point 2-52

tangent lines 2-51
text 4-1
text attributes 4-10
TIFF File Loading C-1
title format 4-10
Triangles 2-33

U

Unconstrained diagonal lines
unconstrained diagonal line tool 2-1

Unconstrained Editing 2-14, 2-28
Unconstrained lines 2-3

drawing an unconstrained line 2-3
Undo 2-93
Undo/Redo A-2
Ungrouping Objects 5-13
Units 6-15
Unlock 5-19
Unscaled Symbols 7-12
Unsmooth 2-72
uppercase 4-10
Using Color 3-5
Using Patterns 3-14

V

Vertical Dimension Objects 4-18
vertical dimension tools 4-16
Vertical Dimensions 4-18

W

Window Menu 1-19



PC Draft 6 Addendum C

A

PC Draft PE 6 Addendum
Contents

New Features.........................................................................
PC Draft & MacDraft File Compatibility...............................
Updated Interface...................................................................
 The Ribbon .............................................................
 The Centered Document..........................................
 Document Tabs........................................................
Custom Scales........................................................................
Increased Drawing Size.........................................................
Linear & Circular Gradients...................................................
 Applying a Gradient.................................................
 Creating a New Gradient.........................................
 Editing a Gradient....................................................
 Duplicating a Gradient.............................................
Create New Colors..................................................................
 Edit Existing Color...................................................
Create New Patterns...............................................................
 Creating a New Pattern............................................ 
 Editing a Pattern.......................................................
 Duplicating a Pattern................................................
Fill & Stroke Opacity..............................................................
The Star Tool..........................................................................
 To Draw a Star.........................................................
 To Draw a Custom Star............................................
The Library Palette.................................................................
 Using the Library Palette.........................................
 Creating a New Library............................................
 Adding an Item to your Library...............................
Undo & Redo.........................................................................

1
1
1
2
27
27
28
29
30
30
31
34
35
35
36
37
40
40
42
42
43
43
44
45
46
47
47
48



PC Draft 6 Addendum 1

A

PC Draft PE 6 Addendum
What's New?

New Features 
PC Draft & MacDraft File Compatibility 

PC Draft now includes the ability to save a MacDraft (.md60) document, that will 
allow you to share the designs you have created in PC Draft with someone else 
who is using MacDraft. What’s more, is that they can then make edits and save 
the file on the Mac, send it back to you and you can reopen it in PC Draft. This 
allows you to share and collaborate with all your deigns no matter what version of 
the software is being used.

By default PC Draft will save your new documents in the new .md60 format, 
however rest assured that your old PC Draft .mdd files are still compatible. Use 
the Open or Save As features to take a look at all of PC Draft's file compatibilities. 

Updated Interface

PC Draft underwent an interface change for version 6.0 and offers a ribbon system 
which holds all of the tools and options you need to use the application. As well 
as the ribbon system, PC Draft uses a document tab system, centered document 
window, scroll bars, rulers and the familiar palettes from previous versions. All of 

PC Draft MacDraft



PC Draft 6 Addendum2

A these features will be what you see when you first launch PC Draft so lets look at 
these new features in a bit more detail.

The Ribbon

The revolutionary ribbon system helps you get the most out of the PC Draft 
application. The very top of the ribbon shows, the file information and below that 
are the titles for the different tabs that can be accessed along the ribbon. 'File' will 
be selected by default when you first open the application.

Clicking any of the tabs will reveal a sub menu with many options and tools 
below it. 

Top Tip - Familiarise yourself with the tab system so you can work out the best way to 
tackle your next design project

Open : The open dialog appears and allows you to 
select and open an existing document.

New Document : Creates a new document, adding a 
new document tab to the bottom of the application.

The File Tab
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A

Save : Saves the current state of the document. 
If this is the first time you are saving you will be 
prompted to name the file.

Open Recent : Selecting this will populate a list of 
your recently saved documents, allowing you to 
open one.

Load Layer : Allows you to load particuar layers 
from an existing document into the current 
document.

Revert : You can eliminate any unsaved changes 
by reverting back to the last saved version of the 
current document.

Import Image : Allows you to import an image into 
the active document.

Save As : Saves the file but as a copy, allowing you 
to change the file name and/or file type. 
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A

Export Report : If you have created a report you can 
export it as a text file.

Export File : Allows you to export an image of your 
active document.

Set Defaults : Set the document and application 
defaults. Here you can change default fonts, colors 
and behaviors for your document and PC Draft.

Page Setup : Change the paper size and orientation 
of your document.

Print Special : You can choose to print just the active 
layer or to print your drawing as slides. 

Print : Print your document from screen to 
paper.
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A

Quit : Closes all documents (prompting you to save 
if necessary) and closes PC Draft.

The Edit Tab

The Edit tab is used to change details of a shape or line such as making it bigger 
or smaller, creating copies or applying attributes. 

Paste Options : Pastes the object, image or text 
from the clipboard. Choose to paste unscaled or use 
repeated paste to paste more copies. 

Cut, Copy & Paste : All 3 of these options are 
separate buttons. Cut will remove the selected item 
from the document and add it to the clipboard. Copy 
will copy the selected item to the clipboard leaving 
the original intact and Paste will paste the item 
currently on the clipboard into the document

Clear : Clears all objects, images and text from your 
clipboard.

Copy Attributes : Copies the stroke and fill settings 
of the selected object
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Apply Attributes : Applies the attributes copied 
(using copy attributes) to the selected object.

Attribute Options : Allows you to select which 
attributes you would like to copy and apply using 
the Copy Attributes and Apply Attributes tools. 

Duplicate : Creates a duplicate of the selected 
object, image or text slightly offset from the 
original.

Linear Duplication : Used to create a number 
of duplicates of the selected object in a linear 
arrangement.

Circular Duplication : Used to create a number 
of duplicates of the selected object in a circular 
arrangement.

Select All : Selects all unlocked objects, text and 
images in the active layer.
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A

Select None : Deselects all currently selected 
objects, text and images in the active layer

Select Special : Define specific characteristics you 
want to select E.g. Set Object Fill to Red to select all 
objects in the active layer that have a red fill.

Move : Lets you set exact coordinates to move the 
selected object to. 

Expand : Allows you to increase the X & Y 
dimensions of the selected object

Contract : Allows you to decrease the X & Y 
dimensions of the selected object.

Reshape : Smooth or Unsmooth freehand lines. 
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Edit Datum : Edit the datum point of the 
selected object.

The Text Tab

The Text Tab is used for, you guessed it, editing and arranging your text. These 
options can be used within a single text box or across multiple text boxes.

Font Select : Change the font of the selected 
text.

Justification Center : Justifies the selected text 
to the center of its text box. 

Justification Left : Justifies the selected text to 
the left.of its text box.

Justification Right : Justifies the selected text 
to the right of its text box..
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Vertical Positon Top : Vertically aligns the 
selected text to the top of the text box.

Vertical Position Bottom : Vertically aligns the 
selected text to the Bottom of the text box.

Line Spacing 1.5 : Sets the space between the 
lines of the selected text as 1.5.

Vertical Position Middle : Vertically aligns the 
selected text to the Middle of the text box.

Line Spacing Single : Sets the space between 
the lines of the selected text as single.

Line Spacing Double : Sets the space between 
the lines of the selected text as double.
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Upper Case : Sets all characters in the selected 
text to UPPER CASE. 

Title Case : Sets the first character of each 
sentence to Upper Case. 

Lower Case : Sets all characters in the selected 
text to lower case. 

Lower Case : Sets all characters in the selected 
text to lower case. 

Hide Text : Hides all text on the active layer. 
Click again to show the hidden text.

The Options Tab
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Border Positon Inside : Sets the drawing 
position of the selected object as inside.

Border Position Outside : Sets the drawing 
position of the selected object as outside.

Round Pen Style : Sets the pen style for lines 
and objects as rounded (round edges).

Border Position Center : Sets the drawing 
position of the selected object as center.

Blade Pen Style : Sets the pen style for lines 
and objects as blade (straight edges).

Zoom Line Weights : Magnifies line weights in 
proportion to the current zoom factor.



PC Draft 6 Addendum12

A

Hide/Show Line Styles : Hide or Show line 
styles such as dashed lines.

New Color : Allows you to create a new color. 
It will be added to the color swatch in the 
properties tab.

New Pattern : Allows you to create a new 
pattern. It will be added to the gradient/pattern 
swatch in the properties tab.

Edit Line Styles : Allows you to edit an 
existing line style to make a custom line style.

New Gradient : Allows you to create a new 
gradient. It will be added to the gradient/
pattern swatch in the properties tab.

Edit Colors : Change a color. That color will 
be updated in the swatch in the propeties tab.
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Edit Patt/Grad : Change an existing pattern 
or gradient. Patterns and gradients will be 
updated in the properties tab.

Hide/Show Fills : Hide or show fills such as 
patterns or gradients.

Tools Options : Select to view special options 
from certain tools such as the regular polygon 
tool.

Duplicate Patt/Grad : Duplicate an existing 
pattern or gradient. Patterns and gradients will 
be updated in the properties tab.

Cross Cursor : Show or Hide the cross cursor.

Top Tip - You can also hold down the ALT key when clicking a tool to view its special 
options.
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The Arrange Tab

Bring to Front : Brings the selected object to 
the front of the document (on top of all other 
objects).

Move Forward : Brings the selected object one 
level forward on the document.

Group : Groups the selected objects, text and 
images together to create a single selection.

Send to Back : Sends the selected object to 
the back of the document (behind all other 
objects).

Move Back : Sends the selected object one 
level back on the document



PC Draft 6 Addendum 15

A

Ungroup : Ungroups the selected grouped 
objects, text and images breaking them back 
up to their individual selections.

Rotate to Zero : Rotates an already rotated 
object back to its original (zero) position.

Flip Horizontal : Flips the selected object 
horizontally.

Rotate : Allows you to rotate the selected 
object freely.

Rotate Options : Brings up a dialog showing 
advanced rotate options for the selected object.

Flip Vertical : Flips the selected object 
vertically.
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Align Bottom edges of selected objects

Align Top edges of selected objects

Align Vertical centers of selected objects

Distribute objects Horizontally by their center

Align Left edges of selected objects

Distribute objects Horizontally by their datum

Align Right edges of selected objects

Distribute objects Vertically by their center

Align Horizontal Centers of selected objects

Distribute objects Vertically by their datum
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Align Again : Use on another object to apply 
the same align settings you used a previous 
object.

Distribute on Line : Manually draw a line you 
want the selected objects to be aligned across.

Unlock : Unlocks the locked object making it 
editable again.

Align Options : Set specific alignment options 
E.g. align to grid, for selected objects.

Lock : Locks the selected object making it 
uneditable.

The Data Tab
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Edit Field Names : Edit the data field names 
(titles) that can be applied to objects.

Find & Replace : Look for and replace an 
object (or object data) with another.

Print Report : Select one of your saved reports 
to print.

Edit Object Info : Edit the data fields currently 
assigned to the selected object. 

Report Formats : Create, Load, Delete and Edit 
reports.

Update Link : Updates links from report 
formats to excel files.
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Break Link : Breaks the link between report 
formats and excel files.

The Layout Tab

Set Grid : Change the grid snapping 
(increments you snap to) for the active 
document.

Set Scale & Units : Choose what scale (1:1) 
and units (mm, inches etc) you would like to 
use throughout the document.

Set Angle Snap : Change the angle at which 
your objects (e.g lines) snap to when drawn.

Hide/Show Rulers : Turn the visibility of the 
rulers on or off.
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Standard Rulers : Shows the stand rulers 
relative to your paper size (doesnt take scale 
into account).

Hide/Show Grid Lines : Turns the dotted/
dashed grid lines on and off. 

Scale Rulers : Adjusts the rulers relative to the 
scale you have set on the active layer.

Snap to Object : Allows you to snap to an 
existing objects anchor points when drawing 
or moving an object.

Hide/Show Page Breaks : Turns the lines 
which display a break between 2 pages on and 
off.

Drawing Size : Allows you to add or remove 
pages from the active document.
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Position : Use to adjust the position of all 
objects within the drawing space.

Restore Previous Zoom : Reverts back to the 
last zoom level you used. 

Zoom : Allows you to zoom in or out to 2x or 
4x zoom level. 

Home View : Restores the zoom level to 1x 
and positions the screen to the top left of the 
document.

The View Tab

Tool Palette : Shows / Hides the Tool Palette.
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Accessory Palette : Shows/Hides the 
Accessory Palette. 

Library Palette : Shows/Hides the Library 
Palette.

Dimension Palette : Shows/ Hides the 
Dimension Palette.

Show Size Palette : Shows/Hides the Show 
Size Palette.

Layers Palette : Shows/Hides the Layers 
Palette.

The Window Tab
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Hide/Show All Palettes : Allows you to show 
or hide all of the currently open palettes.

Dimension Palette : Shows/ Hides the 
Dimension Palette.

Show Size Palette : Shows/Hides the Show 
Size Palette.

Tool Palette : Shows/Hides the Tool Palette.

Accessory Palette : Shows/Hides the 
Accessory Palette.

Library Palette : Shows/Hides the Library 
Palette.
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Cascade : Turns the active document tabs 
into document windows within the PC Draft 
application, the document windows will sit on 
top of each other.

Arrange Icons : Arranges minimized document 
windows neatly at the bottom of the PC Draft 
main window.

Layers Palette : Shows/Hides the Layers 
Palette.

Tile : Turns the active document tabs into 
document windows within the PC Draft 
applilcation, the document windows sit neatly 
next to each other in a grid.
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AThe Properties Tab

Fill Color/Pattern: The first pop up allows you to change the 
fill color or pattern of the selected object. The second pop up 
allows you to change the opacity.

Parallel Line Fill/Pattern : The first pop up allows you to 
change the fill color or pattern of the selected parallel line 
object. The second pop up allows you to change the opacity.

Stroke : The first pop up allows you to change the stroke (line) 
color or pattern of the selected object or text. The second pop 
up allows you to change the opacity.

Line Weight : Adjust the thickness of 
your lines.

Line Style : Change the style of your 
lines from solid to dashed. 

End Marks : Apply end marks such 
as arrow heads to your lines.
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Absolute : Use to edit the desired 
dimensions of the selected object

Relative : Use to add a desired 
value to the existing dimensions of 
the selected object

Width/Height : Use to edit the width 
and height of the selected object, note 
that this option only appears if you have 
an object selected in the document.

X Y Position : Use to edit the X/Y 
coordinates (position) of the selected 
object, note that this option only 
appears if you have an object selected 
in the document.
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AThe Centered Document

The PC Draft document is centered on your screen with a grey zone around it. 
Having the document centered in the window gives you much more control over 
its content and the positioning of objects on the art board. Zooming is also much 
easier to control when working with complex drawings.

Document Tabs

When you create a new document in PC Draft it will be displayed as a tab across 
the bottom of the application window.

The tab shows vital information for the document it represents. It shows the 
Document Name (Tutorial), 
the currently selected Layer 
(Layer-1) and the scale of 
that Layer (1:50). This can 
be seen in the image below.

Top Tip - The Document name will be "Untitled-X" until it has been saved as something 
different
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A Custom Scales
You’ll find a whole set of useful default scales to use, in both English and Metric 
units under the Layout Tab via 'Set Scale & Units'. 

You can use 1:1, 1:50, 1/4 inch = 1 foot and many, many more. All of which have 
been created to help standardize your drawings. If you can’t find the scale you are 
looking for from the default list, you could always create your own custom scale. 
Any new scale you create will be added to the bottom of the list of default scales. 
All custom scales can be used to control the whole document or individual layers 
for added flexibility.

To create a custom scale:

1. Select the Layout Tab

2. Click the Set Scale & Units button

3. The Scale & Units Dialog appears

Create a custom scale here >
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A4. In the Custom Scale field type in your desired scale

5. Click Apply 

6. Click OK to close the dialog

Increased Drawing Size

We have increased the maximum drawing size of PC Draft to bring it in line 
with the Mac version (MacDraft). The new maximum drawing size is 178 x 178 
inches. This gives you full control over more complex and larger designs, making 
it easier for you to produce much larger drawings.

To Increase your document drawing size follow the steps below:

1. Click the Layout Tab on the Ribbon

2. Select the “Drawing Size” option

3. The Drawing Size Dialog appears

4. The pages you have selected will be highlighted (black)

5. Click OK once you are happy

Top Tip - You can also change the page numbering here for when you come to print. You 
can choose if you want page numbers to be listed vertically or horizontally



PC Draft 6 Addendum30

A The maximum drawing size of PC Draft is 178” x 178” or if you are using an A4 
paper size 23 pages wide x 17 pages high. Your choice of paper size of course 
dictates the amount of pages you will have at your disposal in the Drawing Size 
dialog.

Linear & Circular Gradients

Gradients are at the heart of any graphical or vibrant layout. PC Draft now has 
support for the creation and management of Linear and Radial gradients. Create 
vibrant color blends for use in vector illustration, colorful floor and garden plans 
and much more. The gradients can be stored, edited and duplicated making it 
easier for you to manage your swatches and share them throughout all your 
drawings.

A gradient can be applied as a fill or a stroke and can be applied to objects, lines, 
parallel lines and text. 

Applying a Gradient

1. Select the object in the document (for example a rectangle)

2. Click on the Properties Tab

3. Click on the Fill icon (the red pop up box below)

4. A selection of colors and fills appear
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5. Select a Gradient and your rectangle will now be filled

Creating a New Gradient

Whether you want to create a linear gradient or a radial gradient, they are handled 
in the same area of PC Draft. 

1. Go to the Options Tab and select 'New Gradient'.

2. The Gradient Dialog appears.

Solid Colors > 

Patterns > 

Gradients > 
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Click on the White (Color 1) square and a color picker will appear, choose a new 
color and do the same (picking a different color) with the Black (Color 2) square. 
You can also click anywhere between Color 1 and Color 2 to add new colors. To 
remove a color simply drag it off of the color bar and release the mouse. 

You can change the gradient from Linear to Radial at any point using the pop up 
option at the top of this dialog. Select Radial and the preview will update. 

Gradient Type

Gradient Preview

Color 2

Angle of Gradient

Cancel Gradient

Color 1

Confirm Gradient

Apply to 
Selected Object
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A

You will notice that the 'Rotation' option has disappeared, this is only available on 
linear gradients. 

At this stage you can click OK to add the gradient to your color options or you 
can click Apply to Selected to apply it to the object you selected before creating 
this gradient. 

New Gradient
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A Editing a Gradient

You can edit any of the preset patterns or gradients along with any new ones you 
have created too. In the options tab you will see the 'Edit Patt/Grad' button.

1. Go to the Options Tab and select Edit Patt/Grad

2. The fill options dialog appears 

3. Select the gradient you want to edit (right)

4. The gradient dialog appears

5. Change the angle of rotation to 45o

6. Change the Left Green Color to Red

7. Click OK

8. Go to the Options Tab and select the Fill icon

We will use this one
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A

You will notice that the gradient has changed to show your edits!

Duplicating a Gradient

You might find that you want to create a gradient similar to an 
existing one. The best thing to do in this scenario is duplicate the 
existing one and edit it. To do this click on the Duplicate Patt/
Grad button on the Options menu and select a gradient.

The gradient dialog will appear loading a copy of the existing gradient. Make 
your edits and once you are happy click OK to confirm. The new gradient will be 
added to the end of the gradients in the color swatch, the original gradient will 
also be there but will not have been edited. 

Create New Colors

PC Draft now allows you to create new colors, gradients and patterns. You no 
longer have to replace the existing swatches, you can create your own new ones. 
In addition, if a color gradient or pattern is attached to an object and stored in the 
new Library palette, when you add that item to any document, the new swatch 
will be added to that document for use with any object.

Edited Gradient

Top Tip - Select the Preview button in the gradient dialog to see the gradient change on the 
drawing (if the gradient is applied to an object)
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A To Create a New Color

1. Go to the Options Tab and select the New Color button

2. The Color Picker will appear

3. Select the Color you want

4. Click OK to confirm

The new color will appear at the end of the solid color options.

To Edit an Existing Color

1. Go to the Options Tab and select the Edit Colors button

2. The PC Draft Color Options will appear

We will edit this one
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A3. Choose a Color to Edit

4. The Color Picker Appears

5. Change the color and notice the new and original colors in the top left of the 
dialog

6. Click OK. You will now see that the original color has been edited. 

Creating New Patterns

You can create new pixel patterns in PC Draft as well as colors 
and gradients. The pixel patterns are repeatable and are created 
using a square pixel grid via the Options Tab New Pattern Button. 

Go to the Options Tab and Select the New Pattern Button, the 
Pattern Dialog will appear. Below is a break down of its features. 

Original Color Edited Color
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A

Clear : Removes all pixels and leaves you with a blank pattern dialog.

Preview : Shows a small repeatable preview of your pattern.

Grid Size : The pattern grid can be set to 8x8, 16x16 or 32x32 grid squares. 

Scale : If the scale box is turned off as the grid size is increased or decreased, the 
pattern currently in the preview will be replicated to fill the new area. If the scale 
box is turned on as the grid size is increased or decreased the pattern in the pre-
view will remain the same but will be divided into more or less squares. 

Revert : Will revert the pattern back to how it was at the start. If you chose New 
Pattern it will now be blank, if you are editing an existing pattern it will revert 
back to the original pattern.

Fill : Fills the entire pattern with the current color.

Pattern : Loads an existing pattern into the pattern dialog.

Clear

Preview

Scale Other Color
Color

Move/Pan

Black & White

Paint Bucket
Blend

Flip Vertical

Flip HorizontalPatternFill

Invert

Pencil

Revert

Undo OK Cancel

Grid 
Size
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AInvert : This inverts the color of all pixels in the pattern. For example all black 
will become white and all white will become black. If a color is being used it will 
change to a color on the opposite end of the color spectrum.

Flip Horizontal : This is used to flip the pattern in the pattern dialog around the 
vertical axis.

Move Vertical : This is used to flip the pattern in the pattern dialog around the 
horizontal axis.

Pencil : The Pencil is used to change the color of individual pixels within 
the pattern dialog. You can also click and drag to draw as you would with the 
freehand tool.

Blend : The Blend tool is used to blend together the current color and the color of 
any pixel in the pattern dialog. 

Paint Bucket : This is used to fill a section of the pattern dialog. The section filled 
will be any corresponding and attached pixel to the one you selected. 

Hand : The Hand tool is used to move the pattern within the boundaries of the 
pattern dialog. 

Black & White : If you have created a colorful pattern, clicking this will change it 
to a black and white version of the created pattern.

Color : Allows you to choose a color from the existing color swatch, including 
any of your newly created colors. 

Other Color : Allows you to choose a new color from the color picker pop up. 

Undo : Will go back one step, removing the last action you made in the pattern 
dialog.

OK : Confirms the changes and saves the new or edited pattern.

Cancel : Cancels the changes and does not save the new or edited pattern. 
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A To Create a New Pattern

1. Go to the Options Tab and Select New Pattern

2. Click to place black pixels or click the color option to change your color

3. When you are happy with your pattern click OK

Once the pattern is saved you will be able to see it in the fill options and apply it 
to an object.  

To Edit an Existing Pattern

1. Go to the Options Tab and Select Edit Pattern

2. Choose the Pattern you wish to Edit

We will edit this one
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A3. The Edit Pattern Dialog will appear showing the existing Pattern

4. Make edits however you like, we will add a color to make it obvious

5. When you are happy, click OK to save

The pattern will be saved over the original in the position of the original in the 
color swatch.
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A To Duplicate a Pattern

If you want to create a new pattern based on an existing one, choose Duplicate 
Patt/Grad from the Options Tab. 

This will open the Edit Pattern Dialog for you to edit that pattern but will save a 
new version of it rather than saving over the original. 

Fill & Stroke Opacity

Control all of your fills, strokes and parallel line fills with an opacity, giving you 
the ability to create overlays, blends and much more. In addition, you’ll be able to 
control the opacity of text elements, giving you more control over how your fonts, 
labels and markups are displayed.

Opacity is controlled by a percentage. 0% will make an object translucent (clear) 
and 100% will make an object opaque (solid).

To Change the Opacity of an Object, simply select it and click the corresponding 
Opacity box in the Properties Tab. If you want to edit a Parallel Line use the 
Parallel Line Opacity, for the Fill of an object use the Object Fill Opacity and for 
the stroke of an object (or a line) use the Stoke (line) Fill Opacity. Clicking any of 
them will prompt the Opacity Dialog to appear. 

Opacity

Object Fill

Parallel Line Fill

Stroke (line) Fill
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AUse the slider to adjust the opacity of the selected object. The example below 
shows different levels of Opacity on a filled circle. 

The Star Tool

The Star tool allows you to create custom Star shapes in your document, it 
also offers options for the control of the attributes within the star such as how 
many points and thickness of star. Stars are a great way to create badges, labels, 
markups and even arrows if you want to. 

To Draw a Star

1. Select the Star Tool from the Tool Palette

2. Click in the drawing and drag the mouse

3. Once you are happy, release the mouse and the default star will be placed

There are also tool options available which allow you to define the number of 
sides on your star and the thickness of those points. 

0% 25% 50% 75% 100%
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A To Draw a Custom Star

1. Select the Star Tool from the Tool Palette

2. With the Tool selected, go to the Options Tab and select 'Tool Options'

3. The Star Tool Dialog appears

4. Change the number of sides and/or star thickness

5. Click OK and the Custom Star will be placed

In addition you can ungroup the drawn star and edit the handles yourself to create 
more custom and complex shapes. The star shapes can then be controlled with 
color fills and strokes.
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AThe Library Palette

The Library palette allows you to create, store and manage all of your library 
items in one place. You no longer have to worry about drawing those commonly 
used symbols over and over again, you can simply draw them once and store them 
in a custom library catalog. You can then share your custom libraries with other 
PC Draft users, allowing you to collaborate with your colleagues, friends and 
family with any design. The Library palette works on a drag and drop basis, make 
it easier and faster for you to use.

To open the Library Palette, go to the Window tab on the ribbon and select 
'Library'. The Library palette will appear.

Close : Click this to close the Library Palette

Libraries : This is where your different libraries are saved. Think of them as a 
folder full of library items

Library Items : These are the individual items within a Library. Simply drag them 

Close

Scroll Bar

Zoom
SearchOptions

Library Items

Libraries
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Aout of the palette and on to your drawing

Scroll Bar : If you have more items than can fit in the preview window then you 
can scroll up or down to see all items

Options : Click this to bring up the options New Library, Open Library and 
Rename Item

Search : Manually type in the name of the library item you want and it will appear 
in the preview above

Using the Library Palette

The Library Palette stores your created items. Its use is for you to drag and drop 
those items onto your drawing, saving you precious drawing time. 

1. Open the Library Palette via the Window Tab on the ribbon

2. Select the Library your item is stored in 
(For Example Home Plan Graphics)

3. Scroll to find or search for your item

4. Click to select it

5. Drag it from the library palette to the 
document
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A To Create a New Library

1. Open the Library Palette via the Window Tab on the ribbon

2. Click on the Options button in the Library Palette

3. Click New Library

4. Name your library and click OK

5. The library (we named it Example) will appear in the Library Palette

You can now add items to your own library. 

To Add an Item to your Library

Any item can be added to the library palette, text, lines, shapes and groups. 

1. Open the Library Palette via the Window Tab on the ribbon

2. Select the Library you would like to add an item to

3. Select the item you would like to add to the library

4. Hold the Alt key and drag the item into the preview area of the library

Top Tip - Group items before adding them to the library. Selecting multiple objects may add 
multiple items to the library palette. 
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A5. You will see a preview of the item

6. Release the mouse and the item is now added

7. Select the item within the library (The item will highlight)

8. Click on the Options button and select 'Rename'

9. Name the item

Undo & Redo

As of version 6.0 PC Draft boasts an almost unlimited undo tree. Meaning you 
can use CMD + Z (undo), CMD + Shift + Z (redo) or the undo buttons next to 
the save icon at the top of the ribbon to go backwards and forwards through your 
design process. 
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